Autor Thema: homebridge/homekit  (Gelesen 356992 mal)

Offline hijo

  • New Member
  • *
  • Beiträge: 33
Antw:homebridge/homekit
« Antwort #2895 am: 16 Mai 2018, 22:25:32 »
Bei mir bleibt das npm Paket immer auf 3.10.10. Wie bekomme ich das denn auf 6.0.1?

npm -g outdated
Package  Current  Wanted  Latest  Location
npm      3.10.10   6.0.1   6.0.1

Danke
Raspi mit FHEM 5.8, Qivicon mit Telekom App, Web KM200 von Buderus, Philips HUE System, Xiaomi Smart Home Kit, HM-CFG-LAN LAN mit 6x HM-CC-RT-DN und HM-TC-IT-WM-W-EU, Ikea Tradfri, TP-Link HS110

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1538
  • Es begann alles so klein ;-)
homebridge/homekit
« Antwort #2896 am: 16 Mai 2018, 23:03:36 »
Hi,
Ich würde
sudo npm -g install npmVersuchen.
Danach lief meine Homebridge nicht mehr! Lösung:
sudo npm install -g node-gyp
cd /usr/lib/node_modules/homebridge/node_modules/ed25519-hap/
sudo node-gyp BUILDTYPE=Release rebuild
cd ../curve25519-n/
sudo node-gyp BUILDTYPE=Release rebuild
Gruß Arnd


Gesendet von iPhone mit Tapatalk
« Letzte Änderung: 17 Mai 2018, 18:54:55 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline hijo

  • New Member
  • *
  • Beiträge: 33
Antw:homebridge/homekit
« Antwort #2897 am: 17 Mai 2018, 10:32:50 »
Hat geklappt. Danke. Habe das aber auch wirklich nicht gefunden. Sollte vielleicht ins Wiki für die Homebridge mit rein.
Raspi mit FHEM 5.8, Qivicon mit Telekom App, Web KM200 von Buderus, Philips HUE System, Xiaomi Smart Home Kit, HM-CFG-LAN LAN mit 6x HM-CC-RT-DN und HM-TC-IT-WM-W-EU, Ikea Tradfri, TP-Link HS110