Autor Thema: Überwachungskamera (RTSP-Stream) in FTUI anzeigen  (Gelesen 27406 mal)

Offline Gerrit

  • New Member
  • *
  • Beiträge: 25
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #60 am: 28 Januar 2020, 18:50:16 »
Moin,

nachdem meine uralte China-Foscam gestorben war, bei der man noch direkt den MJPEG-Stream abgreifen konnte, musste etwas neues her. Die neue, billige Ezviz-Cam liefert nur rtsp. Lösung für mich war dann die Installation von motioneye https://github.com/ccrisan/motioneye/wiki auf meinem NUC, auf dem auch FHEM läuft. Funktioniert wunderbar und den umgewandelten Stream konnte ich dann wieder in FTUI/FULLY auf dem Tablet einbinden. Das ganze gibt es auch als komplettes Image (motioneyeos) für den Raspberry.

Gruß Gerrit

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

--

FHEM auf NUC (Ubuntu Server) mit

CUL,CUL_HM,EMGZ,EMWZ,FHT80TF,S300TH,FHT80B,FS20,HMS100,DECT200,HUE,Tradfri,UniFi,Harmony

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #61 am: 05 Februar 2020, 18:02:32 »
Hallo!

Mit so einem Interesse habe ich gar nicht gerechnet...  :D

In meinem original Post habe ich schon einige Links dabei. Ich habe (wie auch viele andere) meine Fhem Umgebung in Docker laufen, und dafür habe ich auf GitHub auch eine Demo veröffentlicht, die verwendet werden kann, um den "Janus-Server" zu betreiben. Grundsätzlich kann Janus aber auch direkt auf einen Rechner installiert werden, dabei müsste man im Prinzip einfach alle Schritte aus dem Dockerfile zu Fuß zB am Raspi oder NUC machen.

Bezogen auf die Einrichtung mittels meinem Docker Container:

In groben Zügen muss man folgende Schritte machen
  1. Den Janus Container starten. (Nun kann man mittels IP-Adresse des Hosts, auf dem Janus läuft bereits auf Port 10080 einen Demo-Stream anschauen - http://<Host-IP>:10080/streamingtest.html)
  2. Die Janus Streaming-Config anpassen, also für jeden Stream die Einstellungen tätigen. (Stream ID vergeben, Stream benennen, die RTSP URL eingeben, RTSP username, RTSP passwort, etc.)
      Nach jeder Änderung muss Janus neu gestartet werden, damit die Änderungen übernommen werden.
  3. Es gibt zwei JavaScript Dateien die man in den FTUI Ordner "js" ablegen muss. janus.js und janusStreamer.js
  4. In der Datei janusStreamer.js muss jetzt noch die korrekte IP des Janus Server eingestellt werden.
  5. In der FTUI index.html noch die nötigen Abhängigkeiten inkludieren: zB
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery/3.4.0/jquery.min.js"></script>
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/webrtc-adapter/6.4.0/adapter.min.js"></script>
<script type="text/javascript" src="janus.js"></script>
<script type="text/javascript" src="janusStreamer.js">//Edit Janus Gateway Server IP in this file at first!</script>
  6. Irgendwo in der FTUI (zB in einem Popup Widget hab ich es) den Stream einbinden: zB
        <script>
openStream("99", "rtspdemo");//zB 99 ist die ID des Streams, welche in der Streaming Config am Janus Server vergeben wurde. "rtspdemo" ist die ID des video-Tags, wo das Video spielen soll.
</script>

<video id="rtspdemo" width="400" height="auto" autoplay muted>
<!--Works in Chrome and Firefox for Windows and in Chrome for Android-->
</video>

Klingt nach viel, ist es aber nicht unbedingt.  ;D

In meinem GitHub repo https://github.com/AlpenFlizzer/janus-gateway-docker findet man alle Dateien die benötigt werden. Nutzt man Docker, so ist das ganze zur Hälfte schon Plug'n'Play.
Das Janus Gateway ist eigentlich auch primär als (Video)Konferezn-Call System mittels WebRTC gedacht. Das RTSP Streaming ist nur ein "Abfallprodukt" der Entwickler. Eine Video-Gegensprechanlage innerhalb der FTUI könnte man damit also wahrscheinlich realisieren - da bin ich aber dann raus. :D

Grüße, Sascha

Hallo Sascha,

ich habe es probiert meine beiden Cams mit deinen Janus Docker zum laufen zu bekommen, leider ohne Erfolg.
Hast du evtl. den ein oder anderen Tipp fü mich.

Der Docker läuft soweit die streamtest seite kann ich aufrufen. Dort sehe ich auch meine angelegten rtsp-Streams.
Wenn ich nun einen davon Starte passiert leider nichts.
Hier mal die Stream Config
rtsp-CamHaustuer: {
type = "rtsp"
id = 90
description = "CamHaustuer"
audio = false
video = true
url = "rtsp://192.168.xx.xx:8081/live/ch0"
rtsp_user = "xxxx"
    rtsp_pwd = "xxxxx"
videofmtp = "profile-level-id=42E01F;packetization-mode=1"
}
rtsp-CamTerrasse: {
type = "rtsp"
id = 91
description = "CamTerrasse"
audio = false
video = true
url = "rtsp://user:pass@192.168.xx.xx:8081/live/ch0"
videofmtp = "profile-level-id=42e01f;packetization-mode=1"

Bei der zweiten CamTerrase habe ich die URL mal so eigetragen wie es unter Zoneminder lief.

Im Janus Log steht folgendes
  Starting Meetecho Janus (WebRTC Server) v0.9.0
---------------------------------------------------
Checking command line arguments...
Debug/log level is 4
Debug/log timestamps are disabled
Debug/log colors are enabled
Adding 'vmnet' to the ICE ignore list...
Using 192.168.xx.xx as local IP...
[WARN] Token based authentication disabled
itializing recorder code
Initializing ICE stuff (Full mode, ICE-TCP candidates disabled, half-trickle, IPv6 support disabled)
TURN REST API backend: (disabled)
[WARN] Janus is deployed on a private address (192.168.0.10) but you didn't specify any STUN server! Expect trouble if this is supposed to work over the internet and not just in a LAN...
Crypto: OpenSSL pre-1.1.0
[WARN] The libsrtp installation does not support AES-GCM profiles
[WARN] No cert/key specified, autogenerating some...
Fingerprint of our certificate:
[WARN] Event handlers support disabled
Plugins folder: /opt/janus/lib/janus/plugins
[WARN] Plugin 'libjanus_audiobridge.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_echotest.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_nosip.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_recordplay.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_sip.so' has been disabled, skipping...
Loading plugin 'libjanus_streaming.so'...
Sessions watchdog started
Joining Janus requests handler thread
JANUS Streaming plugin initialized!
[WARN] Plugin 'libjanus_textroom.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_videocall.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_videoroom.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_voicemail.so' has been disabled, skipping...
Transport plugins folder: /opt/janus/lib/janus/transports
Loading transport plugin 'libjanus_http.so'...
HTTP webserver started (port 8088, /janus path listener)...
[WARN] HTTPS webserver disabled
Admin/monitor HTTP webserver started (port 7088, /admin path listener)...
[WARN] Admin/monitor HTTPS webserver disabled
JANUS REST (HTTP/HTTPS) transport plugin initialized!
[WARN] Transport plugin 'libjanus_pfunix.so' has been disabled, skipping...
Loading transport plugin 'libjanus_websockets.so'...
[WARN] libwebsockets has been built without IPv6 support, will bind to IPv4 only
libwebsockets logging: 0
WebSockets server started (port 8188)...
[WARN] Secure WebSockets server disabled
Admin WebSockets server started (port 7188)...
[WARN] Secure Admin WebSockets server disabled
JANUS WebSockets transport plugin initialized!
[WARN] libnice version outdated: 0.1.13 installed, at least 0.1.15 recommended
WebSockets thread started
[rtsp-CamTerrasse] New video stream! (ssrc=149996275, index 0)
[rtsp-CamHaustuer] New video stream! (ssrc=94148464, index 0)
Creating new session: 8666580308003567; 0x7fc53c0010c0
Creating new handle in session 8666580308003567: 6846312543500239; 0x7fc53c0010c0 0x7fc53c001620
[6846312543500239] Creating ICE agent (ICE Full mode, controlling)
[6846312543500239] The DTLS handshake has been completed
[janus.plugin.streaming-0x7fc53c001340] WebRTC media is now available
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[WARN] [rtsp-CamTerrasse] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamTerrasse] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=935727369, index 0)
[rtsp-CamTerrasse] New video stream! (ssrc=2050315095, index 0)
[WARN] [rtsp-CamTerrasse] 5s passed with no media, trying to reconnect the RTSP stream
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamTerrasse] Reconnected to the RTSP server, streaming again

Vielen Dank für deine Mühe

VG Alex
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline SB

  • New Member
  • *
  • Beiträge: 20
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #62 am: 05 Februar 2020, 19:02:56 »
...
ich habe es probiert meine beiden Cams mit deinen Janus Docker zum laufen zu bekommen, leider ohne Erfolg.
Hast du evtl. den ein oder anderen Tipp fü mich.

Hallo Alex, nach der Installation, hast du da mal die Streams getestet die ich zum Testen in der Streaming Config habe? (Highway und Bunny) Haben die gespielt? -> Wenn nicht, liegt es vermutlich am Browser, momentan läufts unter Windows komischerweise nur im Edge. (Unter Android: Edge, Chrome und Fully - habe ich getestet)

Der Docker läuft soweit die streamtest seite kann ich aufrufen. Dort sehe ich auch meine angelegten rtsp-Streams.
Wenn ich nun einen davon Starte passiert leider nichts.
Hier mal die Stream Config
rtsp-CamHaustuer: {
type = "rtsp"
id = 90
description = "CamHaustuer"
audio = false
video = true
url = "rtsp://192.168.xx.xx:8081/live/ch0"
rtsp_user = "xxxx"
    rtsp_pwd = "xxxxx"
videofmtp = "profile-level-id=42E01F;packetization-mode=1"
}
rtsp-CamTerrasse: {
type = "rtsp"
id = 91
description = "CamTerrasse"
audio = false
video = true
url = "rtsp://user:pass@192.168.xx.xx:8081/live/ch0"
videofmtp = "profile-level-id=42e01f;packetization-mode=1"

Bei der zweiten CamTerrase habe ich die URL mal so eigetragen wie es unter Zoneminder lief.

Variante 2 funktioniert jedenfalls nicht, user und pass müssen in den vorgesehenen Variablen übergeben werden (wie in Variante 1 bei dir.)
Im VLC Player für Windows kann man recht gut prüfen, ob die URLs funktionieren. Du könntest mal nachschauen, ob mit den URLs im VLC ein Video kommt. (da kannst du user und pass sogar weglassen, da kommt falls nötig ein Login Fenster) Im VLC "Strg+N" drücken (von den 4 Reitern in dem Fenster "Netzwerk" auswählen) und dort mal deine URLs testen.

Ich habe die Erfahrung gemacht, dass eine falsche Einstellung für einen Stream in der Streaming Config irgendwie die anderen mitreißen kann. Ich würde mich also herantasten, erst mal einen zum Laufen bringen und dann den zweiten dazu.

Viel Glück noch!

Grüße S

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #63 am: 06 Februar 2020, 00:00:51 »
Hallo Sascha

Im Vlc läuft der Stream auf anhiebt natürlich mit Benutzer und Passwort eingabe.
Dein Test Stream läuft leider auch nicht. Aber der Stream geht auch nicht im VLC.
Das mit dem Tipp am PC das nur Edge geht ist schon mal Super ich hätte nur mit Firefox geguckt.

Habe jetzt die Config erst einmal auf ! Stream reduziert. Ich bekomme jetzt folgede Meldungen im LOG

[rtsp-CamHaustuer] New video stream! (ssrc=1952157332, index 0)
Creating new session: 5182987307203176; 0x7f8df80010c0
Creating new handle in session 5182987307203176: 5253337636888115; 0x7f8df80010c0 0x7f8df8001620
[5253337636888115] Creating ICE agent (ICE Full mode, controlling)
[WARN] [5253337636888115] ICE failed for component 1 in stream 1, but let's give it some time... (trickle received, answer received, alert not set)
[5253337636888115] The DTLS handshake has been completed
[janus.plugin.streaming-0x7f8df8001340] WebRTC media is now available
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=1960758513, index 0)
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=1475811090, index 0)
[janus.plugin.streaming-0x7f8df8001340] No WebRTC media anymore
[5253337636888115] WebRTC resources freed; 0x7f8df8001620 0x7f8df80010c0
[5253337636888115] Creating ICE agent (ICE Full mode, controlling)
[WARN] [5253337636888115] ICE failed for component 1 in stream 1, but let's give it some time... (trickle pending, answer received, alert not set)
[ERR] [dtls.c:janus_dtls_retry:1029] [5253337636888115] DTLS taking too much time for component 1 in stream 1...
[janus.plugin.streaming-0x7f8df8001340] No WebRTC media anymore

ICE und DTLS scheinen hier noch ein Problem zu sein. Liegt es vielleicht an einer älteren libnice Version?
Nutzt du das Dockerfile noch so wie im Git?

VG Alex
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #64 am: 06 Februar 2020, 12:26:02 »
Habe heute noch einige Versuche gemacht mit aktueller libnice und auch den Docker Uptodate gebracht (Ubuntu 18.04 usw)
Leider ohne erfolgt.
Die ICE Errors sind nun weg aber der Stream läuft einfach nicht.
Fall Dir noch was einfällt schieß einfach drauf los.
---------------------------------------------------
  Starting Meetecho Janus (WebRTC Server) v0.9.0
---------------------------------------------------
Checking command line arguments...
Debug/log level is 4
Debug/log timestamps are disabled
Debug/log colors are enabled
Adding 'vmnet' to the ICE ignore list...
Using 192.168.xx.xxx as local IP...
[WARN] Token based authentication disabled
itializing recorder code
Initializing ICE stuff (Full mode, ICE-TCP candidates disabled, half-trickle, IPv6 support disabled)
TURN REST API backend: (disabled)
[WARN] Janus is deployed on a private address (192.168.0.10) but you didn't specify any STUN server! Expect trouble if this is supposed to work over the internet and not just in a LAN...
Crypto: OpenSSL >= 1.1.0
[WARN] No cert/key specified, autogenerating some...
Fingerprint of our certificate: A4:56:C1:06:77:7E:AD:03:3D:B2:53:5C:BE:E6:47:C3:A8:17:32:92:72:32:D5:06:EE:C6:A6:E9:B1:F1:55:71
[WARN] Event handlers support disabled
Plugins folder: /opt/janus/lib/janus/plugins
[WARN] Plugin 'libjanus_audiobridge.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_echotest.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_nosip.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_recordplay.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_sip.so' has been disabled, skipping...
Loading plugin 'libjanus_streaming.so'...
Joining Janus requests handler thread
Sessions watchdog started
JANUS Streaming plugin initialized!
[WARN] Plugin 'libjanus_textroom.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_videocall.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_videoroom.so' has been disabled, skipping...
[WARN] Plugin 'libjanus_voicemail.so' has been disabled, skipping...
Transport plugins folder: /opt/janus/lib/janus/transports
Loading transport plugin 'libjanus_http.so'...
HTTP webserver started (port 8088, /janus path listener)...
[WARN] HTTPS webserver disabled
Admin/monitor HTTP webserver started (port 7088, /admin path listener)...
[WARN] Admin/monitor HTTPS webserver disabled
JANUS REST (HTTP/HTTPS) transport plugin initialized!
[WARN] Transport plugin 'libjanus_pfunix.so' has been disabled, skipping...
Loading transport plugin 'libjanus_websockets.so'...
[WARN] libwebsockets has been built without IPv6 support, will bind to IPv4 only
libwebsockets logging: 0
WebSockets server started (port 8188)...
[WARN] Secure WebSockets server disabled
Admin WebSockets server started (port 7188)...
[WARN] Secure Admin WebSockets server disabled
JANUS WebSockets transport plugin initialized!
WebSockets thread started
[rtsp-CamHaustuer] New video stream! (ssrc=1011994142, index 0)
Creating new session: 2687497555481130; 0x7f75f4001320
Creating new handle in session 2687497555481130: 3060060135836127; 0x7f75f4001320 0x7f75f40018e0
[3060060135836127] Creating ICE agent (ICE Full mode, controlling)
[3060060135836127] The DTLS handshake has been completed
[janus.plugin.streaming-0x7f75f40015e0] WebRTC media is now available
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=1237561953, index 0)
[ERR] [ice.c:janus_ice_outgoing_stats_handle:3889] [3060060135836127] Got 1 SRTP/SRTCP errors in the last few seconds (last error: srtp_err_status_replay_fail)
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=228645649, index 0)
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=571133442, index 0)
[janus.plugin.streaming-0x7f75f40015e0] No WebRTC media anymore
[3060060135836127] WebRTC resources freed; 0x7f75f40018e0 0x7f75f4001320
Destroying session 2687497555481130; 0x7f75f4001320
Detaching handle from JANUS Streaming plugin; 0x7f75f40018e0 0x7f75f40015e0 0x7f75f40018e0 0x7f75f4002b00
[3060060135836127] Handle and related resources freed; 0x7f75f40018e0 0x7f75f4001320
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=1011620062, index 0)
[WARN] [rtsp-CamHaustuer] 5s passed with no media, trying to reconnect the RTSP stream
[rtsp-CamHaustuer] Reconnected to the RTSP server, streaming again
[rtsp-CamHaustuer] New video stream! (ssrc=1704636547, index 0)

Muss in den .js Dateien noch was angepasst werden ausser die Ip?
Port oder so?
Evtl Die Apache Einstellungen?
Muss das Docker Netzwerk als Host sein?
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline mrfloppy

  • Full Member
  • ***
  • Beiträge: 178
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #65 am: 06 Februar 2020, 16:16:59 »
Also der Janus aus dem Repo funktioniert!!!

VM in proxmos installiert, docker installiert, repo geclont, docker-compose durchgeführt und gewartet.
Danach im Edge die Seite aufgerufen und das Bunny Video wird einwandfrei abgespielt.

Zur info noch wenn es wer auf einem Tablet versucht.
Es geht eigentlich nur auf Tablets mit einer eigenen GPU wie zb GPU Mali-T628 MP6.

LG Thomas
Fhem 5.9, CCU2, RFXtrx433 E USB, Div. Thermostate, CUL433, Fhemduino, Signalduino, Temp/luftfeuchesensoren,Fensterkontakte,Intertechno Schalter,....... HM-IP

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #66 am: 06 Februar 2020, 17:20:02 »
OK danke für die Info das Bunny Video läuft bei mir auch nicht im VLC
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline Stonemuc

  • Full Member
  • ***
  • Beiträge: 342
    • Baublog WeberHaus Citylife 500
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #67 am: 06 Februar 2020, 22:01:43 »
Welches Docker Image hast du genau genommen? Ich finde diverse janus-gateway images, aber das was du verwendet hast, finde ich auf meinem OMV nicht...
FHEM aus Raspberry PI 3 B+, Haussteuerung auf EnOcean Basis, Tecalor THZ 404eco Wärmepumpe

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #68 am: 06 Februar 2020, 22:19:14 »
Hallo

Ich habe den Docker noch einmal neu gestartet.
Das heißt vom Git ausgecheckt https://github.com/AlpenFlizzer/janus-gateway-docker
in der docker-compose.yml # entfernt um die Demo mit dem Hasen zu bekommen.
Docker erstellt und gestartet.
Danach folgende Fehler im Log und kein Video zu sehen.
Sessions watchdog started
[ERR] [plugins/janus_streaming.c:janus_streaming_rtsp_connect_to_server:5601] Couldn't send DESCRIBE request: Timeout was reached
[ERR] [plugins/janus_streaming.c:janus_streaming_init:1905] Error creating 'rtsp' stream 'rtsp-test'...
JANUS Streaming plugin initialized!

Also eigentlich alles so wie du es auch gemacht hast Thomas.
Wie gesagt der Stream vom Hasen läuft bei mir auch nicht mit VLC

VG Alex
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline mrfloppy

  • Full Member
  • ***
  • Beiträge: 178
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #69 am: 07 Februar 2020, 07:51:07 »
Zitat
in der docker-compose.yml # entfernt um die Demo mit dem Hasen zu bekommen.

habe ich nicht gemacht, sondern so genommen alles wie aus dem Repo.
Fhem 5.9, CCU2, RFXtrx433 E USB, Div. Thermostate, CUL433, Fhemduino, Signalduino, Temp/luftfeuchesensoren,Fensterkontakte,Intertechno Schalter,....... HM-IP

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #70 am: 07 Februar 2020, 13:55:14 »
Ich bekomme den Bunny Stream so oder so einfach nicht zum laufen immer der gleiche Fehler. Und im VLC läuft er auch nicht.
Und wenn der nicht läuft brauche ich glaube ich mit der Kamera erst gar nicht weiter machen.
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #71 am: 11 Februar 2020, 12:57:42 »
Das Problem bei meiner Kamera ist das sie den RTSP-Stream über TCP sendet und nicht über UDP.
Wenn ich es richtig recheriert habe kann Janus nur UDP.

VG Alex
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

Offline SB

  • New Member
  • *
  • Beiträge: 20
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #72 am: 14 Februar 2020, 13:29:20 »
Dieses Detail kannte ich noch gar nicht. Da hatte ich vermutlich "Glück" beim Kamera Kauf.

Inzwischen betreibe ich ohnehin einen extra NVR mit PoE verkabelten Cams. Die Kamerabilder bekomme ich auf einen 13 Zoll Monitor über den HDMI Anschluss des NVR.
"Integrieren" kann man das zwar nicht so 100% aber man kann mit den Alarmeingängen "umschalten", welches Bild gezeigt wird (zB Eventbasiert) oder mittels FTUI Buttons die Bilder durchzappen wie beim Fernsehschauen... :-D

Der Lösung kommt MotionEyeOS zB für den Raspi am nächsten. Siehe auch:
Moin,

nachdem meine uralte China-Foscam gestorben war, bei der man noch direkt den MJPEG-Stream abgreifen konnte, musste etwas neues her. Die neue, billige Ezviz-Cam liefert nur rtsp. Lösung für mich war dann die Installation von motioneye https://github.com/ccrisan/motioneye/wiki auf meinem NUC, auf dem auch FHEM läuft. Funktioniert wunderbar und den umgewandelten Stream konnte ich dann wieder in FTUI/FULLY auf dem Tablet einbinden. Das ganze gibt es auch als komplettes Image (motioneyeos) für den Raspberry.

Gruß Gerrit

Gesendet von meinem ONEPLUS A6013 mit Tapatalk

Gruß, Sascha

PS: Mit dem NVR erlebe ich endlich mal echtes Plug'n'Play ^^

Offline majestro84

  • Full Member
  • ***
  • Beiträge: 327
Antw:Überwachungskamera (RTSP-Stream) in FTUI anzeigen
« Antwort #73 am: 14 Februar 2020, 14:46:29 »
OK danke für deine Antwort.
Motioneye habe ich auch schon ausprobiert allerdings muss ich sagen das Zoneminder für mich besser erscheint. Problem bei der Lösung mit motioneye und Zoneminder ist halt die doch schon hohe Leistungsanforderungen der Software bei drei bis vier Kameras. VG Alex
Server: HP-T610 - Debian 10 aktuellen FHEM-Docker Image:Z-Wave (RollerShutter,DoorWindow,Socket,PIR,....) | ENIGMA2 | EGPM2LAN | BLE-Tag(PRESENCE) | HUE | alexa-fhem | Shelly1&2 | MQTT2
1.Pi-Zero:Viessmann(optolink) mit 89_VCONTROL300.pm
2.Pi3 Dongle Server: Zigbee2MQTT(CC1352P-2), Z-Wave(UZB1), BT

 

decade-submarginal