Autor Thema: Fully Fullscreen Browser für Android  (Gelesen 196247 mal)

Offline topa_LE

  • Jr. Member
  • **
  • Beiträge: 89
Antw:Fully Fullscreen Browser für Android
« Antwort #1155 am: 08 Dezember 2018, 21:12:55 »
Hi Alexey,

nutze deinen Fully auf 3 Tablets. Erst mal vielen Dank, möchte den Full Browser in Verbindung mit FTUI nicht mehr missen.

Vielen Dank dafür!!!

Nun zu mein Problem (hatte hier auch schon gelesen, das User Probleme mit Longpoll haben). Das Problem bemerkte ich erst seit etwa paar Wochen. Starte ich Fully neu oder lösche den Cache, werden die Werte ca. 5 Minuten übertragen/aktualisiert. Danach werden die Werte nicht mehr aktualisiert. Auch die get image (auslösen von Bilder der IP Cam's) sind nicht mehr bedienbar und erstellen keine neuen Bilder. Testweise mit dem Chrome das WebIF am laufen gehabt, alles bestens keine Fehler.

In der index.html hatte ich zuvor nur:
<meta name="longpoll" content="1">
Hab nun mal die zusätzlichen Angaben reingesetzt, mal sehen ob es was bringt.

<meta name="longpoll_filter" content=".*">
<meta name="longpoll_type" content="websocket">
<meta name="longpoll_maxage" content="240">
<meta name="shortpoll_interval" content="15">

Daher vermute ich das deine 1.28.1 mit den Androidversionen irgendeinen Konflikt auslösen.

Folgende Tablet Version laufen auf den Geräten:

webview_version 71.0.3578.83
fully_version 1.28.1
android_version 7.0 (SDK 24)

Hoffe du kannst es nachstellen und findest ein Lösung ...
« Letzte Änderung: 08 Dezember 2018, 21:44:53 von topa_LE »

Offline aloz77

  • Full Member
  • ***
  • Beiträge: 488
Antw:Fully Fullscreen Browser für Android
« Antwort #1156 am: 09 Dezember 2018, 02:53:34 »
Hallo Topa,

du kannst mal testweise eine ältere Version von FKB versuchen:

https://www.ozerov.de/fully-kiosk-browser/files/2018/10/Fully-Kiosk-Browser-v1.27.2.apk
https://www.ozerov.de/fully-kiosk-browser/files/2018/07/Fully-Kiosk-Browser-v1.26.apk

Aber ich tippe darauf, dass das nicht hilft. Das Problem könnte eher durch ein Webview-Update verursacht worden sein. Jedenfalls, alles was Rendering und Scripting betrifft, verantwortet die Android Webview, die auf Android 7 von Google Chrome gestellt wird (wenn Chrome installiert). Fully Kiosk hat kaum Einfluss drauf, wie dort die Prozesse unter der Haube ablaufen.

Und wie bei anderen Android-Komponenten geht der Trend dahin, das Gerät möglichst energiesparend zu betreiben. Das kann dazu führen, dass die langlaufenden Scripte, Sockets etc. möglichst schnell abgeschaltet werden. Das ist jetzt eine Spekulation, aber wenn du das Problem klar reproduzieren kannst, versuch auch mal testweise Chrome deinstallieren/deaktivieren und eine ältere Webview (so um die Version 60) draufzuspielen.

https://www.apkmirror.com/apk/google-inc/android-system-webview/

Gruß Alexey

Offline topa_LE

  • Jr. Member
  • **
  • Beiträge: 89
Antw:Fully Fullscreen Browser für Android
« Antwort #1157 am: 09 Dezember 2018, 11:09:57 »
Hallo Alex,

danke Dir für die Antwort. Ja mit einer älteren wird es scheinbar dann auch nicht mehr gehen. Aber das hätten ja dann auch andere User mit neuen Androidversionen. Man sollte das unten mal ergänzen, als Lösung.

Ich las das mal hier so:

<meta name="longpoll_filter" content=".*">
<meta name="longpoll_type" content="1">
<meta name="longpoll_maxage" content="240">
<meta name="shortpoll_interval" content="15">

in der index.html drin, so funktioniert es erst mal wieder.

Gruß topa

Offline friesenjung

  • Full Member
  • ***
  • Beiträge: 237
Antw:Fully Fullscreen Browser für Android
« Antwort #1158 am: 10 Dezember 2018, 09:41:06 »
Hallo topa,

ich habe seit einiger Zeit ähnliche Probleme und wollte Deinen Tip jetzt ausprobieren.

...
Ich las das mal hier so:

<meta name="longpoll_filter" content=".*">
<meta name="longpoll_type" content="1">
<meta name="longpoll_maxage" content="240">
<meta name="shortpoll_interval" content="15">


Dabei fiel mir auf, dass Du <meta name="longpoll_type" content="1"> verwendest. Ist das ein Schreibfehler? Sollte es nicht <meta name="longpoll" content="1"> <meta name="longpoll_type" content="websocket"> heißen?

Oder ist genau das die wichtige Anpassung/Änderung?

VG
Daniel
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Online sinus61

  • Full Member
  • ***
  • Beiträge: 482
Antw:Fully Fullscreen Browser für Android
« Antwort #1159 am: 26 Dezember 2018, 12:14:15 »
Bei mir hat sich etwas mit der Skalierung getan. Auf dem Tablet wird nicht der gesamte Inhalt eines Dashboard-Tab dargestellt, sondern vergrößert sodass nur ein Teil hinpasst. Man muss jedesmal herauszoomen um alles zu sehen.
Vermutlich liegt es an der Einstellungvon Initial Scale

Hatte das Problem auch gerade. Hab ein neues Tablet mit Android 8 und 1920 x 1200 Auflösung bekommen und das gleiche Verhalten wie oben beschrieben. Obwohl das alte Tablet die gleiche Auflösung hatte, aber dafür eine ältere Android Version. Mit Intial Scale 1 in Fully wurde die FTUI Seite zwar wieder passend angezeigt, aber teilweise sahen die Schriften etwas krakelig aus.

Hab dann mal versucht auf http://viewportsizes.com/mine/ die korrekte Angabe für das Tablet zu finden und die in das Meta-Tag einzutragen, da width=device-width das anscheinend nicht korrekt ermittelt. Dann wird die Seite auch mit den Intial Scale 0, also den Standardeinstellungen in Fully korrekt groß angezeigt, aber die Schriften blieben weiter etwas krakelig.

Am Ende hab ich einfach auf der FTUI Seite die ganze Zeile
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />auskommentiert und jetzt wird alles perfekt in guter Auflösung und klar angezeigt.

Offline cotecmania

  • Sr. Member
  • ****
  • Beiträge: 513
Antw:Fully Fullscreen Browser für Android
« Antwort #1160 am: 26 Dezember 2018, 17:28:43 »
Hallo topa,

ich habe seit einiger Zeit ähnliche Probleme und wollte Deinen Tip jetzt ausprobieren.

Dabei fiel mir auf, dass Du <meta name="longpoll_type" content="1"> verwendest. Ist das ein Schreibfehler? Sollte es nicht <meta name="longpoll" content="1"> <meta name="longpoll_type" content="websocket"> heißen?

Oder ist genau das die wichtige Anpassung/Änderung?

VG
Daniel

Was ist nun richtig und ist das eine Lösung für "eingefrorene" Tablets ?

VG
Joe
FHEM auf RaspberryPI B (jessie)
2xCUL868 für MAX/Slow_RF, HM-LAN, JeeLink
MAX!/HM-Thermostate, FS20/HM-Rolladenschalter, FS20-EM, LevelJet-Ölstandsmessung, PCA301, IT, KM271, IPCAM, ACER Iconia One mit AMAD/FTUI

Offline friesenjung

  • Full Member
  • ***
  • Beiträge: 237
Fully Fullscreen Browser für Android
« Antwort #1161 am: 26 Dezember 2018, 17:37:49 »
Hi, laut Wiki sind die FETT gedruckten richtig.

In meinem Fall hat’s leider nichts gebracht.

Bin noch auf der Suche nach einer Lösung.

Ich vermute, dass bei mir Android (V7) mit seinen div. Energiesparfunktionen das verursacht.

Schritt für Schritt habe ich immer diverse Funktionen deaktiviert. Teils direkt in Android, teils direkt in Fully.

Bis heute leider ohne Erfolg...


Gesendet von iPhone mit Tapatalk
« Letzte Änderung: 26 Dezember 2018, 17:40:57 von friesenjung »
FHEM auf Raspi 2,  Jeelink-Clone 1x für PCA301 und 1x für Lacrosse, THZ304SOL, Homematic: CUL_HM / M-MOD-RPI-PCB, Pushover, Xiaomi s50

Offline topa_LE

  • Jr. Member
  • **
  • Beiträge: 89
Antw:Fully Fullscreen Browser für Android
« Antwort #1162 am: 03 Januar 2019, 17:27:09 »
Hi, laut Wiki sind die FETT gedruckten richtig.

Ja die sind auch richtig, nur funktionierte das bei mir nicht mehr.

Die Änderungen oben von mir war auch nur ein Versuch, der teilweise das Problem beseitigte. Allerdings wird aktuell auch nicht mehr aller 10sek. reloaded. Ist also auch keine fehlerfreie Lösung mehr. Wie Alex oben schon erwähnte, liegt es an den neuen Android-Versionen ab 7 und den Energiesparfunktionen. Irgendwie geht dort am Tablet zu vieles "schlafen". Hab das bei allen 3 Tablets , das Problem.

Wüsste auch nicht, wie ich das beseitigen kann. Eventuell mal probieren Chrome zu deinstallieren und ne alte Webview drauf. Wenn ich Zeit finde, mach ich das mal. 
« Letzte Änderung: 03 Januar 2019, 17:29:15 von topa_LE »

Offline MichaelT

  • Full Member
  • ***
  • Beiträge: 173
Antw:Fully Fullscreen Browser für Android
« Antwort #1163 am: 04 Januar 2019, 13:37:06 »
Hi Alexey,

nutze seit heute 2 mal PLUS. Vielen Dank, möchte den Full Browser in Verbindung mit FTUI nicht mehr missen.

Gruß
Michael
rpi2, 2xHMLAN, 8xHM-LC-BL1-FM, 11xHM-Sec-RHS, 4+HM-LC-Sw2-FM, 5xHM-CC-RT-DN, 3xHM-CC-VD, 2xHM-CC-TC, HM-PBI-4-FM, HM-RC-12-B, 3xHM-TC-IT-WM-W-EU, 2xHM-LC-DIM1T-FM, HM-PB-4DIS-WM-2
externe I/Os (properitär: Heizung, Aussenbereich)

Offline aloz77

  • Full Member
  • ***
  • Beiträge: 488
Antw:Fully Fullscreen Browser für Android
« Antwort #1164 am: 05 Januar 2019, 03:06:35 »
Vielen Dank fürs Feedback. Eine Bewertung bei Google Play ist ebenfalls sehr willkommen.

https://play.google.com/store/apps/details?id=de.ozerov.fully
Zustimmung Zustimmung x 1 Liste anzeigen

Offline hanswerner1

  • Full Member
  • ***
  • Beiträge: 189
Antw:Fully Fullscreen Browser für Android
« Antwort #1165 am: 12 Januar 2019, 13:05:11 »
Hallo Topa,

du kannst mal testweise eine ältere Version von FKB versuchen:

https://www.ozerov.de/fully-kiosk-browser/files/2018/10/Fully-Kiosk-Browser-v1.27.2.apk
https://www.ozerov.de/fully-kiosk-browser/files/2018/07/Fully-Kiosk-Browser-v1.26.apk

Aber ich tippe darauf, dass das nicht hilft. Das Problem könnte eher durch ein Webview-Update verursacht worden sein. Jedenfalls, alles was Rendering und Scripting betrifft, verantwortet die Android Webview, die auf Android 7 von Google Chrome gestellt wird (wenn Chrome installiert). Fully Kiosk hat kaum Einfluss drauf, wie dort die Prozesse unter der Haube ablaufen.

Und wie bei anderen Android-Komponenten geht der Trend dahin, das Gerät möglichst energiesparend zu betreiben. Das kann dazu führen, dass die langlaufenden Scripte, Sockets etc. möglichst schnell abgeschaltet werden. Das ist jetzt eine Spekulation, aber wenn du das Problem klar reproduzieren kannst, versuch auch mal testweise Chrome deinstallieren/deaktivieren und eine ältere Webview (so um die Version 60) draufzuspielen.

https://www.apkmirror.com/apk/google-inc/android-system-webview/

Gruß Alexey


Ich hatte genau das gleiche Problem, nach dem ausschalten des Bildschirm und wieder einschalten wurde der Status nicht mehr aktualisiert. Ich habe ein Lenovo Tab2 10-30 mit Android 6.0.  Das Problem trat erst im Dezember auf.

Ich bin eine Version mit Fully zurückgegangen ohne Effekt. Erst als ich eine ältere Webview Version installiert habe, trat das Problem nicht mehr auf. Bei mir lag es also an Webview, ich habe die Version 68... von August '18 genommen, da das Problem aber erst im Dezember auftrat würde warscheinlich auch eine ältere Version vor Dezember funktionieren.


Nochmal vielen Dank an aloz77 für den Hinweis auf Webview.

 
« Letzte Änderung: 12 Januar 2019, 13:17:53 von hanswerner1 »

Offline Helmi55

  • Sr. Member
  • ****
  • Beiträge: 947
    • Helmi's Fotoseite
Antw:Fully Fullscreen Browser für Android
« Antwort #1166 am: 14 Januar 2019, 18:04:34 »
Guten Abend,
habe jetzt zusätzlich ein Huawei T3 im Einsatz, mit fully plus.
Wenn die Cam eine Bewegung registriert schaltet sie fully ein, aber es läuft zuerst oben der blaue Balken durch?
Ist das ok so. Bei meinem alten LENOVO wurde das Tablet immer durch öffnen der Tür über AMAD aktiviert
Danke
Helmut
System1 fhem 5.9 auf RPi 3B, HMUSBConfig, DS9490R-1Wire, Busware USB 868, Pool-Solarsteuerung mit FHEM. System2 fhem 5.9 auf RPi 3B mit Busware USB 868 und 433 und HMUARTLGW für Haussteuerung

https://www.flickr.com/photos/canonhelmi/album

Offline Stütti

  • Jr. Member
  • **
  • Beiträge: 70
Antw:Fully Fullscreen Browser für Android
« Antwort #1167 am: 14 Januar 2019, 19:30:13 »
Guten Abend,
habe jetzt zusätzlich ein Huawei T3 im Einsatz, mit fully plus.
Wenn die Cam eine Bewegung registriert schaltet sie fully ein, aber es läuft zuerst oben der blaue Balken durch?
Ist das ok so. Bei meinem alten LENOVO wurde das Tablet immer durch öffnen der Tür über AMAD aktiviert
Danke
Helmut
Hallo Helmut,
das verursacht wahrscheinlich die Einstellung "Auto Reload on Screen On" (unter Settings>Web Auto Reload).
Gruß
Stütti
FHEM + FTUI auf Pi 2, NanoCUL 868, SignalESP, ConfigurableFirmataWiFi, ArduCounter für Gas/Wasser/Strom, eBus-Koppler an Vaillant, Jalousien über HM-MOD-Re-8 und Wago Relais, Unterputz-HM-RC-4 (AsksinPP),...

Offline Helmi55

  • Sr. Member
  • ****
  • Beiträge: 947
    • Helmi's Fotoseite
Antw:Fully Fullscreen Browser für Android
« Antwort #1168 am: 14 Januar 2019, 20:08:12 »
Danke dir das wars. Tja unter den vielen settings. Kein Wunder
Aber um ehrlich zu sein, dachte ich diese Einstellung ist notwendig um den screen zu aktualisieren
Gruß
Helmut
System1 fhem 5.9 auf RPi 3B, HMUSBConfig, DS9490R-1Wire, Busware USB 868, Pool-Solarsteuerung mit FHEM. System2 fhem 5.9 auf RPi 3B mit Busware USB 868 und 433 und HMUARTLGW für Haussteuerung

https://www.flickr.com/photos/canonhelmi/album

Offline HoTi

  • Sr. Member
  • ****
  • Beiträge: 749
  • Automatisierungjunky
Antw:Fully Fullscreen Browser für Android
« Antwort #1169 am: 18 Januar 2019, 15:27:42 »
Hallo zusammen,

bei mir läuft Fully seit längern super. Nun habe ich mal mein TabletUI angepasst.

Heute sollte sich das Symbol gelber Sack drehen. Auf dem PC und in Chrome (am Tablet) dreht es sich auch. Aber in Fully nicht. Was könnte ich da falsch gemacht haben?

Hier der TabletUI Code:

                <div data-type="symbol"
                    data-device="abfall"
                    data-get="GelberSack_days"
                    data-icons='["fa-trash warn fa-spin","fa-trash warn"]'
                    data-colors='["yellow","yellow"]'
                    data-get-on='["0","2"]'
                   
                    data-background-colors="lightblue"
                    class="cell large inline" >
                </div>

Vg
Tim
Viele Grüße aus  Oberbayern
Tim (RettungsTim)

Cubian auf Cubitruck (128GB SSD) / FHEM / Arbeite mit Homematic