Autor Thema: ESP gehimmelt und Programierfrage  (Gelesen 10556 mal)

Offline ernst1024

  • Sr. Member
  • ****
  • Beiträge: 597
    • mein youtube
Antw:ESP gehimmelt und Programierfrage
« Antwort #15 am: 04 April 2016, 23:59:53 »
Hallo,

war ein paar Tage mit anderen Dingen beschäftigt, daher die späte Reaktion. Werde die Tips morgen mal ausprobieren und berichten.

Re: Fhem die Arbeit machen lassen. Ja schon, aber ich wollte ein unabhängiges Modul, aber das eine schließt das andere ja nicht aus. Es gibt viel zu experimentieren ....
Gruß Ernst

Offline cs-online

  • Hero Member
  • *****
  • Beiträge: 1240
Antw:ESP gehimmelt und Programierfrage
« Antwort #16 am: 05 April 2016, 11:59:42 »
Hoppla, das stimmt, sorry, hatte das Verzeichnis auf und dann aus dem Browser kopiert...

Danke Friedrich ;-)

Grüße

Christian
FHEM auf RPI 4 4GB, HM-WLAN-Gateway, einige HM-Aktoren, 2x EBUSD an Heizung und Solar, ESP8266 am Strom-, Gas-, Wasserzähler, in WLAN-Steckdosen und Relaisleisten, Sonoff S20, Shelly 1, 2 und 2.5, Lacrosse-Gateway und Sensoren, Signalduino, Alexa-Fhem... und alles auf einem RPI und da geht noch mehr

Offline sbiermann

  • Full Member
  • ***
  • Beiträge: 447
Antw:ESP gehimmelt und Programierfrage
« Antwort #17 am: 06 April 2016, 21:55:23 »
Der ESP8266Flasher hat auch keinen Erfolg gehabt. Bleibt im "Note:Begin find ESP8266." hängen und tut sich nix mehr. Scheint wohl als wenn der Flashspeicher hin ist. Interessanterweise funktioniert der Sketch der drauf ist einwandfrei. Es werden fleißig Daten nach Thingspeak gesendet. Nur Flashen ist nicht mehr möglich.

Offline pink99panther

  • Full Member
  • ***
  • Beiträge: 395
Antw:ESP gehimmelt und Programierfrage
« Antwort #18 am: 06 April 2016, 22:20:45 »
@sbiermann
Aus versehen "serieller Monitor" aus der Arduino IDE oder was ähnliches noch offen?
Daran bin ich auch schon hängen geblieben.  :)

Offline sbiermann

  • Full Member
  • ***
  • Beiträge: 447
Antw:ESP gehimmelt und Programierfrage
« Antwort #19 am: 06 April 2016, 23:26:00 »
Nein, da gibt der Flasher eine Antwort das er den seriellen Port nicht öffnen kann. Das hatte ich eben auch mal. In dem Punkt ist der Flasher sehr redsam.

Offline cs-online

  • Hero Member
  • *****
  • Beiträge: 1240
Antw:ESP gehimmelt und Programierfrage
« Antwort #20 am: 07 April 2016, 07:21:34 »
wird der ESP denn im Windows-Gerätemanager erkannt ? mit wieviel Baut sprichst Du den an ? schon mal versucht mit dem "Esplorer" anzusprechen ? würde mal mit 9600 Baut probieren...
FHEM auf RPI 4 4GB, HM-WLAN-Gateway, einige HM-Aktoren, 2x EBUSD an Heizung und Solar, ESP8266 am Strom-, Gas-, Wasserzähler, in WLAN-Steckdosen und Relaisleisten, Sonoff S20, Shelly 1, 2 und 2.5, Lacrosse-Gateway und Sensoren, Signalduino, Alexa-Fhem... und alles auf einem RPI und da geht noch mehr

Offline sbiermann

  • Full Member
  • ***
  • Beiträge: 447
Antw:ESP gehimmelt und Programierfrage
« Antwort #21 am: 07 April 2016, 08:37:13 »
Es ist kein NodeMCU Board, nur ein reiner ESP12-E. Der FTDI Wandler wird korrekt erkannt und arbeitet auch einwandfrei, ich kann ja meine anderen ESP12-E ohne Probleme flashen. Nur dieser eine den ich zum ausprobieren von Sketches habe ist anscheinend hin. Hier http://internetofhomethings.com/homethings/?p=538 ist das Problem ebenfalls beschrieben und die Lösung den Flashspeicher zu tauschen, aber das lohnt sich nicht wirklich, da bestelle ich mir lieber eine Runde neuer Chips.

Offline Omega-5

  • Full Member
  • ***
  • Beiträge: 402
  • climbing is cool
Antw:ESP gehimmelt und Programierfrage
« Antwort #22 am: 07 April 2016, 12:27:13 »
Hier http://internetofhomethings.com/homethings/?p=538 ist das Problem ebenfalls beschrieben und die Lösung den Flashspeicher zu tauschen, aber das lohnt sich nicht wirklich, da bestelle ich mir lieber eine Runde neuer Chips.

Hallo,

hast du auf der Seite auch mal die Kommentare gelesen? Wenn ich das richtig verstehe sagt der Autor der Seite in Antwort vom 12. Okt. 2015 12:22pm, das es nicht am Flash liegt, sondern am Breadboard-Aufbau. http://internetofhomethings.com/homethings/?p=538#comment-5004
Insbesondere die Spannungsversorgung (Filterkondensatoren) und offene Eingänge am ESP (keine Pullups) scheinen eine Fehlerquelle zu sein. Vergleiche mal den Schaltungsaufbau einer NodeMCU mit deinem Aufbau. Das Problem der Instabilität gab es auch schon beim ESP-01. Bei mir hat da ein Tantal direkt an den Anschlüssen VCC und GND einiges verbessert.
Schau auch mal hier bei locutus: https://forum.fhem.de/index.php/topic,42998.msg359116.html#msg359116

Gruß Friedrich
RaspberryPi2, nanoCUL, 3x DS18B20, FS20: 4x Funk-Schalter ST-4, LaCrosseGW,
HomeMatic: HMLAN, HM-WDS10-TH-O, HM_MYS_RelaisBoard,
I2C: HYT221 über modifiziertes Modul I2_I2C_SHT21.pm (Q&D),

Offline sbiermann

  • Full Member
  • ***
  • Beiträge: 447
Antw:ESP gehimmelt und Programierfrage
« Antwort #23 am: 07 April 2016, 12:40:50 »
Die Kommentare hatte ich glatt nur überflogen. Ist ein interessanter Ansatzpunkt was ich noch testen könnte. Mein bisheriger Schaltungsaufbau ist wie der hier: https://github.com/esp8266/Arduino/blob/master/doc/ESP_improved_stability.png. Allerdings ohne Kondensator, der ist nur bei den ESPs verbaut die ich "produktiv" nutze. Ich werde das mal ausprobieren bzw. schlichtweg mal die Kabel tauschen, sind so billige dünne Chinateile.

Offline Omega-5

  • Full Member
  • ***
  • Beiträge: 402
  • climbing is cool
Antw:ESP gehimmelt und Programierfrage
« Antwort #24 am: 07 April 2016, 13:05:23 »
Mein bisheriger Schaltungsaufbau ist wie der hier: https://github.com/esp8266/Arduino/blob/master/doc/ESP_improved_stability.png. Allerdings ohne Kondensator, der ist nur bei den ESPs verbaut die ich "produktiv" nutze. Ich werde das mal ausprobieren bzw. schlichtweg mal die Kabel tauschen, sind so billige dünne Chinateile.
Die Beschaltung ist so weit in Ordnung. Es geht aber wohl mehr um den Aufbau. Der Autor von IoT erklärt in einem anderen Beitrag noch, dass der wilde Drahtverhau auch nicht zur stabilen Funktion beiträgt.  >:(
http://internetofhomethings.com/homethings/?p=605

Gruß Friedrich
RaspberryPi2, nanoCUL, 3x DS18B20, FS20: 4x Funk-Schalter ST-4, LaCrosseGW,
HomeMatic: HMLAN, HM-WDS10-TH-O, HM_MYS_RelaisBoard,
I2C: HYT221 über modifiziertes Modul I2_I2C_SHT21.pm (Q&D),

Offline sbiermann

  • Full Member
  • ***
  • Beiträge: 447
Antw:ESP gehimmelt und Programierfrage
« Antwort #25 am: 09 April 2016, 08:28:25 »
Sämtliche Kabel getauscht und andere Stromquelle genutzt, hat alles nichts gebracht. Ich hab allerdings festgestellt das der Stromverbrauch auf 100mA ansteigt sobald der GPIO 0 auf GND liegt. Dies war bisher bei allen anderen ESPs die ich schon programmiert habe nicht der Fall. Scheint wohl so als wenn der ESP nicht mehr zu retten wäre, naja ich habe ja noch 6 Stück rumliegen.