Autor Thema: readingsProxy: Keine Aktualisierung von Readings in FHEMWEB (und FLOORPLAN)  (Gelesen 571 mal)

Offline CountAlmasy

  • New Member
  • *
  • Beiträge: 32
Hallo,

ich habe diese Frage ursprünglich im FHEMWEB-Forum gepostet, aber leider keine Antwort erhalten. Vermutlich handelt es sich eher um ein grundsätzliches Problem mit (oder ein Feature von) readingsProxy.

Ich verwende readingsProxy, um die zahlreichen Readings von einem Modbus-Gerät (Sensordaten) als einzelne Geräte verfügbar zu machen. Der Code sieht wie folgt aus:

define Outdoor_Sensor readingsProxy Proxon:Temp_Frischluft
attr Outdoor_Sensor getFn ""
attr Outdoor_Sensor getList %PARENT%
attr Outdoor_Sensor room Außen
attr Outdoor_Sensor valueFn {sprintf("%.1f°C", ReadingsVal("Proxon", "Temp_Frischluft",0))}

Die Readings des ursprünglichen Geräts werden minütlich abgefragt und in FHEMWEB korrekt aktualisiert. Die Readings der abgeleiteten readingsProxy-Geräte werden jedoch nur beim erstmaligen Aufruf der Seite abgefragt und danach nicht mehr aktualisiert.

Ich hatte das bislang so verstanden, dass bei einem Update der Readings des ursprünglichen Geräts die Readings der readingsProxy-Geräte ebenfalls aktualisiert werden. Muss ich da noch etwas konfigurieren?
« Letzte Änderung: 14 Mai 2016, 12:17:45 von CountAlmasy »

Offline Dreamcruise

  • Newbie
  • Beiträge: 2
Hallo,

dein Beitrag steht da seit über einem Jahr. Möglicherweise hat sich das schon erledigt. Es könnte aber sein, dass wir beide eine Heizung der Fa. Zimmermann haben und diese mittels Modbus steuern.
Wenn das so ist, könnten wir unsere Erfahrungen austauschen. Zur Kommunikation verwende ich Modbus und ModbusAttr. Das hat in Verbindung mit der Parameterbeschreibung von Zimmermann auf Anhieb funktioniert.

Gruss Johannes

Offline FHEM_newbie

  • New Member
  • *
  • Beiträge: 5
Hallo Johannes,

habe auch die selbe Heizung, Baujahr 2017 und bisher verzweifelt versucht sie per Modbus anzubinden. Vielleicht kannst Du mir etwas mit deiner Konfiguration auf die Sprünge helfen. Die Anlage ist über einen Digitus Adapter an USB an eine Raspberry Pi angeschlossen und bisher war das einzige was ich hinbekommen habe, das Öffnen des Modbus: State opened. Werte zu lesen oder zu schreiben hat bisher nicht geklappt trotz Parameterliste von Zimmermann.

Schöne Grüße!