FHEM > fhem-users

Wochenplan für FHT setzen

(1/11) > >>

Dr. Boris Neubert:
Hallo @all,

erstmal vorweg ein grosses Lob an Rudolf für seine tolle Arbeit!

Schon lange habe ich mit diversen Funksystemen zum Schalten meiner
Verbraucher gewerkelt bis ich letztens auf das FS20 gestossen bin. Nun
habe ich begonnen mein Haus mit diversen Komponenten auszustatten:
Steckdosen, Dimmer und Heizungssteuerung. Das ganze habe ich seit zwei
Tagen dann auch mit einer FHZ1300 gekoppelt und pgm3 im Einsatz.
Soweit so gut.

Meine FHT80b ist mit 3 Stellventilen sowie zwei Fensterkontakten
gekoppelt. Im pgm3 kann ich dank gnuplot die Graphen gut zur
Information der gemessenen Werte nutzen.

Nun hatte ich den Wochenplan direkt im FHT eingestellt und möchte
diesen jetzt über fhem neu setzen. Hintergrund: meine Frau arbeit
halbtags wöchentlich im Wechsel vor- oder nachmittags. Je nach Woche
soll also unterschiedlich geheizt werden. Da ich diese Anpassungen
nicht händisch machen will, kam mir die Idee das einem cronjob zu
überlassen.

Also habe ich ein Script geschrieben, das ermittelt ob aktuell eine
gerade oder ungerade Woche ist und je nach Ergebnis einen neuen
Wochenplan setzen soll. Dieser job soll dann später wöchentlich
aufgerufen werden, wenn es denn klappen würde :-(

Wenn ich das Script nun starte, werden die Werte scheinbar gesetzt und
auch gesendet (verbose 5). Im Logfile erscheinen auch die Einträge.
Allerdings werden die Werte (*-from1, *-from2, etc) nicht im FHT
gesetzt. Auch im STATEFILE stehen diese Werte nicht. Habe ich evtl.
etwas vergessen?

Auch hatte ich hier gelesen, das evtl. bei zu schneller Befehlfolge
etwas verschluckt wird. Dazu hatte ich das Script auch schon mal mit
"Sleep 1" nach jedem Befehl gebremst; leider ohne Erfolg.

Hier das Script:

#!/bin/bash

let WEEKNR="`date +%V`%2"

WORK="mon tue wed thu fri"
FREE="sat sun"

FHT1="wz_Heizung"

FHEM_BIN="/usr/local/bin/fhem.pl localhost:7072"
CMD="set"

if [ ${WEEKNR} -eq 0 ]; then
        # even = Spätschicht
        for DAY in ${WORK}; do
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from1 08:30"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to1 11:30"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from2 16:30"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to2 22:30"
        done
        for DAY in ${FREE}; do
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from1 08:30"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to1 23:50"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from2 24:00"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to2 24:00"
        done
else
        # odd = Frühschicht
        for DAY in ${WORK}; do
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from1 12:00"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to1 22:30"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from2 24:00"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to2 24:00"
        done
        for DAY in ${FREE}; do
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from1 08:30"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to1 23:50"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-from2 24:00"
                ${FHEM_BIN} "${CMD} ${FHT1} ${DAY}-to2 24:00"
        done
fi

exit 0

Guest:
Originally posted by: <email address deleted>

Hallo,

On Jan 12, 1:43 am, "M.Fischer" wrote:
> Auch hatte ich hier gelesen, das evtl. bei zu schneller Befehlfolge
> etwas verschluckt wird. Dazu hatte ich das Script auch schon mal mit
> "Sleep 1" nach jedem Befehl gebremst; leider ohne Erfolg.

Welche Version hast Du im Einsatz?
"Softwarebuffer for FHT devices" aktiv?
Was sagt "list FHZ" vor und nach dem Aufruf deines Skripts?

Gruß
 Holger



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Dr. Boris Neubert:
hallo holger,

On 12 Jan., 14:07, sweetie-pie wrote:
> Welche Version hast Du im Einsatz?

Server started (version 4.2 from 2007-12-02 ($Id: fhem.pl,v 1.31
2007/11/27 15:17:47 rudolfkoenig Exp $), pid 31413)

> "Softwarebuffer for FHT devices" aktiv?

nein, hatte ich bis eben noch nicht gesetzt... hab's mal enabled..

> Was sagt "list FHZ" vor und nach dem Aufruf deines Skripts?

abe:~ # fhem.pl localhost:7072 "list FHZ"
Internals:
   DEF        /dev/ttyUSB0
   DeviceName /dev/ttyUSB0
   FD         6
   NAME       FHZ
   NR         1
   PARTIAL
   QUEUECNT   0
   STATE      raw 04 01010100010000
   TYPE       FHZ
   Readings:
     2008-01-12 12:00:53   fhtbuf          43
     2008-01-12 12:51:39   init2           1f04a0071c3b40ff
     2008-01-12 12:51:39   serial          136e63ff
   Softbuffer:

abe:~ # /usr/local/src/heizungsplan
abe:~ # fhem.pl localhost:7072 "list FHZ"
Internals:
   DEF        /dev/ttyUSB0
   DeviceName /dev/ttyUSB0
   FD         6
   NAME       FHZ
   NR         1
   PARTIAL
   QUEUECNT   0
   STATE      raw 04 01010100010000
   TYPE       FHZ
   Readings:
     2008-01-12 12:00:53   fhtbuf          43
     2008-01-12 12:51:39   init2           1f04a0071c3b40ff
     2008-01-12 12:51:39   serial          136e63ff
   Softbuffer:

gruß martin
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

rudolfkoenig:
On 12 Jan., 19:43, "M.Fischer" wrote:
> > "Softwarebuffer for FHT devices" aktiv?
>
> nein, hatte ich bis eben noch nicht gesetzt... hab's mal enabled..
>

dabei bin ich dem beispiel aus der command reference gefolgt:

attr FHZ softbuffer 0 # disable the softbuffer for FHT devices
attr FHZ softrepeat 300 # resend failed commands to FHT devices after
300 seconds
attr FHZ softmaxretry 4 # stop resending failed commands to FHT
devices after 4 retries.

allerdings treten dann fehler auf:

2008.01.12 19:46:16 1: Unknown attribute softbuffer, use attr global
userattr (room comment do_not_notify:1,0 dummy
:1,0 filtertimeout repeater:1,0 showtime:1,0 model:fhz1000,fhz1300
loglevel:0,1,2,3,4,5,6 fhtsoftbuffer:1,0)
2008.01.12 19:46:16 1: Unknown attribute softrepeat, use attr global
userattr (room comment do_not_notify:1,0 dummy
:1,0 filtertimeout repeater:1,0 showtime:1,0 model:fhz1000,fhz1300
loglevel:0,1,2,3,4,5,6 fhtsoftbuffer:1,0)
2008.01.12 19:46:16 1: Unknown attribute softmaxretry, use attr global
userattr (room comment do_not_notify:1,0 dum
my:1,0 filtertimeout repeater:1,0 showtime:1,0 model:fhz1000,fhz1300
loglevel:0,1,2,3,4,5,6 fhtsoftbuffer:1,0)

gruß martin
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Dr. Boris Neubert:
                                             

Hallo,

Am Samstag, 12. Januar 2008 schrieb M.Fischer:
> On 12 Jan., 19:43, "M.Fischer" wrote:
> > > "Softwarebuffer for FHT devices" aktiv?
> >
> > nein, hatte ich bis eben noch nicht gesetzt... hab's mal enabled..
>
> dabei bin ich dem beispiel aus der command reference gefolgt:
>
> attr FHZ softbuffer 0 # disable the softbuffer for FHT devices
> attr FHZ softrepeat 300 # resend failed commands to FHT devices after
> 300 seconds
> attr FHZ softmaxretry 4 # stop resending failed commands to FHT
> devices after 4 retries.

sieht aus, als ob die Doku hier nicht der Wirklichkeit entspricht.

fhtsoftbuffer ist das Attribut an der FHZ:
   
   attr myFHZ fhtsoftbuffer 1

retrycount ist das Attribut an der FHT

   attr myFHT retrycount 4

retryafter ist für die FHTs auf 240s hardkodiert.

Grüße,
Boris

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln