FHEM > fhem-users

[FHZ] define at

<< < (3/3)

rudolfkoenig:
Originally posted by: <email address deleted>

Hi,

Martin Haas:
> Wenn das root ist, dann kommt zumindest unter SuSE immer eine
> englische Antwort. So musst du nach einem anderen Wort greppen (z.B:
> printing anstatt druckt).
>
Das ist aber auch sprachspezifisch.

... Test ... die eigentliche Liste ist nicht lokalisiert.

Ich würde einfach sagen

>> if lpq -Pname | grep -qs ^active ; then
       $FHEM "set ..."
   fi

Alternativ kann man auch testen, ob Jobs da sind, aber das schlägt dann
auch bei deaktiviertem Drucker zu:

if [ $(lpq -Pname | wc -l) -gt 2 ] ; then ... ; fi

--
Matthias Urlichs   |   {M:U} IT Design @ m-u-it.de   |  smurf@smurf.noris.de
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
The function of the expert is not to be more right than other people,
but to be wrong for more sophisticated reasons.
      -- Dr. David Butler, British psephologist

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

rudolfkoenig:
                                                   

> ICH KAPITULIERE!

Du doch nicht :-)
Gib mal lpq ohne grep aus...
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Martin Fischer:
hallo rudi und natürlich alle anderen,

Am Samstag, 19. Januar 2008 schrieb Rudolf Koenig:
> > ICH KAPITULIERE!
> Du doch nicht :-)

woher kennst du mich so gut :-) ne, mal ehrlich: geht nicht gibt's nicht!

> Gib mal lpq ohne grep aus...

aaaaalso mal butter bei die fische... manchmal ist man ja sowas von blind, da
wünscht man sich doch tatsächlich einen neuen befehl für fhem.pl:
"set ME off-for-timer 86400"

mein problem war, das ich ROOT_USES_LANG nicht auf ctype hatte... und siehe
da, kaum stellt man es um, ging es auf anhieb.. neeee, wat blöööd.. un dat
mir :-(

danke an alle für ihre zeit! streicht den thread aus euren synapsen :-)

gruß martin

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Martin Fischer:
hi matthias,

Am Samstag, 19. Januar 2008 schrieb Matthias Urlichs:
> > danke für deine anregung! doch das löst das eigentliche problem nicht!
>
> Wieso nicht?

vielleicht habe ich mich nicht richtig ausgedrückt.. ich würde damit mein
problem ja umgehen ohne die ursache des fehlverhalten zu kennen. mir ging es
aber in erster linie darum zu klären, warum es nicht geht. erst wenn die
tatsächliche ursache bekannt wäre, würde ich mir dann deinen vorschlag
ansehen.

> > # set encoding
> > export LANG=de_DE.utf8
> > export LC_CTYPE=de_DE.utf8
>
> Dein Skript kann ich mittels Setzen von LC_ALL problemlos zu
> Fehlverhalten verleiten.

ja, ist soweit auch klar... mein problem war, das ich ROOT_USES_LANG nicht auf
ctype hatte.. somit ist das thema nun erledigt!

danke dir auch nochmal für die anregungen..

gruß martin

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Navigation

[0] Themen-Index

[*] Vorherige Sete

Zur normalen Ansicht wechseln