FHEM > fhem-users

[FHZ] define at

<< < (2/3) > >>

rudolfkoenig:
                                                   

> und nu? also mit utf hat es nichts zu tun, da ich den if auch auf "keine"
> reduzieren kann und trotzdem der at-job alle 25 sec. den befehl ausführt.

Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Martin Fischer:
Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > und nu? also mit utf hat es nichts zu tun, da ich den if auch auf "keine"
> > reduzieren kann und trotzdem der at-job alle 25 sec. den befehl ausführt.
>
> Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
> Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
> Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
> zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).

das mit dem aufruf alle 25 ist ja soweit auch ok.. :-) sonst würde der at ja
nicht greifen..

ok, dann gehe ich nochmal in's gebet und teste.. obwohl ich da kein fehler
sehe und auch env mir sagt, das die umgebung stimmt..

trotzdem danke erstmal!

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Dr. Boris Neubert:
Am Freitag, 18. Januar 2008 schrieb Martin Fischer:
> Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > > und nu? also mit utf hat es nichts zu tun, da ich den if auch auf
> > > "keine" reduzieren kann und trotzdem der at-job alle 25 sec. den befehl
> > > ausführt.
> >
> > Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
> > Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
> > Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
> > zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).
>
> das mit dem aufruf alle 25 ist ja soweit auch ok.. :-) sonst würde der at
> ja nicht greifen..
>
> ok, dann gehe ich nochmal in's gebet und teste.. obwohl ich da kein fehler
> sehe und auch env mir sagt, das die umgebung stimmt..

super.. also irgendwo ist der wurm drin...

nun habe ich alles mögliche ausprobiert und bin aktuell bei matthias' variante
hängengeblieben..

jetzt habe ich genau den umgekehrten fall *uargh* laut verbose 5 wird der at
job auch ausgeführt, doch es passiert absolut nichts...

sowohl ein
define bu.Drucker.timer at +*00:00:25 "lpq -P ml5000a | grep -qs 'druckt' &&
fhem "set bu.Drucker on-for-timer 320""

als auch ein
define bu.Drucker.timer at +*00:00:25 "/usr/local/bin/fhem-cups"

wobei /usr/local/bin/fhem-cups den gleichen inhalt hat wie obiger define at:
#!/bin/bash
lpq -P ml5000a | grep -qs 'druckt' && fhem "set bu.Drucker on-for-timer 320"

wobei /usr/local/bin/fhem nur ein wrapper ist:
#!/bin/bash
/usr/local/bin/fhem.pl 7072 "$*"

die ausgaben von lpq mit und ohne druck-job:
abe:/usr/local/bin # lpq
ml5000a ist bereit und druckt
Rang    Besitz  Auftrag Datei(en)                       Gesamtgröße
active  martin  32      Haussteuerung                   3307520 Byte

abe:/usr/local/bin # lpq
ml5000a ist bereit
keine Einträge

also irgendwas stimmt hier nicht:
ich habe jetzt mal in dem fhem-cups folgendes gemacht:
#!/bin/bash
LPQ=`lpq -P ml5000a | grep 'druckt'`
echo "lpq: $LPQ"
if [ "$LPQ" = "druckt" ]; then
        #/usr/local/bin/fhem "set bu.Drucker on-for-timer 320"
        unset LPQ
fi

wenn ich das in der bash aufrufe klappt es 100%. wird es von dem at-job aus
fhem aufgerufen sieht man im logfile alle 25 sec. das obige echo aber die
variable $LPQ ist leer!:
2008.01.19 00:46:41 4: FHT sc.Heizung actuator: 12%
lpq:
2008.01.19 00:47:08 4: FHT wz.Heizung actuator: 00%
lpq:
lpq:
lpq:
lpq:
2008.01.19 00:48:37 4: FHT sc.Heizung actuator: 12%
lpq:
2008.01.19 00:49:03 4: FHT wz.Heizung actuator: 00%
lpq:
lpq:
lpq:
lpq:

ICH KAPITULIERE!

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

rudolfkoenig:
Originally posted by: <email address deleted>

Hallo,

wie alle anderen auch sagen, kann das nur an deiner Umgebung liegen.

Oben konnte ich nirgends erkennen, ob die fhem auch als user martin
läuft oder als root z.B.
Wenn das root ist, dann kommt zumindest unter SuSE immer eine
englische Antwort. So musst du nach einem anderen Wort greppen (z.B:
printing anstatt druckt).

************************
martin@cpq:~> lpq
hplaserjet ist bereit
keine Einträge
martin@cpq:~> su -
Passwort:
cpq:~ # lpq
hplaserjet is ready
no entries
************************

Grüße,
Martin



On 19 Jan., 02:02, Martin Fischer wrote:
> Am Freitag, 18. Januar 2008 schrieb Martin Fischer:
>
> > Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > > > und nu? also mit utf hat es nichts zu tun, da ich den if auch auf
> > > > "keine" reduzieren kann und trotzdem der at-job alle 25 sec. den befehl
> > > > ausführt.
>
> > > Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
> > > Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
> > > Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
> > > zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).
>
> > das mit dem aufruf alle 25 ist ja soweit auch ok.. :-) sonst würde der at
> > ja nicht greifen..
>
> > ok, dann gehe ich nochmal in's gebet und teste.. obwohl ich da kein fehler
> > sehe und auch env mir sagt, das die umgebung stimmt..
>
> super.. also irgendwo ist der wurm drin...
>
> nun habe ich alles mögliche ausprobiert und bin aktuell bei matthias' variante
> hängengeblieben..
>
> jetzt habe ich genau den umgekehrten fall *uargh* laut verbose 5 wird der at
> job auch ausgeführt, doch es passiert absolut nichts...
>
> sowohl ein
> define bu.Drucker.timer at +*00:00:25 "lpq -P ml5000a | grep -qs 'druckt' &&
> fhem "set bu.Drucker on-for-timer 320""
>
> als auch ein
> define bu.Drucker.timer at +*00:00:25 "/usr/local/bin/fhem-cups"
>
> wobei /usr/local/bin/fhem-cups den gleichen inhalt hat wie obiger define at:
> #!/bin/bash
> lpq -P ml5000a | grep -qs 'druckt' && fhem "set bu.Drucker on-for-timer 320"
>
> wobei /usr/local/bin/fhem nur ein wrapper ist:
> #!/bin/bash
> /usr/local/bin/fhem.pl 7072 "$*"
>
> die ausgaben von lpq mit und ohne druck-job:
> abe:/usr/local/bin # lpq
> ml5000a ist bereit und druckt
> Rang    Besitz  Auftrag Datei(en)                       Gesamtgröße
> active  martin  32      Haussteuerung                   3307520 Byte
>
> abe:/usr/local/bin # lpq
> ml5000a ist bereit
> keine Einträge
>
> also irgendwas stimmt hier nicht:
> ich habe jetzt mal in dem fhem-cups folgendes gemacht:
> #!/bin/bash
> LPQ=`lpq -P ml5000a | grep 'druckt'`
> echo "lpq: $LPQ"
> if [ "$LPQ" = "druckt" ]; then
>         #/usr/local/bin/fhem "set bu.Drucker on-for-timer 320"
>         unset LPQ
> fi
>
> wenn ich das in der bash aufrufe klappt es 100%. wird es von dem at-job aus
> fhem aufgerufen sieht man im logfile alle 25 sec. das obige echo aber die
> variable $LPQ ist leer!:
> 2008.01.19 00:46:41 4: FHT sc.Heizung actuator: 12%
> lpq:
> 2008.01.19 00:47:08 4: FHT wz.Heizung actuator: 00%
> lpq:
> lpq:
> lpq:
> lpq:
> 2008.01.19 00:48:37 4: FHT sc.Heizung actuator: 12%
> lpq:
> 2008.01.19 00:49:03 4: FHT wz.Heizung actuator: 00%
> lpq:
> lpq:
> lpq:
> lpq:
>
> ICH KAPITULIERE!
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Dr. Boris Neubert:
Originally posted by: <email address deleted>

Hi,

Martin Fischer:
> > Machs anders (und sicherer und einfacher):
> >
> >   lpq -P ml5000a | grep -qs 'Muster-wie-ein-Job-Eintrag-aussieht' && fhem
>
> danke für deine anregung! doch das löst das eigentliche problem nicht!
>
Wieso nicht?

> # set encoding
> export LANG=de_DE.utf8
> export LC_CTYPE=de_DE.utf8
>
Dein Skript kann ich mittels Setzen von LC_ALL problemlos zu
Fehlverhalten verleiten.

--
Matthias Urlichs   |   {M:U} IT Design @ m-u-it.de   |  smurf@smurf.noris.de
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
If the rich could pay the poor to die for them, what a living the poor
could make!

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln