Autor Thema: [FHZ] define at  (Gelesen 2065 mal)

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5050
  • Are we just self-replicating DNA?
[FHZ] define at
« am: 17 Januar 2008, 21:14:56 »
hiya,

ganz einfacher at-job:

define bu.Drucker.timer at +*00:00:25   "[[ "$(lpq -P ml5000a | tail -n +2 |
head -n 1)" != "keine Einträge" ]] && fhem.pl localhost:7072 "set bu.Drucker
on-for-timer 320""

zur erklärung:

alle 25 sec soll der timer die queue vom drucker ml5000a abfragen.
wenn wert ungleich "keine Einträge" ist, soll er den Drucker für 320 sec.
anschalten.

obwohl "$(lpq -P ml5000a | tail -n +2 | head -n 1)" gleich "keine Einträge"
ist, führt fhem dennoch den befehl alle 25 sec aus:

2008.01.17 21:03:02 2: FS20 set bu.Drucker on-for-timer 320
2008.01.17 21:03:27 2: FS20 set bu.Drucker on-for-timer 320
2008.01.17 21:03:52 2: FS20 set bu.Drucker on-for-timer 320

in der bash funktioniert dieses ohne probleme!

also irgendwie mag mich fhem.pl nicht oder ich hab's nicht begriffen.

gruß martin

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5050
  • Are we just self-replicating DNA?
[FHZ] Re: define at
« Antwort #1 am: 18 Januar 2008, 08:10:58 »
Originally posted by: <email address deleted>

Hi,

Martin Fischer:
> obwohl "$(lpq -P ml5000a | tail -n +2 | head -n 1)" gleich "keine Einträge"
> ist

Sicher?

Auch mit den Environment-Variablen, die der im Hintergrungd laufende
FHEM hat? Das dürfte entweder Englisch sein, oder ein anderer Code
(d.h. das System liefert UTF-8, aber dein Skript ist in Latin1 kodiert,
oder umgekehrt).

Machs anders (und sicherer und einfacher):

  lpq -P ml5000a | grep -qs 'Muster-wie-ein-Job-Eintrag-aussieht' && fhem ...

--
Matthias Urlichs   |   {M:U} IT Design @ m-u-it.de   |  smurf@smurf.noris.de
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
Aleph-null bottles of beer on the wall,
Aleph-null bottles of beer,
You take one down, and pass it around,
Aleph-null bottles of beer on the wall.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25322
[FHZ] Re: define at
« Antwort #2 am: 18 Januar 2008, 16:09:53 »
hi,

Am Freitag, 18. Januar 2008 schrieb Matthias Urlichs:
> Martin Fischer:
> > obwohl "$(lpq -P ml5000a | tail -n +2 | head -n 1)" gleich "keine
> > Einträge" ist
>
> Sicher?
>
> Auch mit den Environment-Variablen, die der im Hintergrungd laufende
> FHEM hat? Das dürfte entweder Englisch sein, oder ein anderer Code
> (d.h. das System liefert UTF-8, aber dein Skript ist in Latin1 kodiert,
> oder umgekehrt).
>
> Machs anders (und sicherer und einfacher):
>
>   lpq -P ml5000a | grep -qs 'Muster-wie-ein-Job-Eintrag-aussieht' && fhem

danke für deine anregung! doch das löst das eigentliche problem nicht!

ich habe gerade mal folgendes gemacht:

define bu.Drucker.timer at +*00:00:25   "/usr/local/lib/FHEM/scripts/cups"

cups:
#!/bin/bash

# set encoding
export LANG=de_DE.utf8
export LC_CTYPE=de_DE.utf8

LPQ=`lpq -P ml5000a | tail -n +2 | head -n 1`

FHEM_BIN="/usr/local/bin/fhem.pl localhost:7072"

if [ "${LPQ}" != "keine Einträge" ]; then
        ${FHEM_BIN} "set bu.Drucker on-for-timer 320"
fi


das funktioniert in der bash definitiv! probier es mal aus...

fhem.pl macht daraus:
2008.01.18 16:00:53 0: Server started (version =VERS= from =DATE= ($Id:
fhem.pl,v 1.36 2007/12/31 14:43:02 rudolfkoenig Exp $), pid 18529)
2008.01.18 16:01:18 2: FS20 set bu.Drucker on-for-timer 320
2008.01.18 16:01:43 2: FS20 set bu.Drucker on-for-timer 320
2008.01.18 16:02:08 2: FS20 set bu.Drucker on-for-timer 320
2008.01.18 16:03:23 2: FS20 set bu.Drucker on-for-timer 320
2008.01.18 16:03:48 2: FS20 set bu.Drucker on-for-timer 320
2008.01.18 16:04:01 0: Server shutdown

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5050
  • Are we just self-replicating DNA?
[FHZ] Re: define at
« Antwort #3 am: 18 Januar 2008, 16:38:48 »
                                                   

Das ist ziemlich sicher kein fhem Problem. Ich wuerde es an deine
Stelle im script debuggen, z.Bsp mit
env >> /tmp/cups.log
echo $LPQ >> /tmp/cups.log

Rudi

On Jan 18, 4:09 pm, Martin Fischer wrote:
> hi,
>
> Am Freitag, 18. Januar 2008 schrieb Matthias Urlichs:
>
> > Martin Fischer:
> > > obwohl "$(lpq -P ml5000a | tail -n +2 | head -n 1)" gleich "keine
> > > Einträge" ist
>
> > Sicher?
>
> > Auch mit den Environment-Variablen, die der im Hintergrungd laufende
> > FHEM hat? Das dürfte entweder Englisch sein, oder ein anderer Code
> > (d.h. das System liefert UTF-8, aber dein Skript ist in Latin1 kodiert,
> > oder umgekehrt).
>
> > Machs anders (und sicherer und einfacher):
>
> >   lpq -P ml5000a | grep -qs 'Muster-wie-ein-Job-Eintrag-aussieht' && fhem
>
> danke für deine anregung! doch das löst das eigentliche problem nicht!
>
> ich habe gerade mal folgendes gemacht:
>
> define bu.Drucker.timer at +*00:00:25   "/usr/local/lib/FHEM/scripts/cups"
>
> cups:
> #!/bin/bash
>
> # set encoding
> export LANG=de_DE.utf8
> export LC_CTYPE=de_DE.utf8
>
> LPQ=`lpq -P ml5000a | tail -n +2 | head -n 1`
>
> FHEM_BIN="/usr/local/bin/fhem.pl localhost:7072"
>
> if [ "${LPQ}" != "keine Einträge" ]; then
>         ${FHEM_BIN} "set bu.Drucker on-for-timer 320"
> fi
>
> das funktioniert in der bash definitiv! probier es mal aus...
>
> fhem.pl macht daraus:
> 2008.01.18 16:00:53 0: Server started (version =VERS= from =DATE= ($Id:
> fhem.pl,v 1.36 2007/12/31 14:43:02 rudolfkoenig Exp $), pid 18529)
> 2008.01.18 16:01:18 2: FS20 set bu.Drucker on-for-timer 320
> 2008.01.18 16:01:43 2: FS20 set bu.Drucker on-for-timer 320
> 2008.01.18 16:02:08 2: FS20 set bu.Drucker on-for-timer 320
> 2008.01.18 16:03:23 2: FS20 set bu.Drucker on-for-timer 320
> 2008.01.18 16:03:48 2: FS20 set bu.Drucker on-for-timer 320
> 2008.01.18 16:04:01 0: Server shutdown
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2128
    • www.fischer-net.de/
[FHZ] Re: define at
« Antwort #4 am: 18 Januar 2008, 16:58:04 »
Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > ich habe gerade mal folgendes gemacht:
> >
> > define bu.Drucker.timer at +*00:00:25  
> > "/usr/local/lib/FHEM/scripts/cups"
> >
> > cups:
> > #!/bin/bash
> >
> > # set encoding
> > export LANG=de_DE.utf8
> > export LC_CTYPE=de_DE.utf8
> >
> > LPQ=`lpq -P ml5000a | tail -n +2 | head -n 1`
> >
> > FHEM_BIN="/usr/local/bin/fhem.pl localhost:7072"
> >
> > if [ "${LPQ}" != "keine Einträge" ]; then
> >         ${FHEM_BIN} "set bu.Drucker on-for-timer 320"
> > fi

> Das ist ziemlich sicher kein fhem Problem. Ich wuerde es an deine
> Stelle im script debuggen, z.Bsp mit
> env >> /tmp/cups.log
> echo $LPQ >> /tmp/cups.log

ich bin deinem rat gefolgt und habe folgendes ergebnis in cups.log:
gekürzt:
LANG=de_DE.utf8 -> richtig
LC_CTYPE=de_DE.utf8 -> richtig
keine Einträge -> richtig

und nu? also mit utf hat es nichts zu tun, da ich den if auch auf "keine"
reduzieren kann und trotzdem der at-job alle 25 sec. den befehl ausführt.

gruß martin


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25322
[FHZ] Re: define at
« Antwort #5 am: 18 Januar 2008, 17:22:25 »
                                                   

> und nu? also mit utf hat es nichts zu tun, da ich den if auch auf "keine"
> reduzieren kann und trotzdem der at-job alle 25 sec. den befehl ausführt.

Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2128
    • www.fischer-net.de/
[FHZ] Re: define at
« Antwort #6 am: 18 Januar 2008, 17:32:45 »
Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > und nu? also mit utf hat es nichts zu tun, da ich den if auch auf "keine"
> > reduzieren kann und trotzdem der at-job alle 25 sec. den befehl ausführt.
>
> Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
> Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
> Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
> zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).

das mit dem aufruf alle 25 ist ja soweit auch ok.. :-) sonst würde der at ja
nicht greifen..

ok, dann gehe ich nochmal in's gebet und teste.. obwohl ich da kein fehler
sehe und auch env mir sagt, das die umgebung stimmt..

trotzdem danke erstmal!

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5050
  • Are we just self-replicating DNA?
[FHZ] Re: define at
« Antwort #7 am: 19 Januar 2008, 02:02:14 »
Am Freitag, 18. Januar 2008 schrieb Martin Fischer:
> Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > > und nu? also mit utf hat es nichts zu tun, da ich den if auch auf
> > > "keine" reduzieren kann und trotzdem der at-job alle 25 sec. den befehl
> > > ausführt.
> >
> > Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
> > Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
> > Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
> > zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).
>
> das mit dem aufruf alle 25 ist ja soweit auch ok.. :-) sonst würde der at
> ja nicht greifen..
>
> ok, dann gehe ich nochmal in's gebet und teste.. obwohl ich da kein fehler
> sehe und auch env mir sagt, das die umgebung stimmt..

super.. also irgendwo ist der wurm drin...

nun habe ich alles mögliche ausprobiert und bin aktuell bei matthias' variante
hängengeblieben..

jetzt habe ich genau den umgekehrten fall *uargh* laut verbose 5 wird der at
job auch ausgeführt, doch es passiert absolut nichts...

sowohl ein
define bu.Drucker.timer at +*00:00:25 "lpq -P ml5000a | grep -qs 'druckt' &&
fhem "set bu.Drucker on-for-timer 320""

als auch ein
define bu.Drucker.timer at +*00:00:25 "/usr/local/bin/fhem-cups"

wobei /usr/local/bin/fhem-cups den gleichen inhalt hat wie obiger define at:
#!/bin/bash
lpq -P ml5000a | grep -qs 'druckt' && fhem "set bu.Drucker on-for-timer 320"

wobei /usr/local/bin/fhem nur ein wrapper ist:
#!/bin/bash
/usr/local/bin/fhem.pl 7072 "$*"

die ausgaben von lpq mit und ohne druck-job:
abe:/usr/local/bin # lpq
ml5000a ist bereit und druckt
Rang    Besitz  Auftrag Datei(en)                       Gesamtgröße
active  martin  32      Haussteuerung                   3307520 Byte

abe:/usr/local/bin # lpq
ml5000a ist bereit
keine Einträge

also irgendwas stimmt hier nicht:
ich habe jetzt mal in dem fhem-cups folgendes gemacht:
#!/bin/bash
LPQ=`lpq -P ml5000a | grep 'druckt'`
echo "lpq: $LPQ"
if [ "$LPQ" = "druckt" ]; then
        #/usr/local/bin/fhem "set bu.Drucker on-for-timer 320"
        unset LPQ
fi

wenn ich das in der bash aufrufe klappt es 100%. wird es von dem at-job aus
fhem aufgerufen sieht man im logfile alle 25 sec. das obige echo aber die
variable $LPQ ist leer!:
2008.01.19 00:46:41 4: FHT sc.Heizung actuator: 12%
lpq:
2008.01.19 00:47:08 4: FHT wz.Heizung actuator: 00%
lpq:
lpq:
lpq:
lpq:
2008.01.19 00:48:37 4: FHT sc.Heizung actuator: 12%
lpq:
2008.01.19 00:49:03 4: FHT wz.Heizung actuator: 00%
lpq:
lpq:
lpq:
lpq:

ICH KAPITULIERE!

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25322
[FHZ] Re: define at
« Antwort #8 am: 19 Januar 2008, 13:26:36 »
Originally posted by: <email address deleted>

Hallo,

wie alle anderen auch sagen, kann das nur an deiner Umgebung liegen.

Oben konnte ich nirgends erkennen, ob die fhem auch als user martin
läuft oder als root z.B.
Wenn das root ist, dann kommt zumindest unter SuSE immer eine
englische Antwort. So musst du nach einem anderen Wort greppen (z.B:
printing anstatt druckt).

************************
martin@cpq:~> lpq
hplaserjet ist bereit
keine Einträge
martin@cpq:~> su -
Passwort:
cpq:~ # lpq
hplaserjet is ready
no entries
************************

Grüße,
Martin



On 19 Jan., 02:02, Martin Fischer wrote:
> Am Freitag, 18. Januar 2008 schrieb Martin Fischer:
>
> > Am Freitag, 18. Januar 2008 schrieb Rudolf Koenig:
> > > > und nu? also mit utf hat es nichts zu tun, da ich den if auch auf
> > > > "keine" reduzieren kann und trotzdem der at-job alle 25 sec. den befehl
> > > > ausführt.
>
> > > Dass fhem den Skript alle 25 Sekunden aufruft, ist doch völlig in
> > > Ordnung. Was nicht ok ist, dass der "if" im Skript zuschlägt, und ein
> > > Befehl an fhem abgesetzt wird. Das Einzige, was unterschiedlich ist
> > > zwischen manuellen und per-fhem Aufruf ist die Umgebung (env).
>
> > das mit dem aufruf alle 25 ist ja soweit auch ok.. :-) sonst würde der at
> > ja nicht greifen..
>
> > ok, dann gehe ich nochmal in's gebet und teste.. obwohl ich da kein fehler
> > sehe und auch env mir sagt, das die umgebung stimmt..
>
> super.. also irgendwo ist der wurm drin...
>
> nun habe ich alles mögliche ausprobiert und bin aktuell bei matthias' variante
> hängengeblieben..
>
> jetzt habe ich genau den umgekehrten fall *uargh* laut verbose 5 wird der at
> job auch ausgeführt, doch es passiert absolut nichts...
>
> sowohl ein
> define bu.Drucker.timer at +*00:00:25 "lpq -P ml5000a | grep -qs 'druckt' &&
> fhem "set bu.Drucker on-for-timer 320""
>
> als auch ein
> define bu.Drucker.timer at +*00:00:25 "/usr/local/bin/fhem-cups"
>
> wobei /usr/local/bin/fhem-cups den gleichen inhalt hat wie obiger define at:
> #!/bin/bash
> lpq -P ml5000a | grep -qs 'druckt' && fhem "set bu.Drucker on-for-timer 320"
>
> wobei /usr/local/bin/fhem nur ein wrapper ist:
> #!/bin/bash
> /usr/local/bin/fhem.pl 7072 "$*"
>
> die ausgaben von lpq mit und ohne druck-job:
> abe:/usr/local/bin # lpq
> ml5000a ist bereit und druckt
> Rang    Besitz  Auftrag Datei(en)                       Gesamtgröße
> active  martin  32      Haussteuerung                   3307520 Byte
>
> abe:/usr/local/bin # lpq
> ml5000a ist bereit
> keine Einträge
>
> also irgendwas stimmt hier nicht:
> ich habe jetzt mal in dem fhem-cups folgendes gemacht:
> #!/bin/bash
> LPQ=`lpq -P ml5000a | grep 'druckt'`
> echo "lpq: $LPQ"
> if [ "$LPQ" = "druckt" ]; then
>         #/usr/local/bin/fhem "set bu.Drucker on-for-timer 320"
>         unset LPQ
> fi
>
> wenn ich das in der bash aufrufe klappt es 100%. wird es von dem at-job aus
> fhem aufgerufen sieht man im logfile alle 25 sec. das obige echo aber die
> variable $LPQ ist leer!:
> 2008.01.19 00:46:41 4: FHT sc.Heizung actuator: 12%
> lpq:
> 2008.01.19 00:47:08 4: FHT wz.Heizung actuator: 00%
> lpq:
> lpq:
> lpq:
> lpq:
> 2008.01.19 00:48:37 4: FHT sc.Heizung actuator: 12%
> lpq:
> 2008.01.19 00:49:03 4: FHT wz.Heizung actuator: 00%
> lpq:
> lpq:
> lpq:
> lpq:
>
> ICH KAPITULIERE!
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Offline Dr. Boris Neubert

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 5050
  • Are we just self-replicating DNA?
[FHZ] Re: define at
« Antwort #9 am: 19 Januar 2008, 14:44:38 »
Originally posted by: <email address deleted>

Hi,

Martin Fischer:
> > Machs anders (und sicherer und einfacher):
> >
> >   lpq -P ml5000a | grep -qs 'Muster-wie-ein-Job-Eintrag-aussieht' && fhem
>
> danke für deine anregung! doch das löst das eigentliche problem nicht!
>
Wieso nicht?

> # set encoding
> export LANG=de_DE.utf8
> export LC_CTYPE=de_DE.utf8
>
Dein Skript kann ich mittels Setzen von LC_ALL problemlos zu
Fehlverhalten verleiten.

--
Matthias Urlichs   |   {M:U} IT Design @ m-u-it.de   |  smurf@smurf.noris.de
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
If the rich could pay the poor to die for them, what a living the poor
could make!

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
Globaler Moderator, Developer, aktives Mitglied des FHEM e.V. (Marketing, Verwaltung)
Bitte keine unaufgeforderten privaten Nachrichten!

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25322
[FHZ] Re: define at
« Antwort #10 am: 19 Januar 2008, 14:54:17 »
Originally posted by: <email address deleted>

Hi,

Martin Haas:
> Wenn das root ist, dann kommt zumindest unter SuSE immer eine
> englische Antwort. So musst du nach einem anderen Wort greppen (z.B:
> printing anstatt druckt).
>
Das ist aber auch sprachspezifisch.

... Test ... die eigentliche Liste ist nicht lokalisiert.

Ich würde einfach sagen

>> if lpq -Pname | grep -qs ^active ; then
       $FHEM "set ..."
   fi

Alternativ kann man auch testen, ob Jobs da sind, aber das schlägt dann
auch bei deaktiviertem Drucker zu:

if [ $(lpq -Pname | wc -l) -gt 2 ] ; then ... ; fi

--
Matthias Urlichs   |   {M:U} IT Design @ m-u-it.de   |  smurf@smurf.noris.de
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
The function of the expert is not to be more right than other people,
but to be wrong for more sophisticated reasons.
      -- Dr. David Butler, British psephologist

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25322
[FHZ] Re: define at
« Antwort #11 am: 19 Januar 2008, 20:27:52 »
                                                   

> ICH KAPITULIERE!

Du doch nicht :-)
Gib mal lpq ohne grep aus...
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2128
    • www.fischer-net.de/
[FHZ] Re: define at
« Antwort #12 am: 19 Januar 2008, 23:45:52 »
hallo rudi und natürlich alle anderen,

Am Samstag, 19. Januar 2008 schrieb Rudolf Koenig:
> > ICH KAPITULIERE!
> Du doch nicht :-)

woher kennst du mich so gut :-) ne, mal ehrlich: geht nicht gibt's nicht!

> Gib mal lpq ohne grep aus...

aaaaalso mal butter bei die fische... manchmal ist man ja sowas von blind, da
wünscht man sich doch tatsächlich einen neuen befehl für fhem.pl:
"set ME off-for-timer 86400"

mein problem war, das ich ROOT_USES_LANG nicht auf ctype hatte... und siehe
da, kaum stellt man es um, ging es auf anhieb.. neeee, wat blöööd.. un dat
mir :-(

danke an alle für ihre zeit! streicht den thread aus euren synapsen :-)

gruß martin

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2128
    • www.fischer-net.de/
[FHZ] Re: define at
« Antwort #13 am: 19 Januar 2008, 23:51:23 »
hi matthias,

Am Samstag, 19. Januar 2008 schrieb Matthias Urlichs:
> > danke für deine anregung! doch das löst das eigentliche problem nicht!
>
> Wieso nicht?

vielleicht habe ich mich nicht richtig ausgedrückt.. ich würde damit mein
problem ja umgehen ohne die ursache des fehlverhalten zu kennen. mir ging es
aber in erster linie darum zu klären, warum es nicht geht. erst wenn die
tatsächliche ursache bekannt wäre, würde ich mir dann deinen vorschlag
ansehen.

> > # set encoding
> > export LANG=de_DE.utf8
> > export LC_CTYPE=de_DE.utf8
>
> Dein Skript kann ich mittels Setzen von LC_ALL problemlos zu
> Fehlverhalten verleiten.

ja, ist soweit auch klar... mein problem war, das ich ROOT_USES_LANG nicht auf
ctype hatte.. somit ist das thema nun erledigt!

danke dir auch nochmal für die anregungen..

gruß martin

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

 

decade-submarginal