FHEM > fhem-users

[FHZ] FHZ 1300 PC mit openNAS

(1/4) > >>

Guest:
Originally posted by: <email address deleted>

Hallo.

Habe hier ein "kleineres" Problem. Versuche FHEM auf einem NAS
(Longshine 8311) mit der Linux-Variante openNAS ans laufen zu
bekommen. Mein Problem ist, das ich jetzt php, perl und fhem auf dem
NAS habe, aber wohl die falsche Version von Device:SerialPort (1.002).
Jedenfalls erhalte ich im Log beim Start des Servers folgende
Fehlermeldung:
2008.01.20 16:48:32 3: FHZ opening FHZ device /proc/tty/driver/usb-
serial
Invalid signature in /proc/tty/driver/usb-serial: usbserinfo:1.0
driver:v1.4
 at /usr/local/lib/FHEM/00_FHZ.pm line 214
2008.01.20 16:48:32 1: Can't open /proc/tty/driver/usb-serial:
Ich hoffe mal das die aktuellere Version 1.04 diese Problem nicht mehr
macht, nur habe ich keine Ahnung wie ich Sie kompilieren soll, denn
auf dem NAS gehts nicht:
Running ./configure ...
./configure: ./configure.lineno: line 466: expr: not found
The 'configure' script didn't like something.
Kann mir Einer dabei mal unter die Arme greifen?
Danke
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

rudolfkoenig:
                                                   

Das Problem hat nicht mit dem Modul zu tun, es liegt daran, dass /proc/
tty/driver/usb-serial als Konfigurationsfile der Device::SerialPort
angesehen wird weil es kein character-device ist. Du  musst das FHZ-
Device in /dev suchen und nicht im /proc

Gruss,
  Rudi

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Guest:
Originally posted by: <email address deleted>

Das Problem ist nur: in /dev/tty... steht nichts und ändert sich
nichts!
ich bin ja überhaupt kein Linux-Guru, aber ich vermute mal das /dev/..
in openNAS ein read-only Verzeichnis ist das im Flash-ROM steht.

Gruss Jörg

On 21 Jan., 09:42, Rudolf Koenig wrote:
> Das Problem hat nicht mit dem Modul zu tun, es liegt daran, dass /proc/
> tty/driver/usb-serial als Konfigurationsfile der Device::SerialPort
> angesehen wird weil es kein character-device ist. Du  musst das FHZ-
> Device in /dev suchen und nicht im /proc
>
> Gruss,
>   Rudi
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

rudolfkoenig:
                                                   

> ich bin ja überhaupt kein Linux-Guru, aber ich vermute mal das /dev/..
> in openNAS ein read-only Verzeichnis ist das im Flash-ROM steht.

Das mit read-only glaube ich erst nach einem Beweis :-) Versuch mal
eine Datei anzulegen, z.Bsp mit
 mknod /dev/elv_fhz1000 c 188 0
fhem braucht definitiv ein "device", d.h. etwas was im ls -l so
aehnlich ausschaut:
crw-rw----  1 root tty 188, 0 2008-01-21 18:05 /dev/elv_fhz1300pc
Ob auf dem openNAS es 188 und 0 sein muss, da bin ich nicht sicher.

Gruss,
  Rudi
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Guest:
Originally posted by: <email address deleted>

Hi,

Rudolf Koenig:
> Ob auf dem openNAS es 188 und 0 sein muss, da bin ich nicht sicher.

Jedenfalls muss in /proc/devices stehen:
188 ttyUSB

(ob 188 oder nicht ist zweitrangig) genau diese Zahl darfst du als erste
im "mknod"-Befehl verwenden.

Falls /dev/ wirklich readonly ist, dann leg die Gerätedatei woanders an ...

Falls du diese Zeile nicht findest, hilft ein "modprobe ftdi_sio".

--
Matthias Urlichs   |   {M:U} IT Design @ m-u-it.de   |  smurf@smurf.noris.de
Disclaimer: The quote was selected randomly. Really. | http://smurf.noris.de
 - -
Beware of entrance to a quarrel; but being in, bear it that the opposer may
beware of thee.
               -- Shakespeare

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "FHZ1000 users on Linux" group.
To post to this group, send email to FHZ1000-users-on-unix@googlegroups.com
To unsubscribe from this group, send email to FHZ1000-users-on-unix-unsubscribe@googlegroups.com
For more options, visit this group at http://groups.google.com/group/FHZ1000-users-on-unix?hl=en
-~----------~----~----~----~------~----~------~--~-

Navigation

[0] Themen-Index

[#] Nächste Seite

Zur normalen Ansicht wechseln