Autor Thema: RFXTRX nur mehr opened  (Gelesen 5373 mal)

Offline drdownload

  • Sr. Member
  • ****
  • Beiträge: 753
RFXTRX nur mehr opened
« am: 10 Mai 2016, 07:21:37 »
Hi,

in letzter Zeit kommt auf einmal täglich der Fall vor, dass der RFXTRX im WebIf nur noch als opened angezeigt wird und auch nicht mehr reagiert. Erst ein reboot bringt ihn wieder auf initalized. Eingebunden ist er by-name
CUL 868 Slow-RF (FS20 Aktoren, Sender, FHT8V), CUL 868 (WMBUS-Empfang), Jeelink (PCA301), WS3600 (WH3080 über USB-Basis), Bewässerung mit ESP-Easy und Proplanta, RFXTRX433 Home-Easy Empfang und Senden, Oregon TH, WS001 TH), Blackbean IR, Mopidy-Snapcast MR Audio, Kodi, Forum-LED-Controller,

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 593
Antw:RFXTRX nur mehr opened
« Antwort #1 am: 15 Mai 2016, 21:32:45 »
Ich habe die Initialisierung vom RFXTRX433 im TRX-Modul überarbeitet.
Bitte probiere morgen mal ein update von fhem, damit Du die neuen Module hast.

Dabei den RFXTRX433 bitte ohne nonit initialisieren. Bei Problemen, bitte die log posten.
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline drdownload

  • Sr. Member
  • ****
  • Beiträge: 753
Antw:RFXTRX nur mehr opened
« Antwort #2 am: 22 Mai 2016, 08:26:30 »
*aufholzklopf* bis jetzt seit dem update kein disconnect mehr.
lg
CUL 868 Slow-RF (FS20 Aktoren, Sender, FHT8V), CUL 868 (WMBUS-Empfang), Jeelink (PCA301), WS3600 (WH3080 über USB-Basis), Bewässerung mit ESP-Easy und Proplanta, RFXTRX433 Home-Easy Empfang und Senden, Oregon TH, WS001 TH), Blackbean IR, Mopidy-Snapcast MR Audio, Kodi, Forum-LED-Controller,

Offline drdownload

  • Sr. Member
  • ****
  • Beiträge: 753
Antw:RFXTRX nur mehr opened
« Antwort #3 am: 31 Mai 2016, 09:21:24 »
Weiter auf Holz klopf ;) - sieht gut aus. Gibt es eigentlich eine gute Möglichkeit den RFXTRX wieder zu initalisieren wenn man ihn zwischendurch abgesteckt hat vom USB zb für den RFXMgr?
CUL 868 Slow-RF (FS20 Aktoren, Sender, FHT8V), CUL 868 (WMBUS-Empfang), Jeelink (PCA301), WS3600 (WH3080 über USB-Basis), Bewässerung mit ESP-Easy und Proplanta, RFXTRX433 Home-Easy Empfang und Senden, Oregon TH, WS001 TH), Blackbean IR, Mopidy-Snapcast MR Audio, Kodi, Forum-LED-Controller,

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2736
Antw:RFXTRX nur mehr opened
« Antwort #4 am: 31 Mai 2016, 10:19:03 »
Ein "reconnect" sollte automatisch erkannt werden. Ein modify, also DEF der internals im Frontend anklicken, müsste ihn aber spätestens zum reconnect bewegen.
Grüße, Markus
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline drdownload

  • Sr. Member
  • ****
  • Beiträge: 753
Antw:RFXTRX nur mehr opened
« Antwort #5 am: 28 Juni 2016, 11:58:01 »
Leider fängt es jetzt wieder an dass täglich der rfx auf open steht und nur durch kompletten Reboot wieder geht
CUL 868 Slow-RF (FS20 Aktoren, Sender, FHT8V), CUL 868 (WMBUS-Empfang), Jeelink (PCA301), WS3600 (WH3080 über USB-Basis), Bewässerung mit ESP-Easy und Proplanta, RFXTRX433 Home-Easy Empfang und Senden, Oregon TH, WS001 TH), Blackbean IR, Mopidy-Snapcast MR Audio, Kodi, Forum-LED-Controller,

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2736
Antw:RFXTRX nur mehr opened
« Antwort #6 am: 29 Juni 2016, 11:52:19 »
Ich hatte die Tage auch mal Probleme.  :( Jetzt läuft es wieder einwandfrei.  :)
Ich spekuliere bei mir auf irgendeinen "Wackler" in der Rpi - USB-Kabel - USB-Hub - USB-Kabel - RFXTRX Kette. Zum Glück checke ich den RFXTRX-state  alle 5s über ReadingsAge, dass der nicht älter als 30s ist und alarmiere dann per Telefon. War eigentlich zum Erkennen von jamming gedacht, tut für den Ausfall aber bestens !
Grüße, Markus
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline ext23

  • Hero Member
  • *****
  • Beiträge: 2742
    • Homepage
Antw:RFXTRX nur mehr opened
« Antwort #7 am: 30 Juni 2016, 11:03:03 »
Moin,

ich habe auch beide meine RFXtrx433 auf die neue FW1005 geflashed und jetzt leuchten sie nur noch rot und werden als opened angezeigt.

UPDATE: Ein kompletter Reboot scheint es wirklich zu beheben. Was das denn... Anziehen und Stecken muss doch reichen. Ich kann ja nicht jedes mal mein ganzen Server neu starten. Mhh

/Daniel
« Letzte Änderung: 30 Juni 2016, 11:07:00 von ext23 »
HM, FS20, 1-Wire, PanStamp, AVR-NET-IO, SIS-PM, EM1000EM, PCA301, EC3000, HM-LAN, CUL868, RFXtrx433, LGW, DMX @Ubuntu-Server (Hauptsystem) & Raspberry Pi (Satellit)

Offline Rince

  • Hero Member
  • *****
  • Beiträge: 2640
Antw:RFXTRX nur mehr opened
« Antwort #8 am: 14 September 2016, 16:41:43 »
Hatte das gleiche Problem.
Habe den rfxtrx mit der Serial definiert.

Beim Einstecken meckert fhem, dass es das Device nicht öffnen kann (im Logfile).
Wer zu meinen Posts eine Frage schreibt und auf eine Antwort wartet, ist hiermit herzlich eingeladen mich per PN darauf aufmerksam zu machen. (Bitte mit Link zum betreffenden Thread)

Offline wing350

  • Jr. Member
  • **
  • Beiträge: 52
Antw:RFXTRX nur mehr opened
« Antwort #9 am: 21 Oktober 2016, 14:27:02 »
Die gleichen Probleme hatte ich auch in der letzten Zeit.
Die Qualität des USB-Kabels (z.B. mit Ferritring) ist anscheinend ganz wichtig. Auch eine aktive USB-Verlängerung macht gerne Probleme, aber etliche Hänger beim Initialisieren habe ich nicht klären können.
Was jetzt anscheinend eine relativ durchschlagende Wirkung hatte, war, als ich die Transceiver auf einem entfernten Raspi mit ser2net eingebunden habe und auf dem FHEM-Rechner  den RFXTRX über eine virtuelle Schnittstelle mit socat angebunden habe.

Der CUL/Jeelink konnten auch über <IP:Port> definiert werden. Mit der Definition des RFXTRX über <IP:Port> wurde der auch nur als 'opened' angezeigt.

Die Lösung mit socat scheint dauerhaft zu funktionieren. Allerdings habe ich auch noch einen Watchdog definiert, der den Transceiver über einen reopen-Befehl sicher initialisiert.

Änderung:
mit 'noinit' in der Definition des RFXTRX klappts jetzt auch per <IP:Port>!

Reimer
« Letzte Änderung: 21 Oktober 2016, 14:43:27 von wing350 »
RaspberryPi, Jessie-VM auf QNAP, FHEM 5.7, CUL868, 8 FHTs, FHT8w, ca. 20 div. in-/outdoor FS-Aktoren sowie diverse Fernbedienungen u. Programmer, 2 S300TH, RFXtrx433, TFA 30.31.50, TFA 303139,
Jeelink-Clone, PCA301, FBDECT

Offline nonamenogame

  • New Member
  • *
  • Beiträge: 25
Antw:RFXTRX nur mehr opened
« Antwort #10 am: 12 Dezember 2016, 22:05:05 »
Hier bei mir das gleiche Problem.

Ich habe einen Cubieboard 4 als FHEM Hauptinstanz und ein 4 Fach USB HUB dran, daran hängen 2 Jeelinks und der RFX.

Irgendwie scheint da der Wurm drin zu sein. Ich habe Anfansg auch meist rebooted und gut wards, mit der Zeit wurde e s mir aber zu doof.

Folgendes Vorgehen bringt alle diese Devices wieder in Normalzustand.

dmesg| grep tty und das höchste USB device abstöpseln - bei der jeelink für PCA301, danach dann sukzessive den jeelink Lacrosse und am Schluss den RFX.

NAch 3 Sekunden dann wieder in umgekehrter Reihenfolge einstecken, schwupps, geht wieder.

Ich kann meine ganzen Problemchen noch nicht wirklich lokaliseren, da ich die Tage meine FBH Steuerung notgedrungen umstellen mußte. Da tickert jetzt ein HM-Mod-8 dran, funktionierte erst, als ich den CUL868 auf Homematic umstellte (vermutlich wegen dem Burst, der für das MOD8 nötig ist) und seitdem ging mir der HMLAN öfter auf Mute.

Ich habe erst letze Woche den Cubietruck gegen den 4er ersetzt und auf DBlog umgestellt, alles in allem gerade ziemlich dynamisch meine Installation, das macht es ja für mich so schwer, den Dingen genau auf den Grund zu gehen. Wer weiss wie lange der Winter dauert, wenn er denn erst überhaupt kommt, dann finde ich vlt noch etwas Zeit mich darum näher zu kümmern. Bis dahin hilft mir der Watchdog, zumindest relativ zeitnah ne Stöpselaktion durchzuführen.

Viele Grüße

Offline Dittel

  • Sr. Member
  • ****
  • Beiträge: 516
Antw:RFXTRX nur mehr opened
« Antwort #11 am: 20 August 2017, 18:36:11 »
Kann mir mal jemand erklären, was genau "opened" im Status bedeutet? Ist nur der Port geöffnet oder konnte der Stick hier schon erkannt werden. Ich habe nach Jahren der stabilen Funktion aus heiterem Himmel das Problem, daß die Verbindung verloren geht und nur noch "opened" im STATE steht. Die LED ist dann auch aus und es hilft nur ein neueinstecken des USB Kabels und ein "reopen" in FHEM.
#ehemaliger EZ XS1 User

Offline Moonraker1

  • New Member
  • *
  • Beiträge: 13
Antw:RFXTRX nur mehr opened
« Antwort #12 am: 26 August 2017, 17:24:04 »
Hallo zusammen,

ich habe ebenfalls das Problem, dass der RFXTRX433E sich nur noch mit 'opened' meldet.
Im logfile gibt es die bekannte Meldung:
  2017.08.26 17:09:43 3: Opening RFXTRX433 device /dev/RFXtrx433
  2017.08.26 17:09:43 3: Setting RFXTRX433 serial parameters to 38400,8,N,1
  2017.08.26 17:09:45 4: TRX_ReadAnswer arg:Clear
  2017.08.26 17:09:47 1: TRX: Initialization Error: No character read
  2017.08.26 17:09:47 1: Cannot init /dev/RFXtrx433, ignoring it (RFXTRX433)
Das Ganze passiert interessanterweise erst, seit ich das BS neu installiert habe von Ubuntu 12.04 LTS auf 16.04 LTS.

Im dmesg wird der 433 jedoch als völlig richtig erkannt gezeigt:

  [    1.820616] usb 1-2: new full-speed USB device number 2 using xhci_hcd
  [    2.029622] usb 1-2: New USB device found, idVendor=0403, idProduct=6001
  [    2.036275] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  [    2.042743] usb 1-2: Product: RFXtrx433
  [    2.049082] usb 1-2: Manufacturer: RFXCOM
  [    2.055161] usb 1-2: SerialNumber: A1R10O0
  [    2.177270] usb 1-4: new full-speed USB device number 3 using xhci_hcd
  [    2.306506] usb 1-4: New USB device found, idVendor=8087, idProduct=07dc
  [    2.306718] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
  [    5.436920] usbcore: registered new interface driver btusb
  [    6.200777] Modules linked in: bnep btusb btrtl btbcm btintel bluetooth intel_rapl intel_soc_dts_iosf intel_powerclamp coretemp kvm_intel iwlmvm(+) snd_hda_codec_hdmi mac80211 kvm irqbypass iwlwifi punit_atom_debug crct10dif_pclmul     snd_hda_codec_realtek crc32_pclmul snd_hda_codec_generic ghash_clmulni_intel cryptd cfg80211 serio_raw lpc_ich snd_hda_intel snd_hda_codec shpchp snd_hda_core mei_txe mei snd_hwdep ir_lirc_codec lirc_dev ir_xmp_decoder ir_mce_kbd_decoder ir_sharp_decoder ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder ir_nec_decoder 8250_fintek rc_rc6_mce ite_cir snd_soc_rt5640 rc_core snd_intel_sst_acpi snd_soc_rl6231 snd_intel_sst_core snd_soc_sst_mfld_platform snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_seq_midi snd_seq_midi_event snd_pcm snd_rawmidi
  [    6.270242] usbcore: registered new interface driver usbserial
  [    6.270265] usbcore: registered new interface driver usbserial_generic
  [    6.270287] usbserial: USB Serial support registered for generic
  [    6.357510] usbcore: registered new interface driver ftdi_sio
  [    6.358280] usbserial: USB Serial support registered for FTDI USB Serial Device
  [    6.493656] usb 1-2: Detected FT232RL
  [    6.527986] usb 1-2: FTDI USB Serial Device converter now attached to ttyUSB 0

Im RFXmanager am PC wird er richtig erkannt und liefert auch sauber die Werte von z.B. einem Energiesensor OWL160.

Firmware war die 1006, habe ich jetzt auf die 1020 upgedate, hilft aber nix.

vG

Olli
NUC mit Ubuntu, MAX!Cube über LAN, 1 MAX WT, 8 MAX HT, 2 MAX Fensterkontakt, MaxScanner, HM CCU2 mit Homematic HT's, div. Schaltern, Bewegungsmelder, Ökofen Pelletheizung über httpmod

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2736
Antw:RFXTRX nur mehr opened
« Antwort #13 am: 27 August 2017, 08:30:49 »
Zitat
/dev/RFXtrx433
  :o
definier ihn mal by-id: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_DEINESERIAL-if00-port0@38400
Grüße Markus
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline Dittel

  • Sr. Member
  • ****
  • Beiträge: 516
Antw:RFXTRX nur mehr opened
« Antwort #14 am: 27 August 2017, 11:56:50 »
... ich hatte den auch testweise "by id" definiert, hat bei mir keinen unterschied gemacht. zeitweise flog der stick raus und ließ sich nicht reinitialisieren. ich habe jetzt mal die die ports vom usb hub durchgetauscht und seit zwei tagen ist ruhe.
#ehemaliger EZ XS1 User