Autor Thema: [gelöst] knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)  (Gelesen 5083 mal)

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 240
Hallo zusammen!

Ich versuche gerade auf meinem Raspberry Pi B+ FHEM mit knxd und dem KNX IP Interface SCN-IP100.02 in Betrieb zu nehmen!
knxd habe gemäß dieser Anleitung (http://www.fhemwiki.de/wiki/Knxd) installiert.
Bei mir läuft ETS parallel dazu, aber es werden ja mehrere Verbindungen parallel vom IP-Interface unterstützt.

Bei der Prüfung des knxd-Status erhalte ich folgende Fehlermeldung:
pi@raspberrypi:~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Fri 2016-03-25 20:39:19 CET; 2s ago
  Process: 576 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
 Main PID: 576 (code=exited, status=1/FAILURE)

Leider hilft dieses Thread mir nicht weiter: https://forum.fhem.de/index.php?topic=50189.0
Habe auch die Optionen "ipt:" und "ip:" probiert. Und bei der Eingabe von "knxd -t1023 -c -u /tmp/eib -b ipt:192.168.100.<xxx>", sieht es jedoch so aus, als wäre eine Verbindung da!
pi@raspberrypi:~ $ sudo knxd -t1023 -c -u /tmp/eib -b ipt:192.168.100.250
Layer 3(00526C60,56F5BAAC) Open
Layer 4(005371E0,56F5BAAC) GroupCacheInit
Layer 3(00526C60,56F5BAAC) registerLayer2 005371E0
Layer 3(00526C60,56F5BAAC) registerLayer2 005371E0 = 1
Layer 4(005371E0,56F5BAAC) GroupCacheEnable
Layer 8(00537450,56F5BAAC) OpenLocalSocket /tmp/eib
Layer 8(00537450,56F5BAAC) LocalSocket opened
Layer 2(00547968,56F5BAAC) Open
Layer 0(00547E38,56F5BAAC) Open
Layer 0(00547E38,56F5BAAC) Openend
Layer 2(00547968,56F5BAAC) Opened
Layer 3(00526C60,56F5BAAC) registerLayer2 00547968
Layer 3(00526C60,56F5BAAC) registerLayer2 00547968 = 1
W00000020: EIBD should not run as root
Layer 3(00526C60,56F5BAAC) L3 started
Layer 1(00547E38,56F5BAAC) Send(020): 08 01 C0 A8 64 6E 0E 58 08 01 C0 A8 64 6E 0E 58 04 04 02 00
Layer 0(00547E38,56F5BAAC) Send(026): 06 10 02 05 00 1A 08 01 C0 A8 64 6E 0E 58 08 01 C0 A8 64 6E 0E 58 04 04 02 00
Layer 0(00547E38,56F5BAAC) Recv(020): 06 10 02 06 00 14 46 00 08 01 C0 A8 64 FA 0E 57 04 04 11 FA
Layer 1(00547E38,56F5BAAC) Recv(014): 46 00 08 01 C0 A8 64 FA 0E 57 04 04 11 FA
Layer 0(00547E38,56F5BAB4) Recv(023): 06 10 04 20 00 17 04 46 00 00 29 00 BC E0 11 1F 23 09 03 00 80 00 1E
Layer 1(00547E38,56F5BAB4) Recv(017): 04 46 00 00 29 00 BC E0 11 1F 23 09 03 00 80 00 1E
Layer 1(00547E38,56F5BAB4) Send(004): 04 46 00 00
Layer 0(00547E38,56F5BAB4) Send(010): 06 10 04 21 00 0A 04 46 00 00
Layer 1(00547968,56F5BAB4) Recv L_Data low from 1.1.31 to 4/3/9 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00 1E
Layer 3(00526C60,56F5BAB4) Enqueue L_Data low from 1.1.31 to 4/3/9 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00 1E
Layer 3(00526C60,56F5BAB4) RecvData L_Data low from 1.1.31 to 4/3/9 hops: 05 T_DATA_XXX_REQ A_GroupValue_Write 00 1E
Layer 0(00547E38,56F5BABE) Recv(023): 06 10 04 20 00 17 04 46 01 00 29 00 BC E0 11 1F 23 11 03 00 80 00 00
Layer 1(00547E38,56F5BABE) Recv(017): 04 46 01 00 29 00 BC E0 11 1F 23 11 03 00 80 00 00
Layer 1(00547E38,56F5BABE) Send(004): 04 46 01 00
Layer 0(00547E38,56F5BABE) Send(010): 06 10 04 21 00 0A 04 46 01 00
Layer 1(00547968,56F5BABE) Recv L_Data low from 1.1.31 to 4/3/17 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00 00
Layer 3(00526C60,56F5BABE) Enqueue L_Data low from 1.1.31 to 4/3/17 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00 00
Layer 3(00526C60,56F5BABE) RecvData L_Data low from 1.1.31 to 4/3/17 hops: 05 T_DATA_XXX_REQ A_GroupValue_Write 00 00
Layer 0(00547E38,56F5BABE) Recv(023): 06 10 04 20 00 17 04 46 02 00 29 00 BC E0 11 1F 23 06 03 00 80 02 BC
Layer 1(00547E38,56F5BABE) Recv(017): 04 46 02 00 29 00 BC E0 11 1F 23 06 03 00 80 02 BC
Layer 1(00547E38,56F5BABE) Send(004): 04 46 02 00
Layer 0(00547E38,56F5BABE) Send(010): 06 10 04 21 00 0A 04 46 02 00
Layer 1(00547968,56F5BABE) Recv L_Data low from 1.1.31 to 4/3/6 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 02 BC
Layer 3(00526C60,56F5BABE) Enqueue L_Data low from 1.1.31 to 4/3/6 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 02 BC
Layer 3(00526C60,56F5BABE) RecvData L_Data low from 1.1.31 to 4/3/6 hops: 05 T_DATA_XXX_REQ A_GroupValue_Write 02 BC
Layer 0(00547E38,56F5BABE) Recv(023): 06 10 04 20 00 17 04 46 03 00 29 00 BC E0 11 1F 23 09 03 00 80 00 14
Layer 1(00547E38,56F5BABE) Recv(017): 04 46 03 00 29 00 BC E0 11 1F 23 09 03 00 80 00 14
Layer 1(00547E38,56F5BABE) Send(004): 04 46 03 00
Layer 0(00547E38,56F5BABE) Send(010): 06 10 04 21 00 0A 04 46 03 00
Layer 1(00547968,56F5BABE) Recv L_Data low from 1.1.31 to 4/3/9 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00 14
Layer 3(00526C60,56F5BABE) Enqueue L_Data low from 1.1.31 to 4/3/9 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00 14
Layer 3(00526C60,56F5BABE) RecvData L_Data low from 1.1.31 to 4/3/9 hops: 05 T_DATA_XXX_REQ A_GroupValue_Write 00 14
Layer 0(00547E38,56F5BAC0) Recv(023): 06 10 04 20 00 17 04 46 04 00 29 00 BC E0 11 16 22 06 03 00 80 07 D5
Layer 1(00547E38,56F5BAC0) Recv(017): 04 46 04 00 29 00 BC E0 11 16 22 06 03 00 80 07 D5
Layer 1(00547E38,56F5BAC0) Send(004): 04 46 04 00
Layer 0(00547E38,56F5BAC0) Send(010): 06 10 04 21 00 0A 04 46 04 00
Layer 1(00547968,56F5BAC0) Recv L_Data low from 1.1.22 to 4/2/6 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 07 D5
Layer 3(00526C60,56F5BAC0) Enqueue L_Data low from 1.1.22 to 4/2/6 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 07 D5
Layer 3(00526C60,56F5BAC0) RecvData L_Data low from 1.1.22 to 4/2/6 hops: 05 T_DATA_XXX_REQ A_GroupValue_Write 07 D5
Layer 0(00547E38,56F5BAC5) Recv(022): 06 10 04 20 00 16 04 46 05 00 29 00 BC E0 11 16 22 07 02 00 80 0D
Layer 1(00547E38,56F5BAC5) Recv(016): 04 46 05 00 29 00 BC E0 11 16 22 07 02 00 80 0D
Layer 1(00547E38,56F5BAC5) Send(004): 04 46 05 00
Layer 0(00547E38,56F5BAC5) Send(010): 06 10 04 21 00 0A 04 46 05 00
Layer 1(00547968,56F5BAC5) Recv L_Data low from 1.1.22 to 4/2/7 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 0D
Layer 3(00526C60,56F5BAC5) Enqueue L_Data low from 1.1.22 to 4/2/7 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 0D
Layer 3(00526C60,56F5BAC5) RecvData L_Data low from 1.1.22 to 4/2/7 hops: 05 T_DATA_XXX_REQ A_GroupValue_Write 0D

Aber ich bekomme in FHEM keine Verbindung! Sobald ich die KNX-Schnittstelle hinzufüge, kann ich schon nicht mehr die Seite aufrufen!
2016.03.25 23:37:52 1: Including fhem.cfg
2016.03.25 23:37:53 3: WEB: port 8083 opened
2016.03.25 23:37:53 3: WEBphone: port 8084 opened
2016.03.25 23:37:53 3: WEBtablet: port 8085 opened
2016.03.25 23:37:54 2: eventTypes: loaded 0 events from ./log/eventTypes.txt
2016.03.25 23:37:54 1: Including ./log/fhem.save
2016.03.25 23:37:54 2: SecurityCheck:  WEB,WEBphone,WEBtablet has no basicAuth attribute.  Restart FHEM for a new check if the problem is fixed, or set the global attribute motd to none to supress this message.
2016.03.25 23:37:54 0: Featurelevel: 5.7
2016.03.25 23:37:54 0: Server started with 7 defined entities (version $Id: fhem.pl 9893 2015-11-15 08:43:05Z rudolfkoenig $, os linux, user fhem, pid 429)
2016.03.25 23:39:57 1: Including fhem.cfg
2016.03.25 23:39:58 3: WEB: port 8083 opened
2016.03.25 23:39:58 3: WEBphone: port 8084 opened
2016.03.25 23:39:58 3: WEBtablet: port 8085 opened
2016.03.25 23:39:58 2: eventTypes: loaded 0 events from ./log/eventTypes.txt
2016.03.25 23:39:58 3: TUL opening KNX device eibd:localhost
2016.03.25 23:39:58 3: TUL device opened
eibd communication failed
openGroupSocket failed
2016.03.25 23:44:35 1: Cannot init eibd:localhost, ignoring it
2016.03.25 23:44:35 1: define KNX TUL eibd:localhost 1.1.100: 1
2016.03.25 23:44:35 1: Including ./log/fhem.save
2016.03.25 23:44:36 0: Server shutdown

Könnt ihr mir bitte helfen!

Vielen Dank und viele Grüße
NehCoy
« Letzte Änderung: 29 Mai 2016, 11:00:38 von NehCoy »

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 240
Antw:knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)
« Antwort #1 am: 26 März 2016, 00:00:32 »
Okay! - Das Problem befand sich wieder einmal zwischen Tastatur und Stuhllehne!
Das "eibd" nicht funktioniert, wenn ich "knxd" installiere hätte mir auffallen müssen. ::)

Nun steht wenigsten in der Übersicht
TUL
KNX  Initialized

Aber funktionieren tut es dennoch nicht.  :-[ - Im Logfile ist folgendes zu finden:
2016.03.25 23:50:27 3: TUL opening KNX device knxd:localhost
2016.03.25 23:50:27 1: knxd:localhost protocol is not supported

Was mache ich jetzt noch falsch?

Danke und Grüße
NehCoy
« Letzte Änderung: 26 März 2016, 00:12:32 von NehCoy »

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)
« Antwort #2 am: 26 März 2016, 07:36:29 »
Morgen!

Ich denke, ich hatte das gleiche Problem. Probiere:

sudo systemctl stop knxd.service
sudo systemctl stop knxd.socket
sudo systemctl start knxd.service

Wenn ich recht habe, geht's dann. Nach einem Neustart wieder nicht.

Siehe:
https://forum.fhem.de/index.php/topic,48230.0.html

Grüße, Andi

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)
« Antwort #3 am: 26 März 2016, 07:43:48 »
Ach so, vergessen:

In Vorbereitung für den KNXD noch sämtliche Spuren des EIBD aus dem System löschen - Google hilft.
UND - ganz wichtig: Die TUL kenn keinen knxd. Bitte in der FHEM immer eibd stehen lassen.

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 240
Antw:knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)
« Antwort #4 am: 26 März 2016, 19:47:34 »
Hallo Andi291!

Den Deamon stoppen und starten hat leider nicht geholfen:
pi@raspberrypi:~ $ sudo systemctl stop knxd.service
Warning: Stopping knxd.service, but it can still be activated by:
  knxd.socket
pi@raspberrypi:~ $ sudo systemctl stop knxd.socket
pi@raspberrypi:~ $ sudo systemctl stop knxd.service
pi@raspberrypi:~ $ sudo systemctl start knxd.service
Job for knxd.service failed. See 'systemctl status knxd.service' and 'journalctl -xn' for details.
pi@raspberrypi:~ $ systemctl status knxd.service
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sat 2016-03-26 19:38:46 CET; 5s ago
  Process: 685 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
 Main PID: 685 (code=exited, status=1/FAILURE)

Bin gerade dabei das System komplett neu auzusetzen, um damit alles auf den aktuellen Stand zu bringen und alte "Bastelleichen" los zu werden. eibd war nie auf dem System installiert und somit gibt es auch keine "Spuren", die Ursache des Problems sein könnten. :(

Den TUL habe ich wieder auf eibd umgestellt, obwohl FHEM damit hängen bleibt und ich kann nicht einmal die Webseite aufrufen kann. Muss mich dann um die Fehlerursache bei knxd kümmern ... Oder macht es Sinn, alles nochmal zurück auf Anfang und eibd zu nehmen?

Grüße
NehCoy

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)
« Antwort #5 am: 26 März 2016, 20:02:32 »
Ne, das wird auch nicht besser, wenn EIBD vorher gelaufen ist :-P

Ich fahr mit den Parametern recht stabil:

KNXD_OPTS="-e 1.0.240 -c -u /tmp/eib -b ipt:192.168.x.x"

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 240
Antw:knxd auf Raspberry Pi B+ mit KNX MDT IP Interface (SCN-IP100.02)
« Antwort #6 am: 28 März 2016, 15:01:09 »
Ich meinte doch nur eibd, ohne knxd... Weder davor, noch danach. ;-)

Habe die KNXD_OPTS in der /etc/knxd.conf  geändert und die Geräte- und IP-Adresse auf mein IP Interface angepasst.
Tut' net! :-(
$ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Mon 2016-03-28 14:56:55 CEST; 5s ago
  Process: 602 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=1/FAILURE)
 Main PID: 602 (code=exited, status=1/FAILURE)

Grüße
NehCoy

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 240
Hallo zusammen,

erstmal Entschuldigung für die späte Rückmeldung, aber ich komme erst jetzt wieder dazu an diesem Thema weiterzuarbeiten.
Beim erstmaligen Prüfen des Status, sah alles gut aus:
pi@raspberrypi:~ $ sudo nano /etc/knxd.conf
pi@raspberrypi:~ $ /etc/init.d/knxd status
? knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Thu 2016-05-26 23:54:01 CEST; 9min ago
 Main PID: 22945 (knxd)
   CGroup: /system.slice/knxd.service
           +-22945 /usr/bin/knxd -u /tmp/eib -b ip:
(Hinweis: Die Parameter "-u /tmp/eib -b ip:" sind die Standardwerte nach der Installation!)
Nach einem Reboot das gleiche Problem, wie zuvor auch.
Habe dann beim Suchen diesen Beitrag gefunden und ebenfalls den Parameter "-i" entfernt. Aber auch dies hat nicht geholfen.

Summa-Summarum hat sich das Fehlerbild leider nicht geändert.

Hast jemand noch einen weiteren Tipp?

Vielen Dank und viele Grüße
NehCoy




Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 240
Hallo zusammen!

Keine Ahnung, was bisher immer falsch gelaufen ist.
Im x-ten Anlauf klappt es nun ohne Probleme! - Mit den Parametern, die Andi291 bereits schon vor Monaten gepostet hat.

Danke & Grüße
NehCoy

 

decade-submarginal