Autor Thema: Netatmo Modul - 38_netatmo.pm (Support)  (Gelesen 271694 mal)

Offline Karflyer

  • Full Member
  • ***
  • Beiträge: 203
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1155 am: 14 Dezember 2020, 10:09:36 »
Hallo Markus,

hast du auf der 'Roadmap' den Rauchmelder von netatmo in dein Modul einzupflegen?

Grüße
Stefan

Offline Gisbert

  • Hero Member
  • *****
  • Beiträge: 2372
  • Das Ziel ist das Ziel !
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1156 am: 04 Januar 2021, 17:49:31 »
Hallo,

seit gestern oder heute, genauer kann ich's im Moment nicht sagen, bekomme ich keine Updates von öffentlich zugänglichen Sensoren mehr.

Gibt es kürzliche Änderungen bei dem Anzapfen von öffentlichen Sensoren, von denen ich noch nichts mitbekommen habe?

Viele​ Grüße​ Gisbert​
Aktuelles FHEM | HP ThinClient T610 | Debian11 | UniFi-Controller, AP, USG-3 | Homematic, VCCU, HMUART | ESP8266, Eigenbau | Gas-, Wasser-, Stromzähler | Sonoff | 1-Wire-Temperatursensoren | Wlan-Kamera | SIGNALduino, Flamingo Rauchmelder FA21/22RF |  Heizungssteuerung komplett in FHEM

Offline Xell1984

  • Full Member
  • ***
  • Beiträge: 171
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1157 am: 20 Januar 2021, 07:42:04 »
Webhook mit Nginx, letsencrypt und htpasswd

Falls jemand wie ich davor steht und nicht weiß was er tun muss  bei der oben genannten Kombination

Fhem Instanz ohne passwort, in meinem Fall Port 8089. Hab es leider nicht mit passwort geschützten Instanz plus passwort nginx hinbekommen. Aber so geht's ja auch.

In der nginx configuration habe ich folgendes hinterlegt bei der SSL Weiterleitung

Server Name meineweiterleitung.anbieter.de
Proxy_pass http://meinefhemip:fhemport/fhem/netatmo

Bei dev.netatmo und webhook URL

Htpps://htpasswduser:htpasswd@meineweiterleitung.anbieter.de:443

Wichtig ist das der Port dahinter steht. So geht's bei mir in der oben genannten Kombination.

Evtl geht's noch anders, hab jedoch im try and error Verfahren und Recherche 10 Stunden bis zur Lösung gebraucht 🙄

Gruß
« Letzte Änderung: 20 Januar 2021, 09:25:09 von Xell1984 »
Razpberry on Raspberry Pi 3 mit Raspian Jessy

Offline grappa24

  • Sr. Member
  • ****
  • Beiträge: 991
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1158 am: 09 Februar 2021, 16:02:39 »
ist zwar OT hier aber vlt hat ja jemand eine Idee:

Ich hatte "vorübergehend" ein zweites Innenmodul installiert aber dann wieder entfernt. Aus FHEM bekomme ich es ohne Probleme heraus, aber nicht aus der Android-App bzw. von meinem Netatmo Konto. (Wie) kann man denn ein "Haus" löschen bzw. das entspr. Modul? Der Weg in der App über "Haus steuern" - "Innen" - "Löschen" läuft auf einen Fehler.

Gruß
grappa24/Dieter
FHEM 6.1, 2 x RasPi 3B+, Debian Buster; KNX, FS20, HM, HUE, Tradfri, Shellies, KLF200
Rollo-/Lichtsteuerung/-szenarien, T-Sensoren, Fensterkontakte, Heizungssteuerung, HEOS, Sprachsteuerung mit Alexa-FHEM, Netatmo, ...

Offline Gisbert

  • Hero Member
  • *****
  • Beiträge: 2372
  • Das Ziel ist das Ziel !
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1159 am: 27 Februar 2021, 09:51:40 »
Hallo,

ich bekomme keine Updates von öffentlich zugänglichen Sensoren mehr:
Zitat
2021.02.27 09:00:33 2:  netatmo_D70_ee_50_20_80_d8: getmeasure request failed: api.netatmo.com: Connection timed out (110)
...
2021.02.27 09:23:15 1:  myNETATMOWetter: connection check failed: connect to https://api.netatmo.com:443 timed out

Wie kann ich vorgehen, um den Fehler einzugrenzen?

Wenn ich https://api.netatmo.com:443 eingebe, erhalte ich "404 Not Found"

Viele​ Grüße​ Gisbert​
Aktuelles FHEM | HP ThinClient T610 | Debian11 | UniFi-Controller, AP, USG-3 | Homematic, VCCU, HMUART | ESP8266, Eigenbau | Gas-, Wasser-, Stromzähler | Sonoff | 1-Wire-Temperatursensoren | Wlan-Kamera | SIGNALduino, Flamingo Rauchmelder FA21/22RF |  Heizungssteuerung komplett in FHEM

Offline tomcat.x

  • Full Member
  • ***
  • Beiträge: 167
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1160 am: 27 Februar 2021, 11:18:01 »
Ich denke nicht, dass der Fehler bei Dir liegt. Bei mir im Log sehe in den letzten Stunden die gleichen Timeouts, allerdings bekomme ich aktuell Daten für meine Sensoren. Der letzte Timeout war um 09:27:05. Im Browser bekomme ich bei der Adresse auch nichts angezeigt, bin aber nicht sicher, ob das sonst der Fall ist. Ich denke mal, das ist nicht die vollständige URL, mit der ein Aufruf erfolgt, sondern wird nur gekürzt im Log angezeigt.
FHEM: 5.9 auf Raspi 3, Raspbian (Buster), Perl v5.28.1
Sender/Empfänger: 2 x CULv3, Duofern Stick
Gateways: FRITZ!Box 6591 (OS: 7.12), HomeMatic LAN, Trädfri
Sensoren/Aktoren: FRITZ!DECT, FS20, FHT, HMS, HomeMatic, Trädfri, DuoFern, NetAtmo

Offline RappaSan

  • Sr. Member
  • ****
  • Beiträge: 591
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1161 am: 27 Februar 2021, 11:23:59 »
Hier das gleiche. Letztes update heute um 8:43. >:(

Offline Gisbert

  • Hero Member
  • *****
  • Beiträge: 2372
  • Das Ziel ist das Ziel !
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1162 am: 27 Februar 2021, 20:10:07 »
Hallo tomcat.x

kurz nachdem ich meinen Beitrag von heute morgen schrieben hatte, kamen wieder Daten rein. Das scheint bzw. schien dann wohl ein Problem bei netatmo zu sein.
Merke beim nächsten Mal: Etwas Geduld du haben musst, dann netatmo dir wohl gesonnen sein wird ;D

Viele Grüße Gisbert
Aktuelles FHEM | HP ThinClient T610 | Debian11 | UniFi-Controller, AP, USG-3 | Homematic, VCCU, HMUART | ESP8266, Eigenbau | Gas-, Wasser-, Stromzähler | Sonoff | 1-Wire-Temperatursensoren | Wlan-Kamera | SIGNALduino, Flamingo Rauchmelder FA21/22RF |  Heizungssteuerung komplett in FHEM

Offline Newbee

  • Full Member
  • ***
  • Beiträge: 163
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1163 am: 12 April 2021, 12:20:55 »
Hallo Markus,

ich möchte gerne das Thema Thermostate nochmal aufgreifen. Aktuell ist es im Modul so implementiert, das bei folgendem set:

set netatmo_Txx_xx_xx_xx_xx_xx setpoint_temp 12 Grad das Raumthermostat ein manuellen boost für x min. (x min. ist die Zeit die Standard mäßig in der Netatmo APP hinterlegt ist) durchführt. Laut netatmo api, zumindest habe ich es so verstanden, sollte das aber auch für die Thermostat Ventile funktionieren. Wenn ich aber bei einem Ventil nun setpoint_temp 12 Grad setze, dann wird wieder das Raumthermostat auf einen manuelle Boost gestellt.

Könntest Du Dir das bei Gelegenheit mal anschauen, würde eine vorab Version dann auch testen können falls Du keine Thermostate/Ventile hast.

Vielen Dank.

Gruß Mark

Intel-NUC mit ubuntu server 20.04; FHEM 6.0
HM, Dect, Netatmo, Hue

Offline ulobo60

  • Full Member
  • ***
  • Beiträge: 115
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1164 am: 28 April 2021, 15:48:48 »
Bei mir taucht seit heute Vormittag ca. 10:00 Uhr ein Verbindungsfehler des 'netatmo'-Devices auf: "netatmo LOGIN FAILED"
Unter 'status' steht 'invalid_grant'.
Im log finde ich massig Einträge wie "No access token was found!"

Das log wird zügig zugemüllt. Je Sekunde 2mal versucht das Modul, sich mit dem netatmo-Server zu verbinden.
Hier ein Ausschnitt aus dem log:
2021.04.28 15:25:31 1: netatmo: No access token was found! (getDevices)
2021.04.28 15:25:31 1: netatmo: No access token was found! (getHomecoachs)
2021.04.28 15:25:31 1: netatmo: No access token was found! (getDevices)
2021.04.28 15:25:31 1: netatmo: No access token was found! (getHomecoachs)
2021.04.28 15:25:32 1: netatmo: No access token was found! (getDevices)
2021.04.28 15:25:32 1: netatmo: No access token was found! (getHomecoachs)
2021.04.28 15:25:32 1: netatmo_weathermap: No access token was found! (getPublicDevices)
2021.04.28 15:25:32 0: Featurelevel: 6
2021.04.28 15:25:32 0: Server started with 42 defined entities (fhem.pl:23904/2021-03-07 perl:5.020002 os:linux user:fhem pid:539)
2021.04.28 15:26:01 1: 192.168.178.1:1012 reappeared (FritzCallmon)
2021.04.28 15:27:01 1: netatmo: No access token was found! (getDevices)
2021.04.28 15:27:02 1: netatmo: No access token was found! (getHomecoachs)
2021.04.28 15:27:02 1: netatmo_indoor60: No access token was found! (requestDeviceReadings)
2021.04.28 15:27:03 1: netatmo: No access token was found! (getDevices)

Ich vermute mal, dass es leider wieder mal am netatmo-Server liegt !!!

Da nach ca. 1/2 Stunde das gesamte FHEM-System dank der Belastung brach liegt, würde ich gern das netatmo-Modul für ein paar Stunden abschalten.
Könnte mir bitte jemand schreiben, wie ich das am Sinnvollsten mache?
Ich selbst könnte nur die netatmo-Devices in der fhem.cfg auskommentieren und später die Auskommentierung wieder aufheben. Oder gibt es die Möglichkeit, durch Aufruf eines Parameters die Verbindungsversuche von derzeit 2mal/Sec. auf 1mal für alle 3 Stunden zu setzen?

P.S.: meine "auskommentieren Idee" in der .cfg ist wohl Schwachsinn, da ja sicher beim Install eines Devices viel Code in die unterschiedlichsten FHEM-Dateien geschrieben wird. Ich müßte wohl die netatmo-Devices löschen und später neu anlegen. Davor graust es mir aber wirklich. Wäre schön, wenn jemand sich hiermit auskennen würde und mir Hilfe geben könnte...
« Letzte Änderung: 28 April 2021, 18:05:14 von ulobo60 »
2x raspi + cam-Modul mit mmal-motion - 3x raspi mit KODI - 1x raspi mit FHEM + FTUI

Offline tomcat.x

  • Full Member
  • ***
  • Beiträge: 167
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1165 am: 28 April 2021, 18:36:19 »
Bei dem (Account) Device gibt es doch Attribute "interval" und "disable". Funktionieren die nicht? Ich habe übrigens keine Verbindungsprobleme.
FHEM: 5.9 auf Raspi 3, Raspbian (Buster), Perl v5.28.1
Sender/Empfänger: 2 x CULv3, Duofern Stick
Gateways: FRITZ!Box 6591 (OS: 7.12), HomeMatic LAN, Trädfri
Sensoren/Aktoren: FRITZ!DECT, FS20, FHT, HMS, HomeMatic, Trädfri, DuoFern, NetAtmo

Offline ulobo60

  • Full Member
  • ***
  • Beiträge: 115
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1166 am: 28 April 2021, 23:00:42 »
Klasse Hinweise, tomcat.x !
Mit dem Attribut "disable" = 1 habe ich meine 5 netatmo-devices erst mal zur Ruhe gesetzt.
Keine Zugriffsversuche mehr durch die 5 Devices.

Installiert habe ich unter netatmo die (Standard-)Devices:
'netatmo'
'indoor60' Hauptgerät mit den Indoor-Sensoren
'outdoor60' auf der Terrasse mit Temp- und Humidity-Sensoren
'netatmo_forecast'
'netatmo_weathermap'
(Ich glaube, die letzten beiden Devices brauche ich mittlerweise nicht mehr. Hatte alles vor ca. 3 Jahren installiert. Ich schaue morgen mal, ob ich die löschen kann. Sind jetzt jedenfalls auch disabled.)

Habe jetzt das "Disable=1" bei 'net4atmo' gelöscht und dafür den "Interval"-Wert auf '10800' (3 Stdn.) gesetzt.
Falls meine Vermutung mit dem spinnenden netatmo-Server(-Bereich) richtig ist, habe ich erstmal Ruhe und das System bleibt ansonsten stabil.
Oder die haben meine Zugangsdaten kurzfristig geblacklistet. Hatte ich bei der Ursprungsinstallation auch schon. Hatte die Server (aus Unwissenheit) zu oft angepingt.
Dann sollten jetzt 3 Stunden Ruhe mit nur 1 Connect-Versuch ausreichen, um aus der evtl. Sperrung zu fallen.

Noch'n Gedicht:
Habe gerade das log nach "netatmo" durchsucht.
Am 12.04. hatte ich zum 1. Mal den Eintrag "netatmo: No access token was found! (getDevices)" und dasselbe für "... (getHomecoachs).
Dann wieder am 20.04. 15:45 Uhr,
22.04. 11:03 Uhr
24.04. 13:01 und 16:00 Uhr
25.04. 19:10 Uhr
27.04. 13.22 Uhr (danach jede Sekunde bis...
28.04. 20:58 Uhr (da habe ich Deinen "Disable"-Tipp eingesetzt)

Zuletzt: die beiden Token-Werte, die man zur Account-Anmeldung bei netatmo benötigt, habe ich Byte-weise mit den Tokens in meinem sogenannten Entwickler-Account bei netatmo verglichen: seit ca. 3 Jahren identisch.
Ich warte mal bis morgen Mittag ab, ob sich irgendwas mit dem netatmo-Zugriff tut.
Nochmals vielen Dank für Deinen für mich wichtigen Tipp.
Gut's Nächtle,
Ulf
2x raspi + cam-Modul mit mmal-motion - 3x raspi mit KODI - 1x raspi mit FHEM + FTUI

Offline ulobo60

  • Full Member
  • ***
  • Beiträge: 115
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1167 am: 29 April 2021, 17:20:52 »
hi,
kein Erfolg bzgl. meiner Verbindung zum netatmo-Server.

Habe vorhin mal beim netatmo-log verbose auf 5 gestellt.
Siehe da: das Device versucht seit vorgestern je Sekunde 3mal sich mit dem netatmo-Server zu verbinden !!!
Habe jetzt erst mal 'netatmo' disabled. Die anderen 4 netatmo-Devices (indoor, outdoor, etc.) hatte ich ja schon gestern still gelegt.

Ich hatte zwar gestern für den Device 'netatmo' das Attribut 'interval' auf '300' gesetzt und hoffte, dass sich dadurch das Gerät nur alle 5 Minuten 1mal verbinden wird. War ein Irrtum!

Hier mal ein kleiner Auszug aus meinem log mit 'verbose' = 5 von heute Nachmittag:
2021.04.29 15:34:57 2: netatmo: json message error: invalid_grant
2021.04.29 15:34:57 3: netatmo getDevices (devicelist)
2021.04.29 15:34:57 1: netatmo: No access token was found! (getDevices)
2021.04.29 15:34:57 3: netatmo: refreshing token
2021.04.29 15:34:58 4: netatmo: dispatch (token)
2021.04.29 15:34:58 4: netatmo: dispatch return: token
2021.04.29 15:34:58 5: $VAR1 = {
          'error' => 'invalid_grant'
        };

2021.04.29 15:34:58 2: netatmo: json message error: invalid_grant
2021.04.29 15:34:58 3: netatmo getHomecoachs (homecoachlist)
2021.04.29 15:34:58 1: netatmo: No access token was found! (getHomecoachs)
2021.04.29 15:34:58 3: netatmo: refreshing token
2021.04.29 15:34:58 4: netatmo: dispatch (token)
2021.04.29 15:34:58 4: netatmo: dispatch return: token
2021.04.29 15:34:58 5: $VAR1 = {
          'error' => 'invalid_grant'
        };

Okay, ich schätze mal, dass durch diese ständigen vielen Pings (ca. 150 je Minute) mein netatmo-Account geblacklisted ist.
Habe in netatmo-Foren vorhin gelesen, dass eine Sperre 24 Stunden dauert.
Was ich als diesbezüglicher Laie erstaunlich finde ist, dass die netatmo-App auf meinem Mobile gnadenlos funktioniert.
Da werden alle aktuellen netatmo-Daten meines Accounts gezeigt und alle paar Minuten aktualisiert.
Dort gibt's in 'Einstellungen' auch den Punkt 'E-Mail_Benachrichtigungen' und dann unter 'Konto': "Zu viele fehlgeschlagene Versuche". Dort kann man bestimmen, ob man eine Mail möchte, wenn das Konto aufgrund zu vieler Authentifizierungsversuche gesperrt ist. Der Button stand bei mir auf JA. Habe aber bis dato keine diesbezügliche Mail bekommen! Merkwürdig. Scheinbar liegt's daran, dass der Mobile-Zugang zum netatmo-Server ein etwas anderer ist als der über unser FHEM.

Zurück zu unserem Modul.
tomcat.x, ich hatte beim 'netatmo'-Device gestern Nachmittag das Attribut 'interval' auf 600 gesetzt (richtige Codierung des Sekundenwerts?) mit der Hoffnung, dass der Device nur alle 10 Minuten einen Verbindungsversuch durchführt. War aber nix, trotz "shutdown restart".
Dafür funktioniert 'disable=1' (bei allen 5 Modulen)
Jetzt herrscht zumindest erst mal Ruhe.

Habe mal meine logs vom letzten Jahr durchgestöbert. Siehe da: Mitte Mai 2020 hatte ich genau die gleichen Probleme mit netatmo.
Nur war ich da im Urlaub! FHEM lief auf dem raspi durch + ich habe nix davon gemerkt. Jetzt ist mir aufgefallen, dass das damalige logfile etwas größere Ausmaße hatte!!! Als ich aus dem Urlaub zurück kam, lief wieder alles. Das spricht ja für die These "Server-Problem bei netatmo selbst" !
Wie siehst Du das?

Jedenfalls warte ich bis morgen Abend, ehe ich ich 'netatmo' freigebe mit 'disable=0'.

P.S.: 'Webhook' brauche ich doch nicht. Ist nur für Kameras, oder? Ich habe ja lediglich die netatmo-Standardgeräte (1 Innen- + 1-Außensensor).

2x raspi + cam-Modul mit mmal-motion - 3x raspi mit KODI - 1x raspi mit FHEM + FTUI

Offline tomcat.x

  • Full Member
  • ***
  • Beiträge: 167
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1168 am: 01 Mai 2021, 12:46:14 »
Die Attribute hatte ich selbst noch nicht genutzt, daher die Frage, ob das funktioniert. Könnte ja ein Fehler in der Implementierung sein. Ich kenne andere Module, wo das so ist.

Gerade habe ich noch gesehen, dass es nicht nur disable, sondern auch interval bei allen Geräten gibt, nicht nur beim Account. In der Commandref steht dazu nichts explizit drin. Also keine Ahnung, wie das in Kombination vom Account und den einzelnen Geräten funktioniert. Vielleicht zieht es auch bei eine fehlerhaften Verbindung nicht, sondern da wird direkt wieder gestartet.

Generell Probleme bei Netatmo gab es natürlich auch immer mal wieder. Aber in der Regel haben sich dann hier auch mehrere fhem Nutzer getroffen  ;)

Und mit dem Webhook liegst Du richtig, verwende ich auch nicht.
FHEM: 5.9 auf Raspi 3, Raspbian (Buster), Perl v5.28.1
Sender/Empfänger: 2 x CULv3, Duofern Stick
Gateways: FRITZ!Box 6591 (OS: 7.12), HomeMatic LAN, Trädfri
Sensoren/Aktoren: FRITZ!DECT, FS20, FHT, HMS, HomeMatic, Trädfri, DuoFern, NetAtmo

Offline ulobo60

  • Full Member
  • ***
  • Beiträge: 115
Antw:Netatmo Modul - 38_netatmo.pm (Support)
« Antwort #1169 am: 01 Mai 2021, 15:15:06 »
@tomcat.x
Danke für Deinen Beistand  :)

Habe soeben netatmo enabled (ist jetzt ca. 35 Stunden disabled gewesen).
Ergebnis: wie vorher  :'(  = 'netatmo: json message error: invalid_grant'

Werde die netatmo-Devices wieder disablen und warte mal 3 bis 4 Tage ab.
Danach - fürchte ich - werde ich wohl den Gang nach Canossa antreten müssen und versuchen, die netatmo Hotline an zu mailen.
An einen Bann meines Accounts glaube ich nicht mehr, da ja ansonsten meine Mobile App dies anzeigen würde.

Gruselig für mich ist in der Tat, dass sich hier jetzt keine Mitbetroffenen melden...
Ich berichte wieder am Mittwoch.
Merci & nice weekend.
2x raspi + cam-Modul mit mmal-motion - 3x raspi mit KODI - 1x raspi mit FHEM + FTUI

 

decade-submarginal