Autor Thema: Optimierung TCRT5000 Reflexionslichtschranke für Stromzähler o.ä.  (Gelesen 6349 mal)

Online flipse

  • Full Member
  • ***
  • Beiträge: 153
Ich hatte auch meine liebe Not die Scheibe des Energiezählers mit dem bekannten China-Modul abzutasten. Vor allem am Anfang/Ende der Markierung gab es immer mehrfache Pulse. Schlud ist die nicht ganz optimale Beschaltung des Komparators auf der Platine. Dieser arbeitet gänzlich ohne Hysterese und hat einen überflüssigen Kondensator am Eingang. Beides lässt die Schaltung super schwingen.
Enfernt man den Kondensator (im Kreis oben rechts) und bestückt einen Widerstand (180k) zwischen Pin 5 und 7, dann gehören die Probleme der Vergangenheit an es gibt genau eine Flanke am Beginn/Ende der Markierung.
Als Widerstand bietet sich ein 1206er an. Der passt direkt auf die Pins. Ich habe 180k bestückt, da gerade verfügbar. Andere Werte in der Größenordung gehen auch.

Guten Morgen,

ich habe leider auch die Probleme, dass mein TCRT5000, der als Wasserzähler eingesetzt werden soll, zu viele Impulse zählt.
Leider sieht meiner scheinbar anders aus, als deiner und ich bin auch nicht so firm im Löten dieser extrem kleinen Bauteile.
Was kann ich bei diesem Sensor machen?

Offline KarlHeinz2000

  • Full Member
  • ***
  • Beiträge: 127
DAs Modul kenne ich nicht. Anhand der Bauteile auf der Platine scheint die Schaltung leicht anders zu sein. Entweder die Schaltung auf Papier bringen, damit ich was zu sagen kann, oder noch einen Euro in CN in das andere Modul investieren.

Offline KarlHeinz2000

  • Full Member
  • ***
  • Beiträge: 127
@lufi,
hast du die Schwelle richtig satt eingestellt? Beim roten Strich darf nicht gerade so umgeschaltet werden, sonst wird das zu empfindlich auf Umwelteinflüsse.

Offline lufi

  • New Member
  • *
  • Beiträge: 14
@KarlHeinz,

ich habe gestern etwas rumgebastelt, dabei ist mir aufgefallen, dass mit einem 168k Wiederstand, dass Signal invertiert ist.
Wenn ich also 220k habe schaltet das Modul, wenn die Rote Markierung kommt.
Bei einem Wiederstand von 168k (100k + 68k) unterbricht das Modul, wenn der Strich kommt.
In diesem Fall habe ich dann aber Probleme mit der Tasmota Software auf dem WeMos D1, da diese mit dem Signal beim Start nicht gut klar kommt.
 
Um weiter zu testen, habe ich dann einen 100k Wiederstand verwendet, auch da wollte das Modul nicht richtig arbeiten (Reflektionen) da habe ich dann die
Signaldioden etwas gebogen und das Modul wieder schräg auf die Scheibe gesetzt. Das hat erstmal Besserung gebracht aber auch Kratzer auf der Drehscheibe wurden gezählt.
Nachdem ich das Modul jetzt schräg und Horizontal ausgerichtet habe scheint es erstmal zu klappen.
Ich werde in den nächsten Tagen berichten, ob jetzt stabil gezählt wird.

OkOk Das ist jetzt nicht schön, aber es funktioniert erstmal "!


Gruß

Lutz

Offline KarlHeinz2000

  • Full Member
  • ***
  • Beiträge: 127
Gut, wenn es erstmal geht.
Die Platine muss aber eigentlich 90° gedreht montiert werden. So wie du die verbaut hast, ist die Einstellung viel schwieriger.
Mit Klebeband habe ich am Anfang auch probiert. Damit lässt sich die Platine aber nicht langzeitstabil befestigen. Das dehnt sich immer etwas und der Schaltpunkt ist weg...

Offline lufi

  • New Member
  • *
  • Beiträge: 14
Wenn die Platine senkrecht montiert wird, reagiert die Lichtschranke leider auf einige Kerben in der Drehscheibe.
Das konnte ich nur verhindern, wenn ich waagerecht montiere, dabei ist wichtig das nur eine Diode über der Drehscheibe ist.

Ergebnisse sind bisher stabil und präzise.

Gruß

Lutz

 

decade-submarginal