Autor Thema: SCC: Nach Update: Cannot init /dev/ttyAMA0, ignoring it  (Gelesen 2224 mal)

Offline Shardan

  • Jr. Member
  • **
  • Beiträge: 53
Hallo zusammen,

nach dem letzten Update (apt-get dist-upgrade) von Raspian Jessie arbeitet der SCC nicht mehr.
Vorher lief es einwandfrei.

Im Log lässt sich das zurückverfolgen bis zu:

Cannot init /dev/ttyAMA0, ignoring it

Zunächst hatte ich vermutet, dass das Update im der cmdline.txt wieder Einträge hinterlassen hat.
Das ist nicht der Fall.

Eine inittab mit respawn--Einträgen gibt es unter Jessie nicht mehr.

Die Zugriffsrechte auf ttyAMA0 habe ich auch getestet, ohne Erfolg.

Hat jemand noch eine Idee, wo ich nachsehen sollte?


Danke schonmal
FHEM auf Celeron-PC
CUNX mit Pigator, 433 + 868 MHZ.
MAX!-HK-Ventile, ESP8266-Sensoren und -Aktoren
Schaltsteckdosen IT / NetIO230B / Netio4

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5522
Antw:SCC: Nach Update: Cannot init /dev/ttyAMA0, ignoring it
« Antwort #1 am: 08 Juli 2016, 09:09:30 »
Ist überhaubt /dev/ttyAMA0 das richtige Gerät?

BTW:
Besser über /dev/serial/by-id oder alternativ /dev/serial/by-path definieren.

Wenn FHEM abgeschaltet wurde, kannst Du Dich (per console) denn "verbinden"?
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

AndreasP

  • Gast
Antw:SCC: Nach Update: Cannot init /dev/ttyAMA0, ignoring it
« Antwort #2 am: 08 Juli 2016, 16:24:27 »
Hallo zusammen :-)

Ja das Problem hab ich auch bei einer Neuinstallation.

Diese Anleitung funktioniert leider nicht (mehr).

Hallo, da RPI3 mit RPI2 nicht 100% kompatible ist müssen Ports umdefiniert werden ...

busware SCC (CC1101) muss nicht geflasht werden, es wird von busware schon mit der aktuellen firmware geliefert, überprüfen mit:
minicom -b 38400 -o -D /dev/ttyAMA0
V ENTER

Ausgabe bei mir:
V 1.66 CSM868

    Shortcuts: mit Alt+S Beitrag schreiben oder Alt+P für Vorschau
  • Neuste Jessie version auf SD bringen
  • expand file-system, pw, ....
  • apt-get update && apt-get -y upgrade && apt-get -y autoremove && reboot
  • apt-get install rpi-update && rpi-update && reboot
  • systemctl disable hciuart
  • In Datei /boot/config.txt diese Zeile am Ende hinzufügen:
    dtoverlay=pi3-disable-bt-overlay
    Die Datei /boot/overlays/pi3-disable-bt-overlay.dtb muss nicht aktualisiert werden.
    Es muss weder /etc/inittab  (nicht vorhanden  ;)) noch /boot/cmdline.txt editiert werden.
  • disable serial: raspi-config -> Advanced Optins -> Serial
  • reboot
  • ... Installation perl, fhem, .....
  • /etc/init.d/fhem anpassen:
    'start')
            echo "resetting 868MHz extension..."
            if test ! -d /sys/class/gpio/gpio17; then echo 17 > /sys/class/gpio/export; fi
            if test ! -d /sys/class/gpio/gpio18; then echo 18 > /sys/class/gpio/export; fi
            echo out > /sys/class/gpio/gpio17/direction
            echo out > /sys/class/gpio/gpio18/direction
            echo   1 > /sys/class/gpio/gpio18/value
            echo   0 > /sys/class/gpio/gpio17/value
            sleep  1
            echo   1 > /sys/class/gpio/gpio17/value
            sleep  1
            echo "Starting fhem..."
            ...       
Definition in fhem.cfg:

define SCC CUL /dev/ttyAMA0@38400 1234
attr SCC group CUL
attr SCC hmId HEXHEX
attr SCC model CUL
attr SCC rfmode HomeMatic


Viel Erfolg -- Markus.


Irgendwas muss sich geänderd haben.

auch das hab ich versucht, leider kein Erfolg.
https://forum.fhem.de/index.php?topic=47046.0

Hat da jemand sonst noch eine Idee?

MfG

Andreas[/list]
« Letzte Änderung: 08 Juli 2016, 16:34:11 von AndreasP »

Offline Shardan

  • Jr. Member
  • **
  • Beiträge: 53
Antw:SCC: Nach Update: Cannot init /dev/ttyAMA0, ignoring it
« Antwort #3 am: 08 Juli 2016, 19:25:47 »
So.
Etliche Stunden Sucherei und Strickerei haben folgende Gemeinheit erbracht:

Das ganze läuft bei mir auf einem Raspberry Pi 3. Auf dem Ding sitzt ein Bluetooth Modul auf der seriellen Schnittstelle.

Bisher konnte man das Bluetooth abschalten, indem man in der /boot/config.txt die Zeile

dtoverlay=pi3-disable-bt-overlay
eingefügt hat.
Das funktioniert nach dem letzten Update nicht mehr, das Overlay wird nicht mehr geladen. Damit ist Bluetooth wieder aktiv und die serielle Schnittstelle ttyAMA0 (Ja, das ist für das SCC auf dem RPi die richtige Schnittstelle) ist blockiert.

Ursache: Der Name der Overlaydatei wurde geändert!

Die Zeile in der config.txt muss nun lauten:

dtoverlay=pi3-disable-bt
Evtl. muss noch ein

enable_uart=1
darunter, dass kann ich nach etlichen Umbasteleien nicht mehr genau sagen. bei mir ist die drin, schadet auch nicht.

Damit funktioniert das SCC wieder wie gewohnt.
FHEM auf Celeron-PC
CUNX mit Pigator, 433 + 868 MHZ.
MAX!-HK-Ventile, ESP8266-Sensoren und -Aktoren
Schaltsteckdosen IT / NetIO230B / Netio4

AndreasP

  • Gast
Antw:SCC: Nach Update: Cannot init /dev/ttyAMA0, ignoring it
« Antwort #4 am: 08 Juli 2016, 20:12:00 »
Danke geht bei mir auch wieder  8)

 

decade-submarginal