Autor Thema: knxd auf ubilinux Debian Jessi 64Bit auf einem Up-Board  (Gelesen 882 mal)

Offline slawekking

  • New Member
  • *
  • Beiträge: 29
knxd auf ubilinux Debian Jessi 64Bit auf einem Up-Board
« am: 20 August 2016, 01:47:53 »
Hallo,

habe aktuell das Problem KNXd auf meinem neuen System zu installieren.Habe heute ein Up-Board bekommen um meine Fhem Installation zu beschleunigen. Leider bekomme ich bei der Installation auf dem darauf laufendem ubilinux Debian Jessi 64Bit folgenden Fehler:

Der Rest ist im Anhang.Danke im voraus.

Update: Habe das ganze unter Ubuntu -14.04.5 auch probiert. Gleiche Fehlermeldung.

configure: exit 2
dh_auto_configure: ./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libexecdir=${prefix}/lib/knxd --disable-maintainer-mode --disable-dependency-tracking --enable-usb --enable-eibnetip --enable-eibnetiptunnel --enable-eibnetipserver --enable-groupcache --enable-ft12 --enable-pei16s --enable-ncn5120 --enable-tpuarts --enable-dummy returned exit code 2
debian/rules:21: recipe for target 'override_dh_auto_configure' failed
make[1]: *** [override_dh_auto_configure] Error 25
make[1]: Leaving directory '/root/knxd'
debian/rules:14: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules build war 2
root@ubilinux:~/knxd#
« Letzte Änderung: 20 August 2016, 10:16:06 von slawekking »

Offline Marthinx

  • New Member
  • *
  • Beiträge: 33
Antw:knxd auf ubilinux Debian Jessi 64Bit auf einem Up-Board
« Antwort #1 am: 04 Dezember 2016, 00:53:54 »
ich habe auch das gleiche Problem unter Whezzy.

Offline AK-868

  • Full Member
  • ***
  • Beiträge: 255
Antw:knxd auf ubilinux Debian Jessi 64Bit auf einem Up-Board
« Antwort #2 am: 08 Dezember 2016, 16:29:46 »
Das sollte das beheben...

Ausführen
sudo apt-get install git-core build-essential

Danach nochmal nach Anleitung.
« Letzte Änderung: 08 Dezember 2016, 16:31:27 von AK-868 »
Hardware FHEM:
Neue Fritzbox 7390 keine Labor von AVM
Konfigurationsadapter Lan
Funk-Schließerkontaktschnittstellen
Funk-Fenster/Türkontakt
Funk-Schaltaktoren UP ein und zweifach
Funk-Jalousieaktoren
Funk-Rauchmelder


Offline besitzer

  • New Member
  • *
  • Beiträge: 44
Antw:knxd auf ubilinux Debian Jessi 64Bit auf einem Up-Board
« Antwort #3 am: 20 Februar 2017, 15:31:50 »
Ich bekomme leider eine ähnliche Fehlermeldung auf ein RPI 2 und habe den Befehl von oben bereits ausgeführt:

#define HAVE_GROUPCACHE 1

configure: exit 1
dh_auto_configure: ./configure --build=arm-linux-gnueabihf --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --disable-silent-rules --libdir=${prefix}/lib/arm-linux-gnueabihf --libexecdir=${prefix}/lib/arm-linux-gnueabihf --disable-maintainer-mode --disable-dependency-tracking --enable-usb --enable-groupcache --enable-ft12 --enable-ncn5120 --enable-tpuarts --enable-tpuarts-tcp --enable-dummy --libexecdir=/usr/lib --enable-dependency-tracking --enable-silent-rules returned exit code 1
debian/rules:21: recipe for target 'override_dh_auto_configure' failed
make[1]: *** [override_dh_auto_configure] Error 2
make[1]: Leaving directory '/knxd'
debian/rules:14: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules build war 2


Kann mir jemand helfen?

Danke.

gruß Sven


Offline MikeR

  • New Member
  • *
  • Beiträge: 20
RaspberryPi mit Raspian Wheezy das gleiche
« Antwort #4 am: 14 März 2017, 19:34:52 »
Auch hier die folgende Meldung:

configure: exit 1
dh_auto_configure: ./configure --build=arm-linux-gnueabihf --prefix=/usr --includedir=${prefix}/include --mandir=${prefix}/share/man --infodir=${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --libdir=${prefix}/lib/arm-linux-gnueabihf --libexecdir=${prefix}/lib/arm-linux-gnueabihf --disable-maintainer-mode --disable-dependency-tracking --enable-usb --enable-groupcache --enable-ft12 --enable-ncn5120 --enable-tpuarts --enable-tpuarts-tcp --enable-dummy --libexecdir=/usr/lib --enable-dependency-tracking --enable-silent-rules returned exit code 1
debian/rules:21: recipe for target 'override_dh_auto_configure' failed
make[1]: *** [override_dh_auto_configure] Error 255
make[1]: Leaving directory '/home/pi/knxd'
debian/rules:14: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: Fehler: Fehler-Exitstatus von debian/rules build war 2

Habe auch den gcc und g++ in der Version 4.7 unter Wheezy installiert, mit obigem "Effekt".
Hat vielleicht noch jemand eine Idee?

Grüße
MIKE

Offline MikeR

  • New Member
  • *
  • Beiträge: 20
Antw:knxd auf ubilinux Debian Jessi 64Bit auf einem Up-Board
« Antwort #5 am: 14 März 2017, 19:36:10 »
Nachtrag:

"knxd" Sourcen sind die Version "0.12"
"sudo apt-get install git-core build-essential" ebenfalls installiert
Alle Pakete upgedatet "sudo apt-get update|upgrade|dist-upgrade"
Und bei den ersten Dependency-Fehler des "dpkg-buildpackage -b -uc" die fehlenden Abhängikeiten ebenfalls installiert
« Letzte Änderung: 14 März 2017, 19:39:18 von MikeR »

 

decade-submarginal