Autor Thema: apt-get -f install "Correcting dependencies... failed."  (Gelesen 952 mal)

Offline Loki

  • New Member
  • *
  • Beiträge: 13
apt-get -f install "Correcting dependencies... failed."
« am: 30 August 2016, 18:02:12 »
Hallo Zusammen,

ich habe gestern leider mit zuviel gefährlichem Halbwissen meine Paketverwaltung geschrottet und jetzt meckert apt-get bei jeder Aktion über fehlerhafte Abhängigkeiten:
Ein apt-get -f install bringt folgendes zutage:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 fhem : Depends: libcgi-pm-perl
 perl : Depends: perl-base (= 5.22.2-3) but 5.14.2-21+deb7u3 is installed
        Recommends: rename but it is not installable
 perl-modules-5.22 : Depends: perl-base (>= 5.22.2-1) but 5.14.2-21+deb7u3 is installed
 update-inetd : Depends: libfile-temp-perl
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


dpkg --configure -a  schreibt das hier:
dpkg: dependency problems prevent configuration of perl:
 perl depends on perl-base (= 5.22.2-3); however:
  Version of perl-base on system is 5.14.2-21+deb7u3.

dpkg: error processing package perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of perl-modules-5.22:
 perl-modules-5.22 depends on perl-base (>= 5.22.2-1); however:
  Version of perl-base on system is 5.14.2-21+deb7u3.

dpkg: error processing package perl-modules-5.22 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libperl5.22:armhf:
 libperl5.22:armhf depends on perl-modules-5.22 (>= 5.22.2-3); however:
  Package perl-modules-5.22 is not configured yet.

dpkg: error processing package libperl5.22:armhf (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 perl
 perl-modules-5.22
 libperl5.22:armhf

Ich vermute ich habe mir irgendein Perlmodul installiert, bei dem es Versionkonflikte gibt, aber ich komme beim besten Willen nicht weiter...

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13436
  • Das "S" in "IoT" steht für "Security"
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #1 am: 30 August 2016, 18:52:31 »
Ich vermute ich habe mir irgendein Perlmodul installiert, bei dem es Versionkonflikte gibt, aber ich komme beim besten Willen nicht weiter...

Ich vermute, Du hast ein "apt-get dist-upgrade" versucht. Da hast Du nun zwei Möglichkeiten:

  • stundenlang weiterexperimentieren, ohne zu einem Ergebnis zu kommen
  • ein neues System aufsetzen

Meine Empfehlung wäre Weg Nr. 2
Nächster Hamburg-Stammtisch: 15.12.2017

Offline mahowi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 765
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #2 am: 30 August 2016, 19:18:16 »
Das "dist-upgrade" zerschießt im Normalfall nicht die Paketverwaltung. Hast Du irgendwelche Fremdquellen eingebunden? Du hast scheinbar die perl-modules in der Version 5.22 installiert ohne das restliche Perl zu updaten. Versuch mal, das Paket zu deinstallieren.
CUBe (MAX): HT, FK | CUBe (SlowRF): ESA2000WZ
JeeLink: LaCrosse | nanoCUL433: Smartwares SHS-51001-EU, EM1000GZ
ZME_UZB1: GreenWave PowerNode, Popp Thermostat | SIGNALDuino: HE877, X10 MS14A, Revolt NC-5462,  IT Steckdosen + PIR
tado° | Milight | HUE, Lightify | SmarterCoffee

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13436
  • Das "S" in "IoT" steht für "Security"
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #3 am: 30 August 2016, 20:25:15 »
Versuch mal, das Paket zu deinstallieren.

Das wird nicht funktionieren, solange die Paketverwaltung das Paket als "unvollständig installiert" führt.

Das "dist-upgrade" zerschießt im Normalfall nicht die Paketverwaltung.

Da wette ich (aus eigener Erfahrung) eiskalt dagegen.
Nächster Hamburg-Stammtisch: 15.12.2017

Offline mahowi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 765
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #4 am: 31 August 2016, 09:37:52 »
Die "Dampfhammer-Methode" sollte aber funktionieren:
cd /var/lib/dpkg/info
sudo rm perl-modules.*
sudo dpkg --remove --force-remove-reinstreq perl-modules

Es wäre natürlich gut zu wissen, was Loki installiert hat, bevor es zu den Problemen kam.

Da wette ich (aus eigener Erfahrung) eiskalt dagegen.

Ok, man kann sich mit dist-upgrade auch schonmal ein paar Abhängigkeitsprobleme einhandeln, vor allem, wenn man verschiedenste Paketquellen mixt. Allerdings hab ich das noch nicht so weit geschafft, daß ich das komplette System neu installieren musste.

Da erinner ich mich noch an die alte SuSE-"Paketverwaltung" mit tar-Paketen vor ~20 Jahren. Da wurde es spaßig, wenn man mal händisch eingegriffen hat und versuchen konnte, die Abhängigkeiten wieder hinzubekommen.
CUBe (MAX): HT, FK | CUBe (SlowRF): ESA2000WZ
JeeLink: LaCrosse | nanoCUL433: Smartwares SHS-51001-EU, EM1000GZ
ZME_UZB1: GreenWave PowerNode, Popp Thermostat | SIGNALDuino: HE877, X10 MS14A, Revolt NC-5462,  IT Steckdosen + PIR
tado° | Milight | HUE, Lightify | SmarterCoffee

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3206
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #5 am: 31 August 2016, 11:07:32 »
@betateilchen:

da vorher geschrieben wurde: "im Normalfall" würde ich gegenüber Deiner Aussage sagen:
Zitat
Da wette ich (aus eigener Erfahrung) eiskalt dagegen.

Ansonsten hätte ich beruflich einen haufen Ärger
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline erdo_king

  • New Member
  • *
  • Beiträge: 12
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #6 am: 31 August 2016, 11:14:11 »
Ein Dist-Upgrade macht eigentlich nur bei Systemen ärger, die Fremd-Repository's eingebunden haben und/oder defekte Abhängigkeiten haben.
Solange keine tiefgreifenden Änderungen, zB. selbst kompilierter Mist im System vorhanden ist klappt sowas normalerweise immer ...

Als langjähriger Linux-Admin kann ich das mit gutem Gewissen behaupten :)

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13436
  • Das "S" in "IoT" steht für "Security"
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #7 am: 31 August 2016, 13:09:59 »
da vorher geschrieben wurde: "im Normalfall"

wäre es sinnvoll, vielleicht den "Normalfall" genauer zu definieren.

Aber in diesem Fall:

ich habe gestern leider mit zuviel gefährlichem Halbwissen

ist die Definition von "Normalfall" nicht wirklich entscheidend.
Nächster Hamburg-Stammtisch: 15.12.2017

Offline mahowi

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 765
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #8 am: 31 August 2016, 14:12:07 »
wäre es sinnvoll, vielleicht den "Normalfall" genauer zu definieren.

Aber in diesem Fall:

ist die Definition von "Normalfall" nicht wirklich entscheidend.
Der "Normalfall" wäre bei einem System mit Standardeinstellungen ohne Vermischung von verschiedenen Repository-Versionen wie z.B. testing und stable, etc. Dann macht dist-upgrade ja nicht viel was anderes als upgrade, es werden nur evtl. neue Pakete installiert oder bereits installierte entfernt.

Probleme gibt's hauptsächlich wie hier, wenn Abhängigkeiten zu Paketversionen bestehen, die in den Repositories (noch) nicht vorhanden sind oder vorhandenen Abhängigkeiten widersprechen.

Aber ich gebe Dir recht, der Fall hat nichts mit Normalfall zu tun.  8) Wer in den Konfigurationen rumbastelt sollte schon wissen, was er tut. Aber mich haben solche Fehler immer dazu angespornt, daraus zu lernen, wie man sie das nächste Mal verhindert.  :)
CUBe (MAX): HT, FK | CUBe (SlowRF): ESA2000WZ
JeeLink: LaCrosse | nanoCUL433: Smartwares SHS-51001-EU, EM1000GZ
ZME_UZB1: GreenWave PowerNode, Popp Thermostat | SIGNALDuino: HE877, X10 MS14A, Revolt NC-5462,  IT Steckdosen + PIR
tado° | Milight | HUE, Lightify | SmarterCoffee

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3206
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #9 am: 31 August 2016, 15:15:24 »
Und betateilchen hat insofern recht, das bei mischen von Repisitory und solchen Fehlern meistens nur eine Neuinstallation die saubere Lösung ist.

Beruflich sieht es eventuell anders aus, wenn zuviel Arbeit im Server steckt (und zuwenig Zeit vorhanden ist). In diesem Falle sollte man aber den zuständigen Admin aus anderen Gründen "Treten"
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline Loki

  • New Member
  • *
  • Beiträge: 13
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #10 am: 01 September 2016, 08:47:35 »
Hallo Leute, vielen Dank für die Unterstützung.
In der Tat habe ich versucht andere Paketquellen einzubinden, nachem die Installation von homebridge immer wegen fehlender Abhängigkeiten fehlgeschlagen war.
Dabei sind mir wohl Jessie und Wheezy Pakete vermischt worden und das Übel nahm seinen Lauf...

Jetzt habe ich komplett neu aufgesetzt und bin gleich auf Jessie gegangen.

Nun meckert allerdings FHEM, dass "ifconfig" nicht mehr geht.
Wenn ich das richtig deute, ist "ifconfig" nicht mehr enthalten und wurde durch "ip" ersetzt.
Ist FHEM darauf noch nicht vorbereitet?

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3227
  • Wer anderen eine Bratwurst brät...
Antw:apt-get -f install "Correcting dependencies... failed."
« Antwort #11 am: 01 September 2016, 09:04:47 »
Hallo Leute, vielen Dank für die Unterstützung.
In der Tat habe ich versucht andere Paketquellen einzubinden, nachem die Installation von homebridge immer wegen fehlender Abhängigkeiten fehlgeschlagen war.
Dabei sind mir wohl Jessie und Wheezy Pakete vermischt worden und das Übel nahm seinen Lauf...

Jetzt habe ich komplett neu aufgesetzt und bin gleich auf Jessie gegangen.

Nun meckert allerdings FHEM, dass "ifconfig" nicht mehr geht.
Wenn ich das richtig deute, ist "ifconfig" nicht mehr enthalten und wurde durch "ip" ersetzt.
Ist FHEM darauf noch nicht vorbereitet?

sudo apt-get install -y net-tools
Gruß
Dan
FHEM 5.8, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert
Gefällt mir Gefällt mir x 1 Liste anzeigen