Autor Thema: Busware POD / ROT mit Rpi 2/3 und Raspbian Jessie (Lite)  (Gelesen 2399 mal)

Offline DerStefan

  • New Member
  • *
  • Beiträge: 7
Busware POD / ROT mit Rpi 2/3 und Raspbian Jessie (Lite)
« am: 01 September 2016, 17:14:51 »
Hallo,

für die Nutzung mit ETS5 und FHEM habe ich mir das POD Modul von Busware bestellt.

Ich habe bis jetzt nur Erfahrung mit USB basierten Modulen und bin deshalb etwas ratlos, da ich das Modul irgendwie nicht zum laufen bekomme.

Getestet habe ich mit einen RPI2 und einen RPI3 beide mit dem aktuellen Raspbian Jessie (Lite) - Kernel 4.4.17-v7+
Serielle Konsole und BT sind deaktivert.


Ich benutze folgende cmdline.txt

dwc_otg.lpm_enable=0 console=tty1 root=/dev/sda2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait dtoverlay=pi3-disable-bt dtparam=i2c_arm=on
Root is auf einem USB Stick (macht aber funktional keine Unterschied ob ich eine SD Karte nehme)

Die wenigen Anweisungen bringen mich nicht wirklich weiter.

Über den i2c Bus wird etwas erkannt.
Thu Sep  1 15:04:51 2016] i2c i2c-1: new_device: Instantiated device 24c02 at 0x50
[Thu Sep  1 15:04:51 2016] at24 1-0050: 256 byte 24c02 EEPROM, writable, 1 bytes/write
[Thu Sep  1 15:04:51 2016] at24 1-0057: 256 byte 24c02 EEPROM, writable, 1 bytes/write
[Thu Sep  1 15:04:51 2016] i2c i2c-1: new_device: Instantiated device 24c02 at 0x57

und mittels
root@raspberrypi:/# hexdump -C  /sys/class/i2c-adapter/i2c-1/1-0050/eeprom
00000000  54 50 55 41 52 54 00 ff  ff ff ff ff ff ff ff ff  |TPUART..........|
00000010  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
00000100

sehe ich, dass der EEprom des TPUART offenbar sichtbar ist.

Leider habe ich keinerlei serielle Devices die ich in knxd verwenden könnte.
root@raspberrypi:/# ls  /dev/tty*
/dev/tty    /dev/tty15  /dev/tty22  /dev/tty3   /dev/tty37  /dev/tty44  /dev/tty51  /dev/tty59  /dev/tty9
/dev/tty0   /dev/tty16  /dev/tty23  /dev/tty30  /dev/tty38  /dev/tty45  /dev/tty52  /dev/tty6   /dev/ttyprintk
/dev/tty1   /dev/tty17  /dev/tty24  /dev/tty31  /dev/tty39  /dev/tty46  /dev/tty53  /dev/tty60
/dev/tty10  /dev/tty18  /dev/tty25  /dev/tty32  /dev/tty4   /dev/tty47  /dev/tty54  /dev/tty61
/dev/tty11  /dev/tty19  /dev/tty26  /dev/tty33  /dev/tty40  /dev/tty48  /dev/tty55  /dev/tty62
/dev/tty12  /dev/tty2   /dev/tty27  /dev/tty34  /dev/tty41  /dev/tty49  /dev/tty56  /dev/tty63
/dev/tty13  /dev/tty20  /dev/tty28  /dev/tty35  /dev/tty42  /dev/tty5   /dev/tty57  /dev/tty7
/dev/tty14  /dev/tty21  /dev/tty29  /dev/tty36  /dev/tty43  /dev/tty50  /dev/tty58  /dev/tty8

Hier was ich auf i2c sehe
root@raspberrypi:/# i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- 18 -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: UU -- -- -- -- -- -- UU -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

root@raspberrypi:/# i2cdetect -l
i2c-1   i2c             3f804000.i2c                            I2C adapter





Muss ich vielleicht noch irgendwas flashen? Oder habe ich einen defekt?

Ich sehe halt kein /dev/ttyA* device.

Hat jemand ein ROT/POD mit Raspian am laufen?

1000 Dank schon mal!




« Letzte Änderung: 01 September 2016, 17:32:30 von DerStefan »

Offline antonwinden

  • Full Member
  • ***
  • Beiträge: 272
Antw:Busware POD / ROT mit Rpi 2/3 und Raspbian Jessie (Lite)
« Antwort #1 am: 07 September 2016, 13:04:40 »
das POD von deinem Link ist eine Onewire- Schnittstelle und keine KNX-Schnittstelle.
Das kann und soll mit ETS nicht funktionieren.
gruß anton
KNX, Raspberry, Denon 3313, Philips TV, Xtrend9X00 und viel Optimismus...

Offline Franky1992

  • Jr. Member
  • **
  • Beiträge: 54
Antw:Busware POD / ROT mit Rpi 2/3 und Raspbian Jessie (Lite)
« Antwort #2 am: 08 September 2016, 07:57:20 »
Er hat vermutlich das Pigator Modul  EIB/KNX TPUART.

ist nur ziemlich sinnlos dann für eine Bastellösung 110€ auszugeben wo für 40€ mehr eine zertifizierte Schnittstelle von MDT zu haben ist.
http://www.mdt.de/Interfaces.html


Gruß
« Letzte Änderung: 08 September 2016, 07:59:33 von Franky1992 »

Offline DerStefan

  • New Member
  • *
  • Beiträge: 7
Antw:Busware POD / ROT mit Rpi 2/3 und Raspbian Jessie (Lite)
« Antwort #3 am: 08 September 2016, 12:25:40 »
Natürlich habe ich im Pigator Host ein KNX/EIB Pigator Modul, hab ich jetzt mal vorausgesetzt dass dies klar ist da ich ja beim auslesen des eeproms  den "TPUART" finde.

Ich wollte auch keine philosophische Diskussion ob/was Sinn macht.
Danach habe ich nicht gefragt.





Offline Frank Hell

  • Jr. Member
  • **
  • Beiträge: 96
Antw:Busware POD / ROT mit Rpi 2/3 und Raspbian Jessie (Lite)
« Antwort #4 am: 14 September 2016, 14:57:11 »
ist nur ziemlich sinnlos dann für eine Bastellösung 110€ auszugeben wo für 40€ mehr eine zertifizierte Schnittstelle von MDT zu haben ist.

Und wo gibt es das MDT-Interface für 40 EUR? Die USB-Schnittstelle kostet neu bereits rund 130 EUR!