Autor Thema: knxd  (Gelesen 3325 mal)

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
knxd
« am: 10 September 2016, 19:29:18 »
Hallo

Ich habe knxd wie hier beschrieben http://www.fhemwiki.de/wiki/Knxd installiert auf Jessie Lite was mit nachladen von git-core auch klappte.

Nun bekomme ich allerdings diesen Fehler nach reboot des Raspberry.

Was mache ich falsch und der Hinweis auf > See ......... and ......   sagt mir nichts.

Ich bedanke mich im voraus für Eure Mühe

Lars

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #1 am: 16 Oktober 2016, 14:11:45 »
Hi,

hast du rausbekommen, an was es gelegen hat ?

Ich hab es auch genau nach der Anleitung in de Wiki gemacht. Wenn ich nach einem Reboot dann den KNX Status checke, kommt bei mir auch eine ähnliche Fehlermeldung ?

Hast du es schon hinbekommen ?

Grüße,
Visionsurfer

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #2 am: 16 Oktober 2016, 14:15:25 »
Hi,

hier mal mein Screenshot. So sieht es bei mir aus, wenn ich nach dem Reboot den Status überprüfen lasse.

Ich hab entsprechend der Wiki beide Einträge geändert:

4. knxd konfigurieren
es muss als nächstes die Konfigurationsdatei editiert werden.
das geht mit:
sudo nano /etc/default/knxd
dann folgende Einträge anpassen:
DAEMON_ARGS="-u /tmp/eib -u /var/run/knx -i -b ipt:192.168.188.XX"

4a. knxd für Debian Jessie konfigurieren:
Die Konfigurationsdatei bei Jessie hat sich wegen der Nutzung von systemd geändert:
sudo nano /etc/knxd.conf
dann folgende Einträge anpassen:
KNXD_OPTS=="-u /tmp/eib -u /var/run/knx -i -b ipt:192.168.188.XX"

Also ich hab original die beiden jeweiligen Zeilen kopiert und bei mir eingefügt. Dann nur noch die IP Adresse angepasst und das war es.

Was mich ein bisschen wundert, ist das die Einträge vorher anders aussahen. Auch stand da nicht "ipt:....." sondern nur ip:

Kannst du vielleicht sagen, wie du es gemacht hast ?

Grüße,
Visionsurfer

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #3 am: 16 Oktober 2016, 18:40:33 »
Hey
KNXD brauchst Du wenn Du die KNX Bauteile auch programmieren willst. Das mach ich über die ETS und bin was KNXD angeht raus. Auf dem anderem Eintrag hier habe ich Dir die meine beiden Zeilen aus dem FHEM.log geschrieben.
Die ETS 5 Lite gibt es für kleinere KNX Projekte und ist mir lieber als das hier mit FHEM zu probieren.
Viel Erfolg
Lars


Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #4 am: 16 Oktober 2016, 18:47:44 »
Hmmm, puh jetzt bin ich wieder durcheinander.

Also ich habe, bzw. bekomme auch eine ETS Vollversion.

Also hätte ich mir die Mühe gar nicht machen müssen und den ganzen KNXD kram installieren ?

Kann man den KNX Bus aus Fhem direkt ansprechen, nur wenn man entsprechend einen KNX CUL definiert ? Echt ? Das ist dann alles ?

Oder hab ich da was falsch verstanden ?

Grüße,
Visionsurfer

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #5 am: 16 Oktober 2016, 19:02:59 »
Äh ja hast Du.

Ich habe diese beiden Zeilen und dann einmal durch das Haus und alles einmal ein und wieder ausgeschaltet schon hatte ich in Everything die KNXbauteile mit Ihrer Gruppenadresse. Die habe ich dann umbenannt und einen Raum KNX gemacht in den die Bauteile nun alle sind.
Wie man das mit dem umbenennen am besten macht weiß ich nicht. Ich habe es wohl falsch gemacht den danach war das Logfile leer. >:(
Viel Erfolg

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #6 am: 16 Oktober 2016, 19:12:16 »
Hi,

ok. Komisch. Ich dachte man braucht zwangsweise KNXd.

Weil du hast ja oben auch einen Screenshot geschickt der ähnliche Fehler anzeigt wie bei mir ? Also hattest du doch auch was installiert, vorher, oder nicht ?

Grüße,
Visionsurfer

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #7 am: 16 Oktober 2016, 19:20:54 »
Hey
Stimmt da hatte ich mir einen Gateway ausgeliehen, aber zum einen wollte ich nicht über 100€ bezahlen und zum anderen klappte es nicht, wie Du ja in dem LOG siehst.
Da schien mir die BUSWARE Version besser und ich bin zufrieden weil es eben die Trennung gibt.
Ob Du knxd nicht brauchst für das Gateway weiß ich nicht.
Gruß Lars

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd
« Antwort #8 am: 16 Oktober 2016, 19:30:26 »
KNXD brauchts immer. Wer kommt nur auf solche Ideen?

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #9 am: 16 Oktober 2016, 19:35:55 »
Hi,

alles klar. Hab ich mir auch gedacht. Nur kommt bei mir leider einen Fehlermeldung.
Siehe Screenshot in meinem anderen Thread.

Ich weiß leider nicht mehr weiter.

Grüße,
Visionsurfer

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd
« Antwort #10 am: 16 Oktober 2016, 19:38:53 »
Schau doch erstmal ohne Autostart und bring die Möhre so zum laufen.

Also so lange mit

knxd -t1024 -...

probieren, bis es läuft. Die Parameter dann in den Autostart und ab dafür.

Grüße, Andi

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #11 am: 16 Oktober 2016, 19:49:18 »
Hi,

oh je. Das bekomme ich nicht hin. Ich hatte gehofft das die Wiki einfach funktioniert.
O.K. Autostart wieder auf NO zu setzen, das werde ich wohl hinbekommen. Aber der Rest. Keine Ahnung.

Und wenn ich KNXd google, kommt zwar die Seite, aber davon verstehe ich nichts. Welche Parameter für was und wie und wann usw. ?

Grüße,
Visionsurfer

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd
« Antwort #12 am: 16 Oktober 2016, 19:52:51 »
Sorry, aber ganz ohne Eigeninitiative wird's nicht gehen...

Der KNX und auch der KNXD sind alles andere als "Vorstandssicher" und für Newbies nur geeignet, wenn ein gewisses Maß an Freizeit reinfließt :-P

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #13 am: 16 Oktober 2016, 20:03:20 »
Hi,

ja schon. Das ist mir alles klar. Nur hilft es leider nicht, wenn man sich einen Wolf ließt und sucht und trotzdem nicht weiter kommt.
Ich habe zwischendurch das ganze Wochenende versucht eine einfache ST20 Steckdose einzubinden. Ich hatte die ganze Zeit alles richtig gemacht, bis ein User hier aus dem Forum empfohlen hat, doch einfach mal den USB Stick kurz raus und wieder rein. Als ich das gemacht habe, lief es sofort.

O.K. aber zurück zum Thema:

Kann es sein das die Wiki überhaupt nicht mehr stimmt ?

Als Anlage mal meine beiden Configs. Ich habe ja mit folgendem Befehl zwei Dateien geändert:

sudo nano /etc/default/knxd
sudo nano /etc/knxd.conf

Dort hab ich dann entsprechend in die jeweilige Datei die Zeile aus der Wiki eingefügt.

Wenn ich mir jetzt aber die beiden Configs noch mal anschaue, steht da sowas wie "DO NOT user "-u" / "-u /run/knx" usw. here. Aber in der Wiki steht der Code so.

Verstehe ich nicht. Wie soll man da rausfinden was richtig ist ?

Grüße,
Visionsurfer


Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #14 am: 16 Oktober 2016, 20:05:06 »
Hallo
Also nur zum lesen und schreiben für Gruppenadressen brauchst Du keinen KNXD
bei klappt es ja auch.
Sonst würde ich mich doch sehr wundern.
Viel Erfolg
Lars

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #15 am: 16 Oktober 2016, 20:07:03 »
Also ohne KNXd, redet FHEM bzw. mein Raspberry überhaupt nicht mit meinem KNX IP Gateway. Ansonsten hab ich was komplett falsch verstanden.

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #16 am: 16 Oktober 2016, 20:14:24 »
hast Du das mal ausprobiert was ich geschrieben habe mit den zwei Zeilen?

Offline visionsurfer

  • Hero Member
  • *****
  • Beiträge: 1035
Antw:knxd
« Antwort #17 am: 16 Oktober 2016, 20:19:27 »
Sorry, hab ich eventuell überlesen ? Welche 2 Zeilen ?

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd
« Antwort #18 am: 16 Oktober 2016, 20:46:10 »
@Lars:
Das widerum wundert MICH. Wie kommunizierst Du denn mit dem KNX? Du brauchst eine wie auch immer geartete Brücke zwischen FHEM und dem physischen KNX. Nur den Netzwerkstecker reinzustecken, reicht leider nicht. Ohne KNXD (oder den Vorgänger EIBD) werden sich die Bits hier schwer tun.

@Visionsurfer:
Die Anleitung im Wiki taugt auch für meine Konfiguration nicht. Unterstellt, Du hast einen KNX-Router und kein reines KNX-Gateway, kannst Du in einer Putty-Instanz den KNXD starten.
sudo knxd -c -u /tmp/eib -b ipt:a.b.c.dIn einer zweiten Putty-Instanz kannst Du mit groupswrite den Erfolg prüfen.
Wenn NIO, spielst Du so lange an den Parametern rum, bis es klappt. knxd --help hilft dabei.
Die Parameter schreibst Du dann in den Autostart.

Wenn Groupswrite dann immer noch geht, DANN kümmern wir uns um die Integration in FHEM.

Grüße, Andi

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #19 am: 16 Oktober 2016, 22:29:10 »
Hallo
Ich habe einen tpuart von BUSWARE den habe ich im raspi. Das habe ich auch geschrieben dazu folgende zwei Zeilen und es funzt
https://forum.fhem.de/index.php/topic,59070.0.html
wie und warum es geht kann ich nicht sagen. Es klappt und irgendwo hier im WWW habe ich auch eine Textstelle gefunden in der steht das mit dem TPuart ohne KNXD funzt.
Ob das auch für ein Gateway gilt kann ich nicht sagen.
Ich will auch keine KNXBauteile programmieren es geht mir rein um die Gruppenadressen welche ich lese und beschreibe meist einfach nur Licht an und Licht aus.
Ich drücke jedenfalls die Daumen das es bei euch auf funzt.
Gruß Lars

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:knxd
« Antwort #20 am: 17 Oktober 2016, 19:39:27 »
Hallo Lars,

DAS ist richtig. Aber nicht bei Anbindung über Ethernet. Und Visionsurfer telefoniert über Ethernet.

Nebenbei: die reine Anbindung der TUL ohne den KNXD sorgte in der Vergangenheit für Probleme und wird hier NICHT supported. Ich empfehle JEDEM, diesen Zugang nicht zu nutzen.

Grüße, Andi

Offline friedel148

  • Jr. Member
  • **
  • Beiträge: 76
Antw:knxd
« Antwort #21 am: 17 Oktober 2016, 21:48:45 »
Hallo Andi

Danke für den Hinweis

Gruß Lars