Autor Thema: SIGNALDuino Empfänger Firm- und Hardware  (Gelesen 313534 mal)

Offline habeIchVergessen

  • Sr. Member
  • ****
  • Beiträge: 782
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #780 am: 23 Januar 2018, 15:51:07 »
Lässt sich beim beim ESP32 das WIFI auch deaktivieren

beim ESP8266 gibt es Wifi OFF und vermutlich auch für den ESP32
WiFi.mode(WIFI_OFF);

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2730
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #781 am: 23 Januar 2018, 16:26:40 »
Hallo,

ich habe den SignalESP mit 3.3.1rc3.bin file geflasht. Direkt beim Starten kommt an der Konsole
dump EEPROM:
33 1d 07 0d 2e 2d 07 d3 91 3d 04 32 00 00 06 00
10 b0 71 57 c4 30 23 b9 00 07 00 18 14 6c 07 00
90 87 6b f8 56 11 e9 2a 00 1f 41 00 20 77 69 6e
00 84 00 00 00 00 00 00
SRES Started
POR Done
CCVersion=0x14
CCPartnum=0x0
CC1101 found
mounting FS...
failed to mount FS
*WM: SET AP STA
*WM:
*WM: Configuring access point...
*WM: ESP537799
*WM: AP IP address:
*WM: 192.168.4.1
*WM: HTTP server started
Warum kann das FS nicht gemounted werden? Wenn er das Config.File nicht lesen kann, ist es klar das er das auch nicht beschreiben kann. Irgendwie verzweifel ich gerade daran. Ich probiere jetzt schon den ganzen Tag rum, aber er will einfach nicht. Wer kann mir da helfen?

Gruß Christoph

Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline SabineT

  • Full Member
  • ***
  • Beiträge: 189
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #782 am: 23 Januar 2018, 16:37:12 »
kannst du doch bauen (Sourcen hier oder hier)
Naja, ich bin davon ausgegangen, dass die für den ESP8266 sind und nicht optimiert für den ESP32

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2730
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #783 am: 23 Januar 2018, 19:46:49 »
Hallo,

ich habe die Sourcen von habeIchVergessen genommen. Der Sketch läuft durch, ich komme auf die Configseite, die Werte werden anscheinend gespeichert - aber er verbindet sich nicht mit dem Netzwerk. Hier ist der Log von der Konsole
dump config register:
29 2E 3F 07 D3 91 FF 04 45 00 00 0F 00 1E C4 EC
8C 22 02 22 F8 47 07 30 04 76 6C 03 40 91 87 6B
F8 56 10 A9 0A 20 0D 41 00
CCVersion=0x14
CCPartnum=0x0
CC1101 found (rev. 01)
mounting FS...
mounted file system
reading config file
opened config file
{"ip":"192.168.11.10","gateway":"192.168.11.1","subnet":"255.255.255.0"}
parsed json
setting custom ip from config
192.168.11.10
*WM: SET AP STA
*WM:
*WM: Configuring access point...
*WM: ESP537799
*WM: AP IP address:
*WM: 192.168.4.1
*WM: HTTP server started
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Scan done
*WM: Cubie-Wifi
*WM: -50
*WM: Home_Router_N
*WM: -53
*WM: Sent config page
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Handle root
*WM: WiFi save
*WM: static ip
*WM: 192.168.11.10
*WM: static gateway
*WM: 192.168.11.1
*WM: static netmask
*WM: 255.255.255.0
*WM: Sent wifi save page
*WM: Connecting to new AP
*WM: Connecting as wifi client...
*WM: Custom STA IP/GW/Subnet
*WM: 192.168.11.10
*WM: Already connected. Bailing out.
Should save config
connected...)
local ip: 192.168.11.10
saving config
{
  "ip": "192.168.11.10",
  "gateway": "192.168.11.1",
  "subnet": "255.255.255.0"
}CC1100_PKTCTRL0=0 vs EEPROM PKTCTRL0=50
C1100_IOCFG2=46 vs EEPROM IOCFG2=13
cc1101 is not correctly set. Please do a factory reset via command e

Gruß Christoph
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2739
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #784 am: 23 Januar 2018, 20:41:07 »
Hi Bennemanc,

Was für ein ESP Board hast Du denn?


Grüße Sidey

Gesendet von meinem XT1650 mit Tapatalk

Signalduino, Homematic, Raspberry Pi, Mysensors, MQTT, Alexa

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2730
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #785 am: 23 Januar 2018, 21:05:09 »
Wemos D1 mini mit einer Adapterplatine wo der CC1101 drauf ist.
Habe ich hier im Forum so fertig gekauft.
Wenn ich das richtig deute, meldet der sich immer beim falsche (keine Ahnung wo die Daten stehen) Netzwerk an. Da hatte ich mal WPS ausprobiert. Ich kann im LOG auch nicht sehen, das er versucht sich woanders anzumelden.
Connected successful to SSID 'Home_Router_N'
mounting FS...
mounted file system
reading config file
opened config file
{"ip":"192.168.10.60","gateway":"192.168.10.200","subnet":"255.255.255.0"}
parsed json
setting custom ip from config
192.168.10.60
*WM:
*WM: AutoConnect
*WM: Connecting as wifi client...
*WM: Already connected. Bailing out.
*WM: IP Address:

Gruß Christoph
« Letzte Änderung: 23 Januar 2018, 21:14:54 von Bennemannc »
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2739
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #786 am: 23 Januar 2018, 21:52:55 »
Wie hast Du ihm denn mitgeteilt mit welchem WLAN er sich verbinden soll?
Signalduino, Homematic, Raspberry Pi, Mysensors, MQTT, Alexa

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2730
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #787 am: 23 Januar 2018, 21:57:19 »
Na, er macht ja sein eigenes Wlan (AP Mode) auf. Dort kann ich bei dem obersten Punkt ein Wlan auswählen und den Key eingeben. Dann sollte der sich auch in dieses Netz einloggen - aber genau das seint er nicht zu machen.

Gruß Christoph
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2739
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #788 am: 23 Januar 2018, 23:02:14 »
Ich habe das Problem auch und wir sind glaube auch nicht die einzigsten, welche das Problem haben.
Signalduino, Homematic, Raspberry Pi, Mysensors, MQTT, Alexa

Offline pc1246

  • Hero Member
  • *****
  • Beiträge: 3064
  • Kein support per PN oder eMail
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #789 am: 23 Januar 2018, 23:07:22 »
Moin
Hallo Christoph, das dachte ich auch zuerst, da das eigene Netz des ESP immer noch da ist. Es dauert so ca. 20 Sekunden, dann meldet er nach dem Start, dass er mit meinem Netz verbunden ist.
Warum das eigene Netz noch da ist??? Ist bei anderen ESP Implementierungen anders, aber schadet nur bedingt!
Gruss Christoph
RasPi2
Onkyo_AVR;3 Enigma2; SB_Server ; SB_Player; HM-USB mit 15 HM-CC-RT-DN, 3 HM_WDS10_TH_O, 6 HM-Sec-SCo, 4 HM-Sec-MDIR-2, 1 HM-Sen-MDIR-O-2, 8 Ferion 5000 OW ; PhilipsTV; add-on board mit 6 IT-Steckdosen;3 harmony hub; Jeelink mit 9 PCA301; Somfy; S7-300; 3 LGW; KS300; ESA2000; HUE

Offline habeIchVergessen

  • Sr. Member
  • ****
  • Beiträge: 782
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #790 am: 23 Januar 2018, 23:17:57 »
Ich habe das Problem auch und wir sind glaube auch nicht die einzigsten, welche das Problem haben.
habe eine Bugfix hochgeladen (oder s. hier).

Offline hjgode

  • Full Member
  • ***
  • Beiträge: 204
    • Windows CE Programming
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #791 am: 24 Januar 2018, 06:54:10 »

@hjgode:
Du hast vom SIGNALduino ausgehend die Anpassung gemacht. Wäre es nicht besser gewesen den SIGNALesp als Basis zu nehmen?

Grüße Sidey

Ich wollte dass der code möglichst nahe an SignalDuino ist. Wie gesagt, auuser dem Main ino wurde nur die PatternDecoder Klasse angepasst, damit ich dort ein WifiClient object übergeben kann, dass dann ebenfalls als Ausgabe benutzt wird.
Mein Code basiert auf der 3.1.0 und benötigt keine Anpassung des FHEM 00_SIGNALduino Moduls, ähnlich wie die Abindung des Signalduino Nano mit ESPlink.
Debian SID mit aktuellem FHEM, nanoCUL 866, JeeLink EC3000, fhemduino, SIGNALduino,
3 x TFA TH Sensor, 1 x TFA TH Arduino Sender, 3 x EC3000, 4 x Elro Schaltsteckdosen, ESA2000
offline: Wibo Funkthermostat, 2 x ELV Funkthermostat FHT80, 2 FS20 ST4 Funksteckdose

Offline Bennemannc

  • Hero Member
  • *****
  • Beiträge: 2730
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #792 am: 24 Januar 2018, 12:46:11 »
Das hilft leider auch nicht. Ich habe die Quellen neu gezogen und man das Debuging unten wieder reingenommen.
Reading values fom eeprom

dump EEPROM:
33 1d 0d 0d 2e 2d 07 d3 91 3d 04 32 00 00 06 00
10 b0 71 f7 c4 30 23 b9 00 07 00 18 14 6c 07 00
90 87 6b f8 56 11 e9 2a 00 1f 41 00 ff ff ff ff
00 84 00 00 00 00 00 00
SRES Started
POR Done
CCVersion=0x14
CCPartnum=0x0
CC1101 found (rev. 01)

Try connecting to WiFi with SSID 'Home_Router_N'
.
Connected successful to SSID 'Home_Router_N'
mounting FS...
mounted file system
reading config file
opened config file
{"ip":"192.168.11.10","gateway":"192.168.11.1","subnet":"255.255.255.0"}
parsed json
setting custom ip from config
192.168.11.10
*WM: SET AP STA
*WM:
*WM: Configuring access point...
*WM: ESP537799
*WM: AP IP address:
*WM: 192.168.4.1
*WM: HTTP server started
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Sent config page
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Handle root
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Request redirected to captive portal
*WM: Handle root
*WM: WiFi save
*WM: static ip
*WM: 192.168.11.10
*WM: static gateway
*WM: 192.168.11.1
*WM: static netmask
*WM: 255.255.255.0
*WM: Sent wifi save page
*WM: Connecting to new AP
*WM: Connecting as wifi client...
*WM: Custom STA IP/GW/Subnet
*WM: 192.168.11.10
*WM: Already connected. Bailing out.
Should save config
connected...)
local ip: 192.168.11.10
saving config
{
  "ip": "192.168.11.10",
  "gateway": "192.168.11.1",
  "subnet": "255.255.255.0"
}CC1100_PKTCTRL0=50 vs EEPROM PKTCTRL0=50
C1100_IOCFG2=13 vs EEPROM IOCFG2=13
receiver enabled
Er meldet sich beim Start direkt auf "Home_Router_N" an - richtig wäre "Cubie-Wifi". Wenn ich dann die Config aufrufe (192.168.4.1) sehe ich beide Netzwerke. Wenn ich dann das richtige wähle und den Schlüsseleingebe funktioniert alles anscheinend normal, aber das Netzwerk wird nicht gewechselt. Auch nach einem Reset meldet er sich sofort wieder beim falsche AP an. Das Netzwerk und der Schlüssel stehen irgendwo falsch drin und werden immer wieder genommen.

Habe Home_Router_N mal abgeschaltet. Dann schreibt er das richtige über die Webpage rein. Allerdings verbindet er sich damit nicht, weil er anscheinend DHCP versucht - die Config wurde noch nicht gelesen. Da auf Cubie-Wifi kein dhcp-Server läuft, kann er sich nicht verbinden.

Gruß Christoph

BTW. Sollten wir für den SignalESP nicht einen eigenen Threat aufmachen?
« Letzte Änderung: 24 Januar 2018, 13:22:36 von Bennemannc »
Cubietruck, Fhem 5.8
CC-RT-DN|LC-SW2-FM|RC-12|RC-19|LC-SW4-BA-PCB|LCp-SW1-BA-PCB|ES-PMSw1-Pl|LC-Bl1PBU-FM|PBI-4-FM|CC-VD|CC-TC|SEC-SC(2)|RC-KEY3-B|LC-Sw1PBU-FM|PB-2-FM|WDS100-C6-O|WDC7000|LC-Bl1-FM
Module: Dewpoint,FB_Callmonitor,HCS,Panstamp,at,notify,THRESHOLD,average,DOIF

Offline Ralf9

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4447
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #793 am: 24 Januar 2018, 20:09:41 »
Zitat
BTW. Sollten wir für den SignalESP nicht einen eigenen Threat aufmachen?

Ich hab mal ein neues Thema erstellt:
https://forum.fhem.de/index.php/topic,83273.0.html

Gruß Ralf
FHEM auf Cubietruck mit Igor-Image, SSD und  hmland + HM-CFG-USB-2,  HMUARTLGW Lan,   HM-LC-Bl1PBU-FM, HM-CC-RT-DN, HM-SEC-SC-2, HM-MOD-Re-8, HM-MOD-Em-8
HM-Wired:  HMW_IO_12_FM, HMW_Sen_SC_12_DR, Selbstbau IO-Module HBW_IO_SW
Maple-SIGNALduino, WH3080,  Hideki, Id 7

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2739
Antw:SIGNALDuino Empfänger Firm- und Hardware
« Antwort #794 am: 24 Januar 2018, 21:09:13 »
alle GPIOs (bis auf GPIO16) sind voll interruptfähig.

Das sind aber leider alles Software Interrupts und keine echten HW Interrupts

Grüße Sidey
Signalduino, Homematic, Raspberry Pi, Mysensors, MQTT, Alexa