Autor Thema: OSX und Perl Gui Module.  (Gelesen 7454 mal)

Offline Navigator

  • Sr. Member
  • ****
  • Beiträge: 620
OSX und Perl Gui Module.
« am: 12 Oktober 2016, 19:59:42 »
Hallo,

kann mir jemand sagen ob und was für Module auf einem OSX vorinstalliert sind mit Schwerpunkt GUI Programmierung in Perl? Ich füge gleich mal hinzu, daß ich auf betreffender Plattform keinerlei Rechte zur Nachinstallation besitze. :P
Ich würde meine kleinen selbst geschriebenen Helferlein, die meine Arbeit unterstützen jedoch gern von Terminal in grafische Programme umgestalten.  ::)

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21322
Antw:OSX und Perl Gui Module.
« Antwort #1 am: 12 Oktober 2016, 20:11:54 »
ohne nachgesehen zu haben eher keine per default.

du kannst aber sowohl perl module als auch andere libs auch als normaler user für den eigenbedarf installieren.

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline Navigator

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:OSX und Perl Gui Module.
« Antwort #2 am: 12 Oktober 2016, 20:55:40 »
... leider wird das wohl nicht funktionieren. die kiste ist für mich gestutzt bis zum geht nicht mehr. keine programme nachinstallierbar und nur intranet. es ist eigentlich nur ein client für eine datenbank. ich war sowas von froh und überrascht zugleich als mich im terminal der perl interpreter begrüsste.  8)
ich meinte gelesen zu haben, daß python hier in der standardbibliothek mehr bietet. aber dann fange ich von vorn an...  ::)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25815
Antw:OSX und Perl Gui Module.
« Antwort #3 am: 12 Oktober 2016, 22:36:27 »
Ich wuerde auf JavaSript setzen, und die Befehle von einem Backend, was HTTP spricht, ausfuehren lassen.
Wenn man das einigermassen Modular macht, dann kann man damit auch Hausautomationsaufgaben realisieren.

Wie waers mit FHEM auspacken und starten? fhem.pl, FHEMWEB, dummy und notify duerften ohne zusaetzlichen Perl-Module auskommen.

 

decade-submarginal