Autor Thema: (dist-)Upgrade von Jessie - ja oder nein?  (Gelesen 2973 mal)

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
(dist-)Upgrade von Jessie - ja oder nein?
« am: 24 Oktober 2016, 12:01:43 »
Hallo,

auf meinem Raspberry mit FHEM läuft zusätzlich OpenVPN als Server.

Die Fritzbox leitet Port 443 weiter an den Raspberry auf Port 1194 (443 deshalb, weil das der einzige Port ist, über welchen ich z.b. aus dem Firmenlan rauskomme)

Somit hängt mein Raspberry also mit OpenVPN "direkt" am Internet.

Jetzt stelle ich mir die Frage, in wie weit man gefahrlos ein "upgrade" bzw. "dist-upgrade" des OS machen kann/sollte, um alle nötigen Securitypatches zu erhalten...aber möglichst ohne irgendwas zu zerschiessen? Was empfiehlt sich denn da?

Danke!

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4010
  • Wer anderen eine Bratwurst brät...
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #1 am: 24 Oktober 2016, 12:04:09 »
Auf was willst Du denn von Jessie "dist-upgrade"n ?
Eine neuere Version als Jessie gibt es doch (noch) nicht.

Gruß
Dan
FHEM 5.9, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert, 98_serviced

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #2 am: 24 Oktober 2016, 12:10:55 »
Ich bin kein wirklicher Linuxer und habe das hier dazu gelesen:

Zitat
Ein "upgrade" aktualisiert nur bereits installierte Pakete. Ein "dist-upgrade" aktualisiert auch bereits installierte Pakete, aber zusätzlich auch die, für die sich Abhängigkeiten zu anderen Paketen geändert haben. Im Detail bedeutet dass, dass "dist-upgrade" neue Pakete installiert von denen aktualisierte Pakete abhängig sind. Umgekehrt entfernt "dist-upgrade" auch alte Pakete, zu denen keine Abhängigkeiten mehr bestehen

Und jetzt stehe ich vor der Frage, ob und was ich davon machen kann oder soll.

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4010
  • Wer anderen eine Bratwurst brät...
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #3 am: 24 Oktober 2016, 12:16:12 »
upgrade und dist-upgrade sollten bei einem bestehenden Jessie keine Probleme verursachen.

Für die ganz Ängstlichen kann man auch vorher ein Backup des gesamten Betriebssystems anlegen, z.B. Image von SD ziehen.

Gruß
Dan
FHEM 5.9, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert, 98_serviced

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #4 am: 24 Oktober 2016, 12:28:55 »
Vielen Dank. Ich mach dann mal ein Image und probiere es einfach mal mit upgrade.

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5475
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #5 am: 25 Oktober 2016, 10:38:32 »
Dein Zitat ist nicht gaaans richtig:

- Packete werde bei einem Upgrade/Dist-Upgrade nicht entfernt. Dazu muss ein "autoremove" her.

Um es jetzt mal sehr zu vereinfachen (bei Debian!)
upgrade aktuallisiert das System, Sicherheitslücken und eventuelle andere Softwareaktuallisierungen
dist-upgrade hebt das System auf dem nächsten Leven, also z.B. von Weesy auf Jessy

Bei Ubuntu sieht es dagegen etwas anders aus.
upgrade aktuallisiert das System, Sicherheitslücken und eventuelle andere Softwareaktuallisierungen, aber ohne Updates im Kernelbereich
dist-upgrade aktuallisiert zusätzlich Kernel (und andere Basis-Packete)
für Systemupgrades, d.h. nächsten leven, wird "do-release-upgrade" als eigenes Kommando benötigt.

Bei allen gilt:
Packete werden über "autoremove" gelöscht.

Alles ist allerdings etwas sehr vereinfacht ausgedrückt ...
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #6 am: 25 Oktober 2016, 10:49:04 »
Danke für die Erläuterung!

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 5475
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #7 am: 25 Oktober 2016, 10:50:22 »
Nitte berücksichtige, das es, wie beschrieben, Unterschiede zwischen Debian und Ubuntu gibt ....
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #8 am: 25 Oktober 2016, 13:31:05 »
Vielleicht ist das hier nicht das richtige Forum dafür, aber ich versuche es trotzdem einfach mal...das Upgrade hat soweit geklappt, aber es traten (und treten bei wiederholten Versuchen) immer diese Fehler auf:

Möchten Sie fortfahren? [J/n] j
python3-uno (1:4.3.3-2+rpi4) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-uno (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libreoffice:
 libreoffice hängt ab von python3-uno (>= 4.0~) | python-uno; aber:
  Paket python3-uno ist noch nicht konfiguriert.
  Paket python-uno ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes libreoffice (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
python3-pgzero (1.1-1) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-pgzero (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
python3-pil:armhf (2.6.1-2+deb8u2) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-pil:armhf (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
python3-rpi.gpio (0.6.2~jessie-1) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-rpi.gpio (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python3-sense-hat:
 python3-sense-hat hängt ab von python3-pil; aber:
  Paket python3-pil:armhf ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes python3-sense-hat (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
python3-picamera (1.12) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-picamera (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 python3-uno
 libreoffice
 python3-pgzero
 python3-pil:armhf
 python3-rpi.gpio
 python3-sense-hat
 python3-picamera
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ich habe es mit

sudo apt-get update  (lief fehlerfrei)
sudo apt-get upgrade

...durchgeführt.

Gibt es hier einen Ansatz für mich,wie ich das fixen kann?

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4010
  • Wer anderen eine Bratwurst brät...
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #9 am: 25 Oktober 2016, 13:35:29 »
Vorher auch:
sudo apt-get updatesudo apt-get autoremovegemacht?

Gruß
Dan
FHEM 5.9, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert, 98_serviced

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #10 am: 25 Oktober 2016, 13:56:03 »
Vorher nicht, habe es jetzt gerade versucht.

apt-get update läuft weiterhin fehlerfrei, aber leider die gleichen Fehler bei -autoremove:

pi@raspberrypi ~ $ sudo apt-get autoremove
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  libasn1-8-heimdal libdrm-freedreno1 libdrm-nouveau2 libdrm-radeon1 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal libllvm3.5
  libroken18-heimdal libwind0-heimdal libxfce4ui-1-0 xfce-keyboard-shortcuts
0 aktualisiert, 0 neu installiert, 15 zu entfernen und 11 nicht aktualisiert.
7 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 30,6 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 116801 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von libgssapi3-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libheimntlm0-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libkrb5-26-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libhx509-5-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libdrm-freedreno1:armhf (2.4.65-3~bpo8+1) ...
Entfernen von libdrm-nouveau2:armhf (2.4.65-3~bpo8+1) ...
Entfernen von libdrm-radeon1:armhf (2.4.65-3~bpo8+1) ...
Entfernen von libhcrypto4-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libheimbase1-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libllvm3.5:armhf (1:3.5-10+rpi1) ...
Entfernen von libwind0-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libxfce4ui-1-0 (4.10.0-6) ...
Entfernen von xfce-keyboard-shortcuts (4.10.0-6) ...
Entfernen von libasn1-8-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Entfernen von libroken18-heimdal:armhf (1.6~rc2+dfsg-9+rpi1) ...
Trigger für libc-bin (2.19-18+deb8u6) werden verarbeitet ...
python3-uno (1:4.3.3-2+rpi4) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-uno (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libreoffice:
 libreoffice hängt ab von python3-uno (>= 4.0~) | python-uno; aber:
  Paket python3-uno ist noch nicht konfiguriert.
  Paket python-uno ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes libreoffice (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
python3-pgzero (1.1-1) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-pgzero (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
python3-pil:armhf (2.6.1-2+deb8u2) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-pil:armhf (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
python3-rpi.gpio (0.6.2~jessie-1) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-rpi.gpio (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python3-sense-hat:
 python3-sense-hat hängt ab von python3-pil; aber:
  Paket python3-pil:armhf ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes python3-sense-hat (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
python3-picamera (1.12) wird eingerichtet ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/lib/python3.4/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 290, in <module>
    main()
  File "/usr/bin/py3compile", line 270, in main
    options.force, options.optimize, e_patterns)
  File "/usr/bin/py3compile", line 156, in compile
    cfn = interpreter.cache_file(fn, version)
  File "/usr/share/python3/debpython/interpreter.py", line 212, in cache_file
    (fname[:-3], self.magic_tag(version), last_char))
  File "/usr/share/python3/debpython/interpreter.py", line 246, in magic_tag
    return self._execute('import imp; print(imp.get_tag())', version)
  File "/usr/share/python3/debpython/interpreter.py", line 359, in _execute
    raise Exception('{} failed with status code {}'.format(command, output['returncode']))
Exception: python3.4 -c 'import imp; print(imp.get_tag())' failed with status code 1
dpkg: Fehler beim Bearbeiten des Paketes python3-picamera (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 python3-uno
 libreoffice
 python3-pgzero
 python3-pil:armhf
 python3-rpi.gpio
 python3-sense-hat
 python3-picamera
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Letzte Änderung: 25 Oktober 2016, 13:58:18 von errazzor »

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4010
  • Wer anderen eine Bratwurst brät...
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #11 am: 25 Oktober 2016, 14:01:12 »
Fehler traten auf beim Bearbeiten von:
 python3-uno
 libreoffice
 python3-pgzero
 python3-pil:armhf
 python3-rpi.gpio
 python3-sense-hat
 python3-picamera
E: Sub-process /usr/bin/dpkg returned an error code (1)

Sind denn das Pakete die Du benötigst? Ansonsten purge sie doch einfach.

Gruß
Dan
FHEM 5.9, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert, 98_serviced

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #12 am: 25 Oktober 2016, 14:29:16 »
Das ist eine gute Frage - keine Ahnung :-) ... Habe halt FHEM und zusätzlich OpenVPN am laufen.
Wenn man es dafür nicht benötigt...wie purge ich die weg?

Offline DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4010
  • Wer anderen eine Bratwurst brät...
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #13 am: 25 Oktober 2016, 14:36:48 »
Das ist eine gute Frage - keine Ahnung :-) ... Habe halt FHEM und zusätzlich OpenVPN am laufen.
Wenn man es dafür nicht benötigt...wie purge ich die weg?

purge sollte doch das Stichwort sein um im Zweifelsfall über die Suchmaschine Deines Vertrauens etwas zu finden, denn das hat nichts mit FHEM zu tun.

Aber bitte:
sudo apt-get purge python3-uno libreoffice python3-pgzero python3-pil:armhf python3-rpi.gpio python3-sense-hat python3-picamera
Gruß
Dan
FHEM 5.9, Brix, VIVO mini, RPi3, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 22_HOMEMODE, 98_Hyperion, 98_FileLogConvert, 98_serviced

Offline errazzor

  • Full Member
  • ***
  • Beiträge: 304
Antw:(dist-)Upgrade von Jessie - ja oder nein?
« Antwort #14 am: 25 Oktober 2016, 15:10:23 »
Das hat geklappt, herzlichen Dank. Upgrade läuft nun sauber durch.

 

decade-submarginal