Autor Thema: culfw:Fehler nach Modus-Wechsel & 'B00' unknown  (Gelesen 303 mal)

Offline tca

  • Jr. Member
  • **
  • Beiträge: 67
culfw:Fehler nach Modus-Wechsel & 'B00' unknown
« am: 05 November 2016, 13:50:32 »
Hallo,

ich habe einen Raspberry mit COC Erweiterung. Jede Nacht um 4 Uhr wechsel ich mit
*04:00:00 attr MAX_Scanner disable 1;attr COC rfmode WMBus_T; in den WMBus_T Modus, dann um um 6 Uhr wieder zurück zu MAX!
*06:00:00 attr COC rfmode MAX; attr MAX_Scanner disable 0;
Nach dem Zurückwechseln zu MAX, bekomme ich dann im Log immer diese Fehlermeldungen:
2016.11.05 06:00:00 2: Switched COC rfmode to MAX
2016.11.05 06:00:10 2: COC: unknown message ZERR316
2016.11.05 06:15:06 2: COC: unknown message ZERR316
2016.11.05 06:16:56 2: COC: unknown message ZERR316
2016.11.05 06:18:52 2: COC: unknown message ZERR316
2016.11.05 06:30:49 2: COC: unknown message ZERR316
2016.11.05 07:02:00 2: COC: unknown message ZERR316
2016.11.05 07:15:43 2: CUL_MAX_Parse: Got unhandled message type F9
2016.11.05 07:18:03 2: COC: unknown message ZERR316
2016.11.05 07:21:09 2: COC: unknown message ZERR316
2016.11.05 07:24:10 2: COC: unknown message ZERR316
2016.11.05 07:27:11 2: COC: unknown message ZERR316
2016.11.05 07:27:23 2: COC: unknown message Z027402
2016.11.05 07:31:10 2: COC: unknown message ZERR316
2016.11.05 07:33:03 2: COC: unknown message ZERR316
...

Es sieht so aus, als ob der Fehler durch die culfw (COC) ausgelöst wird.
Nach einem Reboot des Raspberry werden keine Fehlermeldungen mehr angezeigt, bis zum nächsten Hin- und Herwechsel.

Noch eine Beobachtung: das raw-commando 'B00' (FHEM & Terminal) ist unbekannt:
? (B00 is unknown) Use one of m b C F i A Z O G M K b R T V W X e f l t u x
Leider kann also ich keinen Reboot für nur das COC auslösen.

Hat jemand ähnliche Beobachtungen gemacht?

Danke,
Tom

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16025
Antw:culfw:Fehler nach Modus-Wechsel & 'B00' unknown
« Antwort #1 am: 05 November 2016, 16:35:24 »
COC kenne ich nicht wirklich, der culfw Autor fuer das Geraet hat das B(oot) Befehl tatsaechlich nicht implementiert.

Eigentlich ist weder MAX noch WMBUS von mir, ich sehe aber gerade, dass bei der Umstellung von WMBUS auf MAX die WMBUS Verarbeitug in culfw nicht abgestellt wird, und vmtl. deswegen dazwischenfunkt.
Abstellen kann man die WMBUS Verarbeitung mit sowas wie "set CUL raw brx", das wuerde ich vor dem Setzen des rfMode Attributes senden. Ja, mir ist bekannt, dass das Umstellen der rfMode Parameter nicht sauber ist, war nicht so geplant.
Zustimmung Zustimmung x 1 Liste anzeigen

Offline tca

  • Jr. Member
  • **
  • Beiträge: 67
Antw:culfw:Fehler nach Modus-Wechsel & 'B00' unknown
« Antwort #2 am: 05 November 2016, 21:21:55 »
Ah - danke für den Tip, das war es!

Schalte jetzt mit 'set CUL raw brx' zunächst den WMBUS-Empfang explizit ab und erst anschliessend den rfmode auf MAX um :-) 

 

decade-submarginal