Autor Thema: 10_KNX.pm || hier: Gruppenadressen (GA) / Hautgruppe > 15  (Gelesen 1417 mal)

Offline its2bit

  • New Member
  • *
  • Beiträge: 13
10_KNX.pm || hier: Gruppenadressen (GA) / Hautgruppe > 15
« am: 07 November 2016, 19:43:05 »
Hallo FHEM-Forum,

ich bin bei der Zuweisung der KNX Objekte in FHEM auf ein Problem gestoßen. Meine Gruppenadresse lautet 27/3/60 diese wird mit der autocreate Funktion nicht angelegt. Das Modul mappt die Adresse auf 11/3/60.

Ein manuelles Rename funktioniert. Bei der Get-Abfrage hängt sich der FHEM Dienst auf.

Im Modul steht ein Hinweis auf die GA 0-15/0-15/0-255. Laut meinen Informationen gibt es nur 0-31/0-7/0-255.

- Kann mir einer sagen, wie ich es in Perl umschreiben könnte?

Ein bisschen Spaß beim Experimentieren kann ja nicht schaden.

Danke fürs Lesen.

Mfg
its2bit


Offline its2bit

  • New Member
  • *
  • Beiträge: 13
Antw:10_KNX.pm || hier: Gruppenadressen (GA) / Hautgruppe > 15
« Antwort #2 am: 08 November 2016, 13:27:52 »
Hallo Andi291,

Danke für die Antwort.
Ich hab noch eine Verständnisfrage. Die physikalische Adresse sind wie folgt aufgebaut 0-15.0-15.0-255. Das Trennzeichen ist der ".".

Das Modul müsste doch mit den Gruppenadressen 0-31/0-7/00-255, Trennzeichen "/" arbeiten.

- ist meine Annahme korrekt?

Danke

Its2bit

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1125
Antw:10_KNX.pm || hier: Gruppenadressen (GA) / Hautgruppe > 15
« Antwort #3 am: 08 November 2016, 19:26:25 »
Ja, Deine Annahme ist korrekt. Nur eben die Bereiche passen nicht.
Das Problem ist auch nicht einfach im Modul KNX zu lösen. Zusätzlich sind TUL, ggf. externe Treiber und ggf. der KNXD anzupassen. Nur Modultuning hilft nicht :-)

Grüße, Andi

Offline its2bit

  • New Member
  • *
  • Beiträge: 13
Antw:10_KNX.pm || hier: Gruppenadressen (GA) / Hautgruppe > 15
« Antwort #4 am: 08 November 2016, 20:15:36 »
Schade.  :-[

Ich werd mir mal in Ruhe das TUL anschauen.


Trotzdem Danke für die schnelle Hilfe/ Antwort.

Its2bit