Autor Thema: ModbusTCPServer plötzlich disconnected  (Gelesen 311 mal)

Offline Conti

  • New Member
  • *
  • Beiträge: 29
ModbusTCPServer plötzlich disconnected
« am: 09 November 2016, 16:13:34 »
Hallo zusammen

ich frage schon seit fast einem Jahr wie im SolarLog Wiki beschrieben meinen SolarLog mit fhem ab und zeige die Daten zusätzlich noch im FTUI an.
Klappt reibungslos.
Seit heute Morgen zeigt mein ModbusTCPServer nur noch disconnected an und schreibt so keine Daten mehr ins log.

Der SolarLog ist da.
Die IP Adresse ist immer noch dieselbe.

Ich habe gestern Abend wieder mal den Raspi sowie FHEM auf den neusten Stand updated.

Wie, wo sollte ich mit der Fehlersuche loslegen. Hab keinen Plan was ich noch checken könnte.

Kann mir ev. jemand weiterhelfen?
Vielen Dank im Voraus.
Beste Grüsse
Conti

Online ChrisD

  • Sr. Member
  • ****
  • Beiträge: 668
Antw:ModbusTCPServer plötzlich disconnected
« Antwort #1 am: 09 November 2016, 17:12:36 »
Hallo,

Du kannst zuerst mit telnet ausprobieren ob der Modbus Server noch funktioniert:
telnet IP-Adresse 502
Wenn die Verbindung vom RasPi aus aufgebaut werden kann und bei Tastendrücken wirre Zeichen auftauchen ist der Server wahrscheinlich in Ordnung.

Anschließend kannst du das Attribut 'verbose' beim ModbusTCPServer auf 5 setzen und im Log schauen welche Meldungen ausgegeben werden.

Grüße,

ChrisD

Offline Conti

  • New Member
  • *
  • Beiträge: 29
Antw:ModbusTCPServer plötzlich disconnected
« Antwort #2 am: 10 November 2016, 14:05:57 »
Vielen Dank ChrisD.

Versuche ich gleich mal heut Abend.

Viele Grüsse
Conti