Autor Thema: [alexa-fhem | Generell] Alles zu Installation und damit verbundenen Problemen  (Gelesen 453022 mal)

Offline netbus

  • Full Member
  • ***
  • Beiträge: 352
Ja, ist wieder verfügbar.

« Letzte Änderung: 27 April 2021, 14:47:10 von netbus »

Offline JoWiemann

  • Tester
  • Hero Member
  • ****
  • Beiträge: 3186
Hallo,

ich hatte heute folgende Situation. Unser FI hat ausgelöst und alles Stromlos. Nach dem Einschalten funktionierten alle Fhem Geräte in Alexa nicht mehr. Also RPi noch einmal neu gestartet. Keine Veränderung. Alexa ist weiterhin der Meinung, die Geräte reagieren nicht. Nach dem Löschen aller Geräte in der Alexa App und neu starten des RPi wurden alle Geräte in der Alexa App als neu angelegt angezeigt und funktionierten wieder. Hat jemand eine Idee, was da geklemmt haben könnte.

Grüße Jörg
Jörg Wiemann

Slave: RPi B+ mit 512 MB, COC (868 MHz), CUL V3 (433.92MHz SlowRF); FHEMduino, Aktuelles FHEM

Master: CubieTruck; Debian; Aktuelles FHEM

Offline gvzdus

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 852
Um wild Spekulationen von mir zu geben: Hast Du vielleicht implizit damit ein Update von einer sehr, sehr alten FHEM-Version auf eine aktuellere Version aktiviert? Die uuid ist neumodisch Krams in FHEM und wurde erst vor vielleicht einem Jahr (?) eingeführt.

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2864
Hi,
habt ihr auch die Email von Amazon bekommen das ihr nodejs auf 14x updaten müsst? Ich hab da leider Probleme auf meinem Cubietruck mit armbian, wenn ich dort über ein
[CODE]curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bash -xbekomme ich diese Meldung:

curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bas                                                                                                                     h -x
+ export DEBIAN_FRONTEND=noninteractive
+ DEBIAN_FRONTEND=noninteractive
+ SCRSUFFIX=_14.x
+ NODENAME='Node.js 14.x'
+ NODEREPO=node_14.x
+ NODEPKG=nodejs
+ test -t 1
++ which tput
++ tput colors
+ ncolors=8
+ test -n 8
+ test 8 -ge 8
++ tput cols
+ termcols=80
++ tput bold
+ bold=''
++ tput smul
+ underline=''
++ tput smso
+ standout=''
++ tput sgr0
+ normal=''
++ tput setaf 0
+ black=''
++ tput setaf 1
+ red=''
++ tput setaf 2
+ green=''
++ tput setaf 3
+ yellow=''
++ tput setaf 4
+ blue=''
++ tput setaf 5
+ magenta=''
++ tput setaf 6
+ cyan=''
++ tput setaf 7
+ white=''
+ setup
+ script_deprecation_warning
+ '[' X_14.x == X ']'
+ node_deprecation_warning
+ [[ XNode.js 14.x == \X\i\o\.\j\s\ \1\.\x ]]
+ [[ XNode.js 14.x == \X\i\o\.\j\s\ \2\.\x ]]
+ [[ XNode.js 14.x == \X\i\o\.\j\s\ \3\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \0\.\1\0 ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \0\.\1\2 ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \4\.\x\ \L\T\S\ \A\r\g\o\n ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \5\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \6\.\x\ \L\T\S\ \B\o\r\o\n ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \7\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \8\.\x\ \L\T\S\ \C\a\r\b\o\n ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \9\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \1\0\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \1\1\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \1\3\.\x ]]
+ print_status 'Installing the NodeSource Node.js 14.x repo...'
+ echo

+ echo '## Installing the NodeSource Node.js 14.x repo...'
## Installing the NodeSource Node.js 14.x repo...
+ echo

++ uname -m
++ grep -Eq '^armv6'
+ PRE_INSTALL_PKGS=
+ '[' '!' -e /usr/lib/apt/methods/https ']'
+ '[' '!' -x /usr/bin/lsb_release ']'
+ PRE_INSTALL_PKGS=' lsb-release'
+ '[' '!' -x /usr/bin/curl ']'
+ '[' '!' -x /usr/bin/gpg ']'
+ print_status 'Populating apt-get cache...'
+ echo

+ echo '## Populating apt-get cache...'
## Populating apt-get cache...
+ echo

+ exec_cmd 'apt-get update'
+ exec_cmd_nobail 'apt-get update'
+ echo '+ apt-get update'
+ apt-get update
+ bash -c 'apt-get update'
Holen:1 http://security.debian.org buster/updates InRelease [65,4 kB]
OK:3 http://httpredir.debian.org/debian buster InRelease
Holen:4 http://httpredir.debian.org/debian buster-updates InRelease [51,9 kB]
Holen:5 http://httpredir.debian.org/debian buster-backports InRelease [46,7 kB]
Holen:2 https://mirrors.netix.net/armbian/apt buster InRelease [18,4 kB]
Holen:6 http://security.debian.org buster/updates/main armhf Packages [351 kB]
Holen:7 http://httpredir.debian.org/debian buster-backports/main armhf Packages.diff/Index [27,8 kB]
Holen:8 http://httpredir.debian.org/debian buster-backports/main armhf Packages 2021-05-11-1400.52.pdiff [677 B]
Holen:8 http://httpredir.debian.org/debian buster-backports/main armhf Packages 2021-05-11-1400.52.pdiff [677 B]
Holen:9 https://mirrors.netix.net/armbian/apt buster/main armhf Packages [867 kB]
Holen:10 https://mirrors.netix.net/armbian/apt buster/main armhf Contents (deb) [24,4 MB]
Holen:11 https://mirrors.netix.net/armbian/apt buster/buster-utils armhf Packages [73,9 kB]
Holen:12 https://mirrors.netix.net/armbian/apt buster/buster-utils armhf Contents (deb) [12,8 kB]
Holen:13 https://mirrors.netix.net/armbian/apt buster/buster-desktop armhf Packages [28,4 kB]
Es wurden 25,9 MB in 3 min 7 s geholt (139 kB/s).
Paketlisten werden gelesen... Fertig
+ '[' 'X lsb-release' '!=' X ']'
+ print_status 'Installing packages required for setup: lsb-release...'
+ echo

+ echo '## Installing packages required for setup: lsb-release...'
## Installing packages required for setup: lsb-release...
+ echo

+ exec_cmd 'apt-get install -y lsb-release > /dev/null 2>&1'
+ exec_cmd_nobail 'apt-get install -y lsb-release > /dev/null 2>&1'
+ echo '+ apt-get install -y lsb-release > /dev/null 2>&1'
+ apt-get install -y lsb-release > /dev/null 2>&1
+ bash -c 'apt-get install -y lsb-release > /dev/null 2>&1'
++ lsb_release -d
++ grep 'Ubuntu .*development'
main: Zeile 206: lsb_release: Kommando nicht gefunden.
++ echo 1
+ IS_PRERELEASE=1
+ [[ 1 -eq 0 ]]
++ lsb_release -c -s
main: Zeile 212: lsb_release: Kommando nicht gefunden.
+ DISTRO=
+ check_alt SolydXK solydxk-9 Debian stretch
+ '[' X == Xsolydxk-9 ']'
+ check_alt Kali sana Debian jessie
+ '[' X == Xsana ']'
+ check_alt Kali kali-rolling Debian bullseye
+ '[' X == Xkali-rolling ']'
+ check_alt 'Sparky Linux' Tyche Debian stretch
+ '[' X == XTyche ']'
+ check_alt 'Sparky Linux' Nibiru Debian buster
+ '[' X == XNibiru ']'
+ check_alt 'MX Linux 17' Horizon Debian stretch
+ '[' X == XHorizon ']'
+ check_alt 'MX Linux 18' Continuum Debian stretch
+ '[' X == XContinuum ']'
+ check_alt 'MX Linux 19' 'patito feo' Debian buster
+ '[' X == 'Xpatito feo' ']'
+ check_alt 'Linux Mint' maya Ubuntu precise
+ '[' X == Xmaya ']'
+ check_alt 'Linux Mint' qiana Ubuntu trusty
+ '[' X == Xqiana ']'
+ check_alt 'Linux Mint' rafaela Ubuntu trusty
+ '[' X == Xrafaela ']'
+ check_alt 'Linux Mint' rebecca Ubuntu trusty
+ '[' X == Xrebecca ']'
+ check_alt 'Linux Mint' rosa Ubuntu trusty
+ '[' X == Xrosa ']'
+ check_alt 'Linux Mint' sarah Ubuntu xenial
+ '[' X == Xsarah ']'
+ check_alt 'Linux Mint' serena Ubuntu xenial
+ '[' X == Xserena ']'
+ check_alt 'Linux Mint' sonya Ubuntu xenial
+ '[' X == Xsonya ']'
+ check_alt 'Linux Mint' sylvia Ubuntu xenial
+ '[' X == Xsylvia ']'
+ check_alt 'Linux Mint' tara Ubuntu bionic
+ '[' X == Xtara ']'
+ check_alt 'Linux Mint' tessa Ubuntu bionic
+ '[' X == Xtessa ']'
+ check_alt 'Linux Mint' tina Ubuntu bionic
+ '[' X == Xtina ']'
+ check_alt 'Linux Mint' tricia Ubuntu bionic
+ '[' X == Xtricia ']'
+ check_alt 'Linux Mint' ulyana Ubuntu focal
+ '[' X == Xulyana ']'
+ check_alt 'Linux Mint' ulyssa Ubuntu focal
+ '[' X == Xulyssa ']'
+ check_alt LMDE betsy Debian jessie
+ '[' X == Xbetsy ']'
+ check_alt LMDE cindy Debian stretch
+ '[' X == Xcindy ']'
+ check_alt LMDE debbie Debian buster
+ '[' X == Xdebbie ']'
+ check_alt elementaryOS luna Ubuntu precise
+ '[' X == Xluna ']'
+ check_alt elementaryOS freya Ubuntu trusty
+ '[' X == Xfreya ']'
+ check_alt elementaryOS loki Ubuntu xenial
+ '[' X == Xloki ']'
+ check_alt elementaryOS juno Ubuntu bionic
+ '[' X == Xjuno ']'
+ check_alt elementaryOS hera Ubuntu bionic
+ '[' X == Xhera ']'
+ check_alt elementaryOS odin Ubuntu focal
+ '[' X == Xodin ']'
+ check_alt Trisquel toutatis Ubuntu precise
+ '[' X == Xtoutatis ']'
+ check_alt Trisquel belenos Ubuntu trusty
+ '[' X == Xbelenos ']'
+ check_alt Trisquel flidas Ubuntu xenial
+ '[' X == Xflidas ']'
+ check_alt Trisquel etiona Ubuntu bionic
+ '[' X == Xetiona ']'
+ check_alt 'Uruk GNU/Linux' lugalbanda Ubuntu xenial
+ '[' X == Xlugalbanda ']'
+ check_alt BOSS anokha Debian wheezy
+ '[' X == Xanokha ']'
+ check_alt BOSS anoop Debian jessie
+ '[' X == Xanoop ']'
+ check_alt BOSS drishti Debian stretch
+ '[' X == Xdrishti ']'
+ check_alt BOSS unnati Debian buster
+ '[' X == Xunnati ']'
+ check_alt bunsenlabs bunsen-hydrogen Debian jessie
+ '[' X == Xbunsen-hydrogen ']'
+ check_alt bunsenlabs helium Debian stretch
+ '[' X == Xhelium ']'
+ check_alt bunsenlabs lithium Debian buster
+ '[' X == Xlithium ']'
+ check_alt Tanglu chromodoris Debian jessie
+ '[' X == Xchromodoris ']'
+ check_alt PureOS green Debian sid
+ '[' X == Xgreen ']'
+ check_alt PureOS amber Debian buster
+ '[' X == Xamber ']'
+ check_alt Devuan jessie Debian jessie
+ '[' X == Xjessie ']'
+ check_alt Devuan ascii Debian stretch
+ '[' X == Xascii ']'
+ check_alt Devuan beowulf Debian buster
+ '[' X == Xbeowulf ']'
+ check_alt Devuan ceres Debian sid
+ '[' X == Xceres ']'
+ check_alt Deepin panda Debian sid
+ '[' X == Xpanda ']'
+ check_alt Deepin unstable Debian sid
+ '[' X == Xunstable ']'
+ check_alt Deepin stable Debian buster
+ '[' X == Xstable ']'
+ check_alt Pardus onyedi Debian stretch
+ '[' X == Xonyedi ']'
+ check_alt 'Liquid Lemur' lemur-3 Debian stretch
+ '[' X == Xlemur-3 ']'
+ check_alt 'Astra Linux' orel Debian stretch
+ '[' X == Xorel ']'
+ check_alt Ubilinux dolcetto Debian stretch
+ '[' X == Xdolcetto ']'
+ '[' X == Xdebian ']'
+ print_status 'Confirming "" is supported...'
+ echo

+ echo '## Confirming "" is supported...'
## Confirming "" is supported...
+ echo

+ '[' -x /usr/bin/curl ']'
+ exec_cmd_nobail 'curl -sLf -o /dev/null '\''https://deb.nodesource.com/node_14.x/dists//Release'\'''
+ echo '+ curl -sLf -o /dev/null '\''https://deb.nodesource.com/node_14.x/dists//Release'\'''
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_14.x/dists//Release'
+ bash -c 'curl -sLf -o /dev/null '\''https://deb.nodesource.com/node_14.x/dists//Release'\'''
+ RC=22
+ [[ 22 != 0 ]]
+ print_status 'Your distribution, identified as "", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support'
+ echo

+ echo '## Your distribution, identified as "", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support'
## Your distribution, identified as "", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support
+ echo

+ exit 1

Was mach ich falsch?

Danke[/code]
Fhem Cubitruck  Armbian Buster with Linux 5.3.9-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2019,FB6590
Allnetl Wandtablett mit FTUI

Offline gvzdus

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 852
Das dürfte für die Lamba-Funktionen gelten, also etwas, was auf den Deckel vom FHEM-Verein zentral bei FHEM-Connector für alle betrieben wird. Das nodejs auf dem Raspi etc. mit alexa-fhem ist ein "rein persönliche" Angelegenheit und hat keine Auswirkung auf die Kompatibilität mit FHEM-Connector.

Also besser nicht anfangen, an der Distribution und dem mitgelieferten "nodejs" rumzuverbessern!
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline sinemeter

  • New Member
  • *
  • Beiträge: 6
Hallo zusammen,

Fhem-connector lief bei mir über viele Monate stabil - soweit alles gut.

Hatte allerdings vor ein paar Tagen bemerkt das Alexa die Geräte plötzlich nicht mehr erkennt.
Der Fhem-connector war gestoppt.

Das Problem war das die SD Karte vom Raspi voll war.
Dieses Problem habe  ich beseitigt zunächst mal mit
sudo apt-get clean

Allerdings bekomme ich den Fhem-Connector nicht mehr zum laufen.
Alexa Loggile sagt:

error: auth format wrong. must be user:password

Version:
FVERSION
39_alexa.pm:0.238200/2021-02-24


Fhem-log:

2021.08.14 22:54:56 3: alexa: starting
2021.08.14 22:54:56 3: alexa: using logfile: ./log/alexa-2021-08-14.log
2021.08.14 22:54:56 3: alexa: read: end of file reached while sysread
2021.08.14 22:54:56 3: alexa: stopped

Hat hier jemand eine Idee?
Kann ich evtl. eine komplette Neuinstallation des Connectors machen und wie würde ich da am besten vorgehen?


Vielen Dank schon einmal für Eure Idden.


Sinemeter

« Letzte Änderung: 14 August 2021, 23:06:22 von sinemeter »

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 10971
  • NIVEAu ist keine Creme...
sudo apt-get clean wird aber nicht wirklich (lange) helfen!

Besser alte (verm. unnötige) Logfiles etc. löschen!

Evtl. ist auch die SD defekt, kann schon mal passieren, wenn gar kein Platz mehr war: je weniger Platz auf der SD desto schneller/wahrscheinlicher kommt ein Defekt...

Neuinstallation geht problemlos (normalerweise).

Aber wenn du komplett neu installierst, dann musst du auch neu verknüpfen etc.
EDIT: also neu installieren auf NEUEM System. Ansonsten ist es keine Neuinstallation, sondern wird ja nur "drüber" installiert...

Alternativ zum neu Verknüpfen nach Neuinstallation (neues System/SD) kannst auch die ssh-Dateien mit umziehen.
Normalerweise: /opt/fhem/.ssh
dann musst du nicht neu verknüpfen (bzw. bin ich so schon 2x umgezogen)...

Wichtig: die Rechte/Besitzverhältnisse MÜSSEN STIMMEN! Also von /opt/fhem/.ssh

Bevor du aber NUR den Connector neu installierst (oder auch generell):

mal das alexa-Log vom Start posten...

und auch mal da schauen: https://wiki.fhem.de/wiki/FHEM_Connector_f%C3%BCr_Amazon_Alexa#M.C3.B6gliche_Probleme_und_L.C3.B6sungen

Wenn die SD voll ist/war, evtl. ganz neu installieren auf größere SD...
...oder wirklich aufräumen...

Gruß, Joachim
« Letzte Änderung: 15 August 2021, 00:03:26 von MadMax-FHEM »
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 RaspiOS (Test)
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline sinemeter

  • New Member
  • *
  • Beiträge: 6
Danke Joachim für Deine schnelle Antwort.

Ich wollte noch kurz Erfolg vermelden:

apt-get clean hat ca. 2GB freigemacht.
Zusätzlich werde ich jetzt noch die Logfiles löschen.

Gerettet hat mich ein mit fhem selbst erstelltes ca. 2 Monate altes Backup.
Dieses einfach mit tar  ins existierende Verzeichnis drübergebügelt.


Läuft alles wieder!👍

Nicht ganz saubere Methode aber hat geholfen.
Parallel bereite ich den Umzug auf eine frische Installation auf Raspi4 vor.

Derzeit ist mein Produktivsystem Raspi3B mit alten Raspian Stretch.

VG
Sinemeter

Offline sinemeter

  • New Member
  • *
  • Beiträge: 6
Hallo zusammen,

meine Umzugsaktion macht Fortschritte. Womit ich aber bislang noch scheitere ist das Thema den
.ssh Key umzuziehen:


Alternativ zum neu Verknüpfen nach Neuinstallation (neues System/SD) kannst auch die ssh-Dateien mit umziehen.
Normalerweise: /opt/fhem/.ssh
dann musst du nicht neu verknüpfen (bzw. bin ich so schon 2x umgezogen)...

Wichtig: die Rechte/Besitzverhältnisse MÜSSEN STIMMEN! Also von /opt/fhem/.ssh


Mit den mir bekannten Methoden entweder über WinSCP  oder auch per Terminal am altren Pi3   per
scp Befehl klappt das nich:

sudo scp ./.ssh pi@raspi4.fritz.box:/opt/fhem
./.ssh: not a regular file
/



Hat jemand eine Idee wie ich das mache?


Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 10971
  • NIVEAu ist keine Creme...
Einfacher ist ein Neuverknüpfen... ;)

EDIT: du kopierst ja auch (versuchst es) ein Verzeichnis. Das genau sagt der Fehler: was du kopieren willst ist keine "normale Datei" -> korrekt es ist ein Verzeichnis ;)

Vorausgesetzt auf beiden Systemen sind die User (fhem) IDs und Group IDs gleich ("identische" Installation mehr oder weniger), dann:

rsync sollte gehen

ich habe es mit tar gemacht (die .tar Datei ist jetzt in /opt/fhem und wird somit bei einem fhem backup mitgesichert :) ):
cd /opt/fhem
sudo tar -cf ssh.tar .ssh/
sudo chown fhem: ssh.tar

zurücksichern sollte mittels gehen:
sudo tar -xf ssh.tar -C /opt/fhem/

OHNE GEWÄHR!!

EDIT: die .tar Datei kannst du jetzt z.B. mittels scp übertragen ;) (weil das ist eine Datei mit dem Inhalt des Verzeichnisses und des Verzeichnisses selbst)...

Gruß, Joachim

P.S.: wenn du es bislang nicht geschafft hast und auch noch nicht (viel) mit tar und rsync gemacht hast, dann besser lassen, weil du dann verm. auch nicht (genau) weißt wie du etwas "reparieren" kannst, wenn etwas "schief gegangen" ist...
« Letzte Änderung: 19 August 2021, 11:07:28 von MadMax-FHEM »
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 RaspiOS (Test)

Offline misux

  • Sr. Member
  • ****
  • Beiträge: 916
Hallo.

Mal so nebenbei etwas gerfagt...

Wie lösche ich am schnellsten die Logfiles von alexa und vor allem wie stelle ich ein das nicht so viele geschrieben werden? habe auch so um die eine Million.... ::) :-\

hoffe einer erbarmt sich die blöde Frage zu beantworten...

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 20830
wie in der commandref beschrieben: nrarchive setzen. also genau so wie für FileLog auch.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline TomLee

  • Hero Member
  • *****
  • Beiträge: 3564
  • ... wer sät, der erntet ...
sudo rm /opt/fhem/log/alexa*log
löscht alle Dateien.

Nach dem löschen aller Dateien gibts keine Log-Datei mehr bis zu einem restart (reload reicht nicht aus, hat mein Test gezeigt) oder einfach nix machen  :P ,  ab 0 Uhr wird eh ein neues geschrieben .!?

Und (nochmal) halt nrarchive setzen

Beispiel:
attr alexa nrarchive 2erreicht man bspw. das nur zwei Files geschrieben werden.

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 20830
unter unix werden files erst dann endgültig gelöscht wenn niemand mehr das file offen hat. d.h. nach dem löschen von hand von dem fhem nix mit bekommt schreibt es so lange weiter in das für alle anderen unsichbrare file bis die nächste rotation ansteht. kann man so machen. ist aber unsauber.

einfach nur narchive sezten sollte völlig reichen
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH
Informativ Informativ x 1 Liste anzeigen

Offline misux

  • Sr. Member
  • ****
  • Beiträge: 916
Danke euch!

 8)

 

decade-submarginal