Autor Thema: [alexa-fhem | Generell] Alles zu Installation und damit verbundenen Problemen  (Gelesen 235608 mal)

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3921
  • NIVEAu ist keine Creme...
@Brad Majors:

Wann hast du den Skill angelegt?

Es sieht so aus als bräuchtest du alexa-fhem 0.4.x mit payload V3...

https://forum.fhem.de/index.php/topic,81324.0.html

Kurz, da nur Handy...

Gruß, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 17763
@Heimweh: deine node version ist zu alt. es ist mindestens nötig 0.12.8.

siehe hinweise im wiki.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2246
Hi,
einer noch eine idee für mein Problem aus #2096?

Danke
Fhem Linux cubietruck 4.14.0-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3921
  • NIVEAu ist keine Creme...
Hi,
einer noch eine idee für mein Problem aus #2096?

Danke

Statt der Nummer wäre ein direkter Link schöner gewesen aber es liegt ja noch nicht so weit zurück ;)

Welchen Autostart hast du eingerichtet?
Sicher nur den initd (startscript unter /etc/init.d/) oder beide Varianten die im Wiki genannt sind?

Die Rechte des Startscriptes sehen für Autostart eigenartig aus, sollte (wie die anderen Dateien auch) root root sein.
Zwar für Autostart wohl egal, da das von root ausgeführt wird aber halt auffällig...

Bitte noch den Inhalt der Dateien unter /etc/sudoers.d/

Den Rest muss ich mir mal in Ruhe am PC abschauen per Handy is mir das zu mühsam...

EDIT: das gepostete Startscript ist aber unvollständig, oder!?

Gruß, Joachim
« Letzte Änderung: 14 Januar 2018, 13:05:06 von MadMax-FHEM »
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline Brad Majors

  • New Member
  • *
  • Beiträge: 44
Danke. Mein Problem ist gelöst.

Es hat mit der alten Version zu tun gehabt. Bin auf die 0.4.4 gegangen und es hat direkt funktioniert.

Danke für den Support. Ich habe mich wirklich für das richtige System und Forum entschieden :).
Raspberry Pi. * Eigenbau Nano Cul 433 und 866 * EnOcean TCM_3 * Netatmo * Max! Thermostate * SMA PV Inverter *

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2246
Statt der Nummer wäre ein direkter Link schöner gewesen aber es liegt ja noch nicht so weit zurück ;)

Welchen Autostart hast du eingerichtet?
Sicher nur den initd (startscript unter /etc/init.d/) oder beide Varianten die im Wiki genannt sind?

Die Rechte des Startscriptes sehen für Autostart eigenartig aus, sollte (wie die anderen Dateien auch) root root sein.
Zwar für Autostart wohl egal, da das von root ausgeführt wird aber halt auffällig...

Bitte noch den Inhalt der Dateien unter /etc/sudoers.d/

Den Rest muss ich mir mal in Ruhe am PC abschauen per Handy is mir das zu mühsam...

EDIT: das gepostete Startscript ist aber unvollständig, oder!?

Gruß, Joachim

Hi, Problem gelöst, es reichte nicht den user fhem in die sudoers einzutragen, sondern auch das sudo musste aktiviert werden.
Die Datei sieht jetzt so aus, und damit funktioniert das Schalten über Fhem.
Das starten muss ich mir nachher nochmal ansehen.

Danke für die Hilfe
Fhem Linux cubietruck 4.14.0-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline Brad Majors

  • New Member
  • *
  • Beiträge: 44
Jetzt habe ich das Problem das der Autostart nicht will.

Anbei mein log bei start.

pi@raspberrypi:~ $ sudo systemctl daemon-reload
pi@raspberrypi:~ $ sudo systemctl enable alexa
pi@raspberrypi:~ $ sudo systemctl start alexa
pi@raspberrypi:~ $ sudo systemctl status alexa
● alexa.service - Node.js Alexa Server
   Loaded: loaded (/etc/systemd/system/alexa.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2018-01-14 14:31:04 CET; 3s ago
  Process: 1187 ExecStart=/opt/fhem/alexa-fhem/bin/alexa -U /home/alexa/.alexa (code=exited, status=1/FAILURE)
 Main PID: 1187 (code=exited, status=1/FAILURE)

Jan 14 14:31:04 raspberrypi systemd[1]: Unit alexa.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
pi@raspberrypi:~ $


Anbei mein Alexa service file.

[Unit]
Description=Node.js Alexa Server
After=syslog.target network-online.target

[Service]
Type=simple
User=alexa
WorkingDirectory=/opt/fhem/alexa-fhem
ExecStart=/opt/fhem/alexa-fhem/bin/alexa -U /home/alexa/.alexa
Restart=on-failure
RestartSec=10
KillMode=process

[Install]
WantedBy=multi-user.target
Raspberry Pi. * Eigenbau Nano Cul 433 und 866 * EnOcean TCM_3 * Netatmo * Max! Thermostate * SMA PV Inverter *

Offline Brad Majors

  • New Member
  • *
  • Beiträge: 44
Hat niemand eine Idee woran es liegen könnte?
Raspberry Pi. * Eigenbau Nano Cul 433 und 866 * EnOcean TCM_3 * Netatmo * Max! Thermostate * SMA PV Inverter *

Offline basti2s

  • Full Member
  • ***
  • Beiträge: 109
Hat jemand noch eine Idee zu meiner Frage?
https://forum.fhem.de/index.php/topic,60452.msg747989.html#msg747989

Ich habe auch schon beim Forum von feste-ip.net gefragt:
https://forum.feste-ip.net/viewtopic.php?f=7&t=465

Dort konnte mir auch niemand weiterhelfen.
Wo sind denn die leute mit DSlite und Alexa die das alle hinbekommen haben????

Wenn ich das ganze mit inadyn probiere funktioniert es auch nicht. Anscheinend ist die Konfiguration die auf feste-ip.net steht einfach falsch. Das nervt langsam echt. Gibt es denn noch alternativen?

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3921
  • NIVEAu ist keine Creme...
Hat niemand eine Idee woran es liegen könnte?

Gibt es Logausgaben?

Bei systemd geht das mit journalctrl, z.B. http://www.linux-magazin.de/ausgaben/2016/02/systemd-journal/ (oder im Forum suchen)...

Gruß, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3921
  • NIVEAu ist keine Creme...
Hat jemand noch eine Idee zu meiner Frage?
https://forum.fhem.de/index.php/topic,60452.msg747989.html#msg747989

Wo sind denn die leute mit DSlite und Alexa die das alle hinbekommen haben????

Hier irgendwo.
Habe schon einige "gesehen", die das wohl so hinbekommen haben.

Schon mal mit google gesucht?
Hier im Forum gesucht?

schon gefunden?:
https://forum.fhem.de/index.php?topic=72001.0

Sorry mehr fällt mir dazu nicht ein, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline viegener

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3652
    • Meine Seite im fhemwiki
Hat jemand noch eine Idee zu meiner Frage?
https://forum.fhem.de/index.php/topic,60452.msg747989.html#msg747989

Ich habe auch schon beim Forum von feste-ip.net gefragt:
https://forum.feste-ip.net/viewtopic.php?f=7&t=465

Dort konnte mir auch niemand weiterhelfen.
Wo sind denn die leute mit DSlite und Alexa die das alle hinbekommen haben????

Wenn ich das ganze mit inadyn probiere funktioniert es auch nicht. Anscheinend ist die Konfiguration die auf feste-ip.net steht einfach falsch. Das nervt langsam echt. Gibt es denn noch alternativen?

Ich würde empfehlen bei der IP-Einrichtung nochmals ganz von vorne anzufangen und die Dateen zu löschen / nur eine Anleitung zu verwenden / Jeden Schritt zu protokollieren (und zwar im Detail) und dann zu fragen / zu schauen wenn etwas unklar vorkommt.

Du brauchst Ja wohl eine IPV6-Adresse, die im feste-ip dyndns auftaucht - solange das nicht passiert ist ein schritt irgendwo fehlerhaft abgelaufen
Kein Support über PM - Anfragen gerne im Forum - Damit auch andere profitieren und helfen können

Offline Tuxi70

  • Jr. Member
  • **
  • Beiträge: 74
Nach einem Update via DOIF-Tools will er bei mir nicht neu starten. Im Log ist folgendes zu finden

pi@james:~ $ sudo systemctl status fhem
* fhem.service - FHEM Home Automation
   Loaded: loaded (/etc/systemd/system/fhem.service; enabled; vendor preset:
   Active: inactive (dead) since Tue 2018-01-16 08:07:04 CET; 2min 13s ago
  Process: 27980 ExecStart=/usr/bin/perl fhem.pl fhem.cfg (code=exited, stat
 Main PID: 27981 (code=exited, status=0/SUCCESS)

Ein manueller Neustart danach funktioniert.

Meine FHEM.service schaut so aus:


# $Id: fhem.service 15784 2018-01-05 11:29:16Z betateilchen $

[Unit]
Description=FHEM Home Automation
Wants=network.target
After=network.target

[Service]
Type=forking
User=fhem
Group=dialout
WorkingDirectory=/srv/usb-hdd/raspberry/fhem
ExecStart=/usr/bin/perl fhem.pl fhem.cfg
#ExecStart=/usr/bin/perl fhem.pl configDB
# uncomment next two lines if auto-restart desired

# please select restart options according your needs
# Restart=on-abnormal # uncomment for crash and watchdog event recovery only (keeps shutdown working)
# Restart=always # alternativly uncomment this line for recover always
RestartSec=5 # uncomment always if restart required!

[Install]
WantedBy=multi-user.target

Wo ist da der Fehler zu suchen?

Ich vermute, die eigene Dummheit gefunden zu haben. Denn wo er Angewiesen wird neu zu starten, war im Servicefile  "nur" ein Kommentar.
« Letzte Änderung: 16 Januar 2018, 09:56:15 von Tuxi70 »
FRITZ!Box: Fon WLAN 7560, FW: 7.0
James: Raspberry Pi 3 Alexa-Fhem 0.4.4 & FHEM 5.8 Latest Revision: 16799 & SVG-DBLog MySQL 3.10.8
Netz : VDSL 1&1 50.000 3x FRITZ!Powerline 530E FW: 1.4.0-00
Smarthome: 4x Comet DECT Thermostat Firmware: 3.68 8x FritzDECT200 Firmware: 4.08
Steuerung: Alexa

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3921
  • NIVEAu ist keine Creme...
@Tuxi70: bist du sicher, dass du den richtigen Thread gewählt hast?!

Besser einen passenden (fhem Start etc.) suchen oder einen neuen eröffnen (oder ich hab es falsch verstanden)...

Und dort dann mal ein paar Logausgaben (fhem Log sofern da schon was kommt beim Startversuch und ansonsten per journalctrl vom Service Start)...

Erster schneller Verdacht: ist die USB-Platte zum Startzeitpunkt bereits gemountet?
Nachdem ein nachträglicher Manueller Start ja dann klappt...

Warum das "jetzt" nach dem Update (von was?) kommt, mag ja "Zufall" sein...

Gruß, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline Tuxi70

  • Jr. Member
  • **
  • Beiträge: 74
@Tuxi70: bist du sicher, dass du den richtigen Thread gewählt hast?!

Nein.  ;)

Zitat
Besser einen passenden (fhem Start etc.) suchen oder einen neuen eröffnen (oder ich hab es falsch verstanden)...

Möge ein Moderator den Beitrag bitte verschieben oder löschen.

Zitat
Warum das "jetzt" nach dem Update (von was?) kommt, mag ja "Zufall" sein...

Von FHEM.
FRITZ!Box: Fon WLAN 7560, FW: 7.0
James: Raspberry Pi 3 Alexa-Fhem 0.4.4 & FHEM 5.8 Latest Revision: 16799 & SVG-DBLog MySQL 3.10.8
Netz : VDSL 1&1 50.000 3x FRITZ!Powerline 530E FW: 1.4.0-00
Smarthome: 4x Comet DECT Thermostat Firmware: 3.68 8x FritzDECT200 Firmware: 4.08
Steuerung: Alexa