Autor Thema: Selbstbau CUN (MapleCUN)  (Gelesen 211394 mal)

Offline Maui

  • Sr. Member
  • ****
  • Beiträge: 693
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1260 am: 26 August 2019, 23:20:10 »
Ich habe das jetzt endlich mal ins Wiki geschrieben...
Danke.

Außerdem überlege ich schon länger wie man das Flashen vereinfachen könnte.
Ich frage mich ob das flashen vielen Probleme bereitet. Ich denke mir jemand, der Teile auf eine Platine lötet, kann den CUN auch flashen.
Das bootloader flashen geht ja schon ohne TTL und ist ja ne einmalige Sache und dfu-util finde ich persönlich unter windows auch ziemlich straight.

Offline Telekatz

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 969
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1261 am: 27 August 2019, 12:52:24 »
Zum einfachen flashen gibt es seit kurzen den MSC Bootloader. Das DFU-Util ist damit nicht mehr notwendig und eine .bin Datei auf ein USB-Laufwerk zu kopieren sollte jeder schaffen.

Zum updaten vom Maple-Bootloader auf den MSC Bootloader gibt es hier auch ein Update Sketch, der mit der Arduino IDE geladen werden kann.
Gefällt mir Gefällt mir x 4 Liste anzeigen

Offline Ranseyer

  • Hero Member
  • *****
  • Beiträge: 1815
    • Homepage
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1262 am: 29 August 2019, 12:13:10 »
Danke für den Input. (Ich hatte den MSC-Bootloader vor ein paar Wochen belächelt... "Das ist ja so als ob der Windows-NT Server beim kopieren von Dateien eine grafische Animation bekommt..." [Wer alt genug ist kann das verstehen])

Ich hab mir mal Text zusammengeschrieben fürs Wiki, und würde diesen später veröffentlichen. Geflasht habe ich den Bootloader wie gewohnt, weil das am einfachsten ist (wenn man es kennt).



Zu der Bootloader-Tauschmethode mittels Arduino Sketch: Sehe ich das richtig ?
-Ich brauche eine Arduino IDE mit SAM und STMDuino Erweiterungen auf z.B. siehe hier: https://www.heise.de/developer/artikel/Keine-bittere-Pille-die-Blue-Pill-mit-ARM-Cortex-M3-4009580.html
-Dann muss man wohl noch für einen Treiber sorgen mittels der Skript von STM-Duino...
-Ich wähle als Board Maple-Mini mit Original Bootloader, 72 Mhz, smallest
-wähle den Port vomn FTDI-Adapter
-verkable diesen wie zum bisherigen Bootloader-Flashen
Wäre das der Weg ?
FHEM mit FTUI. Homematic-Funk für Thermostate und Licht. MySensors als Basis für eigene HW.
Zentrale ist der MAPLE-CUL mit RFM69+HModUART-AddOn.
Doku zu meinen Projekten: Github/Ranseyer. Platinen falls verfügbar gerne auf Anfrage.
Support: gerne wenn ich Zeit+Lust habe im Forum. Nicht per PN!

Offline Eistee

  • Full Member
  • ***
  • Beiträge: 222
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1263 am: 29 August 2019, 12:42:59 »
Ich kenne es so das man den Maple mini mit Original Bootloader direkt mit USB am PC anschließt und ihn dann mit Arduino flashen kann. Also so wie auch einen Arduino UNO z.B. da braucht man keinen FTDI für. Hab das mit diesem Bootloader aber noch nicht getestet.

Offline Maui

  • Sr. Member
  • ****
  • Beiträge: 693
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1264 am: 29 August 2019, 13:21:23 »
Danke für den Input. (Ich hatte den MSC-Bootloader vor ein paar Wochen belächelt... "Das ist ja so als ob der Windows-NT Server beim kopieren von Dateien eine grafische Animation bekommt..." [Wer alt genug ist kann das verstehen])

Ich hab mir mal Text zusammengeschrieben fürs Wiki, und würde diesen später veröffentlichen. Geflasht habe ich den Bootloader wie gewohnt, weil das am einfachsten ist (wenn man es kennt).



Zu der Bootloader-Tauschmethode mittels Arduino Sketch: Sehe ich das richtig ?
-Ich brauche eine Arduino IDE mit SAM und STMDuino Erweiterungen auf z.B. siehe hier: https://www.heise.de/developer/artikel/Keine-bittere-Pille-die-Blue-Pill-mit-ARM-Cortex-M3-4009580.html
-Dann muss man wohl noch für einen Treiber sorgen mittels der Skript von STM-Duino...
-Ich wähle als Board Maple-Mini mit Original Bootloader, 72 Mhz, smallest
-wähle den Port vomn FTDI-Adapter
-verkable diesen wie zum bisherigen Bootloader-Flashen
Wäre das der Weg ?
Wenn das ins Wiki kommt (und ein ordentlicher und einfacher Weg ist für Bootloader und image flashen auf vielen Systemen) dann wäre ich aber stark dafür den Rest gleich aus dem Wiki zu nehmen. Also das flashen BL mit TTL und ohne sowie den Teil mit dfu-util.
Sonst hat der User wieder x Möglichkeiten und weiss nicht welche er nehmen sol
Just my 2ct

Offline Telekatz

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 969
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1265 am: 29 August 2019, 13:51:11 »
Wenn auf dem Maple Mini schon ein DFU Bootloader vorhanden ist braucht man keinen FTDI Adapter für den Update Sketch.

Die STMDuino Erweiterung muss installiert sein und die Bootloader Version muss in der IDE angegeben werden (Original oder Bootloader 2.0). Und wenn bereits die aculfw auf dem Maple Mini geflasht ist, muss man noch manuell den Reset am Maple Mini betätigen sobald "Resetting to bootloader via DTR pulse" beim hochladen im Ausgabebereich der IDE angezeigt wird.

Offline Ranseyer

  • Hero Member
  • *****
  • Beiträge: 1815
    • Homepage
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1266 am: 29 August 2019, 14:35:36 »
Zitat
Wenn auf dem Maple Mini schon ein DFU Bootloader vorhanden ist braucht man keinen FTDI Adapter für den Update Sketch.

OK, du wählst an der Stelle dann aber einen seriellen Port aus. (Aber ich bekomme keinen angeboten nach der folgenden Aktion:)
Zitat
Please open a cmd window (run as administrator), navigate to the folder: /drivers/win/ and run: install_drivers.bat. Note: This doesn't actually install drivers. Windows comes pre-installed with a compatible Serial USB driver and a DFU (upload) driver. However the built in drivers need to be associated with the USB ID of the Maple serial and DFU devices. The batch file and wdi-simple.exe do the clever stuff to convince Windows 7 or newer, that it should use its drivers with the Maple serial and DFU devices.

Grund könnte sein, dass bei mir per LibUSB direkt ein MAPLE-DFU Gerät erkannt wird...

=> Fazit den Part finde ich frickelig und keinesfalls so richtig unter Windows. Ich schau mir das nachher nochmals unter Linux an. Da sollte das alles einfacher sein...



edit: Z.B. Mittels Zadig kann ich den Treiber umbiegen auf USB-Serial (CDC), dann kann ich auch einen Port in der IDE angeben. Aber es mein Maple hat PID "0004" und erwartet wird jedoch "0003"...
« Letzte Änderung: 29 August 2019, 14:49:52 von Ranseyer »
FHEM mit FTUI. Homematic-Funk für Thermostate und Licht. MySensors als Basis für eigene HW.
Zentrale ist der MAPLE-CUL mit RFM69+HModUART-AddOn.
Doku zu meinen Projekten: Github/Ranseyer. Platinen falls verfügbar gerne auf Anfrage.
Support: gerne wenn ich Zeit+Lust habe im Forum. Nicht per PN!

Offline Telekatz

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 969
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1267 am: 29 August 2019, 19:05:04 »
OK, du wählst an der Stelle dann aber einen seriellen Port aus. (Aber ich bekomme keinen angeboten nach der folgenden Aktion:)
Grund könnte sein, dass bei mir per LibUSB direkt ein MAPLE-DFU Gerät erkannt wird...
Verwendest du einen neuen Maple Mini auf dem nur der Bootloader drauf ist? Solange da kein Programm raufgeladen wurde bleibt der Bootloader im DFU Mode. Dann muss man auch keinen COM Port in der IDE auswählen. Es wird beim flashen ja ein Gerät im DFU Mode erwartet und dann verwendet.

Und hast du eventuell schon früher mal mit dem Zadig Tool den Treiber für den Maple verbogen? Normalerweise braucht man das hier nicht.

Offline Maui

  • Sr. Member
  • ****
  • Beiträge: 693
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1268 am: 06 September 2019, 14:15:06 »
Mahlzeit zusammen,

In meiner Verzweiflung muss ich mich noch mal an euch wenden.
Ich habe 2 mapleCUN's (1x Large, 1x small von Ranseyer Platinen) bestückt und beide empfangen und senden.
Mit einfachem Empfangen von 433 MHz habe ich keine Probleme.
Für 868 nutze ich MAX.
Da ich vor kurzem ein Thermostat austauschen musste, ist mir aufgefallen, dass das ACK mit dem Maple nicht klappt. Mit beiden nicht.
Auf beiden ist die aktuellste a-culfw drauf. Tests mit älteren Versionen von a-culfw waren auch nicht erfolgreich.
Ich habe dann mal meinen nanoCUL entstaubt und dort klappt es problemlos.
Die HTs werden in fhem problemlos erkannt und per autocreate angelegt, allerdings zeigt der HT kein AC an beim pairing und im Log kommen dann immer Meldungen mit "missing ACK".
CUL_MAX_SendQueueHandler: Missing ack from 18b264 for 0f01040312345618b264001306038b70

Ich sehe im Log auch die Meldung mit dem PairPing
2019.09.06 08:29:15 4:  CUL_Parse: mapleCUN1 Z17000000165824000000001001A04E455130363730363339EB -84.5
2019.09.06 08:29:15 5:  mapleCUN1: dispatch Z17000000165824000000001001A04E455130363730363339
2019.09.06 08:29:15 5:  CUL_MAX_Parse: len 23, msgcnt 00, msgflag 00, msgTypeRaw PairPing, src 165824, dst 000000, groupid 0, payload 1001A04E455130363730363339
2019.09.06 08:29:15 5:  CUL_MAX_Parse: rssi: -84.5
2019.09.06 08:29:15 5:  CUL_MAX_Parse: Got PairPing (dst 000000, pairmode 0), firmware 16, type 1, testresult 160, serial NEQ0670639
2019.09.06 08:29:15 3:  CUL_MAX_Parse: Pairing device 165824 of type HeatingThermostat with serial NEQ0670639
Ändern einer Temperatur geht auch, allerdings frisst das halt schnell die Credits auf, da er immer wieder sendet, weil er kein ACK bekommt vom HT.
Hat zufällig jemand noch eine Idee, wo ich ansetzen kann?
Ich will ungern für den kommenden Winter wieder Pi's entstauben und mit nanoCULs meine HT steuern.

Gruß
Maui

Offline Telekatz

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 969
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1269 am: 06 September 2019, 15:24:39 »
Ein RSSI von -84.5 ist nicht wirklich gut. Wie weit sind der MapleCUN und Thermostat voneinander entfernt? Und wie ist der RSSI beim nanoCUL?

Hast du eventuell ein schlechtes CC1101 Modul verbaut: https://forum.fhem.de/index.php/topic,91740.0.html

Offline rieders

  • Full Member
  • ***
  • Beiträge: 168
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1270 am: 06 September 2019, 17:49:40 »
Hallo

Ich habe nun mein Maple fertig und auch im Gehäuse.
Nun habe ich ihn per Lan Modul 5500 ans Netzwerk angeschlossen.
Vorher war er per USB mit einem Banana Pi verbunden und alles war OK.
Jetzt hat er bei  Modul 3 und 4 nur Opend in FHEM stehen.

Cun1 habe ich per Lan verbunden und auch die Stack´s sind da. bzw Defined.

Wie bekomme ich die 2 Cun´s wieder mit Initialized zum laufen ?


Grüße André

Offline gloob

  • Hero Member
  • *****
  • Beiträge: 3143
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1271 am: 06 September 2019, 18:07:59 »
Hallo

Ich habe nun mein Maple fertig und auch im Gehäuse.
Nun habe ich ihn per Lan Modul 5500 ans Netzwerk angeschlossen.
Vorher war er per USB mit einem Banana Pi verbunden und alles war OK.
Jetzt hat er bei  Modul 3 und 4 nur Opend in FHEM stehen.

Cun1 habe ich per Lan verbunden und auch die Stack´s sind da. bzw Defined.

Wie bekomme ich die 2 Cun´s wieder mit Initialized zum laufen ?


Grüße André

Zeig doch mal deine FHEM Definitionen.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline rieders

  • Full Member
  • ***
  • Beiträge: 168
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1272 am: 06 September 2019, 18:19:15 »
Ich habe jetzt die 2 Stack´s entfernt und dann auch die Cun´s.
Danach alles wie im Wiki beschrieben neu erstellt.
Jetzt ist wieder alle OK.


Grüße
André

Offline Eistee

  • Full Member
  • ***
  • Beiträge: 222
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1273 am: 06 September 2019, 19:30:04 »
Wenn derartige Probleme wieder auftreten dann nutz mal STACKABLE_CC statt STACKABLE. Im Wiki steht wie das da geht. STACKABLE_CC verursacht öfter derartige Probleme.

Offline Maui

  • Sr. Member
  • ****
  • Beiträge: 693
Antw:Selbstbau CUN (MapleCUN)
« Antwort #1274 am: 07 September 2019, 13:26:11 »
Ein RSSI von -84.5 ist nicht wirklich gut. Wie weit sind der MapleCUN und Thermostat voneinander entfernt? Und wie ist der RSSI beim nanoCUL?

Hast du eventuell ein schlechtes CC1101 Modul verbaut: https://forum.fhem.de/index.php/topic,91740.0.html
Danke für den Tipp. Könnten wirklich defekte Module sein.
Ich habe jetzt mal neue bestellt. Hoffe die laufen besser.

Gruß