Autor Thema: Zoneminder Installation für rtsp Stream  (Gelesen 3381 mal)

Offline Sky

  • Full Member
  • ***
  • Beiträge: 224
Zoneminder Installation für rtsp Stream
« am: 03 Dezember 2016, 18:34:10 »
Hallo ,

ich versuche nun schon seit Tagen Zoneminder auf meinem Raspberry 3 zu installieren .
Nach etlichen Informationen im I-Net habe ich mich an folgende Anleitung gehalten :
https://wiki.zoneminder.com/Raspbian

Alles läuft so wie in dieser Anleitung bis zu dem Schritt  > mysql < /usr/share/zoneminder/db/zm_create.sql >
Dort kommt als Fehlermeldung :
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

ich drehe mich hier im Kreis und finde keine Lösung .....etliche male mein Backup zurück gespielt und von vorne angefangen um Fehler auszuschliessen...
es ändert sich aber nichts ..

Könnt Ihr mir helfen ??

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3543
    • _.:|:._
Antw:Zoneminder Installation für rtsp Stream
« Antwort #1 am: 03 Dezember 2016, 19:24:58 »
Das verwendete MySQL Passwort ist falsch.

Offline Sky

  • Full Member
  • ***
  • Beiträge: 224
Antw:Zoneminder Installation für rtsp Stream
« Antwort #2 am: 03 Dezember 2016, 19:29:15 »
Danke für Deine Antwort ,

ich habe aber ,wie das Eingabefenster zur Vergabe eines Passwortes kam , keins angegeben .

Bei den ersten Versuchen habe ich eins angegeben ,das Resultat war das gleiche ...

Ich weis nicht mehr weiter ...????

Offline Sky

  • Full Member
  • ***
  • Beiträge: 224
Antw:Zoneminder Installation für rtsp Stream
« Antwort #3 am: 05 Dezember 2016, 22:07:47 »
Hallo ,

habe jetzt eine reibungslose Zoneminder Installation  8)
Allerdings wenn ich Zoneminder im Webbrowser öffne ( http://serverip/zm )
kommt folgende Fehlermeldung :
ZoneMinder is not installed properly: php's date.timezone is not set to a valid timezone

Ich habe in der php.ini folgendes schon geändert :

Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = Europe/Berlin


trotzdem bleibt der Fehler im Webbrowser
Weiß jemand warum ??

Danke


Offline gbotti

  • New Member
  • *
  • Beiträge: 5
Antw:Zoneminder Installation für rtsp Stream
« Antwort #4 am: 07 Dezember 2016, 14:55:01 »
In welcher php.ini hast du das denn geändert? Abhängig von der Installation kann es mehrere php.ini's geben, die für CLI und Webserver unterschiedlich sein können.

root@home01:/etc/php5# find . -name php.ini
./cli/php.ini
./apache2/php.ini
root@home01:/etc/php5#

Nachdem du die (richtige) php.ini geändert hast muss dann der Webserver neu gestartet werden. Bei NGinx und php-fpm muss php-fpm neu gestartet werden.

EDIT: Schreib Europe/Berlin bitte mal in Anführungszeichen.
« Letzte Änderung: 07 Dezember 2016, 15:24:57 von gbotti »
RaspberryPi 2 mit fhem, fhemduino, mysensors, milight, alexa, pfSense, EC3000, Retroenthusiast, Lötwillig

Offline stromer-12

  • Hero Member
  • *****
  • Beiträge: 1356
Antw:Zoneminder Installation für rtsp Stream
« Antwort #5 am: 07 Dezember 2016, 19:53:33 »
die richtige ist /etc/php5/apache2/php.ini
laut Debian_8_64-bit_with_Zoneminder_1.29.0_the_Easy_Way
« Letzte Änderung: 07 Dezember 2016, 19:56:01 von stromer-12 »
FHEM 5.9(SVN) auf cubietruck mit HMUSB
FHEM 5.9(SVN) auf RPi1B mit HMser | CUNO
FHEM 5.9(SVN) virtuell mit HMLAN | CUL

Offline Sky

  • Full Member
  • ***
  • Beiträge: 224
Antw:Zoneminder Installation für rtsp Stream
« Antwort #6 am: 20 August 2017, 19:49:15 »
Hallo ,

auf Nachfrage stelle ich einfach mal eine selbst angewendete Anleitung zur Verfügung , hoffe damit gegen keine Regeln zu verstoßen


https://wiki.zoneminder.com/Debian_8_64-bit_with_Zoneminder_1.29.0_the_Easy_Way
https://wiki.zoneminder.com/Debian_8_64-bit_with_Zoneminder_1.29.0_the_Easy_Way

sudo su
apt-get update
apt-get upgrade
apt-get dist-upgrade
nano /etc/apt/sources.list
deb http://http.debian.net/debian jessie-backports main
nano /etc/apt/preferences.d/zoneminder
Package: *
Pin: origin http.debian.net
Pin-Priority: 1100

apt-get update

you will get a GPG error message like this:
W: GPG error: http://http.debian.net jessie-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553    NO_PUBKEY 7638D0442B90D010


Fix this as following:
gpg --keyserver pgpkeys.mit.edu --recv-key  8B48AD6246925553
gpg -a --export 8B48AD6246925553 | sudo apt-key add -
gpg --keyserver pgpkeys.mit.edu --recv-key  7638D0442B90D010
gpg -a --export 7638D0442B90D010 | sudo apt-key add -

apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get install  php5 mysql-server php-pear php5-mysql
 11.(sudo apt-get install php5 mysql-server php-pear php5-mysql php5-gd)
eigenes Passwort
eigenes Passwort wiederholen

apt-get install zoneminder
apt-get install libvlc-dev libvlccore-dev vlc
cd ~
nano .my.cnf
[client]
user=root
password=(mysqlpass) Passwort wie oben

mysql < /usr/share/zoneminder/db/zm_create.sql

mysql -e "grant select,insert,update,delete,create on zm.* to 'zmuser'@localhost identified by 'zmpass';"

rm .my.cnf

chmod 740 /etc/zm/zm.conf

chown root:www-data /etc/zm/zm.conf

systemctl enable zoneminder.service

adduser www-data video

systemctl start zoneminder.service

a2enmod cgi
a2enconf zoneminder
service apache2 restart


cd /usr/src && wget http://www.andywilcock.com/code/cambozola/cambozola-latest.tar.gz

tar -xzvf cambozola-latest.tar.gz
replace 936 with cambozola version downloaded


cp cambozola-0.936/dist/cambozola.jar /usr/share/zoneminder

sudo su -

echo "kernel.shmmax = 134217728" >> /etc/sysctl.conf

exit
-----------------------------------
Add timezone to PHP
nano /etc/php5/apache2/php.ini

Search for [Date] (Ctrl + w then type Date and press Enter) and make changes as follows for your time zone
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = America/New_York    #ändern in eigene Zeitzone !!! #
Ctrl+o Enter to save
CTRL+x to exit

Edit /etc/apache2/conf-enabled/zoneminder.conf
nano /etc/apache2/conf-enabled/zoneminder.conf
Add at the bottom:
<Directory /usr/share/zoneminder/www/api>
    AllowOverride All
</Directory>
Ctrl+o Enter to save
CTRL+x to exit

Offline outhouse

  • Full Member
  • ***
  • Beiträge: 107
Antw:Zoneminder Installation für rtsp Stream
« Antwort #7 am: 21 August 2017, 15:59:13 »
Hallo Sky

Herzlichen Dank. So hat es auch bei mir geklappt

Gruss

Chris
Schreibfehler die ihr findet, könnt ihr behalten.
Raspberry 3 B+ mit Raspbian Stretch Lite und FHEM-Image 5.9 von fhem.de
Cul CC 1101 V4 als CUL_HM
Cul V3.4 + V3.4 als RFR
enocean-pi

Offline Florian_GT

  • Developer
  • Full Member
  • ****
  • Beiträge: 306
    • Florian-Asche
Antw:Zoneminder Installation für rtsp Stream
« Antwort #8 am: 23 November 2017, 22:19:51 »
Das passende Raspberry Pi Image für die Kamera als Streaming Server bekommt ihr hier: https://github.com/florian-asche/RaspberryPiStreamingCamera falls da jemand bedarf hat.
FHEM: Proxmox Server, FHEM in VM, pgSQL DB
Hardware: Ethersex (Pollin NETIO Boards), SONOFF, SONOFF POW, Raspberry Pi Zero W Kameras, (Github RaspberryPiStreamingCamera)

Development: Luftdaten - 60_airquality.pm (non-commit)

 

decade-submarginal