Autor Thema: Alexa startet nicht als Dienst  (Gelesen 3572 mal)

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 2206
  • Niveau ist keine Creme...
Antw:Alexa startet nicht als Dienst
« Antwort #15 am: 01 Februar 2017, 13:13:12 »
Hallo MadMax-Fhem

würde eine Neuinstallation unter dem pi user das Problem lösen ?

Habe da gar kein Augenmerk bei der Inst. drauf gelegt.

Kein Augenmerk drauf legen geht unter Linux eigentlich nicht.
Wenn etwas unter/als root getan wird, muss man sehr wohl "Augenmerk" drauf haben weil man muss ja erst mal root werden...


Ob es das Problem löst kann ich nicht sagen aber die Anleitungen und das Script gehen von den genannten Dingen aus:

Installation bzw. zumindest Start als User "pi" und im Verzeichnis /opt/fhem/alexa-fhem

config.json dann unter: /home/pi/.alexa

Allerdings musst du dafür sorgen, dass der User "pi" in /opt/fhem/log schreibberechtigt ist...

Ich habe unter /home/pi/alexa-fhem installiert, da passen alle Rechte.
Im Startscript dann noch die Pfade angepasst: /opt/fhem/alexa-fhem -> /home/pi/alexa-fhem und /opt/fhem/log -> /home/pi/alexa-fhem/log (oder wo immer du das Log haben willst) und nat. nicht vergessen den Pfad für die Logdatei (sollte er nicht existieren) anzulegen: mkdir /home/pi/alexa-fhem/log


Aber wenn es wirklich so ist/war, dass du ohne großes Augenmerk als/unter root installiert hast/arbeitest, dann vielleicht erst mal ein wenig mehr mit Linux etc. beschäftigen!! -> als gut gemeinten Rat verstehen...

Gruß, Joachim
« Letzte Änderung: 01 Februar 2017, 13:24:53 von MadMax-FHEM »
FHEM 5.8 Pi 2, HM-CFG-USB2, 8x HM-TC-IT-WM-W-EU, 5x HM-CC-RT-DN, 5x HM-SEC-SC-2, 1x HM-WDS10-TH-O, 1x HM-DIS-WM55
FHEM 5.8 PI B+, HM-CFG-USB2, 7x HM-CC-RT-DN, 3x HM-TC-IT-WM-W-EU, 4x HM-Sec-SCo
FHEM 5.8 PI 2 (Testsystem), CUL868, 1x HM-TC-IT-WM-W-EU, 1x HumTempESP8266, 1x mySensorsFillingLevel

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3204
Antw:Alexa startet nicht als Dienst
« Antwort #16 am: 01 Februar 2017, 16:21:37 »
/root die Berechtigung 755 geben ... nicht optimal

Kannst Du nicht die Verzeichnisse verschieben?
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 2206
  • Niveau ist keine Creme...
Antw:Alexa startet nicht als Dienst
« Antwort #17 am: 01 Februar 2017, 16:32:45 »
/root die Berechtigung 755 geben ... nicht optimal

Kannst Du nicht die Verzeichnisse verschieben?

Ah jetzt habe ich gefunden worauf sich das bezieht ;)

Jep: keine gute Idee!

Also noch mal als wirklich gut gemeinten Rat: Linux-Kenntnisse aufbauen!

Ist nicht wirklich schlimm...
...und bei öfterer Anwendung (die du ja jetzzt hast ;)  ) geht das ja automatisch, wenn man nicht (wie in deinem Fall) immer gleich mit den ganz ganz großen Kanonen schießt: als root arbeiten und jeder Berechtigung auf alles...

Sorgt zwar dafür, dass "augenscheinlich" alles geht aber bei sowas geht auch ganz schnell ganz ganz ganz viel kaputt!

Aber es ist open source und open mind ;)

Jeder wie er will...

Gruß und viel Spaß, Joachim
FHEM 5.8 Pi 2, HM-CFG-USB2, 8x HM-TC-IT-WM-W-EU, 5x HM-CC-RT-DN, 5x HM-SEC-SC-2, 1x HM-WDS10-TH-O, 1x HM-DIS-WM55
FHEM 5.8 PI B+, HM-CFG-USB2, 7x HM-CC-RT-DN, 3x HM-TC-IT-WM-W-EU, 4x HM-Sec-SCo
FHEM 5.8 PI 2 (Testsystem), CUL868, 1x HM-TC-IT-WM-W-EU, 1x HumTempESP8266, 1x mySensorsFillingLevel

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3204
Antw:Alexa startet nicht als Dienst
« Antwort #18 am: 02 Februar 2017, 08:48:43 »
BTW:
Anfängliche Unix-Kentrnisse sind auch für Windows nützlich. Dort wird meistens dieses per GUI überdeckt .... aber Gundlagen sind nicht zu überschätzen!

BTW2:
Nur mal am Rande:
Große Windows-Server werden heute auch wieder per Kommandozeile Administriert. Also "back to the root"
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline raimundl

  • Full Member
  • ***
  • Beiträge: 262
Antw:Alexa startet nicht als Dienst
« Antwort #19 am: 02 Februar 2017, 09:04:43 »
Ich weiß nicht ob nun alle das Problem mit dem Autostart gelöst haben?

Daher möchte ich meine Lösung (Autostart hat bei mir auch nicht funktioniert) hier kurz aufzeigen:

Ein "sleep 7" am Beginn des scripts eingefügt und es hat bei mir funktioniert.

Ich nehme an, dass fhem bei mir etwas mehr Zeit zum Start braucht und daher eine Überschneidung entstanden ist.

LG
Homematic: Licht, Heizung, Alarm,...  auf zwei RaspberryPi3 mit OS "Jessie" und HM-MOD-RPI-PCB

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3204
Antw:Alexa startet nicht als Dienst
« Antwort #20 am: 02 Februar 2017, 11:41:04 »
Darüber wurde schon an anderer Stelle Diskutiert.

Dem Start-Script vom FHEM erzählen, das er auf andere Elemente (wie z.B. Netzwerk) warten soll.

Je nachdem, ob DU fhem per init.d oder systemd startest, wird es anders eingerichtet. Wurde aber schon mehrfach diskutiert
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline bjbrill

  • New Member
  • *
  • Beiträge: 13
Antw:Alexa startet nicht als Dienst
« Antwort #21 am: 07 Februar 2017, 21:34:25 »
Ich benutze Fhem auch auf einem Ubuntu 14.05 System und hatte genau die gleichen Probleme.
Nachdem ich den User von pi auf bjorn (mein User) gewechselt hatte und dann noch einen Pfad angepasst hatte
klappte es bei mir dann auch mit dem Autostart.

export NODE_PATH=$NODE_PATH:/usr/local/lib/n
Hier einmal die ganze Autostart von mir:
#!/bin/sh
### BEGIN INIT INFO
# Provides: alexa
# Required-Start: $network $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time for alexa
# Description: Enable service provided by daemon.
### END INIT INFO
export PATH=$PATH:/usr/local/bin
#export NODE_PATH=$NODE_PATH:/usr/local/lib/node_modules
export NODE_PATH=$NODE_PATH:/usr/local/lib/n
PID=`pidof alexa`
export ALEXAPATH="/opt/fhem/alexa-fhem"
export LOGPATH="/opt/fhem/log"
case "$1" in
start)
if ps -p $PID > /dev/null 2>&1; then
        echo "Alexa is already running"
        perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa is already running"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status on"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
else
        su - "bjorn" -c "cd $ALEXAPATH;./bin/alexa > $LOGPATH/alexa-`date +%Y-%m`.log 2>&1 &"
        echo "Alexa starting"
        sleep 2
$0 status
fi
;;
stop)
if ! ps -p $PID > /dev/null 2>&1; then
        echo "Alexa is not running"
        perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa is not running"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status off"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
else
        kill $PID
        echo "Alexa closed"
        perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa closed"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status off"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
fi
;;
restart)
if ! ps -p $PID > /dev/null 2>&1; then
        $0 start
else
        $0 stop
        $0 start
fi
;;
status)
if ps -p $PID > /dev/null 2>&1; then
        echo "Alexa is running PID $PID"
        perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa running as PID $PID"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status on"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
else
        echo "Alexa is not running"
        perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa is not running"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status off"
        perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
fi
;;
*)
echo "Usage: $0 {start|stop|status|restart}"
exit 1
;;
esac
echo "script done"
exit 0

Also bei mir hatte es geholfen.

Schöne Grüße Björn
Ubuntu 14.04 Server, Tecalor Heizung/Lüftung, Homematic, Dect200, Jeelink, Unifi Wlan AP, GWY 433 Mhz, Arduino mit Firmata (USB),ESP 8266 mit WS2812b LED, HUE Lights, JeeLight Wifi, Alexa, Bewässerung Garten.

Offline hyper2910

  • Sr. Member
  • ****
  • Beiträge: 586
Antw:Alexa startet nicht als Dienst
« Antwort #22 am: 21 April 2017, 15:05:03 »
Hallo,

ich komme einfach nicht weiter. Ich habe schon alles versucht.

./bin/alexa start
geht nicht.

ich mache es immer mit alexa start

jedoch kommt immer folgendes:

alexa start
Alexa starting
Alexa is not running
script done
script done


ich habe schon alles durch.

installiert habe ich unter User: pi

ich kann Starten unter Pi oder Root immer das gleiche.


kann mir jemand weiterhelfen?

Cubietruck mit FHEM, CUL V3 443MHz, 2 x CULV3 868MHz, Milights, Max Heizungssteuerung, Homematic, IT,

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 2206
  • Niveau ist keine Creme...
Antw:Alexa startet nicht als Dienst
« Antwort #23 am: 21 April 2017, 17:33:32 »

./bin/alexa start
geht nicht.

Klar, dass das nicht geht!

Entweder:

./bin/alexa

unter dem User der gedacht ist alexa-fhem zu starten (weil sonst die config.json nicht gefunden wird) und zwar wenn "man" im Installationsverzeichnis "steht"...
Also vielleicht mal so probieren...

Oder:

sudo /etc/init.d/alexa start

(sofern man init.d zum automatischen Starten nimmt)



ich mache es immer mit alexa start

jedoch kommt immer folgendes:

alexa start
Alexa starting
Alexa is not running
script done
script done


ich habe schon alles durch.

installiert habe ich unter User: pi

ich kann Starten unter Pi oder Root immer das gleiche.


kann mir jemand weiterhelfen?

Ich nehme mal an hier meinst du dann Variante "Oder" ;)

Wird ein alexa-fhem Log angelegt?
(wo steht im Script: /etc/init.d/alexa)

Wenn ja: was steht drin?

Wohin hast du alexa-fhem installiert?
Also Pfad.
Wo liegt die config.json?
Also auch Pfad... ;)

Welcher User soll denn alexa-fhem starten?
Also was steht im Script (/etc/init.d/alexa)?
Wenn du das Script einfach ohne Änderungen genommen hast, dann ist das wohl der User pi...


ich habe schon alles durch.

installiert habe ich unter User: pi

ich kann Starten unter Pi oder Root immer das gleiche.


kann mir jemand weiterhelfen?

Sehr aussagekräftige Informationen!
Bestimmt findet sich da leicht Hilfe ;)

Gruß, Joachim
FHEM 5.8 Pi 2, HM-CFG-USB2, 8x HM-TC-IT-WM-W-EU, 5x HM-CC-RT-DN, 5x HM-SEC-SC-2, 1x HM-WDS10-TH-O, 1x HM-DIS-WM55
FHEM 5.8 PI B+, HM-CFG-USB2, 7x HM-CC-RT-DN, 3x HM-TC-IT-WM-W-EU, 4x HM-Sec-SCo
FHEM 5.8 PI 2 (Testsystem), CUL868, 1x HM-TC-IT-WM-W-EU, 1x HumTempESP8266, 1x mySensorsFillingLevel

Offline hyper2910

  • Sr. Member
  • ****
  • Beiträge: 586
Antw:Alexa startet nicht als Dienst
« Antwort #24 am: 21 April 2017, 21:31:48 »
Hallo Joachim,

vielen Dank.

ier mal die Infos, ich bin Schritt für Schritt der Anleitung gefolgt.

Wird ein alexa-fhem Log angelegt?
(wo steht im Script: /etc/init.d/alexa)
ja  ein Log wird angelegt! in /opt/fhem/log
Wenn ja: was steht drin?

ein eintrag:
/usr/bin/env: node: No such file or directory

Wohin hast du alexa-fhem installiert?

/opt/fhem/alexa-fhem

Wo liegt die config.json?

Home/pi/.alexa/


Welcher User soll denn alexa-fhem starten?
pi

Also was steht im Script (/etc/init.d/alexa)?
#!/bin/sh
### BEGIN INIT INFO
# Provides: alexa
# Required-Start: $network $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time for alexa
# Description: Enable service provided by daemon.
### END INIT INFO
export PATH=$PATH:/usr/local/bin
export NODE_PATH=$NODE_PATH:/usr/local/lib/node_modules
PID=`pidof alexa`
export ALEXAPATH="/opt/fhem/alexa-fhem"
export LOGPATH="/opt/fhem/log"
case "$1" in
start)
if ps -p $PID > /dev/null 2>&1; then
GNU nano 2.2.6 File: alxa GNU nano 2.2.6 File: alexa
#!/bin/sh
### BEGIN INIT INFO
# Provides: alexa
# Required-Start: $network $remote_fs $syslog
GNU nano 2.2.6 File: alexa
#!/bin/sh
### BEGIN INIT INFO
# Provides: alexa
# Required-Start: $network $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time for alexa
# Description: Enable service provided by daemon.
### END INIT INFO
export PATH=$PATH:/usr/local/bin
export NODE_PATH=$NODE_PATH:/usr/local/lib/node_modules
PID=`pidof alexa`
export ALEXAPATH="/opt/fhem/alexa-fhem"
export LOGPATH="/opt/fhem/log"
case "$1" in
start)
if ps -p $PID > /dev/null 2>&1; then
echo "Alexa is already running"
perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa is already running"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status on"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
else
su - "pi" -c "cd $ALEXAPATH;./bin/alexa > $LOGPATH/alexa-`date +%Y-%m`.log 2>&1 &"
echo "Alexa starting"
sleep 2
$0 status
fi
;;
stop)
if ! ps -p $PID > /dev/null 2>&1; then
echo "Alexa is not running"
perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa is not running"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status off"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
else
kill $PID
echo "Alexa closed"
perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa closed"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status off"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
fi
;;
restart) if ! ps -p $PID > /dev/null 2>&1; then
$0 start
else
$0 stop
$0 start
fi
;;
status)
if ps -p $PID > /dev/null 2>&1; then
echo "Alexa is running PID $PID"
perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa running as PID $PID"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status on"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
else
echo "Alexa is not running"
perl /opt/fhem/fhem.pl 7072 "setreading FHEM.Alexa.Status info Alexa is not running"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa.Status off"
perl /opt/fhem/fhem.pl 7072 "set FHEM.Alexa off"
fi
;;
*)
echo "Usage: $0 {start|stop|status|restart}"
exit 1
;;
esac
echo "script done"

Wenn du das Script einfach ohne Änderungen genommen hast, dann ist das wohl der User pi...
Cubietruck mit FHEM, CUL V3 443MHz, 2 x CULV3 868MHz, Milights, Max Heizungssteuerung, Homematic, IT,

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 2206
  • Niveau ist keine Creme...
Antw:Alexa startet nicht als Dienst
« Antwort #25 am: 21 April 2017, 22:00:06 »
Was kommt bei:

./bin/alexa

Wenn du als User pi im Verzeichnis /opt/fhem/alexa-fhem/ "stehst"...


Was kommt bei:

node -v

Gruß, Joachim
FHEM 5.8 Pi 2, HM-CFG-USB2, 8x HM-TC-IT-WM-W-EU, 5x HM-CC-RT-DN, 5x HM-SEC-SC-2, 1x HM-WDS10-TH-O, 1x HM-DIS-WM55
FHEM 5.8 PI B+, HM-CFG-USB2, 7x HM-CC-RT-DN, 3x HM-TC-IT-WM-W-EU, 4x HM-Sec-SCo
FHEM 5.8 PI 2 (Testsystem), CUL868, 1x HM-TC-IT-WM-W-EU, 1x HumTempESP8266, 1x mySensorsFillingLevel

Offline hyper2910

  • Sr. Member
  • ****
  • Beiträge: 586
Antw:Alexa startet nicht als Dienst
« Antwort #26 am: 21 April 2017, 22:15:37 »
Hi,


mit ./bin/alexa

kommt
/usr/bin/env: node no such file or directory


node command not found


Cubietruck mit FHEM, CUL V3 443MHz, 2 x CULV3 868MHz, Milights, Max Heizungssteuerung, Homematic, IT,

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 2206
  • Niveau ist keine Creme...
Antw:Alexa startet nicht als Dienst
« Antwort #27 am: 21 April 2017, 22:23:53 »
Tja, dann ist wohl node nicht (richtig) installiert...
...und ohne das läuft alexa-fhem eben nicht.

Gruß, Joachim
FHEM 5.8 Pi 2, HM-CFG-USB2, 8x HM-TC-IT-WM-W-EU, 5x HM-CC-RT-DN, 5x HM-SEC-SC-2, 1x HM-WDS10-TH-O, 1x HM-DIS-WM55
FHEM 5.8 PI B+, HM-CFG-USB2, 7x HM-CC-RT-DN, 3x HM-TC-IT-WM-W-EU, 4x HM-Sec-SCo
FHEM 5.8 PI 2 (Testsystem), CUL868, 1x HM-TC-IT-WM-W-EU, 1x HumTempESP8266, 1x mySensorsFillingLevel

Offline hyper2910

  • Sr. Member
  • ****
  • Beiträge: 586
Antw:Alexa startet nicht als Dienst
« Antwort #28 am: 21 April 2017, 22:27:43 »
ok, wie installiere ich die node denn richtig?
Cubietruck mit FHEM, CUL V3 443MHz, 2 x CULV3 868MHz, Milights, Max Heizungssteuerung, Homematic, IT,

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 2206
  • Niveau ist keine Creme...
Antw:Alexa startet nicht als Dienst
« Antwort #29 am: 21 April 2017, 22:33:24 »
Steht im Wiki...

Welches System überhaupt?

Gruß, Joachim
FHEM 5.8 Pi 2, HM-CFG-USB2, 8x HM-TC-IT-WM-W-EU, 5x HM-CC-RT-DN, 5x HM-SEC-SC-2, 1x HM-WDS10-TH-O, 1x HM-DIS-WM55
FHEM 5.8 PI B+, HM-CFG-USB2, 7x HM-CC-RT-DN, 3x HM-TC-IT-WM-W-EU, 4x HM-Sec-SCo
FHEM 5.8 PI 2 (Testsystem), CUL868, 1x HM-TC-IT-WM-W-EU, 1x HumTempESP8266, 1x mySensorsFillingLevel

 

decade-submarginal