Autor Thema: Push-API (deCONZ)  (Gelesen 1219 mal)

Offline olindner

  • New Member
  • *
  • Beiträge: 39
Antw:Push-API (deCONZ)
« Antwort #30 am: 01 März 2017, 18:14:22 »
Hallo CT, ich muss die Push-Bridge wohl noch aktivieren ... mhhh
Was muss ich noch einstellen? In der rest_bridge.conf steht leider eine NULL  :'(
pi@raspbee-gw:/var/log $ cat /usr/share/deCONZ/rest_bridge.conf
0

... habe ./build.sh vergessen :(  und noch was installieren! sudo apt-get install qt4-qmake libqt4-dev
melde mich wenn später ...
« Letzte Änderung: 01 März 2017, 19:55:56 von olindner »

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #31 am: 01 März 2017, 20:21:41 »
Hallo Olaf,

hm... build.sh bitte nicht ausführen. Der Quellcode ist nicht aktuell.
Falls du es schon gemacht hast, dann bitte nochmal das Repo neu clonen.

Nur um ganz sicher zu gehen. Hast du noch Readings zum Konfigurieren in dem deCONZ-FHEM-device?
Aso die fhemPort, fhemtunnel, etc..?

Die solltest du löschen, da diese die rest_push.conf sozusagen überschreiben. Somit würde das Plugin angewießen nach dem Connect den Telnet auf einem anderen Port neuzustarten.

Grüße,
ct

Offline olindner

  • New Member
  • *
  • Beiträge: 39
Antw:Push-API (deCONZ)
« Antwort #32 am: 01 März 2017, 20:39:35 »
dachte ich hatte es übersehen (build ist leider gelaufen) ... so neu git clone geholt, readings sind keine mehr da

nach install.sh kommt nur eine Warnung!
pi@raspbee-gw:~/deconz-push $ ./install.sh
Warning: $FHEM_HOME/FHEM not available!

nach restart immer noch eine Null in rest_bridge.conf ...

Was könnte ich noch tun? vg Olaf

Internals:
   .triggerUsed 1
   CFGFN      fhem-HUEDevice.cfg
   DEF        192.168.178.69
   Host       192.168.178.69
   INTERVAL   60
   NAME       lightlink
   NOTIFYDEV  global
   NR         355
   NTFY_ORDER 50-lightlink
   STATE      connected
   TYPE       HUEBridge
   apiversion 1.0.0
   mac        74:da:38:27:ea:cd
   manufacturer dresden elektronik
   modelName  Philips hue bridge 2012
   modelid
   name       RaspBee-GW
   noshutdown 1
   swversion  20435
   updatestate 0
   zigbeechannel 15
   Readings:
     2017-02-18 18:51:00   lastError       resource, /lights/3, not available
     2017-03-01 20:41:41   state           connected
   Helper:
     apiversion 65536
     count      0
     last_config_timestamp 1488397301
     updatestate 0
Attributes:
   event-on-change-reading .*
   httpUtils  1
   key        bf4b06e277514e50da1292d631580fa8
   pollDevices 2
   room       HUEDevice
   verbose    1
« Letzte Änderung: 01 März 2017, 20:43:05 von olindner »

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #33 am: 01 März 2017, 20:44:37 »
Hallo Olaf,

das kann ich mir leider erst später ansehen, aber du könntest die ID direkt in die Datei eintragen. Die /usr/share/deCONZ/rest_bridge.conf sollte aus zwei Zeilen bestehen und so aussehen:

355

Die zweite Zeile leer lassen. Kommt per Telnet auf port 7073 eine Ausgabe?

Grüße,
ct

Offline olindner

  • New Member
  • *
  • Beiträge: 39
Antw:Push-API (deCONZ)
« Antwort #34 am: 01 März 2017, 21:00:37 »
Hallo CT, kein Problem, es läuft ja alles noch  :)

hier scheint noch was zu klemmen:
pi@raspbee-gw:~/deconz-push $ telnet 192.168.178.69 7073
Trying 192.168.178.69...
telnet: Unable to connect to remote host: Connection refused

der port wird gar nicht aufgemacht ...

vg Olaf

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #35 am: 01 März 2017, 21:06:54 »
Hallo Olaf,

sehe grad, du meintest 0 :-)
Bei NULL wäre etwas anderes schiefgelaufen und wäre kritischer ...
Bei 0 scheint keine Verbindung zu FHEM aufgebaut werden zu können.

Dann führe auf dem deCONZ-RPi mal ein ./install.sh 1 aus. Damit wird die Debug-Version installiert. Nach dem Starten werden 2 Logdateien erzeugt:
/tmp/raspBeeBridge.log
/tmp/beeBridge.log
Lass mir bitte die beide zukommen und ich schau mal wo es genau stockt. Am besten per PM oder Dropbox, etc. schicken.

Grüße,
ct

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #36 am: 01 März 2017, 22:10:34 »
Upss... :D

Hallo Olaf,

mir ist grad aufgefallen, dass ich noch "Testcode" im Installer habe. Öffne doch die install.sh und kommentiere die Zeile 43 aus.

Um ganz sicher zu gehen, dass du den richtigen Branch aktualisierst solltest du folgendes ausführen:

git pull origin v0.2
Danach sollte das Plugin mit ./install.sh tatsächlich installiert werden.

Grüße,
ct
« Letzte Änderung: 01 März 2017, 22:27:41 von ct »

Offline olindner

  • New Member
  • *
  • Beiträge: 39
Antw:Push-API (deCONZ)
« Antwort #37 am: 02 März 2017, 09:11:29 »
Moin CT,

jetzt hat der Installer auch was installiert  :) jetzt kommt auch die Ausschrift "Please restart deCONZ process now."
pi@raspbee-gw:~/deconz-push $ ./install.sh
Warning: $FHEM_HOME/FHEM not available!
Please restart deCONZ process now.

raspbee-gw neu gestartet (Ich sehe im Code, deConz als Service /etc/init.d/deConz zu integrieren, wird/ist dies schon umgesetzt? zz habe ich keinen Plan, wie ich deConz richtig neu starte!)
pi@raspbee-gw:~/deconz-push $ telnet raspbee-gw 7073
Trying 127.0.1.1...
Connected to raspbee-gw.
Escape character is '^]'.
355^l^3^level^255
355^l^3^bri^255
355^l^3^pct^100
355^l^3^level^255^bri^255^pct^100
355^l^3^manufacturer^OSRAM^modelid^Plug 01^swversion^V1.04.12^type^On/Off plug-in unit^manufacturerCode^48042^clusterId^25^groupCapacity^7^on^1^groupCount^1^sceneCapacity^16
355^l^3^id^3^uniqueid^84:18:26:00:00:09:84:2D-03^available^1
355^l^3^state^on^onoff^1
355^l^3^level^255^bri^255^pct^100

Sehe noch keine neuen Readings im Device, Neustart FHEM? Reload 99_myDeconz1.pm hatte ich gemacht!

Kann es aber erst heute Abend ausprobieren, hänge noch im Office fest  ;D

Danke uvg Olaf

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #38 am: 02 März 2017, 13:43:53 »
Hallo Olaf,

das sieht doch schon sehr gut aus. Gib mal in der FHEM-Kommandobox folgendes ein und schau ob "pushupd1"-Einträge in der fhem-log mit deCONZ_... erscheinen.

{deCONZ_set_verbose(1)}
Das Skript 99_myDeconz1.pm baut einen Cache mit Referenzen zu den HUEDevices zum Beschleunigen der Zugriffe auf. Allerdings wird der ungültig, wenn du ein "rereadcfg" in die Kommandobox eingibst. Sollte bald gefixt sein.

Bis dahin kannst du den Cache immer wieder neu aktualisieren oder neu aufbauen mit:

{deCONZ_get_config(0)}
Dies wird auch jedesmal automatisch aufgerufen, wenn sich deCONZ mit FHEM verbindet.

Zum init-skript für deCONZ kann ich heute Abend evtl. noch nen Tipp geben.

Grüße,
ct

Offline olindner

  • New Member
  • *
  • Beiträge: 39
Antw:Push-API (deCONZ)
« Antwort #39 am: 02 März 2017, 14:36:48 »
Hallo CT, hier mal der log ...

2017.03.02 14:34:04 1: pushupd1: Bridge 355 not found!
2017.03.02 14:34:04 1: deCONZ_get_config: Bridge found with NR 355
2017.03.02 14:34:04 1: deCONZ_get_config: Found 1 bridges.
2017.03.02 14:34:04 1: deCONZ_get_config: Bridge NR 355
2017.03.02 14:34:04 1: deCONZ_get_config: Creating Bridge for NR 355
2017.03.02 14:34:04 1: deCONZ_get_config: Creating lights
2017.03.02 14:34:04 1: deCONZ_get_config: Creating sensors
2017.03.02 14:34:04 1: deCONZ_get_config: Creating groups
2017.03.02 14:34:04 1: deCONZ_get_config: Device lightlink-3 ( HUEDevice3 ) -> 3 -> Device -> Added.
2017.03.02 14:34:04 1: deCONZ_get_config: Device lightlink-G1 ( HUEGroup1 ) -> G1 -> Group 1 -> Added.
2017.03.02 14:34:04 1: deCONZ_get_config: Device lightlink-1 ( HUEDevice1 ) -> 1 -> Device -> Added.
2017.03.02 14:34:04 1: deCONZ_get_config: Device lightlink-G0 ( HUEGroup0 ) -> G0 -> Group 0 -> Added.
2017.03.02 14:34:04 1: deCONZ_get_config: Device lightlink-2 ( HUEDevice2 ) -> 2 -> Device -> Added.
2017.03.02 14:34:04 1: deCONZ_get_config: Device lightlink-G2 ( HUEGroup2 ) -> G2 -> Group 2 -> Added.
2017.03.02 14:34:04 1: deCONZ_get_config: Added 6 devices.
2017.03.02 14:34:04 1: pushupd1: l:3 bri 255
2017.03.02 14:34:04 1: pushupd1: l:3 pct 100
2017.03.02 14:34:04 1: pushupd1: l:3 state on
2017.03.02 14:34:04 1: pushupd1: l:3 onoff 1
2017.03.02 14:34:04 1: pushupd1: l:3 level 255
2017.03.02 14:34:04 1: pushupd1: l:3 bri 255
2017.03.02 14:34:04 1: pushupd1: l:3 pct 100

Bekomme keine Readings ans Device :( ...
« Letzte Änderung: 02 März 2017, 18:41:35 von olindner »

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #40 am: 02 März 2017, 21:59:59 »
Hallo Olaf,
die Logs sehen eigentlich gut aus. Die pushupd1-Meldungen bedeuten, dass die Verbindung von deCONZ zu FHEM funktioniert und zumindest 4 Readings ins Device lightlink-3 gepushed wurden. Sind keine weiteren Readings in den Logs zu sehen?

Wenn die Readings sich in FHEM nicht ändern, dann könnte der Cache ungültig geworden sein, was allerdings ungewöhnlich wäre. Möglicherweise ist da noch ein Bug drin.

Falls keine weiteren logs zu sehen sind, könntest du versuchen die debug-logs mit "./install.sh 1" zu erzeugen?

Grüße,
ct

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #41 am: 03 März 2017, 17:54:09 »
Hallo Olaf,

Danke dir für die Logs. Die Logs sehen eigentlich gut aus. Nur um sicher zu gehen, weil du die HUEBridge-Device angehängt hast.
Meinst du die Readings im Device der HUEBridge oder denen der HUEDevice?

Die Readings in dein einzelnen HUEDevices sollten sich ändern, also z.B. HUEDevice3 ( https://192.168.xxx.xxx:8083/fhem?detail=HUEDevice3 )
bzw. wie viele Readings (ungefähr) sind dort zu finden?

Grüße,
ct

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #42 am: 05 März 2017, 00:16:16 »
Version wurde auf v0.2 aktualisiert.

NEU:
- Telnet Passwort
- Telnet Passwort / SSL
- deCONZ kann auf einem anderen RaspBerry als FHEM laufen

Damit push nach einem rereadcfg funktioniert, muss ein push-Device erzeugt werden:

define myDeconz myDeconz1
Danke an Olaf fürs Testen!

Grüße,
ct

Online mahowi

  • Sr. Member
  • ****
  • Beiträge: 543
Antw:Push-API (deCONZ)
« Antwort #43 am: 06 März 2017, 08:23:11 »
Hallo ct,

bei der Installation der aktuellen Version gibt es noch ein Problem:
Installing plugin ...
cp: der Aufruf von stat für „rest_push.conf“ ist nicht möglich: Datei oder Verzeichnis nicht gefunden
Failed to install rest_push.conf
Failed to install plugin!

Heißt die Konfigurationsdatei jetzt rest_push.conf? Dann muß die Datei rest_push.txt noch umbenannt werden.


Edit:
Es fehlt noch eine Datei:
Installed rest_push.conf. You should update the configuration through this file.
cp: der Aufruf von stat für „rest_bridge.conf“ ist nicht möglich: Datei oder Verzeichnis nicht gefunden
Failed to install rest_bridge.conf

Ich habe die beiden Dateien mal aus dem v0.2 Branch genommen, dann läuft die Installation auch durch.


Edit2:
Noch was, das Modul 99_myDeconz1.pm wird mit uid.gid root.root installiert, d.h. der FHEM-User kann die Datei nicht laden.

Was sollte denn nach dem define myDeconz myDeconz1 passieren? Bei mir kommt die Meldung deCONZ_value:NR:166; Es wird aber kein Device angelegt.
« Letzte Änderung: 06 März 2017, 08:48:29 von mahowi »
CUBe (MAX): HT, WT+, FK, EcoTaster | CUBe (SlowRF): ESA2000WZ
JeeLink: LaCrosse | nanoCUL433: Smartwares SHS-51001-EU, EM1000GZ
ZME_UZB1: GreenWave PowerNode, Popp Thermostat | SIGNALDuino: HE877, X10 MS14A, Revolt NC-5462,  IT Steckdosen + PIR
tado° | Milight | HUE, Lightify | SmarterCoffee

Offline ct

  • New Member
  • *
  • Beiträge: 27
Antw:Push-API (deCONZ)
« Antwort #44 am: 06 März 2017, 10:27:15 »
Hallo mahowi,

Danke dir für den Hinweis. Ich habe die Konfigurationsdateien und den Installer korrigiert.

Nach dem define müsste ein Device mit dem Namen myDeconz angelegt worden sein. Dieses dient lediglich dazu mitzubekommen, wenn fhem die Konfiguration neu ladet. D.h. du findest dieses auch nicht, wenn du es direkt mit https://IP:8083/fhem?detail=myDeconz abrufst?

Grüße,
ct