Verschiedenes > Projekte

FHEM-Plugin für checkMK

<< < (20/22) > >>

erdo_king:
Einsetzen tue ich das nicht.

Ich vermute das liegt an den Longpolls von FHEM (irgendwie sowas). FHEM "lässt sich Zeit" mit Antworten, bzw aktualisiert sich selbsttätig alle paar minuten ... das scheint den check zu verwirren.
Aber wirklich verstehen tue ich das auch nicht ... Sorry das hat aber nichts mit dem Plugin zu tun, daher debugge ich hier auch nichts.

Falls du das Thema weiter aufgreifen willst mach bitte einen extra Thread dafür, dass ist in meinen Augen kein CheckMK Problem sondern geht Richtung FHEM-Konfiguration

gadget:
Hallo,

Ich habe mir das Plugin rein interessehalber heute mal angeschaut. Bin mir aber noch nicht so ganz klar ob die Kombination cmk und fhem für mich Sinn macht. Ist aber auf jeden Fall eine interessante Idee und ich schließe mich dem Lob an den Autor vollumfänglich an.

Was mir aufgefallen ist und wofür ich keine Lösung gefunden habe:

AVM FBDECT Funkschalter (fhem Modul FBDECT) lieferen u.a. ein reading "mode". Das steht bei mir auf "manuell", weil ich den Schalter nicht über irgendwelche Timer in der Fritzbox schalte, sondern von fhem aus bzw. weil ich den Funkschalter nur zur Energiemessung nutze.

Im plugin output schaut das so aus


--- Code: ---FBDECT_waschmaschine    FBDECT_waschmaschine TYPE                 FBDECT
                     2020-02-15 16:13:39  FBDECT_waschmaschine   AIN                  09711 0128412
                     2020-02-15 16:13:39  FBDECT_waschmaschine   FBNAME               Waschmaschine
                     2020-02-15 16:13:39  FBDECT_waschmaschine   FBPROP               microphone,powerMeter,tempSensor,switch
                     2020-02-15 16:13:39  FBDECT_waschmaschine   FBTYPE               FRITZ!DECT 200
                     2020-02-15 16:13:39  FBDECT_waschmaschine   ID                   17
                     2020-02-15 16:13:39  FBDECT_waschmaschine   devicelock           no
                     2020-02-15 16:13:39  FBDECT_waschmaschine   energy               1136067 Wh
                     2020-02-15 16:13:39  FBDECT_waschmaschine   fwversion            04.16
                     2017-09-30 14:10:47  FBDECT_waschmaschine   humidity             0
                     2020-02-15 16:13:39  FBDECT_waschmaschine   locked               no
                     2020-02-15 16:13:39  FBDECT_waschmaschine   mode                 manuell
                     2020-02-15 16:13:39  FBDECT_waschmaschine   power                1.85 W
                     2020-02-15 16:13:39  FBDECT_waschmaschine   present              yes
                     2020-02-15 16:13:39  FBDECT_waschmaschine   state                on
                     2020-02-15 16:13:39  FBDECT_waschmaschine   tempadjust           0.0 C
                     2020-02-15 16:13:39  FBDECT_waschmaschine   temperature          28.0 C (measured)
                     2020-02-15 16:13:39  FBDECT_waschmaschine   voltage              233.013 V

--- Ende Code ---


In cmk führt das dann zu einem CRIT wegen "mode: manuell (expected: auto)".
Ich vermute, das ist eigentlich für Homematic gedacht, aber lt. Online Hilfe zur WATO Regel sollte der Default ja eigentlich "ignore" sein.

Ich hab mir die Implentierung nicht genauer angeschaut, aber ich vermute, dass das deutsch geschriebene "manuell" ein edge case ist ... :-)

Viele Grüße,

gadget.



erdo_king:
Hi gadget,

erst einmal danke für deine - durchaus positive - Rückmeldung :)
 
Den Tippfehler habe ich korrigiert. Fließt in das nächste Release mit ein.
https://github.com/erdoking/mk_fhem/commit/4b6574a33a00d553683f2168b37c0e3a85174f05

Zu deinem Problem:
Das wird tatsächlich an der deutschen Übersetzung liegen.

Du kannst unter "Manufacturer -> HomeMatic -> Control Mode" den Wert auf "custom" ändern und dort einen beliebigen Wert hinterlegen (zB. "manuell")
Das sollte dein Problem lösen.

Der eigentliche Check ist dumm, das ist ein reiner String-Vergeich.
Ich wǘsste hier keine Lösung - außer eine Art Wörterbuch für alle möglichen Übersetzungen zu hinterlegen, das sprengt den Rahmen. Genau dafür kann man den Filter custom setzen ..

Grüße
erdo

gadget:
Hallo,

soweit verstanden, aber mein Problem wäre erst dann 100% gelöst, wenn man den mode tatsächlich per WATO Regel ignorieren könnte. IMHO sollte das ignorieren eigentlich auch der default sein.

Eilt aber nicht, ich hab die Fritzdect jetzt insgesamt aus dem inventory geworfen, die brauche ich in cmk nicht unbedingt.


--- Code: ---ignored_services = [
{'condition': {'service_description': [{'$regex': u'FHEM\\ FBDECT\\_'}]}, 'value': True, 'options': {'description': u'keine FBDECT'}},
] + ignored_services

--- Ende Code ---

Grüße, gadget

erdo_king:
Oha, stimmt ignorieren darf man den Wert nicht ...
Das werde ich ändern! Wobei der default-Wert "auto" meiner Meinung nach zumindest für Homematic-Benutzer am meisten Sinn macht ... Ob das nun für alle Anwender gilt ... mhmmm kp

Ich setze CheckMK vor allem für Konfigurationsüberwachung ein, daher ist der default - für mich - korrekt gewählt ...

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln