Autor Thema: FHEM-Plugin für checkMK  (Gelesen 10319 mal)

Offline erdo_king

  • Jr. Member
  • **
  • Beiträge: 57
Antw:FHEM-Plugin für checkMK
« Antwort #60 am: 28 September 2018, 08:56:02 »
mhm okay Problem verstanden...
Die HM-WDS30-OT2-SM liefern Temperature auf mehreren Channels - das wird vom Plugin derzeit nicht unterstützt!

Muss ich mir mal in Ruhe anschauen wie man das umsetzen kann, auf die schnelle fällt mir keine Lösung ein.
Im Grunde sollte für jeden Channel+Differenz ein Graph mit Humidity+Temperature+Dewpoint (sofern deklariert) angelegt werden.

Normalerweise liefern Geräte nur 1x Temperatur oder ich habe, wie bei einigen HomeMatic-Devices, einen  Channel festgesetzt

Online hauwech

  • Full Member
  • ***
  • Beiträge: 259
Antw:FHEM-Plugin für checkMK
« Antwort #61 am: 28 September 2018, 13:23:10 »
Hallo erdo_king,
wenn Dir was einfällt, wäre schön, aber Prio bei mir liegt bei "nice to have"  :)

Gruß Roland
System: Ubuntu 14.04 LTS als Hyper-V VM -> jetzt umgezogen auf Raspbian/Raspi2 -> nochmal umgezogen auf Intel NUC mit Ubuntu 16.04 LTS

Online hauwech

  • Full Member
  • ***
  • Beiträge: 259
Antw:FHEM-Plugin für checkMK
« Antwort #62 am: 08 Oktober 2018, 13:26:07 »
Hallo zusammen,
ich habe bei allen fhem services in WATO -> Services -> Monitored Services unter "CHECK PARAMETERS" "invalid check parameter..."
Invalid check parameter: Undefined key 'var_activity' in the dictionary. Allowed are common_params, climate_params, various_params, devicetypes_params, manufacturer_params.! The parameter is: {'var_activity': 'alive', 'var_brightness': 'ignore', 'level_averageAmbientTemperature_min': (15, 12), 'level_averageAmbientTemperature_max': (26, 30), 'level_ambientTemperature_max': (26, 30), 'var_presence': 'present', 'level_ambientTemperature_min': (15, 12), 'var_state': 'ignore', 'var_globalBtnLock': 'ignore', 'level_data_age': (30, 90), 'level_humidity_min': (50, 45), 'var_modusBtnLock': 'ignore', 'var_dewpoint_override': 'true', 'level_humidity_max': (70, 80), 'level_ping_max': (100, 150), 'level_hotWaterTemperature_max': (60, 65), 'var_opModeHotWater': 'Automatik', 'level_hotWaterTemperature_min': (40, 37), 'var_RGB_color': 'ignore', 'var_btnLock': 'ignore', 'level_dewpoint_max': (3, 1), 'var_heatingSystemCircPump': 'ignore', 'level_upload_min': (1.5, 1.0), 'level_batteryLevel_min': (2.3, 2.1), 'var_opModeHeating': 'Automatik', 'var_opStateHeatPump1': 'ignore', 'var_contact': 'ignore', 'level_download_min': (10.0, 8.0), 'level_temperature_max': (26, 30), 'level_temperature_min': (15, 12), 'var_battery': 'ok'} The variable name is: checkgroup_parameters:fhemWas habe ich gemacht:
- auf Check_MK Maschine: mkp install fhem-<>.mkp
- auf fhem Maschine: Agent-Plugin auf dem FHEM-Server nach /usr/lib/check_mk_agent/plugins/ kopieren
chmod +x /usr/lib/check_mk_agent/plugins/mk_fhem
Der Aufruf von /usr/lib/check_mk_agent/plugins/mk_fhem spuckt alle Werte aus.
Was habe ich falsch gemacht/vergessen/übersehen?

Gruß Roland
« Letzte Änderung: 08 Oktober 2018, 14:51:30 von hauwech »
System: Ubuntu 14.04 LTS als Hyper-V VM -> jetzt umgezogen auf Raspbian/Raspi2 -> nochmal umgezogen auf Intel NUC mit Ubuntu 16.04 LTS

Offline erdo_king

  • Jr. Member
  • **
  • Beiträge: 57
Antw:FHEM-Plugin für checkMK
« Antwort #63 am: 08 Oktober 2018, 16:51:45 »
Ich empfehle dem Entwickler (mir) vor das Scheinbein zu treten und wüst zu Beschimpfen ;)
Der Entwickler - ohne Namen nennen zu wollen - sollte seine default-Parameter im Quellcode sauberer pflegen ...

Der Fehler kommt bei mir auch  :-\

Ich schau mir das die Tage an - das Plugin sollte aber ansonsten laufen!
Ist mehr eine Warnung wie ein echte Error.


Online hauwech

  • Full Member
  • ***
  • Beiträge: 259
Antw:FHEM-Plugin für checkMK
« Antwort #64 am: 08 Oktober 2018, 17:28:15 »
Danke für die Info, ich bin schon froh, wenn ich nicht selbst der Depp bin. Ich tue mich mit check_mk teilweise noch etwas schwer, in der Firma habe ich SCOM zum Monitoring, da sind im Detail doch erhebliche Unterschiede.
Mich hat allerdings gewundert: Mein Kollege hat das auch am Laufen - auch unter check_mk 1.5.0p4 - bei ihm gibt's aber diese Einträge nicht. Mal kucken, was rauskommt.
Aber sonst läuft alles, danke dafür.

Gruß Roland
« Letzte Änderung: 08 Oktober 2018, 17:31:26 von hauwech »
System: Ubuntu 14.04 LTS als Hyper-V VM -> jetzt umgezogen auf Raspbian/Raspi2 -> nochmal umgezogen auf Intel NUC mit Ubuntu 16.04 LTS

Offline erdo_king

  • Jr. Member
  • **
  • Beiträge: 57
Antw:FHEM-Plugin für checkMK
« Antwort #65 am: 09 Oktober 2018, 08:01:03 »
Ich habe 1.5.0p5 im Einsatz -> und die Warnungen kommen noch!
Ich denke dein Kollege hat an der falschen Stelle gesucht.

edit:
Ich fürchte das Thema ist nicht trivial, kann durchaus sein das ich das garnicht selbst gefixt bekomme und das Problem im CheckMK-Core liegt...


Falls es jemanden interessiert:
In der fhem.py werden die Wato-Optionen deklariert.
Diese habe ich aus Übersichtsgründen strukturiert.

common_params
 - state_params
   # var_presence
 - battery_params
   # var_battery
   # level_batteryLevel_min
...
various_params
 - speedtest_params
...


Wato wertet offenbar nur die oberste Ebene aus:
Zitat
Allowed are common_params, climate_params, various_params, devicetypes_params, manufacturer_params

Alle Sub-Elemente werden ignoriert (funktinieren aber).
Bin mir jetzt nur nicht sicher ob ich was falsche mache oder das ein CheckMK-"Bug" ist ...
« Letzte Änderung: 09 Oktober 2018, 11:32:59 von erdo_king »

Online hauwech

  • Full Member
  • ***
  • Beiträge: 259
Antw:FHEM-Plugin für checkMK
« Antwort #66 am: 09 Oktober 2018, 13:53:00 »
Ich denke dein Kollege hat an der falschen Stelle gesucht.
Stimmt fast: Die Ansicht stand auf "Hide Check parameters" ::)
Mit "show..." sieht man die "Invalid..." Einträge bei ihm auch.

Gruß Roland
System: Ubuntu 14.04 LTS als Hyper-V VM -> jetzt umgezogen auf Raspbian/Raspi2 -> nochmal umgezogen auf Intel NUC mit Ubuntu 16.04 LTS

Offline erdo_king

  • Jr. Member
  • **
  • Beiträge: 57
Antw:FHEM-Plugin für checkMK
« Antwort #67 am: 15 Oktober 2018, 16:03:27 »
Neue Version v0.9.3 online!

## [0.9.3] - 2018-10-15
### Added
 - support for MAX! readings (desiredTemperature,mode,window,groupid)
 - support for XiaomiFlowerSens readings (fertility,lux,moisture)

### Changed
 - tranform on/off (HomeMatic/MAX desiredTemp) to zero


https://github.com/erdoking/mk_fhem/releases



Nebenbei arbeite ich an Version 1.0 - da ist vor allem ein größeres Code-Cleanup von Nöten...
Geplantes Release 2019 - und ich nenne absichtlich keinen Monat  ::) ::)

Offline jogibaer

  • Newbie
  • Beiträge: 1
Antw:FHEM-Plugin für checkMK
« Antwort #68 am: 19 November 2018, 16:29:04 »
Hallo erdo,

kann es sein, dass das Plugin nicht in Verbindung mit piVCCU funktioniert?

Ich habe folgende Konstallation:
1. fhem-server mit über VCCU angebundenen HM Geräten. Da geht auch die Überwachung mit check_mk.
2. fhem-test-server mit über piVCCU angebundene Geräten. Da werden mit der Abfrage von mk_fhem keine Geräte erkannt, es ist nach der Ausgabe "<<<fhem>>> Detected Devices:" Schluß.

Hintergrund ist, dass ich von VCCU auf piVCCU umstellen möchte, damit cih auch HomematicIP Geräte verwenden kann.

Achja, beide Server sind raspi's. Der produktive ist ein pi3 b und der zum Testen ist ein pi2 b. Auf dem pi3 läuft neben fhem auch check_mk.

Danke und Gruß
Jörg

EDIT: Hat sich erledigt, die devices werden nun angezeigt, bei den ganzen Test hatte ich nicht bemerkt, dass die piVCCU abgestürzt war

Gruß
Jörg
« Letzte Änderung: 19 November 2018, 18:05:52 von jogibaer »

Offline erdo_king

  • Jr. Member
  • **
  • Beiträge: 57
Antw:FHEM-Plugin für checkMK
« Antwort #69 am: 22 November 2018, 14:28:01 »
Hi Jörg,

meine liebsten Probleme sind immer diejenigen welche sich von selbst Lösen :)
Falls du doch nich Probleme haben solltest - das CheckMK Plugin für den Agent schickt eine gefilterte Anfrage an FHEM.

Da ich keinesfalls alle Situation abfangen kann fliegen hier sicherlich ein paar Geräte bei raus ...
Dann muss der Filter entsprechend kalibriert werden - bestenfalls von mir.

Grüße
erdo

 

decade-submarginal