Autor Thema: Probleme bei der Installation von Node-Js  (Gelesen 581 mal)

Offline raspklaus

  • Sr. Member
  • ****
  • Beiträge: 674
Probleme bei der Installation von Node-Js
« am: 07 Januar 2017, 16:59:42 »
Hallo zusammen,

ich versuche gerade die Grundlagen für den Dot seit zwei Tagen zu installieren:

apt-get install nodejs-legacy
als System habe ich:

Linux cubietruck 3.4.107-cubietruck #6 SMP PREEMPT Thu May 21 20:27:01 CEST 2015 armv7l GNU/Linux
Statt einer Installation kommt folgende Fehlermeldung:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'nodejs' instead of 'nodejs-legacy'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nodejs : Depends: libc6 (>= 2.16) but 2.13-38+deb7u11 is to be installed
          Depends: libstdc++6 (>= 5.2) but 4.7.2-5 is to be installed
E: Unable to correct problems, you have held broken packages.

Leider kann mir da Mama Google etc auch nicht weiterhelfen.

Hat jemand eine Idee ?

Danke
« Letzte Änderung: 08 Januar 2017, 16:58:33 von raspklaus »

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3347
Antw:Probleme bei der Instalation von Node-JS
« Antwort #1 am: 07 Januar 2017, 17:42:42 »
Sorry: Lesen und Verstehen
nodejs :  Depends: libc6 (>= 2.16) but 2.13-38+deb7u11 is to be installed
          Depends: libstdc++6 (>= 5.2) but 4.7.2-5 is to be installed

Was für eine libc und libstdc++ ist auf Deinem System installiert?
Laut der Beschreibung 2.13 und 4.7.2, beide sind zu alt, er will >= 2.16 und >= 5.2

Als Lösung hast Du:
Entweder anders nodejs oder System aktuallisieren.

Woher hast Du denn nodejs (Quelle)?

Edit
2 Threads für ein Thema ist NICHT wünschenswert. Warum hast Du in 2 Forumsbereiche den gleichen Thread eröffnet?
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline raspklaus

  • Sr. Member
  • ****
  • Beiträge: 674
Antw:Probleme bei der Instalation von Node-JS
« Antwort #2 am: 07 Januar 2017, 20:50:40 »
Ich habe das System vorher mit

apt-get update
apt-get dist-upgrade

upgedated und auch die Abhängigkeiten überprüft mit

apt-get -f install
Für den Amazon Echo Dot wird nodejs 4.2.6. oder höher und npm benötigt.

Das node habe ich von:

wget https://nodejs.org/download/release/v4.2.6/node-v4.2.6-linux-arm64.tar.gz
und mit

tar xzvf ~/node-v4.2.6-linux-arm64.tar.gz --strip=1
entpackt.

Dann kommt wie gesagt die Meldung:

The following packages have unmet dependencies:
 nodejs : Depends: libc6 (>= 2.16) but 2.13-38+deb7u11 is to be installed
          Depends: libstdc++6 (>= 5.2) but 4.7.2-5 is to be installed
E: Unable to correct problems, you have held broken packages.

Ich kann zwar etwas Linux aber soweit dieses Problem zu fixen bin ich leider noch nicht  :-[ :-[ :-[

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 3347
Antw:Probleme bei der Installation von Node-Js
« Antwort #3 am: 08 Januar 2017, 17:32:26 »
Es ist kein Distri Fehler, sondern wie Du schon sagst, das Packet braucht einige neuere Module.

Du hast jetzt die Möglichkeit:
- Gibt es ein Update zu Deiner Distri (oder Testing)
- Aktuelleren Distri wechseln
- Manuell diese Module Updaten
- ....

Aber da ... kann (und will) ich Dir nicht helfen. Da solltest Du in einem Forum zu Deiner Distri (oder Cupi) nachfragen. Dort sitzen bestimmt die passenden Spezialisten
- Bitte um Input für Output
- When there is a Shell, there is a Way

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline MandelHL

  • Jr. Member
  • **
  • Beiträge: 75
Antw:Probleme bei der Installation von Node-Js
« Antwort #4 am: 05 Juli 2017, 11:07:30 »
Hallo, ich hatte auch das Problem, dass sich note.js 4.x nicht installieren ließ und mit einer Fehlermeldung abgeschlossen wurde.
Nun habe ich 6.x ohne Fehlermeldungen installiert.

Gestern hatte ich aber bei Amazon Web Services Google und FHEM mit 4.x eingerichtet. Kann und muss ich das jetzt ändern, da auf dem RaPi nun eine andere Version installiert ist?

Danke für Eure Unterstützung.
Mandel