Autor Thema: Tul lässt sich nicht definieren??  (Gelesen 3952 mal)

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Tul lässt sich nicht definieren??
« am: 21 Januar 2017, 20:19:46 »
Hi

Hab meinen Raspberry 3 neu aufgesetzt mit Jessie Lite, anschließend Fhem neu installiert und dann Knxd nach (https://wiki.fhem.de/wiki/Knxd) dieser Anleitung,
wenn ich jetzt in Fhem den Tul mit

define tul TUL knxd:127.0.0.1 1.1.140

definieren will bekomme ich diese Fehlermeldung im Log.

2017.01.21 20:09:07 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref. As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.01.21 20:09:07 3: TUL opening tul device knxd:127.0.0.1
2017.01.21 20:09:07 3: TUL device opened openGroupSocket failed
2017.01.21 20:09:07 1: Cannot init knxd:127.0.0.1, ignoring it
2017.01.21 20:09:07 1: define tul TUL knxd:127.0.0.1 1.1.140: 1

knxd läuft

@raspberrypi:~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
Active: active (running) since Sat 2017-01-21 19:19:48 CET; 31min ago
Main PID: 795 (knxd)
CGroup: /system.slice/knxd.service
└─795 /usr/bin/knxd -e 1.0.240 -b ipt:192.168.5.15

Das komische ist ich hab die gleichen Einstellungen auf einer VM mit Linux Debian8 laufen da geht es nur mit meinen Raspberry nicht.
Hat jemand eine Idee.
« Letzte Änderung: 21 Januar 2017, 20:46:09 von SebastianN »

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #1 am: 21 Januar 2017, 20:45:20 »
Hallo SebastianN,

du solltest in Fhem und in KNXD die gleiche Gruppenadresse (1.1.140) angeben.

define tul TUL knxd:127.0.0.1 1.1.140

/etc/knxd.conf
KNXD_OPTS="-e 1.1.140 -b ipt:192.168.5.15"

Viel Erfolg!

Gruß Jens

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #2 am: 21 Januar 2017, 21:14:03 »
Hallo EIB-Fan

Hab ich gleich mal ausprobiert leider erfolglos es ändert nichts. :'(
Und in (https://fhem.de/commandref_DE.html#TUL  )steht
define <name> TUL <device> <physical address> physikalische adresse nicht Gruppenadresse.


 
« Letzte Änderung: 21 Januar 2017, 22:24:11 von SebastianN »

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #3 am: 21 Januar 2017, 22:09:43 »
Hallo SebastianN,

du natürlich hast Recht. Es ist die physikalische Adresse.   ???

Diese sollte aber in Fhem und knxd gleich sein...

Sehe gerade, dass dein Fhem und dein KNX-Gateway nicht im gleichen IP-Bereich (z. B. 192.168.4.XXX) liegen.

192.168.4.75:8083/fhem/docs/commandref_DE.html#TUL

KNXD_OPTS="-e 1.1.140 -b ipt:192.168.5.15

Schau mal, ob es daran liegt.

Gruß Jens
« Letzte Änderung: 21 Januar 2017, 22:15:20 von EIB-Fan »

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #4 am: 21 Januar 2017, 22:28:31 »
Der IP Bereich ist der gleiche.

Offline antonwinden

  • Full Member
  • ***
  • Beiträge: 181
Antw:Tul lässt sich nicht definieren??
« Antwort #5 am: 22 Januar 2017, 07:43:37 »
bei mir ist er mit eibd: und nicht mit knxd:
gruß anton
KNX, Raspberry, Denon 3313, Philips TV, Xtrend9X00 und viel Optimismus...

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #6 am: 22 Januar 2017, 08:45:57 »
Hab heute den tul mal mit einer falschen Ip definiert
define tul TUL knxd:192.168.5.16 1.1.140das lustige ist dann wird er in Fhem angelegt (logischerweise mit STATE
disconnected) und im Log steht

2017.01.22 08:35:03 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref. As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.01.22 08:35:03 3: TUL opening tul device knxd:192.168.5.16
2017.01.22 08:35:06 3: Can't connect to knxd:192.168.5.16: No route to host

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #7 am: 22 Januar 2017, 19:59:44 »
Das kenn ich. 127.0.0.1 verweigert er. Warum auch immer. Ist nichts, was ich in der TUL lösen könnte.

Für die andere Meldung bitte nach route add googlen. Das sollte helfen.

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #8 am: 23 Januar 2017, 14:10:28 »
Ich hab auf meiner VM einen mit 127.0.0.1 laufen (siehe Anhang) und am Raspberry gehts nicht.
Kannst du mir genauer erklären wie mir route add helfen soll bei meinem Problem soll ich ihn falsch definieren und über die Route wieder umleiten?

Offline jmike

  • Developer
  • Full Member
  • ****
  • Beiträge: 186
Antw:Tul lässt sich nicht definieren??
« Antwort #9 am: 23 Januar 2017, 15:20:33 »
Hi Sebastian.

Wenn dein knxd wirklich sauber läuft musst du mal schauen wo der Port geöffnet worden ist.
Eventuell wird bei dir der Port nicht auf dem loopback geöffnet.

Zeig mal den Output von "netstat -tlnp"

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #10 am: 23 Januar 2017, 16:31:35 »
@raspberrypi:~ $ sudo netstat -tlnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:7072            0.0.0.0:*               LISTEN      673/perl
tcp        0      0 0.0.0.0:8083            0.0.0.0:*               LISTEN      673/perl
tcp        0      0 0.0.0.0:8084            0.0.0.0:*               LISTEN      673/perl
tcp        0      0 0.0.0.0:8085            0.0.0.0:*               LISTEN      673/perl
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      509/sshd
tcp6       0      0 :::6720                 :::*                    LISTEN      1/init
tcp6       0      0 :::22                   :::*                    LISTEN      509/sshd
« Letzte Änderung: 23 Januar 2017, 16:37:18 von SebastianN »

Offline jmike

  • Developer
  • Full Member
  • ****
  • Beiträge: 186
Antw:Tul lässt sich nicht definieren??
« Antwort #11 am: 25 Januar 2017, 11:50:45 »
Hmm.

Ändert sich dein Portbinding wenn du knxd und knxd.socket nach dem reboot neu startest?
Also von :::6720 auf den ipv4 0.0.0.0:6720?

In meinem Setup lief das mit :::6720 und in der TUL dann die IPv4 Adresse 192.168.5.15 (der PI selber).

geht denn sowas wie "knxtool groupswrite local: 2/1/5 0" nun?

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #12 am: 27 Januar 2017, 09:42:11 »
Ich hab mal neu aufgesetzt und jeden Schritt aufgeschrieben (vielleicht hab ich ja was vergessen)

RASPBIAN JESSIE LITE, Version:January 2017, Kernel version:4.4
hab ich mit win32diskImager auf ne 16 Gb Sd kopiert

Am Pi über
sudo raspi-config "Expand Filesystem" und "Advanced Options" "A4 SSH" eingeschaltet
Reboot
ab jetz per SSH

sudo dpkg-reconfigure tzdata"Europe"und "Berlin"

sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y autoremove && sudo reboot
wget -qO - https://debian.fhem.de/archive.key | sudo apt-key add - && echo "deb https://debian.fhem.de/stable ./" |
 sudo tee -a /etc/apt/sources.list && sudo apt-get -y install apt-transport-https && sudo apt-get update && sudo apt-get -y install fhem

sudo apt-get install debhelper cdbs automake libtool libusb-1.0-0-dev git-core build-essential libsystemd-daemon-dev dh-systemd libev-dev
git clone https://github.com/knxd/knxd.git
cd knxd
dpkg-buildpackage -b -uc
cd ..
sudo dpkg -i knxd_*.deb knxd-tools_*.deb
sudo nano /etc/knxd.conf
KNXD_OPTS="-e 1.0.240  -b ipt:192.168.5.15"
In Fhem define KNX TUL knxd:127.0.0.1 1.0.240
Tul hat sich problemlos definieren lassen (STATE
Initialized)


systemctl status knxd.service● .service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/.service; enabled)
   Active: active (running) since Fri 2017-01-27 09:19:16 CET; 18min ago
 Main PID: 803 ()
   CGroup: /system.slice/.service
           └─803 /usr/bin/ -e 1.0.240 -b ipt:192.168.5.15

knxtool groupswrite local: 2/1/5 0Connect failed: Connection reset by peer

Wenn ich dann in Fhem eine update mache verschwindet der Tul in Everything
in der fhem.cfg ist er noch mit define KNX TUL :127.0.0.1 1.0.240 drinnen.
Da ist doch irgendwas komisch ohne Fhem Update lässt sich der Tul definieren aber knxd läuft nicht richtig, und mit dem Update geht weder der Tul noch knxd .





« Letzte Änderung: 27 Januar 2017, 09:56:41 von SebastianN »

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #13 am: 27 Januar 2017, 10:08:20 »
Hallo SebastianN,

probier mal

define KNX TUL knxd:localhost 1.0.240
statt

define KNX TUL knxd:127.0.0.1 1.0.240
Du kannst auch statt 127.0.0.1 die IP des Rasperry angeben.

Andi hatte von Problemen mir 127.0.0.1 weiter oben geschrieben.

Viel Erfolg!

Gruß Jens

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #14 am: 27 Januar 2017, 10:27:04 »
Hi

Ich habe es nochmal ausprobiert, aber es ist wie ich oben schon geschrieben habe: sobald ich den Tul neu definieren will kommen die gleichen Fehler wie oben-egal ob ich localhost/127.0.0.1/192.168.5.10 eingebe-nur bei bei ner falschen IP taucht er in Everything, auf dann aber mit STATE disconnected (und falsche IP macht auch keinen Sinn).
Und vor dem Fhem update lässt er sich ja mit 127.0.0.1 definieren.

« Letzte Änderung: 05 Februar 2017, 20:54:25 von SebastianN »

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #15 am: 27 Januar 2017, 10:42:22 »
Hallo SebastianN,

welche Version vom knxd hast du?

knxd -V
Ich arbeite mit

knxd 0.10.0
Bei knxd ist jetzt Verion 0.12 verfügbar. Eventuell sind hier noch zusätzliche Parameter zu programmieren.

Gruß Jens

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #16 am: 27 Januar 2017, 10:48:56 »
Hallo SebastianN,

habe gerade noch etwas bei dir gesehen.

Bei dir wird beim knxd-Status das knxd nich mit angegeben.

● .service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/.service; enabled)
   Active: active (running) since Fri 2017-01-27 09:19:16 CET; 18min ago
 Main PID: 803 ()
   CGroup: /system.slice/.service
           └─803 /usr/bin/ -e 1.0.240 -b ipt:192.168.5.15

Bei mir schaut das so aus:

● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Mi 2017-01-18 02:37:37 CET; 1 weeks 2 days ago
 Main PID: 456 (knxd)
   CGroup: /system.slice/knxd.service
           └─456 /usr/bin/knxd -e 1.1.240 -b ipt:192.168.178.XX

Gruß Jens

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #17 am: 27 Januar 2017, 11:00:56 »
Hi

hab des gerade nochmal kontrolliert bei mir schaut es aktuell so aus wie bei dir
knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Fri 2017-01-27 10:06:20 CET; 44min ago
 Main PID: 833 (knxd)
   CGroup: /system.slice/knxd.service
           └─833 /usr/bin/knxd -e 1.0.240 -b ipt:192.168.5.15

des ohne knxd war vor dem Update, aber das ist doch mal ein guter Ansatz.
Wenn ich jetzt noch mein Image vor dem Update gesichert hätte könnten wir des kontrollieren :-) .
Ich setz nochmal auf. :-(

« Letzte Änderung: 04 Februar 2017, 13:58:20 von SebastianN »

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #18 am: 29 Januar 2017, 13:23:48 »
Hallo allerseits,

ich scheitere seit dem Wochenende (Freitag) an dem TUL. Auf meinem Raspi 2 habe ich das neuste Jessie mit fhem 5.7 installiert. Ich möchte gerne den vorhanden KNX/EIP IP Server von Busch, IP Adresse ist im Netz, in meinem fhem konfigurieren.

Aktuell läuft:
root@Rasp-2:/# knxd -V
knxd 0.12.5
root@Rasp-2:/# etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2017-01-29 12:55:41 CET; 8min ago
 Main PID: 1026 (knxd)
   CGroup: /system.slice/knxd.service
           └─1026 /usr/bin/knxd -e 1.0.240 -b ipt:192.168.178.98

Jan 29 12:55:41 Rasp-2 systemd[1]: Started KNX Daemon.

im Fhem ist der Status disconnected

Im logfile steht, dass die tul connection geöffnet ist

017.01.29 12:55:35 0: Featurelevel: 5.7
2017.01.29 12:55:35 0: Server started with 14 defined entities (fhem.pl:13259/2017-01-28 perl:5.020002 os:linux user:fhem pid:552)
2017.01.29 12:59:13 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.01.29 12:59:13 3: TUL opening tul device knxd:192.168.178.98


Ich habe verschiedene konfigs ausprobiert..

Habt ihr eine Idee warum die Schnittstelle zwar geöffnet ist, aber der tul immer noch disconncted?

Besten Dank für eure Unterstützung.
Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #19 am: 29 Januar 2017, 14:51:02 »
Hallo wagenkna,

du musst im knxd die IP des IP-Interface angeben,

KNXD_OPTS="-e 1.0.240 -b ipt:192.168.178.98"

und hier die IP des Raspberry(oder "localhost" bzw. "127.0.0.1")

define KNX TUL knxd:localhost 1.0.240

Viel Erfolg!

Gruß Jens

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #20 am: 29 Januar 2017, 21:47:24 »
Hallo Jens,

Danke ein kleines Stück weiter!

Siehe Logfile:
2017.01.29 21:34:39 1: Cannot init knxd:localhost, ignoring it
2017.01.29 21:34:39 1: define KNX TUL knxd:localhost 192.168.178.56: 1
2017.01.29 21:44:35 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.01.29 21:44:35 3: TUL opening KNX device knxd:192.168.178.56
2017.01.29 21:44:35 3: TUL device opened
openGroupSocket failed
2017.01.29 21:44:35 1: Cannot init knxd:192.168.178.56, ignoring it
2017.01.29 21:44:35 1: define KNX TUL knxd:192.168.178.56 1.0.240: 1

Aber wie bekomme ich den GroupSocket geöffnet?

Vielen Dank für deinen Support !!

Grüße

awa
Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

Offline kalleknx

  • New Member
  • *
  • Beiträge: 9
Antw:Tul lässt sich nicht definieren??
« Antwort #21 am: 04 Februar 2017, 21:54:33 »
2017.01.29 21:44:35 3: TUL opening KNX device knxd:192.168.178.56
2017.01.29 21:44:35 3: TUL device opened
openGroupSocket failed
2017.01.29 21:44:35 1: Cannot init knxd:192.168.178.56, ignoring it
2017.01.29 21:44:35 1: define KNX TUL knxd:192.168.178.56 1.0.240: 1

Aber wie bekomme ich den GroupSocket geöffnet?

Vielen Dank für deinen Support !!

Grüße

awa


Ich scheitere leider genau am gleichen Punkt.

Wenn ich knxd direkt starte (knxd -e 1.1.128 -u /tmp/eib -i -t1023 -b ipt:192.168.0.115) sehe ich viele Send/Recv, aber in/aus Richtung FHEM leider tot....

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #22 am: 05 Februar 2017, 14:52:53 »
Hallo allerseits,

ich bin schon mal wieder weiter gekommen...

Device angelegt..
KNX
   
Initialized
Internals
AckLineDef
   
Clients
   
:KNX:EIB:
DEF    
EIBD:192.168.XXX.XXX 1.0.1  ==> IP vom Raspi
DeviceAddress
   
1001
DeviceName
   
EIBD:192.168.XXX.XXX
NAME
   
KNX
NR
   
2
PARTIAL
   
STATE
   
Initialized
TYPE
   
TUL


Im fhem bekomme ich die Fehler Meldung

TUL opening KNX device EIBD:192.168.XXX.XXX
2017.02.05 14:45:00 1: EIBD:192.168.XXX.XXX protocol is not supported
2017.02.05 14:45:00 3: TUL device opened

Wie bekomme ich das Protokoll zum laufen? Fhem ist auf dem neuesten Stand..

Auf dem Raspi   läuft knxd..

● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2017-02-05 13:50:34 CET; 41min ago
 Main PID: 1010 (knxd)
   CGroup: /system.slice/knxd.service
           └─1010 /usr/bin/knxd -e 1.0.1 -b ipt:192.168.XXX.XXX

Ich bekomme aber bei groupwrite mit dem knxtool, die Meldung

 $ knxtool groupswrite local: 2/1/10 0
Connect failed: Connection reset by peer

Kann jemand helfen?

Danke & schönes We....


Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

Offline makro123

  • New Member
  • *
  • Beiträge: 4
Antw:Tul lässt sich nicht definieren??
« Antwort #23 am: 05 Februar 2017, 18:19:43 »
Hallo,
hatte dieselben Probleme wie hier beschrieben.

Habe nun die v0.10 von knxd installiert nach dieser Anleitung:
https://github.com/knxd/knxd/blob/v0.10/README.md
Mit dieser funktioniert es auf Anhieb.
Weder mit v0.12 oder v0.13 konnte ich eine Verbindung von FHEM zum Bus erstellen.

Gruß
Manuel
Informativ Informativ x 1 Liste anzeigen

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #24 am: 05 Februar 2017, 20:50:23 »
Hallo

hab heute nochmal komplett neu aufgesetzt und versucht das Pfadproblem zu rekonstruieren, was mir leider nicht gelungen ist - vermutlich weil inzwischen knxd v 13 installiert wird.
Was nicht so schlimm ist, da ich dann dank makro123 knxd v10 installiert habe und siehe da es geht.
 

Hier noch mal Schritt für Schritt.

RASPBIAN JESSIE LITE, Version:January 2017, Kernel version:4.4
hab ich mit win32diskImager auf ne 16 Gb Sd kopiert


Am Pi über

sudo raspi-config
"Expand Filesystem" und "Advanced Options" "A4 SSH" eingeschaltet
Reboot
ab jetz per SSH

sudo dpkg-reconfigure tzdata
"Europe"und "Berlin"

sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y autoremove && sudo reboot
wget -qO - https://debian.fhem.de/archive.key | sudo apt-key add - && echo "deb https://debian.fhem.de/stable ./" |
 sudo tee -a /etc/apt/sources.list && sudo apt-get -y install apt-transport-https && sudo apt-get update && sudo apt-get -y install fhem
sudo apt-get install debhelper cdbs automake libtool libusb-1.0-0-dev git-core build-essential libsystemd-daemon-dev dh-systemd libev-dev
git clone https://github.com/knxd/knxd.git
wget https://www.auto.tuwien.ac.at/~mkoegler/pth/pthsem_2.0.8.tar.gz
tar xzf pthsem_2.0.8.tar.gz
cd pthsem-2.0.8
dpkg-buildpackage -b -uc
cd ..
sudo dpkg -i libpthsem*.deb
cd knxd
git checkout v0.10 ## this branchdpkg-buildpackage -b -uccd ..sudo dpkg -i knxd_*.deb knxd-tools_*.debsudo nano /etc/knxd.conf

KNXD_OPTS="-e 1.0.240  -b ipt:192.168.5.15"

In Fhem

define KNX TUL knxd:127.0.0.1 1.0.240
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline kalleknx

  • New Member
  • *
  • Beiträge: 9
Antw:Tul lässt sich nicht definieren??
« Antwort #25 am: 05 Februar 2017, 21:05:47 »
Hallo,
hatte dieselben Probleme wie hier beschrieben.

Habe nun die v0.10 von knxd installiert nach dieser Anleitung:
https://github.com/knxd/knxd/blob/v0.10/README.md
Mit dieser funktioniert es auf Anhieb.
Weder mit v0.12 oder v0.13 konnte ich eine Verbindung von FHEM zum Bus erstellen.

Gruß
Manuel


Vielen Dank!

Offline mehfmurof

  • Newbie
  • Beiträge: 1
Antw:Tul lässt sich nicht definieren??
« Antwort #26 am: 08 Februar 2017, 16:12:02 »
Hallo allerseits,

ich bin schon mal wieder weiter gekommen...

Device angelegt..
KNX
   
Initialized
Internals
AckLineDef
   
Clients
   
:KNX:EIB:
DEF    
EIBD:192.168.XXX.XXX 1.0.1  ==> IP vom Raspi
DeviceAddress
   
1001
DeviceName
   
EIBD:192.168.XXX.XXX
NAME
   
KNX
NR
   
2
PARTIAL
   
STATE
   
Initialized
TYPE
   
TUL


Im fhem bekomme ich die Fehler Meldung

TUL opening KNX device EIBD:192.168.XXX.XXX
2017.02.05 14:45:00 1: EIBD:192.168.XXX.XXX protocol is not supported
2017.02.05 14:45:00 3: TUL device opened

Wie bekomme ich das Protokoll zum laufen? Fhem ist auf dem neuesten Stand..

Auf dem Raspi   läuft knxd..

● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2017-02-05 13:50:34 CET; 41min ago
 Main PID: 1010 (knxd)
   CGroup: /system.slice/knxd.service
           └─1010 /usr/bin/knxd -e 1.0.1 -b ipt:192.168.XXX.XXX

Ich bekomme aber bei groupwrite mit dem knxtool, die Meldung

 $ knxtool groupswrite local: 2/1/10 0
Connect failed: Connection reset by peer

Kann jemand helfen?

Danke & schönes We....

diese zeile in 00_TUL.pm von FHEM suchen und "eibd" durch "knxd" ersetzen: ich verwende übrigens knxd version 0.13.0 mit #KNXD_OPTS="-t1023 -e 1.1.250 -E 1.1.251:8 -DTRS -c -B single -b ipt:(ip vom knx-server)"
if($dev =~ m/^(knxd):(.+)$/) { # eibd:host[:port]
neustart fhem

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #27 am: 09 Februar 2017, 10:30:28 »
Hallo  mehfmurof

Probier doch mal die knxd Version 0.10.0 mit der sollte es gehen.

Zitat
ich verwende übrigens knxd version 0.13.0 mit #KNXD_OPTS="-t1023 -e 1.1.250 -E 1.1.251:8 -DTRS -c -B single -b ipt:(ip vom knx-server)"

bei mir läuft es mit KNXD_OPTS="-e 1.0.240  -b ipt:(ip vom knx-Ip Interface) "
 

Offline IROC_KNX

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Tul lässt sich nicht definieren??
« Antwort #28 am: 09 Februar 2017, 17:44:30 »
Hallo,

weil ich mein System von eibd auf knxd umstellen wollte, hatte ich es heute komplett neu aufgesetzt.
Das definieren der KNX Schnittstelle ist nicht möglich. Als Antwortmeldung kommt in FHEM nur eine "1".

knxd Version: 0.13.0

knxd Status "active (running)
/usr/bin/knxd -e 1.1.1 -b ipt:192.168.0.(ABB IP Gateway)

In FHEM hatte ich dann immer wieder probiert folgendes einzugeben:
define KNX TUL knxd:192.168.0.(Raspberry IP) 1.1.1

Klappt das generell nicht mit der neusten knxd Version?

FHEM 5.8 auf RaspberryPi mit knxd

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #29 am: 09 Februar 2017, 19:12:58 »
Setze Verbose = 5, starte neu und poste mal ein Log.

Meine Glaskugel ist grad beim Reinigen :-)

Grüße, Andi

Offline IROC_KNX

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Tul lässt sich nicht definieren??
« Antwort #30 am: 09 Februar 2017, 19:24:37 »
Hallo Andi,
hier mein Log

2017.02.09 19:22:28 5: Cmd: >define KNX TUL knxd:192.168.0.X 1.1.1<
2017.02.09 19:22:28 5: Loading ./FHEM/00_TUL.pm
2017.02.09 19:22:28 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.02.09 19:22:28 3: TUL opening KNX device knxd:192.168.0.X
2017.02.09 19:22:28 3: TUL device opened
2017.02.09 19:22:28 5: sendRequest: 0026000000

2017.02.09 19:22:28 5: Received packet: 0004

openGroupSocket failed
2017.02.09 19:22:28 1: Cannot init knxd:192.168.0.X, ignoring it
2017.02.09 19:22:28 1: define KNX TUL knxd:192.168.0.X 1.1.1: 1
2017.02.09 19:22:28 4: name: /fhem&fw_id=24&cmd=define+KNX+TUL+knxd%3A192.168.0.X+1.1.1 / RL:1099 / text/html; charset=UTF-8 / Content-Encoding: gzip

Als Schnittstelle ist eine ABB IPS/S 2.1 verbaut.
Wie gesagt, gestern mit eibd lief alles noch problemlos.
in meiner alten FHEM Config stand:
define EIB TUL eibd:192.168.0.X 1.1.1
attr EIB useEIB 1

« Letzte Änderung: 09 Februar 2017, 19:28:14 von IROC_KNX »
FHEM 5.8 auf RaspberryPi mit knxd

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #31 am: 09 Februar 2017, 20:16:09 »
OK - der Reihe nach. Am FHEM liegst wahrscheinlich nicht. Schau erstmal, dass Dein knxd sauber läuft. Dazu am besten groupswrite oder so benutzen.

Ich nutze folgende Parameter:

-e=1.1.251 -c -u /tmp/knx -i -b ipt:192.168.XXX.XXX

Offline IROC_KNX

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Tul lässt sich nicht definieren??
« Antwort #32 am: 09 Februar 2017, 20:37:32 »
OK - der Reihe nach. Am FHEM liegst wahrscheinlich nicht. Schau erstmal, dass Dein knxd sauber läuft. Dazu am besten groupswrite oder so benutzen.

Ich nutze folgende Parameter:

-e=1.1.251 -c -u /tmp/knx -i -b ipt:192.168.XXX.XXX

Du hast recht, mit groupswrite kann ich kein Licht schalten.
Wenn ich deinen Befehl eingebe, kommt allerdings eine Fehlermeldung.
Folgendes stand in der alten eibd:
DAEMON_ARGS="-D -T -S -d -i --eibaddr=1.1.1 --daemon=/var/log/eibd.log --no-tunnel-client-queuing ipt:192.168.0.X"
« Letzte Änderung: 09 Februar 2017, 20:43:34 von IROC_KNX »
FHEM 5.8 auf RaspberryPi mit knxd

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #33 am: 11 Februar 2017, 19:11:22 »
Dann klicker Dich bitte mal durch die anderen Threads und bring den knxd sauber zum Laufen.
Dann kümmern wir uns um die Definition im FHEM...

Grüße, Andi

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #34 am: 26 Juli 2017, 13:55:55 »
Hallo zusammen,

nach einem Problem mit FHEM habe ich nun versucht auf KNXD umzustellen. KNXD läuft offensichtlich:
pi@raspberrypi:~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Wed 2017-07-26 11:06:45 CEST; 2h 37min ago
 Main PID: 1066 (knxd)
   CGroup: /system.slice/knxd.service
           └─1066 /usr/bin/knxd -e 1.0.240 -c -u /tmp/eib -b ipt:192.168.178....

Die /etc/knxd.conf sieht so aus: KNXD_OPTS="-e 1.0.240 -c -u /tmp/eib -b ipt:192.168.178.30"
START_KNXD=YES

FHEM läuft mittlerweile auch wieder  ;D, allerdings können die beiden sich nicht verständigen! Wenn ich diesen TUL eingebe:
define KNX TUL knxd:192.168.178.30 1.0.240 erscheint nach der Bestätigung lediglich eine 1.

Anbei mein Logfile nach Reboot.

Für Eure Hilfe wäre ich sehr dankbar!

VG Marc
« Letzte Änderung: 26 Juli 2017, 14:16:01 von dauma »

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #35 am: 26 Juli 2017, 19:00:18 »
So, nun habe ich parallel auf einer zweiten Karte eibd installiert. Die Installation lief komplett fehlerfrei durch, allerdings bekomme ich beim starten folgende Fehlermeldung:
pi@raspberrypi:~ $ eibd -t 1023 -S -D -R -T -i --no-tunnel-client-queuing ipt:192.168.178.30
Segmentation fault

Vielleicht hat hierzu jemand eine Idee. Die andere Lösung würde mir zwar besser gefallen, aber wie es so ist in der Not!  :-\

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #36 am: 26 Juli 2017, 20:27:51 »
Öhm...Da hast DU irgendwie Käse gemacht...

Wenn die 192.168.178.30 die IP-Adresse Deines KNX-Gateways ist, dann gebe diese bitte nicht in der fhem.cfg an. Hier muss "localhost" oder die IP-Adresse des KNXD-Gerätes rein.

Hast Du geschaut, ob groupswrite... funktioniert?

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #37 am: 26 Juli 2017, 20:45:27 »
Ich glaube mir ist das zu hoch! :(
Ich bastele schon seit Stunden und mir fehlt irgendwie das Verständnis, oder die richtige Erklärung auf einer der zwanzig Webseiten die ich parallel auf habe.
Aktueller Stand ist wie folgt:
pi@raspberrypi:~ $ systemctl status knxd.service
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Wed 2017-07-26 20:35:52 CEST; 2min 50s ago
 Main PID: 1069 (knxd)
   CGroup: /system.slice/knxd.service
           └─1069 /usr/bin/knxd -e 1.1.255 -b ist:192.168.178.30
Groupswrite habe ich zwar gelesen, aber nicht verstanden (Frage ich mich wie ich das bisher alles habe programmieren können)!
Das mit den IP-Adressen hatte ich auch schon auf dem Schirm, aber leider nicht geblickt welche welche ist und wohin sie muss. Auch die 1.1.255 habe ich nicht verstanden. :(

Anbei noch der aktuelle Logfile!

Sagt Bescheid, wenn ich ein hoffnungsloser Fall bin!

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #38 am: 26 Juli 2017, 20:55:56 »
Groupswrite z.b. hier:
https://forum.fhem.de/index.php/topic,65396.msg569082.html#msg569082

Wie ist nun die IP Deines KNX-GW's? 192.168.178.30?

Wen dem so ist - dann nochmals die Bitte, Deine TUL-config entpsrehcend ändern:
KNX myTUL knxd:localhost 1.1.254

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #39 am: 26 Juli 2017, 21:17:08 »
Hier der Logfile nach der Änderung:
2017.07.26 21:13:09 3: TUL opening KNX device knxd:localhost
2017.07.26 21:13:09 3: TUL device opened
openGroupSocket failed
2017.07.26 21:13:09 1: Cannot init knxd:localhost, ignoring it
2017.07.26 21:13:09 1: define KNX TUL knxd:localhost 1.1.254: 1
2017.07.26 21:13:09 1: Including ./log/fhem.save
2017.07.26 21:13:19 0: Server shutdown
2017.07.26 21:13:21 1: Including fhem.cfg
2017.07.26 21:13:21 3: telnetPort: port 7072 opened
2017.07.26 21:13:22 3: WEB: port 8083 opened
2017.07.26 21:13:22 3: WEBphone: port 8084 opened
2017.07.26 21:13:22 3: WEBtablet: port 8085 opened
2017.07.26 21:13:22 2: eventTypes: loaded 1 events from ./log/eventTypes.txt
2017.07.26 21:13:22 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.07.26 21:13:22 3: TUL opening KNX device knxd:localhost
2017.07.26 21:13:22 3: TUL device opened
openGroupSocket failed
2017.07.26 21:13:22 1: Cannot init knxd:localhost, ignoring it
2017.07.26 21:13:22 1: define KNX TUL knxd:localhost 1.1.254: 1
2017.07.26 21:13:22 1: Including ./log/fhem.save
2017.07.26 21:13:22 1: configfile: 1

2017.07.26 21:13:22 2: Messages collected while initializing FHEM: configfile: 1
2017.07.26 21:13:22 0: Featurelevel: 5.8
2017.07.26 21:13:22 0: Server started with 8 defined entities (fhem.pl:14634/2017-07-03 perl:5.020002 os:linux user:fhem pid:1171)

Groupswrite war leider auch negativ: Connection reset by peer

Die 192.168.178.30 ist die IP des Gateway, welche ich bisher auch erfolgreich mit eibd nutze und die ..27 die des RPI.

KNXD_OPTS="-e 1.1.255 -b ipt:192.168.178.30"
« Letzte Änderung: 26 Juli 2017, 21:19:28 von dauma »

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #40 am: 26 Juli 2017, 21:26:43 »
Naja, wir nähern uns doch.

Wenn groupswrite nicht tut, tut der knxd noch nicht. Also fhem erstmal abschalten und liegenlassen. Damit kannst wieder anfangen, wenn groupswrite was tut...

Mein Tip:
ALLE laufenden Prozesse stoppen:

- sudo systemctl stop knxd.socket
- sudo systemctl stop knxd.service
- mit ps -ef | grep alle ggf. vorhandenen Reste finden und mit kill killen...
- in einer eigenen Putty-Instanz mal klein anfangen: sudo knxd -c -b ipt:192.168.178.30
- in einer weiteren Putty-Instanz per groupswrite probieren...

Erst wenn das läuft, machst Du mit systemd und fhem weiter...

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #41 am: 26 Juli 2017, 21:32:56 »
Wenn Du das sagst! :/

pi@raspberrypi:~ $ sudo nano /etc/knxd.conf
pi@raspberrypi:~ $ sudo systemctl stop knxd.socket
pi@raspberrypi:~ $ sudo systemctl stop knxd.service
pi@raspberrypi:~ $ ps -ef | grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
pi@raspberrypi:~ $ sudo knxd -c -b ipt:192.168.178.30
knxd requires a bus address (option -e)!
pi@raspberrypi:~ $ sudo knxd -c -b -e ipt:192.168.178.30
knxd requires a bus address (option -e)!
pi@raspberrypi:~ $ knxtool groupswrite local: 2/1/5 0
Open failed: Connection refused
pi@raspberrypi:~ $


Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #42 am: 26 Juli 2017, 21:36:16 »
 a bisserl mitspielen und meine Fehler ausbügeln musst schon :-)

sudo systemctl stop knxd.socket
sudo systemctl stop knxd.service
ps -ef | grep knx

Müsste leer sein...

sudo knxd -e 1.0.200 -c -b ipt:192.168.178.30


Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #43 am: 26 Juli 2017, 21:41:15 »
Glaub mir, bin froh um jede Hilfe und versuche mein Bestes!
Konnte kein Fehler entdecken! ;)

pi@raspberrypi:~ $ sudo systemctl stop knxd.socket
pi@raspberrypi:~ $ sudo systemctl stop knxd.service
pi@raspberrypi:~ $ ps -ef | grep knx
pi        1277  1150  0 21:39 pts/1    00:00:00 grep --color=auto knx
pi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -b ipt:192.168.178.30
I only have one interface. Nothing to do. Giving up.

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #44 am: 26 Juli 2017, 21:49:29 »
OK - wir nähern uns. Dir fehlen die Sockets...

sudo knxd -e 1.0.200 -c -u /tmp/eib -b ipt:192.168.178.30

oder

sudo knxd -e 1.0.200 -c -u /run/eib -b ipt:192.168.178.30

oder

sudo knxd -e 1.0.200 -c -u /run/knx -b ipt:192.168.178.30

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #45 am: 26 Juli 2017, 21:57:59 »
Sockets und die Nerven!  :o

Wenn ich die Befehle eingebe passiert irgendwie nichts! :

pi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -u /tmp/eib -b ipt:192.168.178.30

^Cpi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -u /run/eib -b ipt:192.168.178.30

^Cpi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -u /run/knx -b ipt:192.168.178.30


Muss das so?

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 171
Antw:Tul lässt sich nicht definieren??
« Antwort #46 am: 20 August 2017, 23:59:06 »
Hallo zusammen!

Endlich -nach über einem Jahr, nachdem ein Pi "hopps" gegangen ist- habe ich nun angefangen mein System neu aufzusetzen.
Das bedeutet aktuelles "Raspian Stretch", sowie knxd Version 0.14 (Stable).
Und ich habe das selbe Problem, wie der TO. Auch ich kann kein Verbindung von FHEM über knxd aufbauen.
Bei mir läuft knxd augenscheinlich:
pi@fhem:~ $ sudo systemctl status knxd.service
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: ena
   Active: active (running) since Sun 2017-08-20 23:22:14 CEST; 4min 7s ago
 Main PID: 422 (knxd)
   CGroup: /system.slice/knxd.service
           └─422 /usr/bin/knxd -e 1.1.251 -c -u /tmp/eib -b ipt:192.168.10.250

Aug 20 23:22:13 fhem systemd[1]: Starting KNX Daemon...
Aug 20 23:22:14 fhem systemd[1]: Started KNX Daemon.
Und in FHEM steht folgendes:
2017.08.20 23:41:01 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.08.20 23:41:01 3: TUL opening KNX device eibd:192.168.10.151
2017.08.20 23:41:01 3: TUL device opened
openGroupSocket failed
2017.08.20 23:41:01 1: Cannot init eibd:192.168.10.151, ignoring it
2017.08.20 23:41:01 1: define KNX TUL eibd:192.168.10.151 1.1.251: 1
Habe es schon mit
  • define tul TUL eibd:localhost 1.1.251
  • define KNX eibd:localhost 1.1.251
  • define KNX knxd:localhost 1.1.251
  • define KNX eibd:192.168.10.151 1.1.251
  • define KNX knxd:192.168.10.151 1.1.251
erfolglos probiert.

Mein KNX-Optionen vom letzten Jahr sind:
KNXD_OPTS="-e 1.1.251 -c -u /tmp/eib -b ipt:192.168.10.250"Ein Groupwrite (knxtool groupswrite local: 2/1/4 1) geht dennoch nicht. Also das Licht geht nicht an, aber eine Fehlermeldung gibt es dennoch nicht...

Grüße
NehCoy
« Letzte Änderung: 21 August 2017, 00:04:47 von NehCoy »

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 171
Antw:Tul lässt sich nicht definieren??
« Antwort #47 am: 21 August 2017, 00:25:18 »
Sockets und die Nerven!  :o

Wenn ich die Befehle eingebe passiert irgendwie nichts! :

pi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -u /tmp/eib -b ipt:192.168.178.30

^Cpi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -u /run/eib -b ipt:192.168.178.30

^Cpi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -u /run/knx -b ipt:192.168.178.30


Muss das so?

Ist bei mir auch so.... Auch wenn man vorher die jeweiligen Dienste stopt:
pi@fhem:~ sudo systemctl stop  knxd.service
Warning: Stopping knxd.service, but it can still be activated by:
  knxd.socket
pi@fhem:~ $ sudo systemctl stop  knxd.socket

Offline smurfix

  • Developer
  • Full Member
  • ****
  • Beiträge: 268
Antw:Tul lässt sich nicht definieren??
« Antwort #48 am: 21 August 2017, 05:41:56 »
Wie wäre es mit dem Lesen der Anleitung, speziell der README-Datei, Abschnitt "Migration auf 0.12"?
Ohne -E-Option geht nix. Das ist Absicht.

Ich stelle die "stable"-Version heute auf v0.14 um, die meckert wenn man das vergisst …

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #49 am: 21 August 2017, 08:00:19 »
Schönen guten Morgen!

Hiermit läuft es bei mir:

KNXD_OPTS="-e 1.4.200 -E 1.4.200:8 -b ipt:192.168.178.30"
START_KNXD=YES

Greetz Marc

Offline NehCoy

  • Full Member
  • ***
  • Beiträge: 171
Antw:Tul lässt sich nicht definieren??
« Antwort #50 am: 21 August 2017, 14:55:01 »
Ähm ... ja ...
Ja, gebe ich zu! - Überlesen! Bzw. gar nicht darauf geachtet.
Habe mich halt hier im Wesentlichen durch die FHEM-Wikiartikel
https://wiki.fhem.de/wiki/Einrichten_knxd_mit_MDT_SCN-IP000.02
und
https://wiki.fhem.de/wiki/Knxd
gelesen und da steht darüber auch nichts.

Grüße
NehCoy

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #51 am: 18 September 2017, 16:27:31 »
Hallo allerseits,

hier eine Rückmeldung von mir. Ich hatte das Problem, dass Tul auf dem Raspberry 2 lief, aber nicht auf dem Raspi 3!
Obwohl gleich Konfiguration, IPs usw.
Durch ändern der KNX Version von 0.12.x.x auf 0.10.xx ist das Problem gefixt und der Raspi3 versteht und sendet jetzt auch KNX.
Wenn hilft...
Viel Erfolg

awa
Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

 

decade-submarginal