Autor Thema: Tul lässt sich nicht definieren??  (Gelesen 3952 mal)

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #15 am: 27 Januar 2017, 10:42:22 »
Hallo SebastianN,

welche Version vom knxd hast du?

knxd -V
Ich arbeite mit

knxd 0.10.0
Bei knxd ist jetzt Verion 0.12 verfügbar. Eventuell sind hier noch zusätzliche Parameter zu programmieren.

Gruß Jens

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #16 am: 27 Januar 2017, 10:48:56 »
Hallo SebastianN,

habe gerade noch etwas bei dir gesehen.

Bei dir wird beim knxd-Status das knxd nich mit angegeben.

● .service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/.service; enabled)
   Active: active (running) since Fri 2017-01-27 09:19:16 CET; 18min ago
 Main PID: 803 ()
   CGroup: /system.slice/.service
           └─803 /usr/bin/ -e 1.0.240 -b ipt:192.168.5.15

Bei mir schaut das so aus:

● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Mi 2017-01-18 02:37:37 CET; 1 weeks 2 days ago
 Main PID: 456 (knxd)
   CGroup: /system.slice/knxd.service
           └─456 /usr/bin/knxd -e 1.1.240 -b ipt:192.168.178.XX

Gruß Jens

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #17 am: 27 Januar 2017, 11:00:56 »
Hi

hab des gerade nochmal kontrolliert bei mir schaut es aktuell so aus wie bei dir
knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Fri 2017-01-27 10:06:20 CET; 44min ago
 Main PID: 833 (knxd)
   CGroup: /system.slice/knxd.service
           └─833 /usr/bin/knxd -e 1.0.240 -b ipt:192.168.5.15

des ohne knxd war vor dem Update, aber das ist doch mal ein guter Ansatz.
Wenn ich jetzt noch mein Image vor dem Update gesichert hätte könnten wir des kontrollieren :-) .
Ich setz nochmal auf. :-(

« Letzte Änderung: 04 Februar 2017, 13:58:20 von SebastianN »

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #18 am: 29 Januar 2017, 13:23:48 »
Hallo allerseits,

ich scheitere seit dem Wochenende (Freitag) an dem TUL. Auf meinem Raspi 2 habe ich das neuste Jessie mit fhem 5.7 installiert. Ich möchte gerne den vorhanden KNX/EIP IP Server von Busch, IP Adresse ist im Netz, in meinem fhem konfigurieren.

Aktuell läuft:
root@Rasp-2:/# knxd -V
knxd 0.12.5
root@Rasp-2:/# etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2017-01-29 12:55:41 CET; 8min ago
 Main PID: 1026 (knxd)
   CGroup: /system.slice/knxd.service
           └─1026 /usr/bin/knxd -e 1.0.240 -b ipt:192.168.178.98

Jan 29 12:55:41 Rasp-2 systemd[1]: Started KNX Daemon.

im Fhem ist der Status disconnected

Im logfile steht, dass die tul connection geöffnet ist

017.01.29 12:55:35 0: Featurelevel: 5.7
2017.01.29 12:55:35 0: Server started with 14 defined entities (fhem.pl:13259/2017-01-28 perl:5.020002 os:linux user:fhem pid:552)
2017.01.29 12:59:13 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.01.29 12:59:13 3: TUL opening tul device knxd:192.168.178.98


Ich habe verschiedene konfigs ausprobiert..

Habt ihr eine Idee warum die Schnittstelle zwar geöffnet ist, aber der tul immer noch disconncted?

Besten Dank für eure Unterstützung.
Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

Offline EIB-Fan

  • Full Member
  • ***
  • Beiträge: 123
Antw:Tul lässt sich nicht definieren??
« Antwort #19 am: 29 Januar 2017, 14:51:02 »
Hallo wagenkna,

du musst im knxd die IP des IP-Interface angeben,

KNXD_OPTS="-e 1.0.240 -b ipt:192.168.178.98"

und hier die IP des Raspberry(oder "localhost" bzw. "127.0.0.1")

define KNX TUL knxd:localhost 1.0.240

Viel Erfolg!

Gruß Jens

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #20 am: 29 Januar 2017, 21:47:24 »
Hallo Jens,

Danke ein kleines Stück weiter!

Siehe Logfile:
2017.01.29 21:34:39 1: Cannot init knxd:localhost, ignoring it
2017.01.29 21:34:39 1: define KNX TUL knxd:localhost 192.168.178.56: 1
2017.01.29 21:44:35 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.01.29 21:44:35 3: TUL opening KNX device knxd:192.168.178.56
2017.01.29 21:44:35 3: TUL device opened
openGroupSocket failed
2017.01.29 21:44:35 1: Cannot init knxd:192.168.178.56, ignoring it
2017.01.29 21:44:35 1: define KNX TUL knxd:192.168.178.56 1.0.240: 1

Aber wie bekomme ich den GroupSocket geöffnet?

Vielen Dank für deinen Support !!

Grüße

awa
Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

Offline kalleknx

  • New Member
  • *
  • Beiträge: 9
Antw:Tul lässt sich nicht definieren??
« Antwort #21 am: 04 Februar 2017, 21:54:33 »
2017.01.29 21:44:35 3: TUL opening KNX device knxd:192.168.178.56
2017.01.29 21:44:35 3: TUL device opened
openGroupSocket failed
2017.01.29 21:44:35 1: Cannot init knxd:192.168.178.56, ignoring it
2017.01.29 21:44:35 1: define KNX TUL knxd:192.168.178.56 1.0.240: 1

Aber wie bekomme ich den GroupSocket geöffnet?

Vielen Dank für deinen Support !!

Grüße

awa


Ich scheitere leider genau am gleichen Punkt.

Wenn ich knxd direkt starte (knxd -e 1.1.128 -u /tmp/eib -i -t1023 -b ipt:192.168.0.115) sehe ich viele Send/Recv, aber in/aus Richtung FHEM leider tot....

Offline wagenkna

  • New Member
  • *
  • Beiträge: 30
Antw:Tul lässt sich nicht definieren??
« Antwort #22 am: 05 Februar 2017, 14:52:53 »
Hallo allerseits,

ich bin schon mal wieder weiter gekommen...

Device angelegt..
KNX
   
Initialized
Internals
AckLineDef
   
Clients
   
:KNX:EIB:
DEF    
EIBD:192.168.XXX.XXX 1.0.1  ==> IP vom Raspi
DeviceAddress
   
1001
DeviceName
   
EIBD:192.168.XXX.XXX
NAME
   
KNX
NR
   
2
PARTIAL
   
STATE
   
Initialized
TYPE
   
TUL


Im fhem bekomme ich die Fehler Meldung

TUL opening KNX device EIBD:192.168.XXX.XXX
2017.02.05 14:45:00 1: EIBD:192.168.XXX.XXX protocol is not supported
2017.02.05 14:45:00 3: TUL device opened

Wie bekomme ich das Protokoll zum laufen? Fhem ist auf dem neuesten Stand..

Auf dem Raspi   läuft knxd..

● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2017-02-05 13:50:34 CET; 41min ago
 Main PID: 1010 (knxd)
   CGroup: /system.slice/knxd.service
           └─1010 /usr/bin/knxd -e 1.0.1 -b ipt:192.168.XXX.XXX

Ich bekomme aber bei groupwrite mit dem knxtool, die Meldung

 $ knxtool groupswrite local: 2/1/10 0
Connect failed: Connection reset by peer

Kann jemand helfen?

Danke & schönes We....


Homematic mit CCU2, Fensterkontakt, Thermostaten, Steckdosen, Regen.-Bewegung.-Wassermelder (76) Devices)
Raspberry2 und 3 Mit KNX, OWL, Fritzbox, Unifi, Luftmessungmodul

Offline makro123

  • New Member
  • *
  • Beiträge: 4
Antw:Tul lässt sich nicht definieren??
« Antwort #23 am: 05 Februar 2017, 18:19:43 »
Hallo,
hatte dieselben Probleme wie hier beschrieben.

Habe nun die v0.10 von knxd installiert nach dieser Anleitung:
https://github.com/knxd/knxd/blob/v0.10/README.md
Mit dieser funktioniert es auf Anhieb.
Weder mit v0.12 oder v0.13 konnte ich eine Verbindung von FHEM zum Bus erstellen.

Gruß
Manuel
Informativ Informativ x 1 Liste anzeigen

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #24 am: 05 Februar 2017, 20:50:23 »
Hallo

hab heute nochmal komplett neu aufgesetzt und versucht das Pfadproblem zu rekonstruieren, was mir leider nicht gelungen ist - vermutlich weil inzwischen knxd v 13 installiert wird.
Was nicht so schlimm ist, da ich dann dank makro123 knxd v10 installiert habe und siehe da es geht.
 

Hier noch mal Schritt für Schritt.

RASPBIAN JESSIE LITE, Version:January 2017, Kernel version:4.4
hab ich mit win32diskImager auf ne 16 Gb Sd kopiert


Am Pi über

sudo raspi-config
"Expand Filesystem" und "Advanced Options" "A4 SSH" eingeschaltet
Reboot
ab jetz per SSH

sudo dpkg-reconfigure tzdata
"Europe"und "Berlin"

sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y autoremove && sudo reboot
wget -qO - https://debian.fhem.de/archive.key | sudo apt-key add - && echo "deb https://debian.fhem.de/stable ./" |
 sudo tee -a /etc/apt/sources.list && sudo apt-get -y install apt-transport-https && sudo apt-get update && sudo apt-get -y install fhem
sudo apt-get install debhelper cdbs automake libtool libusb-1.0-0-dev git-core build-essential libsystemd-daemon-dev dh-systemd libev-dev
git clone https://github.com/knxd/knxd.git
wget https://www.auto.tuwien.ac.at/~mkoegler/pth/pthsem_2.0.8.tar.gz
tar xzf pthsem_2.0.8.tar.gz
cd pthsem-2.0.8
dpkg-buildpackage -b -uc
cd ..
sudo dpkg -i libpthsem*.deb
cd knxd
git checkout v0.10 ## this branchdpkg-buildpackage -b -uccd ..sudo dpkg -i knxd_*.deb knxd-tools_*.debsudo nano /etc/knxd.conf

KNXD_OPTS="-e 1.0.240  -b ipt:192.168.5.15"

In Fhem

define KNX TUL knxd:127.0.0.1 1.0.240
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline kalleknx

  • New Member
  • *
  • Beiträge: 9
Antw:Tul lässt sich nicht definieren??
« Antwort #25 am: 05 Februar 2017, 21:05:47 »
Hallo,
hatte dieselben Probleme wie hier beschrieben.

Habe nun die v0.10 von knxd installiert nach dieser Anleitung:
https://github.com/knxd/knxd/blob/v0.10/README.md
Mit dieser funktioniert es auf Anhieb.
Weder mit v0.12 oder v0.13 konnte ich eine Verbindung von FHEM zum Bus erstellen.

Gruß
Manuel


Vielen Dank!

Offline mehfmurof

  • Newbie
  • Beiträge: 1
Antw:Tul lässt sich nicht definieren??
« Antwort #26 am: 08 Februar 2017, 16:12:02 »
Hallo allerseits,

ich bin schon mal wieder weiter gekommen...

Device angelegt..
KNX
   
Initialized
Internals
AckLineDef
   
Clients
   
:KNX:EIB:
DEF    
EIBD:192.168.XXX.XXX 1.0.1  ==> IP vom Raspi
DeviceAddress
   
1001
DeviceName
   
EIBD:192.168.XXX.XXX
NAME
   
KNX
NR
   
2
PARTIAL
   
STATE
   
Initialized
TYPE
   
TUL


Im fhem bekomme ich die Fehler Meldung

TUL opening KNX device EIBD:192.168.XXX.XXX
2017.02.05 14:45:00 1: EIBD:192.168.XXX.XXX protocol is not supported
2017.02.05 14:45:00 3: TUL device opened

Wie bekomme ich das Protokoll zum laufen? Fhem ist auf dem neuesten Stand..

Auf dem Raspi   läuft knxd..

● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since So 2017-02-05 13:50:34 CET; 41min ago
 Main PID: 1010 (knxd)
   CGroup: /system.slice/knxd.service
           └─1010 /usr/bin/knxd -e 1.0.1 -b ipt:192.168.XXX.XXX

Ich bekomme aber bei groupwrite mit dem knxtool, die Meldung

 $ knxtool groupswrite local: 2/1/10 0
Connect failed: Connection reset by peer

Kann jemand helfen?

Danke & schönes We....

diese zeile in 00_TUL.pm von FHEM suchen und "eibd" durch "knxd" ersetzen: ich verwende übrigens knxd version 0.13.0 mit #KNXD_OPTS="-t1023 -e 1.1.250 -E 1.1.251:8 -DTRS -c -B single -b ipt:(ip vom knx-server)"
if($dev =~ m/^(knxd):(.+)$/) { # eibd:host[:port]
neustart fhem

Offline SebastianN

  • New Member
  • *
  • Beiträge: 17
Antw:Tul lässt sich nicht definieren??
« Antwort #27 am: 09 Februar 2017, 10:30:28 »
Hallo  mehfmurof

Probier doch mal die knxd Version 0.10.0 mit der sollte es gehen.

Zitat
ich verwende übrigens knxd version 0.13.0 mit #KNXD_OPTS="-t1023 -e 1.1.250 -E 1.1.251:8 -DTRS -c -B single -b ipt:(ip vom knx-server)"

bei mir läuft es mit KNXD_OPTS="-e 1.0.240  -b ipt:(ip vom knx-Ip Interface) "
 

Offline IROC_KNX

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Tul lässt sich nicht definieren??
« Antwort #28 am: 09 Februar 2017, 17:44:30 »
Hallo,

weil ich mein System von eibd auf knxd umstellen wollte, hatte ich es heute komplett neu aufgesetzt.
Das definieren der KNX Schnittstelle ist nicht möglich. Als Antwortmeldung kommt in FHEM nur eine "1".

knxd Version: 0.13.0

knxd Status "active (running)
/usr/bin/knxd -e 1.1.1 -b ipt:192.168.0.(ABB IP Gateway)

In FHEM hatte ich dann immer wieder probiert folgendes einzugeben:
define KNX TUL knxd:192.168.0.(Raspberry IP) 1.1.1

Klappt das generell nicht mit der neusten knxd Version?

FHEM 5.8 auf RaspberryPi mit knxd

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #29 am: 09 Februar 2017, 19:12:58 »
Setze Verbose = 5, starte neu und poste mal ein Log.

Meine Glaskugel ist grad beim Reinigen :-)

Grüße, Andi