Autor Thema: Tul lässt sich nicht definieren??  (Gelesen 3937 mal)

Offline IROC_KNX

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Tul lässt sich nicht definieren??
« Antwort #30 am: 09 Februar 2017, 19:24:37 »
Hallo Andi,
hier mein Log

2017.02.09 19:22:28 5: Cmd: >define KNX TUL knxd:192.168.0.X 1.1.1<
2017.02.09 19:22:28 5: Loading ./FHEM/00_TUL.pm
2017.02.09 19:22:28 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.02.09 19:22:28 3: TUL opening KNX device knxd:192.168.0.X
2017.02.09 19:22:28 3: TUL device opened
2017.02.09 19:22:28 5: sendRequest: 0026000000

2017.02.09 19:22:28 5: Received packet: 0004

openGroupSocket failed
2017.02.09 19:22:28 1: Cannot init knxd:192.168.0.X, ignoring it
2017.02.09 19:22:28 1: define KNX TUL knxd:192.168.0.X 1.1.1: 1
2017.02.09 19:22:28 4: name: /fhem&fw_id=24&cmd=define+KNX+TUL+knxd%3A192.168.0.X+1.1.1 / RL:1099 / text/html; charset=UTF-8 / Content-Encoding: gzip

Als Schnittstelle ist eine ABB IPS/S 2.1 verbaut.
Wie gesagt, gestern mit eibd lief alles noch problemlos.
in meiner alten FHEM Config stand:
define EIB TUL eibd:192.168.0.X 1.1.1
attr EIB useEIB 1

« Letzte Änderung: 09 Februar 2017, 19:28:14 von IROC_KNX »
FHEM 5.8 auf RaspberryPi mit knxd

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #31 am: 09 Februar 2017, 20:16:09 »
OK - der Reihe nach. Am FHEM liegst wahrscheinlich nicht. Schau erstmal, dass Dein knxd sauber läuft. Dazu am besten groupswrite oder so benutzen.

Ich nutze folgende Parameter:

-e=1.1.251 -c -u /tmp/knx -i -b ipt:192.168.XXX.XXX

Offline IROC_KNX

  • Jr. Member
  • **
  • Beiträge: 57
Antw:Tul lässt sich nicht definieren??
« Antwort #32 am: 09 Februar 2017, 20:37:32 »
OK - der Reihe nach. Am FHEM liegst wahrscheinlich nicht. Schau erstmal, dass Dein knxd sauber läuft. Dazu am besten groupswrite oder so benutzen.

Ich nutze folgende Parameter:

-e=1.1.251 -c -u /tmp/knx -i -b ipt:192.168.XXX.XXX

Du hast recht, mit groupswrite kann ich kein Licht schalten.
Wenn ich deinen Befehl eingebe, kommt allerdings eine Fehlermeldung.
Folgendes stand in der alten eibd:
DAEMON_ARGS="-D -T -S -d -i --eibaddr=1.1.1 --daemon=/var/log/eibd.log --no-tunnel-client-queuing ipt:192.168.0.X"
« Letzte Änderung: 09 Februar 2017, 20:43:34 von IROC_KNX »
FHEM 5.8 auf RaspberryPi mit knxd

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #33 am: 11 Februar 2017, 19:11:22 »
Dann klicker Dich bitte mal durch die anderen Threads und bring den knxd sauber zum Laufen.
Dann kümmern wir uns um die Definition im FHEM...

Grüße, Andi

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #34 am: 26 Juli 2017, 13:55:55 »
Hallo zusammen,

nach einem Problem mit FHEM habe ich nun versucht auf KNXD umzustellen. KNXD läuft offensichtlich:
pi@raspberrypi:~ $ /etc/init.d/knxd status
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Wed 2017-07-26 11:06:45 CEST; 2h 37min ago
 Main PID: 1066 (knxd)
   CGroup: /system.slice/knxd.service
           └─1066 /usr/bin/knxd -e 1.0.240 -c -u /tmp/eib -b ipt:192.168.178....

Die /etc/knxd.conf sieht so aus: KNXD_OPTS="-e 1.0.240 -c -u /tmp/eib -b ipt:192.168.178.30"
START_KNXD=YES

FHEM läuft mittlerweile auch wieder  ;D, allerdings können die beiden sich nicht verständigen! Wenn ich diesen TUL eingebe:
define KNX TUL knxd:192.168.178.30 1.0.240 erscheint nach der Bestätigung lediglich eine 1.

Anbei mein Logfile nach Reboot.

Für Eure Hilfe wäre ich sehr dankbar!

VG Marc
« Letzte Änderung: 26 Juli 2017, 14:16:01 von dauma »

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #35 am: 26 Juli 2017, 19:00:18 »
So, nun habe ich parallel auf einer zweiten Karte eibd installiert. Die Installation lief komplett fehlerfrei durch, allerdings bekomme ich beim starten folgende Fehlermeldung:
pi@raspberrypi:~ $ eibd -t 1023 -S -D -R -T -i --no-tunnel-client-queuing ipt:192.168.178.30
Segmentation fault

Vielleicht hat hierzu jemand eine Idee. Die andere Lösung würde mir zwar besser gefallen, aber wie es so ist in der Not!  :-\

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #36 am: 26 Juli 2017, 20:27:51 »
Öhm...Da hast DU irgendwie Käse gemacht...

Wenn die 192.168.178.30 die IP-Adresse Deines KNX-Gateways ist, dann gebe diese bitte nicht in der fhem.cfg an. Hier muss "localhost" oder die IP-Adresse des KNXD-Gerätes rein.

Hast Du geschaut, ob groupswrite... funktioniert?

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #37 am: 26 Juli 2017, 20:45:27 »
Ich glaube mir ist das zu hoch! :(
Ich bastele schon seit Stunden und mir fehlt irgendwie das Verständnis, oder die richtige Erklärung auf einer der zwanzig Webseiten die ich parallel auf habe.
Aktueller Stand ist wie folgt:
pi@raspberrypi:~ $ systemctl status knxd.service
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Wed 2017-07-26 20:35:52 CEST; 2min 50s ago
 Main PID: 1069 (knxd)
   CGroup: /system.slice/knxd.service
           └─1069 /usr/bin/knxd -e 1.1.255 -b ist:192.168.178.30
Groupswrite habe ich zwar gelesen, aber nicht verstanden (Frage ich mich wie ich das bisher alles habe programmieren können)!
Das mit den IP-Adressen hatte ich auch schon auf dem Schirm, aber leider nicht geblickt welche welche ist und wohin sie muss. Auch die 1.1.255 habe ich nicht verstanden. :(

Anbei noch der aktuelle Logfile!

Sagt Bescheid, wenn ich ein hoffnungsloser Fall bin!

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #38 am: 26 Juli 2017, 20:55:56 »
Groupswrite z.b. hier:
https://forum.fhem.de/index.php/topic,65396.msg569082.html#msg569082

Wie ist nun die IP Deines KNX-GW's? 192.168.178.30?

Wen dem so ist - dann nochmals die Bitte, Deine TUL-config entpsrehcend ändern:
KNX myTUL knxd:localhost 1.1.254

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #39 am: 26 Juli 2017, 21:17:08 »
Hier der Logfile nach der Änderung:
2017.07.26 21:13:09 3: TUL opening KNX device knxd:localhost
2017.07.26 21:13:09 3: TUL device opened
openGroupSocket failed
2017.07.26 21:13:09 1: Cannot init knxd:localhost, ignoring it
2017.07.26 21:13:09 1: define KNX TUL knxd:localhost 1.1.254: 1
2017.07.26 21:13:09 1: Including ./log/fhem.save
2017.07.26 21:13:19 0: Server shutdown
2017.07.26 21:13:21 1: Including fhem.cfg
2017.07.26 21:13:21 3: telnetPort: port 7072 opened
2017.07.26 21:13:22 3: WEB: port 8083 opened
2017.07.26 21:13:22 3: WEBphone: port 8084 opened
2017.07.26 21:13:22 3: WEBtablet: port 8085 opened
2017.07.26 21:13:22 2: eventTypes: loaded 1 events from ./log/eventTypes.txt
2017.07.26 21:13:22 0: Using EIB is deprecated. Please migrate to KNX soon. Module 10_EIB is not maintained any longer. If you still want to use the module EIB,
   please set the attribute useEIB to 1 within the tul-device. Please keep in mind, that 10_KNX has a changed syntax regarding the definition, arguments and readings. Please refer to the commandref.
   As well 10_EIB and 10_KNX are compatible to daemon eibd and knxd.
2017.07.26 21:13:22 3: TUL opening KNX device knxd:localhost
2017.07.26 21:13:22 3: TUL device opened
openGroupSocket failed
2017.07.26 21:13:22 1: Cannot init knxd:localhost, ignoring it
2017.07.26 21:13:22 1: define KNX TUL knxd:localhost 1.1.254: 1
2017.07.26 21:13:22 1: Including ./log/fhem.save
2017.07.26 21:13:22 1: configfile: 1

2017.07.26 21:13:22 2: Messages collected while initializing FHEM: configfile: 1
2017.07.26 21:13:22 0: Featurelevel: 5.8
2017.07.26 21:13:22 0: Server started with 8 defined entities (fhem.pl:14634/2017-07-03 perl:5.020002 os:linux user:fhem pid:1171)

Groupswrite war leider auch negativ: Connection reset by peer

Die 192.168.178.30 ist die IP des Gateway, welche ich bisher auch erfolgreich mit eibd nutze und die ..27 die des RPI.

KNXD_OPTS="-e 1.1.255 -b ipt:192.168.178.30"
« Letzte Änderung: 26 Juli 2017, 21:19:28 von dauma »

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #40 am: 26 Juli 2017, 21:26:43 »
Naja, wir nähern uns doch.

Wenn groupswrite nicht tut, tut der knxd noch nicht. Also fhem erstmal abschalten und liegenlassen. Damit kannst wieder anfangen, wenn groupswrite was tut...

Mein Tip:
ALLE laufenden Prozesse stoppen:

- sudo systemctl stop knxd.socket
- sudo systemctl stop knxd.service
- mit ps -ef | grep alle ggf. vorhandenen Reste finden und mit kill killen...
- in einer eigenen Putty-Instanz mal klein anfangen: sudo knxd -c -b ipt:192.168.178.30
- in einer weiteren Putty-Instanz per groupswrite probieren...

Erst wenn das läuft, machst Du mit systemd und fhem weiter...

Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #41 am: 26 Juli 2017, 21:32:56 »
Wenn Du das sagst! :/

pi@raspberrypi:~ $ sudo nano /etc/knxd.conf
pi@raspberrypi:~ $ sudo systemctl stop knxd.socket
pi@raspberrypi:~ $ sudo systemctl stop knxd.service
pi@raspberrypi:~ $ ps -ef | grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
pi@raspberrypi:~ $ sudo knxd -c -b ipt:192.168.178.30
knxd requires a bus address (option -e)!
pi@raspberrypi:~ $ sudo knxd -c -b -e ipt:192.168.178.30
knxd requires a bus address (option -e)!
pi@raspberrypi:~ $ knxtool groupswrite local: 2/1/5 0
Open failed: Connection refused
pi@raspberrypi:~ $


Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #42 am: 26 Juli 2017, 21:36:16 »
 a bisserl mitspielen und meine Fehler ausbügeln musst schon :-)

sudo systemctl stop knxd.socket
sudo systemctl stop knxd.service
ps -ef | grep knx

Müsste leer sein...

sudo knxd -e 1.0.200 -c -b ipt:192.168.178.30


Offline dauma

  • New Member
  • *
  • Beiträge: 18
Antw:Tul lässt sich nicht definieren??
« Antwort #43 am: 26 Juli 2017, 21:41:15 »
Glaub mir, bin froh um jede Hilfe und versuche mein Bestes!
Konnte kein Fehler entdecken! ;)

pi@raspberrypi:~ $ sudo systemctl stop knxd.socket
pi@raspberrypi:~ $ sudo systemctl stop knxd.service
pi@raspberrypi:~ $ ps -ef | grep knx
pi        1277  1150  0 21:39 pts/1    00:00:00 grep --color=auto knx
pi@raspberrypi:~ $ sudo knxd -e 1.0.200 -c -b ipt:192.168.178.30
I only have one interface. Nothing to do. Giving up.

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 886
Antw:Tul lässt sich nicht definieren??
« Antwort #44 am: 26 Juli 2017, 21:49:29 »
OK - wir nähern uns. Dir fehlen die Sockets...

sudo knxd -e 1.0.200 -c -u /tmp/eib -b ipt:192.168.178.30

oder

sudo knxd -e 1.0.200 -c -u /run/eib -b ipt:192.168.178.30

oder

sudo knxd -e 1.0.200 -c -u /run/knx -b ipt:192.168.178.30

 

decade-submarginal