Autor Thema: [gelöst] FHEM startet nicht mehr nach DSM Update, bitte um Unterstützung  (Gelesen 2611 mal)

Offline FhemOnSynology

  • New Member
  • *
  • Beiträge: 32
Mein Workflow:

Folgende Pakete installieren:
  • Easy Bootstrap Installer von QTip, Version 0.4-034

Ich versuche nach einem Update auf DSM 6.1 ebenfalls meine FHEM Installation zu "reparieren", bin aber bisher gescheitert.
Wählst Du optware oder entware bei der Installation von Bootstrap aus?[/list]
HW: Synology DS212+, Aeon Labs Z-Wave USB-Stick 2, 3x Fibaro FGWPE wall plugs, 3x Everspring ST814 multilevel sensors, 1x Fibaro FGSS-001 smoke sensor.
SW: Synology DSM 4.3, fhem 5.5 (OpenSSL, Perl 5.16.0 und fhem 5.3 Pakete von Fischer-Net.de installiert und dann über fhem aktualisiert).

Offline FhemOnSynology

  • New Member
  • *
  • Beiträge: 32
Ich habe FHEM mittlerweile wieder zum Laufen gebracht. Habe beim Easy Bootstrap Installer "entware" ausgewählt und danach Active Perl installiert.

Ein Problem habe ich aber: Bei der Installation des FHEM Paketes habe ich ein Passwort angegeben. FHEM läuft daher nicht unter root sondern mit dem Benutzer "fhem".
Damit hat FHEM aber keinen Zugriff auf den USB Stick (/dev/ttyUSB0), der unter root läuft.
Temporär kann ich dem ttyUSB0 mit chown fhem:users die "richtigen" Rechte geben. Dann funktioniert der Zugriff. Leider nur bis zum nächsten Neustart der DS.
Wie kann ich das dauerhaft beheben?
HW: Synology DS212+, Aeon Labs Z-Wave USB-Stick 2, 3x Fibaro FGWPE wall plugs, 3x Everspring ST814 multilevel sensors, 1x Fibaro FGSS-001 smoke sensor.
SW: Synology DSM 4.3, fhem 5.5 (OpenSSL, Perl 5.16.0 und fhem 5.3 Pakete von Fischer-Net.de installiert und dann über fhem aktualisiert).