Autor Thema: [82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS  (Gelesen 173526 mal)

Offline mi.ke

  • Sr. Member
  • ****
  • Beiträge: 798
  • JASPER (powered by FHEM)
    • J.A.S.P.E.R. --> Just A Smart Perl Engineered Roomie
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1230 am: 29 April 2021, 12:52:35 »
Kannst Du bitte einmal die neue Version testen

https://git.cooltux.net/FHEM/mod-LGTV_WebOS/raw/branch/devel/82_LGTV_WebOS.pm

In Deiner neuen Version sind alle vermisste APPs in die launchApp Liste eingebaut.

Danke schön.

Soll ich noch mehr testen?

Ich gestehe, dass ich das Modul bis dato immer automatisch nach ausschalten des TV disabled habe, weil es bei mir bis zu >500 sec langen hängern kam. FHEMWEB war dann nicht mehr zu erreichen. Einschalten kann ich den TV über IR, dann disable 0 und alles ist gut. Kein einziger blocker mehr. Ich kann damit sehr gut leben.

Habe hier im Thread gelesen, dass Du die Blocking-Problematik bereits im Modul verbessert hast. Ob der Fehler in der neuen Version nicht mehr auftritt, kann ich mir aber erst heute abend anschauen, Mittagspause ist gleich vorbei.

Aber erstmal Danke für's verbessern des bereits Guten.

cheers
mi.ke

PS.
war nicht heute Abend der Workshop?
FHEM 5.9 | RPi4 + 5 x RPi(Z) + FB7590 + FB 6890 LTE via LAN und WAN (VPN) verbunden.
2 x CUL868 + 3 x RFXTRX(e) + 4 x HMwLanGW + 4 x z2tGw + 3 x LGW + IRBlast + CO2 +++
FS20, FHT, FMS, Elro(mod), CM160, Revolt, LGTV, STV, AVR, withings, HM-sec-*, HM-CC-RT-DN, AMAD, PCA301, arlo, Aqara

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 27037
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1231 am: 29 April 2021, 13:29:55 »
Na dann schauen wir mal.

Heute Abend ist Stammtisch Onlinetreffen. Alle sind eingeladen.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://www.paypal.com/paypalme/MOldenburg
My FHEM Git: https://git.cooltux.net/FHEM/
Mein Dokuwiki:
https://www.cooltux.net

Offline Invers

  • Hero Member
  • *****
  • Beiträge: 2081
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1232 am: 03 September 2021, 19:19:35 »
Ich hänge mich hier mal mit rein.
Seit vermutlich vorgestern (Log leider gelöscht) bekomme ich den Fehler:
2021.09.03 19:08:57 1: Timeout for LGTV_WebOS_PresenceRun reached, terminated process 1879
wobei sich process Nummer ändert.
Ich vermute, dass der Fehler seit dem Update der Firmware des TV kommt.
Kann man da etwas tun?
Vielleicht kann ich einige Zeilen im Modul löschen? Ich nutze es nur zum Ein- und Ausschalten des TV und zum Senderwechsel.
Internals:
   DEF        192.168.178.61
   FUUID      5f5f5511-f33f-8098-a0ce-efe05b5b89b04fe1
   FVERSION   82_LGTV_WebOS.pm:v3.2.4-s22008/2020-05-22
   HOST       192.168.178.61
   LAST_RECV  1630688206.34683
   NAME       meinLGTV
   NR         421
   PARTIAL   
   STATE      off
   TYPE       LGTV_WebOS
   VERSION    v3.2.4
   READINGS:
     2021-09-03 18:57:48   channel         -
     2020-09-14 15:23:03   channelCurrentEndTime -
     2020-09-14 15:23:03   channelCurrentStartTime -
     2020-09-14 15:23:03   channelCurrentTitle -
     2021-09-03 18:57:48   channelMedia    -
     2021-09-03 18:57:48   channelName     -
     2020-09-14 15:23:03   channelNextEndTime -
     2020-09-14 15:23:03   channelNextStartTime -
     2020-09-14 15:23:03   channelNextTitle -
     2021-09-02 21:30:22   extInput_HDMI   1 connect_0
     2021-09-03 18:56:06   extInput_HDMI 1 connect_0
     2021-09-03 18:56:06   extInput_HDMI 2 connect_1
     2021-09-03 18:56:06   extInput_HDMI 3 connect_0
     2021-09-03 18:56:06   extInput_HDMI 4 connect_0
     2020-09-14 13:34:51   input           -
     2021-09-03 18:57:26   lastResponse    ok
     2021-09-03 14:15:30   launchApp       TV
     2020-09-14 13:34:47   lgKey           c77c01ca9053b58a029a90f5baff896a
     2021-09-03 08:00:23   mute            off
     2020-09-20 10:30:28   mySchalter      "off"
     2021-09-02 00:03:55   pairing         paired
     2021-09-03 19:12:44   presence        absent
     2020-09-14 14:04:41   service_api     v.1
     2020-09-14 14:04:41   service_audio   v.1
     2020-09-14 14:04:41   service_config  v.1
     2020-09-14 14:04:41   service_externalpq v.1
     2020-09-14 14:04:41   service_media.controls v.1
     2020-09-14 14:04:41   service_media.viewer v.1
     2020-09-14 14:04:41   service_pairing v.1
     2020-09-14 14:04:41   service_settings v.1
     2020-09-14 14:04:41   service_system  v.1
     2020-09-14 14:04:41   service_system.launcher v.1
     2020-09-14 14:04:41   service_system.notifications v.1
     2020-09-14 14:04:41   service_timer   v.1
     2020-09-14 14:04:41   service_tv      v.1
     2020-09-14 14:04:41   service_user    v.1
     2020-09-14 14:04:41   service_webapp  v.2
     2021-09-03 18:57:40   state           off
     2021-09-03 17:55:22   volume          86
   helper:
     wsKey      MTYzMDY4ODE0OC4xMjk5

     RUNNING_PID:
       abortFn    LGTV_WebOS_PresenceAborted
       arg        meinLGTV|192.168.178.61
       bc_pid     118
       finishFn   LGTV_WebOS_PresenceDone
       fn         LGTV_WebOS_PresenceRun
       pid        2139
       telnet     telnetForTvUpdateFn_1630688428_127.0.0.1_53396
       timeout    5
       abortArg:
     device:
       registered 1
       runsetcmd  0
       channelguide:
         counter    79
       inputapps:
         com.webos.app.hdmi1 HDMI 1
         com.webos.app.hdmi2 HDMI 2
         com.webos.app.hdmi3 HDMI 3
         com.webos.app.hdmi4 HDMI 4
       inputs:
         HDMI 1     com.webos.app.hdmi1
         HDMI 2     com.webos.app.hdmi2
         HDMI 3     com.webos.app.hdmi3
         HDMI 4     com.webos.app.hdmi4
Attributes:
   comment    myOnOffIcon
   devStateIcon on:it_television@lime:off off:it_television@LightSkyBlue:on

   pingPresence 1
   room       Andere->Fernsehen
   wakeOnLanMAC 58:FD:B1:60:EA:5C

Ich kann bei Bedarf auch mal verbose 4 oder 5 testen.

Eine Lösung wäre toll, weil ich dadurch Timingprobleme mit HM bekomme:
2021.09.03 19:08:50 3: Setting myHmUART serial parameters to 115200,8,N,1
2021.09.03 19:08:50 1: /dev/ttyAMA0 reappeared (myHmUART)

Danke im Voraus.




EDIT:
Ich vermute, es hat sich erledigt. Mein halbes fhem ist abgeraucht. erstmal sehen, was passiert ist. Melde mich bei Bedarf noch einmal. Danke.
« Letzte Änderung: 03 September 2021, 22:59:08 von Invers »
Pi3B Buster | F.-Box 7490 | CUL433 | CUL868 | SDuino + Siro | HM-LAN | 12 x Dect200  | 3 x Heizung FHT + FKont. | KeyMatic + 4 FB | HM Wandtaster 2-fach m. LED | 6 x TKont. TFK-TI | HM-Bew.-Melder aussen + innen | 3 x Smoked. HM-SEC-SD-2

Offline locodriver

  • Full Member
  • ***
  • Beiträge: 460
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1233 am: 04 Oktober 2021, 10:41:30 »
Hallo!

Seit Kurzem habe ich einen OLED 65C17LB. Darauf ist die Sw 03.15.95 installiert mit webOS 6.1.0-43.

Ich habe den TV in fhem angelegt und kann ihn ausschalten, das einschalten funzt leider nicht.

Folgende Einstellungen habe ich vorgenommen: WOL ist im Router aus, Stat. IP ist vergeben, Quick Start+ ist aus, SIMPLINK aus, LAN IPv6 ein.

Hier das List:

Internals:
   CFGFN     
   DEF        192.168.178.35
   FUUID      615870ee-f33f-b425-4180-2d6897a730747f29
   FVERSION   82_LGTV_WebOS.pm:v3.2.4-s22008/2020-05-22
   HOST       192.168.178.35
   NAME       Fernseher
   NR         102177
   PARTIAL   
   STATE      Aus
   TYPE       LGTV_WebOS
   VERSION    v3.2.4
   READINGS:
     2021-10-02 16:47:10   channel         -
     2021-10-02 16:47:10   channelCurrentEndTime -
     2021-10-02 16:47:10   channelCurrentStartTime -
     2021-10-02 16:47:10   channelCurrentTitle -
     2021-10-02 16:47:10   channelMedia    -
     2021-10-02 16:47:10   channelName     -
     2021-10-02 16:47:10   channelNextEndTime -
     2021-10-02 16:47:10   channelNextStartTime -
     2021-10-02 16:47:10   channelNextTitle -
     2021-10-02 16:55:24   extInput_HDMI 1 connect_0
     2021-10-02 16:55:24   extInput_HDMI 2 connect_1
     2021-10-02 16:55:24   extInput_HDMI 3 connect_0
     2021-10-02 16:55:24   extInput_HDMI 4 connect_0
     2021-10-03 23:34:39   extInput_RX-V473 connect_1
     2021-10-04 10:16:42   input           RX-V473
     2021-10-04 10:19:06   lastResponse    ok
     2021-10-04 10:16:42   launchApp       -
     2021-10-02 16:55:11   lgKey           zzzzzzzzzzzzzzzzzzzzzz
     2021-10-02 16:55:16   mute            off
     2021-10-04 10:12:27   pairing         paired
     2021-10-04 10:35:08   state           off
     2021-10-04 00:28:43   volume          9
   helper:
     wsKey      yyyyyyyyyyyyyyyyyy

     device:
       registered 1
       runsetcmd  0
       channelguide:
         counter    14826
       inputapps:
         com.webos.app.hdmi1 HDMI 1
         com.webos.app.hdmi2 RX-V473
         com.webos.app.hdmi3 HDMI 3
         com.webos.app.hdmi4 HDMI 4
       inputs:
         HDMI 1     com.webos.app.hdmi1
         HDMI 2     com.webos.app.hdmi2
         HDMI 3     com.webos.app.hdmi3
         HDMI 4     com.webos.app.hdmi4
         RX-V473    com.webos.app.hdmi2
Attributes:
   devStateIcon on:10px-kreis-gruen:off off:10px-kreis-rot:on
   eventMap   on:Ein off:Aus
   room       070Audio/Video
   wakeOnLanBroadcast 192.168.178.255
   wakeOnLanMAC xxxxxxxxxxxx

Den Einbefehl setze ich mit: "set Fernseher Ein" ab...

Wie komme ich dem Fehler auf den Grund bzw. habe ich etwas übersehen oder falsch eingestellt?

Falls noch Infos fehlen bitte fragen.

Vielen Dank.
fhem 5.9 auf Rpi3 Buster
HM-LAN-CFG (FW 0.961)
2x HM-TC-IT-WM-W-EU mit je 1x HM-Sec-RHS und 1x/2x HM-CC-RT-DN
6x HM-LC-Bl1-FM mit je 1x Somfy-Motor
2x HM-LC-SW2-FM für Licht und Lüfter, 2x HM-PB-6-WM55

Offline Invers

  • Hero Member
  • *****
  • Beiträge: 2081
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1234 am: 04 Oktober 2021, 15:24:25 »
Ich denke, WOL muss im Router ein. MAC muss in fhem eingetragen sein.
Pi3B Buster | F.-Box 7490 | CUL433 | CUL868 | SDuino + Siro | HM-LAN | 12 x Dect200  | 3 x Heizung FHT + FKont. | KeyMatic + 4 FB | HM Wandtaster 2-fach m. LED | 6 x TKont. TFK-TI | HM-Bew.-Melder aussen + innen | 3 x Smoked. HM-SEC-SD-2

Offline Ellert

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3741
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1235 am: 04 Oktober 2021, 15:59:43 »
Der Fernseher muss so eingestellt werden, dass die Netzwerk-Schnittstelle im Aus-Zustand aktiv bleibt.

Offline locodriver

  • Full Member
  • ***
  • Beiträge: 460
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1236 am: 04 Oktober 2021, 16:39:17 »
Der Fernseher muss so eingestellt werden, dass die Netzwerk-Schnittstelle im Aus-Zustand aktiv bleibt.

Welche Einstellung meinst du damit?

Ich denke, WOL muss im Router ein. MAC muss in fhem eingetragen sein.

WOL werde ich aktivieren, die MAC steht doch im Attribut "Wake on LAN MAC" - oder gibt es noch eine andere Stelle, MAC einzutragen?
fhem 5.9 auf Rpi3 Buster
HM-LAN-CFG (FW 0.961)
2x HM-TC-IT-WM-W-EU mit je 1x HM-Sec-RHS und 1x/2x HM-CC-RT-DN
6x HM-LC-Bl1-FM mit je 1x Somfy-Motor
2x HM-LC-SW2-FM für Licht und Lüfter, 2x HM-PB-6-WM55

Offline Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19508
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1237 am: 04 Oktober 2021, 20:57:31 »
WOL im Router?  ::) was hat das mit dem Modul und dem Fernseher zu tun?
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline Invers

  • Hero Member
  • *****
  • Beiträge: 2081
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1238 am: 05 Oktober 2021, 10:58:38 »
bei der Fritzbox:
https://avm.de/service/wissensdatenbank/dok/FRITZ-Box-7590/36_Netzwerkgerat-uber-das-Internet-starten-Wake-on-LAN/

Bei mir ging es auch intern nicht ohne Aktivierung

Mac war icht zu sehen. Ich war mir nicht sicher, ob du die gext hast.
« Letzte Änderung: 05 Oktober 2021, 11:00:16 von Invers »
Pi3B Buster | F.-Box 7490 | CUL433 | CUL868 | SDuino + Siro | HM-LAN | 12 x Dect200  | 3 x Heizung FHT + FKont. | KeyMatic + 4 FB | HM Wandtaster 2-fach m. LED | 6 x TKont. TFK-TI | HM-Bew.-Melder aussen + innen | 3 x Smoked. HM-SEC-SD-2

Offline Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 19508
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1239 am: 05 Oktober 2021, 11:22:21 »
Du willst den Fernseher über eine öffentliche IP starten?  :o ok, wenn das die Aufgabe ist.
Aber alle Nutzer die einfach im internen Netz arbeiten wollen, werden dadurch nur noch verwirrter. Alle die den Fernseher nicht über das Internet per Wake on Lan starten wollen sollten diesen Beitrag ignorieren! Der einzige sinnvolle Hinwies darin ist: man kann testhalber das Gerät mit WOL mit Hilfe der Fritzbox UI starten!

Allerdings meine ich hier verstanden zu haben, das es bei jedem Fernsehertyp etwas anders ist und WOL nicht in jedem Fall zum Start verwendet wird. Aber da kann ich mich geirrt haben!
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline locodriver

  • Full Member
  • ***
  • Beiträge: 460
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1240 am: 05 Oktober 2021, 11:58:34 »
Es "scheint" zu funzen...

Ich habe die Funktion "TV ein mit Mobilgerät" aktiviert -dies scheint die entscheidente Einstellung zu sein.

Allerdings habe ich im Reading LastResponse immer im Wechsel "ok" für 8 sec. und dann für 2 sec. "error - 404 no such service or method".

IPv6 habe ich übrigens deaktiviert und WOL im Router auch.

Aktuell gibt es eine neue SW: 03.20.16
fhem 5.9 auf Rpi3 Buster
HM-LAN-CFG (FW 0.961)
2x HM-TC-IT-WM-W-EU mit je 1x HM-Sec-RHS und 1x/2x HM-CC-RT-DN
6x HM-LC-Bl1-FM mit je 1x Somfy-Motor
2x HM-LC-SW2-FM für Licht und Lüfter, 2x HM-PB-6-WM55

Offline Invers

  • Hero Member
  • *****
  • Beiträge: 2081
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1241 am: 06 Oktober 2021, 15:11:29 »
Vor einiger Zeit (im letzten Jahr) ging es bei mir nur mit der Aktivierung von WOL in der Fritzbox. Hatte mich auch gewundert. Vielleicht war das auch nur Zufall, oder iein Problem der damaligen Firmware der Fritzbox. Ich habe nun WOL bei mir ebenfalls deaktiviert und es läuft jetzt trotzdem. Damals jedoch definitiv nicht. Kann natürlich sein, dass es bei der vielen Probiererei sowieso gegangen wäre. Ich hatte damals ziemlich mit dem Problem zu kämpfen und die Aktivierung war meiner Meinung nach mein letzter verzweifelter Versuch.

Aber egal, Hauptsache, es läuft nun.
Pi3B Buster | F.-Box 7490 | CUL433 | CUL868 | SDuino + Siro | HM-LAN | 12 x Dect200  | 3 x Heizung FHT + FKont. | KeyMatic + 4 FB | HM Wandtaster 2-fach m. LED | 6 x TKont. TFK-TI | HM-Bew.-Melder aussen + innen | 3 x Smoked. HM-SEC-SD-2

Offline TheRelativ

  • New Member
  • *
  • Beiträge: 20
Antw:[82_LGTV_WebOS.pm] Modul für LG TV's mit WebOS
« Antwort #1242 am: 11 Oktober 2021, 15:42:05 »
Ich habe seit dem Einsatz dieses Moduls ein seltsames Phänomen, vielleicht hat ja jemand ähnliche Erfahrungen gemacht.

Nutze einen LG CX mit WebOS 3

im Device ist WOL als attribut mit MAC Adresse gesetzt.
Ich kann den Fernseher mit dem Modul ein-/aussschalten und die Funktionen gehen auch.

Bei der Nacht und Abwesend Schaltung prüfe ich per Script ob der TV läuft und sende ggf. ein Ausschaltkommando

Nun das Phänomen: Wenn ich den TV kurz vorher per normaler Fernbedienung ausgeschaltet hab und dann so ca. 1-2 Minunten danach die Nachtschaltung aktiviere (bzw. geschieht automatisch) dann schaltet sich der TV warum auch immer wieder ein.

Da mir das einschalten nicht so wichtig ist, habe ich die WOL Config rausgenommen, anschließend das HDMI Kabel zwischen raspberry und TV getrennt (habe auch ein CEC Script womit ich u.a. die PS5 einschalten kann).
und trotz der deaktivierung passiert das immer noch.

Ich kann auch beobachten, dass beim ausschalten via Fernbedieunung, der Fernseher noch 3-4 Minuten in einer Art "Zwischenstatus" ist, in dem er nicht ganz aus ist. Nach dieser Zeit hört man auch ein kleines klicken und dann ist er ganz aus.
Das deckt sich auch ziehmlich damit, dass das LGTV Modul erst dann merkt, dass der Fernseher tatsächlich aus ist.

Mein Verdacht:
Der LG Fernseher interpretiert in dem Zwischenstatus jegliches Netzwerkkommando als Einschaltsignal, also auch der Versuche den bereits ausgeschalteten Fernseher nochmal ein Ausschaltkommando zu senden?!
FHEM @ Raspberry Pi3
868MhZ USB CUL @ Homematic (Thermostate + Heizungssteuerung)
433MhZ USB CUL @ Intertechno + 16-Channel FB zur Steuerung von FHEM Devices
2,4 GhZ nRF24L01+ PA-LAN for mySensors Network (~15 Dev.)
CC2530 USB Zigbee+Zigbee2MQTT (~30 Dev.)