Autor Thema: ESPEasy Modul fehler?  (Gelesen 340 mal)

Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
ESPEasy Modul fehler?
« am: 29 April 2020, 17:30:08 »
Hallo zusammen,

ich habe folgendes definiert:

defmod ESPEasy_Tiefgarage ESPEasy 192.168.175.40 80 espBridge Tiefgarage
attr ESPEasy_Tiefgarage IODev espBridge
attr ESPEasy_Tiefgarage Interval 300
attr ESPEasy_Tiefgarage eventMap /gpio 5 on:on/gpio 5 off:off/
attr ESPEasy_Tiefgarage group ESPEasy
attr ESPEasy_Tiefgarage presenceCheck 1
attr ESPEasy_Tiefgarage readingSwitchText 1
attr ESPEasy_Tiefgarage room ESPEasy
attr ESPEasy_Tiefgarage setState 3
attr ESPEasy_Tiefgarage stateFormat {ReadingsVal($name,"presence","") eq "absent" ? "absent" : ReadingsVal($name,"GPIO 5","")}

Bekomme leider aber immer den state absent und das Relais nicht geschalten. Kann mir jmd. helfen?

Dankke und Grüße
Julian

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3929
Antw:ESPEasy Modul fehler?
« Antwort #1 am: 29 April 2020, 17:42:01 »
Absent kommt wenn das device nicht regelmäsig sendet.
Lass  das relais zykisch den status senden und es kommt kein absent meht.

Zum manuellen schalten felt das attribut setusercmds.
( on => {url=>"/control?cmd=gpio,12,1"}, off => {url=>"/control?cmd=gpio,12,0"} )

Hier ein komplettes espeasy relais:


defmod Licht_Schuppen_klein ESPEasy 192.168.12.201 80 ESPBridge SONOFF_11_Relais
attr Licht_Schuppen_klein IODev ESPBridge
attr Licht_Schuppen_klein Interval 300
attr Licht_Schuppen_klein event-on-change-reading .*
attr Licht_Schuppen_klein presenceCheck 0
attr Licht_Schuppen_klein readingSwitchText 1
attr Licht_Schuppen_klein room_map Rel:on:on|Rel:off:off
attr Licht_Schuppen_klein setState 3
attr Licht_Schuppen_klein stateFormat Relais
attr Licht_Schuppen_klein userSetCmds ( on => {url=>"/control?cmd=gpio,12,1"}, off => {url=>"/control?cmd=gpio,12,0"} )



Gesendet von meinem S68Pro mit Tapatalk
« Letzte Änderung: 29 April 2020, 17:44:34 von Frank_Huber »

Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
Antw:ESPEasy Modul fehler?
« Antwort #2 am: 29 April 2020, 17:47:06 »
Hallo Frank,

danke für die schnelle antwort!

Folgendes:
Lass  das relais zykisch den status senden und es kommt kein absent meht.
--> Wie funktioniert das?

Das Atribut userSetCmds... bringt mir einen Fehler.
Wie genau muss ich dieses eingeben?

{url=>"/control?cmd=gpio,12,1"}

Danke!!
« Letzte Änderung: 29 April 2020, 17:50:58 von Julian.jul »

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3929
Antw:ESPEasy Modul fehler?
« Antwort #3 am: 29 April 2020, 18:10:08 »
Das machst im gerät in espeasy. Delay ist das setting.


attr Licht_Schuppen_klein userSetCmds ( on => {url=>"/control?cmd=gpio,12,1"}, off => {url=>"/control?cmd=gpio,12,0"} )

 Bei dir aber gpio,5


Gesendet von meinem S68Pro mit Tapatalk

Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
Antw:ESPEasy Modul fehler?
« Antwort #4 am: 29 April 2020, 18:15:39 »
Hi Frank,

das delay setting kann ich nirgends finden. - Bin auch ein espeasy Neuling...

das userSetcmds hat nun so funktioniert. Danke Dir.
Jedoch schaltet sich das Relais nicht... im Log kommt allerdings keine Fehlermeldung:
2020.04.29 18:14:18 3: ESPEasy ESPEasy_Tiefgarage: set ESPEasy_Tiefgarage gpio 5 on

Habe ich noch etwas vergessen?

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3929
Antw:ESPEasy Modul fehler?
« Antwort #5 am: 29 April 2020, 18:18:05 »
Zeig mal ein list von deinem device.
Kannst ja dann auch mit meinem vergleichen.
Das delay ist in espeasy. Screenshot. Kann aber je nach version bisl anderst ausehen. (https://uploads.tapatalk-cdn.com/20200429/ff3fb4def4a211c81340d0b43313fa94.jpg)

Gesendet von meinem S68Pro mit Tapatalk


Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
Antw:ESPEasy Modul fehler?
« Antwort #6 am: 29 April 2020, 18:20:17 »
Das Delay bei mir heißt Interval :)
Habe das mal auf 100 gesetzt.

Jedoch bekomme ich das Relais nach wie vor nicht geschalten.

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3929
Antw:ESPEasy Modul fehler?
« Antwort #7 am: 29 April 2020, 18:24:51 »
Dann vergleiche mal alle attribute oder poste ein list.

Gesendet von meinem S68Pro mit Tapatalk


Offline rischbiter123

  • Full Member
  • ***
  • Beiträge: 378
Antw:ESPEasy Modul fehler?
« Antwort #8 am: 29 April 2020, 18:25:47 »
Moin,

nur kurz eingeworfen:

Rules erstellt?

LG

Andreas
4*Raspi, Max Thermostate und Fensterkontakte, FB7590, Mysensors und NanoCUL, IT und Sonoff, zigbee2mqtt2

Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
Antw:ESPEasy Modul fehler?
« Antwort #9 am: 29 April 2020, 18:28:08 »
defmod ESPEasy_Tiefgarage ESPEasy 192.164.164.98 80 espBridge Tiefgarage
attr ESPEasy_Tiefgarage IODev espBridge
attr ESPEasy_Tiefgarage Interval 300
attr ESPEasy_Tiefgarage eventMap /gpio 5 on:on/gpio 5 off:off/
attr ESPEasy_Tiefgarage group ESPEasy
attr ESPEasy_Tiefgarage presenceCheck 1
attr ESPEasy_Tiefgarage readingSwitchText 1
attr ESPEasy_Tiefgarage room ESPEasy
attr ESPEasy_Tiefgarage setState 3
attr ESPEasy_Tiefgarage stateFormat {ReadingsVal($name,"presence","") eq "absent" ? "absent" : ReadingsVal($name,"GPIO 5","")}
attr ESPEasy_Tiefgarage userSetCmds ( on => {url=>"/control?cmd=gpio,5,1"}, off => {url=>"/control?cmd=gpio,5,0"} )



setstate ESPEasy_Tiefgarage absent
setstate ESPEasy_Tiefgarage 2020-04-29 18:23:45 presence absent
setstate ESPEasy_Tiefgarage 2020-04-29 18:23:45 state absent


Oder kann es auch noch daran liegen, dass mein ESPEasy Gerät anders heißt? -Minimal, IR with AC-
« Letzte Änderung: 29 April 2020, 18:31:14 von Julian.jul »

Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
Antw:ESPEasy Modul fehler?
« Antwort #10 am: 29 April 2020, 18:31:44 »
Moin,

nur kurz eingeworfen:

Rules erstellt?

LG

Andreas

Was meinst du damit?

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 3929
Antw:ESPEasy Modul fehler?
« Antwort #11 am: 29 April 2020, 18:52:38 »
Die rules brauchst für den taster am esp.

Welche version espeasy hast du?

Gesendet von meinem S68Pro mit Tapatalk


Offline Julian.jul

  • New Member
  • *
  • Beiträge: 22
Antw:ESPEasy Modul fehler?
« Antwort #12 am: 29 April 2020, 18:58:09 »
Firmware
Build:⋄   20105 - Mega
System Libraries:⋄   ESP82xx Core 3d128e5c, NONOS SDK 2.2.2-dev(38a443e), LWIP: 2.1.2 PUYA support
Git Build:⋄   mega-20200410
Plugin Count:⋄   3 [Normal] [Minimal 1M OTA]
Build Md5:   83c9ada0bc5470e8d13cdd5871116f6
Md5 check:   passed.
Build Time:⋄   Apr 10 2020 19:44:14
Binary Filename:⋄   ESP_Easy_mega-20200410_minimal_core_263_ESP8266_1M_OTA_FHEM_HA.b

Rules habe ich wirklich noch keine. Habe soebend ie Advanced setting aktiviert.
Welche Regeln benötigt man denn?
« Letzte Änderung: 29 April 2020, 19:01:35 von Julian.jul »

 

decade-submarginal