Autor Thema: FHEM mit KNXD über Loxone KNX Ip Gatway  (Gelesen 262 mal)

Offline X-Files

  • New Member
  • *
  • Beiträge: 25
FHEM mit KNXD über Loxone KNX Ip Gatway
« am: 08 Februar 2017, 22:42:36 »
Hi

Habe zwar schon den Beitrag im Anfänger Forum gestellt.
Aber ich glaube das ich mit der Fragestellung hier im KNX Bereich besser aufgehoben bin.


Ich möchte mit Knxd eine Verbidnung zum Loxone Homeserver die IP Gatway aufbauen.
KNXD habe ich erfolgreich installiert auf ein ununto mint system.

Die Status Abfrage:

Feb 08 15:53:16 manfred-Parallels-Virtual-Platform systemd[1]: Starting KNX Daem
Feb 08 15:53:16 manfred-Parallels-Virtual-Platform systemd[1]: Started KNX Daemo
...skipping...
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: ena
   Active: active (running) since Mit 2017-02-08 15:53:16 CET; 31s ago
 Main PID: 2529 (knxd)
   CGroup: /system.slice/knxd.service
           └─2529 /usr/bin/knxd --eibaddr=1.1.251 -b ipt:192.168.XXX.XXX:3671



Laut Support Seite von loxen braucht er das port :3671

Support Auszug:
 Um KNX Geräte von der Ferne umprogrammieren zu können, müssen folgende Port auf den Miniserver weitergeleitet werden: TCP, UDP 3671. In der ETS muss zusätzlich der NAT Modus aktiviert werden.


Aber ich bekomme keine Verbindung zum KNX.

~ $ knxtool groupsocketlisten local:
Connect failed: Connection reset by peer

In weiter folge möchte ich mit der Verbindung den Fhem zum KNX anbinden.
Wäre toll wenn mir da wer weiter helfen könnte.

Danke in vorraus

manfred

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 793
Antw:FHEM mit KNXD über Loxone KNX Ip Gatway
« Antwort #1 am: 09 Februar 2017, 19:10:37 »
Abend!

Probier mal:

--eibaddr=1.1.251 -c -u /tmp/knx -i -b ipt:192.168.XXX.XXX:3671

Grüße, Andi



Offline X-Files

  • New Member
  • *
  • Beiträge: 25
Antw:FHEM mit KNXD über Loxone KNX Ip Gatway
« Antwort #2 am: 10 Februar 2017, 15:22:43 »

Ich habe die knxd 0.13.0:40742d6 version installiert.

Ähnlich nach der Anleitung siehe Link. https://github.com/knxd/knxd

Leider bekomme ich eine Fehler Meldung, wenn ich die Zeile von dir eintrage.
Liegt höchstwahrscheinlich wegen der Neuen Version.
Habe hier Link https://github.com/knxd/knxd/ gelesen.
Dass bei der Neuen version die –i und –u option nicht mehr gebrauch wird.
„If you use Debian Jessie or another systemd-based distribution, /lib/systemd/system/knxd.socket is used to open the "standard" sockets on which knxd listens to clients. You no longer need your old -i or -u options.“
Meine Zeile in der knxd.conf :
KNXD_OPTS=" --eibaddr=1.1.251 - DTRS -b ipt:192.168.XXX.XXX"
Aber leider bekomme ich noch immer keine Verbindung zum KNX bus.

knxtool groupsocketlisten local:
Connect failed: Connection reset by peer

Gruß
Manfred

Offline Andi291

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 793
Antw:FHEM mit KNXD über Loxone KNX Ip Gatway
« Antwort #3 am: 11 Februar 2017, 19:16:06 »
Sorry, da bin ich raus - klingt so, als ob ein Socket nicht verfügbar wäre. Such mal ein wenig im FOrum und schau vielleicht mal mit netstat oder so.
Für eine qualifizierte Analyse fehlen mir leider die Hintergründe...