Autor Thema: FHEM unter Apache zum laufen bekommen...  (Gelesen 200 mal)

Offline xDarKyx

  • New Member
  • *
  • Beiträge: 13
FHEM unter Apache zum laufen bekommen...
« am: 12 Februar 2017, 23:06:06 »
Hallo zusammen,

habe es nach endlosen Stunden endlich geschafft mein fhem ans Netz zu bringen (das SSL Zertifikat hat mir den letzen Nerv geraubt )

Nun geht es aber natürlich gleich weiter mit den Problemen. Wenn ich die Seite aufrufe erfolgt eine endlose Abfrage nach dem favicon.ico

folgendes steht im Access Log von Apache

95.168.135.247 - - [12/Feb/2017:22:58:16 +0100] "GET /favicon.ico HTTP/1.1" 301 675 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:16 +0100] "GET /fhemfavicon.ico HTTP/1.1" 301 683 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:16 +0100] "GET /fhemfhemfavicon.ico HTTP/1.1" 301 691 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:16 +0100] "GET /fhemfhemfhemfavicon.ico HTTP/1.1" 301 699 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:16 +0100] "GET /fhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 707 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 715 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 723 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 731 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 739 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 747 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 755 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 763 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 771 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 779 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 787 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 795 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 803 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 811 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"
95.168.135.247 - - [12/Feb/2017:22:58:17 +0100] "GET /fhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfhemfavicon.ico HTTP/1.1" 301 819 "https://darkyfhem.ddns.net/fhem" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"

Und die Webseite meldet dadurch

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /fhem.

Reason: Error reading from remote server

Mir gehen echt die Ideen aus :(
« Letzte Änderung: 13 Februar 2017, 17:09:06 von xDarKyx »

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 15708
Antw:GET favicon.ico fehlerhaft?
« Antwort #1 am: 13 Februar 2017, 14:05:00 »
Zitat
folgendes steht im Access Log von Apache
Ich gehe davon aus, dass die Apache Konfiguration falsch ist. Da ich nicht weiss, was du auf welchem Weg erreichen willst, kann ich auch nicht helfen, abgesehen davon, dass ich kein Apache-Guru bin, oder dass hier kein Apache Forum ist. Ich verwende fuer die Apache/FHEM Anbindung
ProxyPass        /fhem  http://localhost:8083/fhem
ProxyPassReverse /fhem  http://localhost:8083/fhem
und nicht mehr.

P.S.: Das Betreff ist irrefuehrend.

Offline xDarKyx

  • New Member
  • *
  • Beiträge: 13
Antw:GET favicon.ico fehlerhaft?
« Antwort #2 am: 13 Februar 2017, 16:50:17 »
Bezüglich des Betreffs entschuldige ich mich. Bin bezüglich Linux / WebServer kompletter Neuling. Meine Config sieht in etwa auch so aus wie du sie gepostet hast nur das dass /fhem vor der URL nicht mit dabei steht. Werde es heute Abend mal ausprobieren.

Danke für den Tipp

P.S.: bin nach diesen Tutorial vorgegangen

https://haus-automatisierung.com/hardware/fhem/2016/12/30/fhem-tutorial-reihe-part-21-zugriff-auf-fhem-ueber-das-internet.html

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 15708
Antw:GET favicon.ico fehlerhaft?
« Antwort #3 am: 13 Februar 2017, 16:55:28 »
Zitat
Bezüglich des Betreffs entschuldige ich mich.
Nicht entschuldigen sondern bitte korrigieren :)

Offline xDarKyx

  • New Member
  • *
  • Beiträge: 13
Antw:FHEM unter Apache zum laufen bekommen...
« Antwort #4 am: 13 Februar 2017, 20:16:59 »
Problem vollständig gelöst :)
« Letzte Änderung: 16 Februar 2017, 10:57:23 von xDarKyx »