Autor Thema: FHEM 5.8 freigegeben  (Gelesen 22320 mal)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16618
FHEM 5.8 freigegeben
« am: 19 Februar 2017, 15:21:42 »
Ich habe gerade fhem 5.8 als Paket auf fhem.de hochgeladen, und in fhem.pl featurelevel auf 5.8 gesetzt (update ab morgen).

Aenderungen fuer bisherige Anwender ergeben sich durch featurelevel 5.8, da die folgenden Attribute per Voreinstellung aktiviert sind:

- perlSyntaxCheck: damit werden Perl-Ausdruecke beim Erstellen/Aendern von at/notify/stateFormat/readingsChange/readingsGroup/readingsProxy geprueft, und ggf. eine Fehlermeldung ausgegeben. Bisher erfolgte die Meldung erst beim Ausfuehren dieser Ausdruecke.

- csrfToken: dieses FHEMWEB Attribut verhindert CSRF Angriffe, indem alle FHEMWEB-Aufrufe, die einen FHEM Befehl ausfuehren, das Token spezifizieren muessen.
Fuer Benutzer bedeutet das ein Neuladen der FHEMWEB-Seite in Browser nach jedem FHEM-Neustart.
Fuer (verschlafene) Frontend-Modulentwickler: Der nach jedem FHEMWEB-Start zufaellig generierte Token wird im <body> als Attribut oder im HTTP-Header hinterlegt, und muss als fwcsrf Parameter angegeben werden.
Man kann es aber auch abschalten oder statisch konfigurieren.
Gefällt mir Gefällt mir x 49 Liste anzeigen

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 13174
  • Probleme sind auch keine Lösung.
Antw:FHEM 5.8 freigegeben
« Antwort #1 am: 19 Februar 2017, 17:25:08 »
Bereitstellung auf https://debian.fhem.de erledigt.
Mach doch mal "fheminfo send" um die FHEM Statistik zu unterstützen!

Nächster Hamburg-Stammtisch am 15.09.2017!
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16579
ACHTUNG: fhem 5.8 und alexa-fhem/hombridge-fhem
« Antwort #2 am: 19 Februar 2017, 17:50:11 »
um alexa-fhem und homebridge-fhem jeweils problemlos weiter zu verwenden ist es nötig diese zu aktualisieren oder das csrfToken attribut im WEB device bis dahin auf none zu setzen.

alexa-fhem: https://forum.fhem.de/index.php/topic,60244.msg540117.html#msg540117.

homebridge-fhem: die aktuelle version drüber installieren

gruss
  andre
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH
Gefällt mir Gefällt mir x 10 Hilfreich Hilfreich x 3 Liste anzeigen

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16618
Antw:FHEM 5.8 freigegeben
« Antwort #3 am: 06 März 2017, 11:14:59 »
Einen Wiki-Artikel fuer die csrfToken Probleme gibts inzwischen auch, siehe https://wiki.fhem.de/wiki/CsrfToken-HowTo
Gefällt mir Gefällt mir x 7 Liste anzeigen

 

decade-submarginal