Autor Thema: Bitte etwas Hilfe zur HMS KS300 Wetterstation  (Gelesen 254 mal)

Offline marty29ak

  • Full Member
  • ***
  • Beiträge: 134
Bitte etwas Hilfe zur HMS KS300 Wetterstation
« am: 24 Februar 2017, 14:53:16 »
Hallo,
nachdem ich die verstreuten und über die Forum Suche gefundenen Beiträge zur KS300 durchgelesen habe bin ich leider noch nicht wirklich weiter gekommen.

Habe also die KS300 Wetterstation vorgestern in betrieb genommen. Soweit hat auch alles gut funktioniert. Der Wettersensor wurde automatisch angelegt, genau so die Logdatei und die zwei Graphen.

Für meine SlowRF Geräte ist im Erdgeschoss ist ein MAX! Cube als Cuno (CUn3) und im Obergeschoss ein auf den Raspberry auf steckbarer Cul (CUL_0) installiert. Beide sind ansonsten identisch konfiguriert.

CUL_0
defmod CUL_0 CUL /dev/ttyAMA0@38400 1034
attr CUL_0 alias FS20_oben
attr CUL_0 room 02_Kino/Büro,A_Global
attr CUL_0 sendpool CUL_0,CUn3

setstate CUL_0 2017-02-24 14:17:12 ccconf freq:868.300MHz bWidth:325KHz rAmpl:42dB sens:4dB
setstate CUL_0 2017-02-24 13:09:49 cmds  m B b C F i A Z G M Y R T V W X e f * % l t u x z
setstate CUL_0 2016-03-30 17:21:56 raw isF00FF0000FF0
setstate CUL_0 2017-02-24 14:21:41 state Initialized
 

CUn3
defmod CUn3 CUL 192.168.178.42:2323 2234
attr CUn3 alias FS20_unten
attr CUn3 model CUN
attr CUn3 rfmode SlowRF
attr CUn3 room 02_Kino/Büro,A_Global
attr CUn3 sendpool CUL_0,CUn3

setstate CUn3 2017-02-24 14:19:28 ccconf freq:868.300MHz bWidth:325KHz rAmpl:42dB sens:4dB
setstate CUn3 2017-02-24 13:09:51 cmds  B b C F i A Z N E k G M K L U Y R T V W X e f h l t x z
setstate CUn3 2016-03-07 23:37:55 credit10ms 900
setstate CUn3 2017-02-24 09:23:30 raw isF00F00F00FF0
setstate CUn3 2017-02-24 14:23:36 state Initialized
setstate CUn3 2016-12-17 15:02:16 uptime 0 01:00:37
setstate CUn3 2016-12-17 15:03:09 version V 1.23.04 a-culfw Build: 127 (2016-12-16_23-39-31) CUBe (F-Band: 868MHz)

Die Wetterstation ist auf dem Dach befestigt.

defmod KS300 KS300 1234
attr KS300 IODev CUL_0
attr KS300 room O_Wetter

setstate KS300 T: 8.5  H: 55  W: 0.2  R: 8.4  IR: no  Wi: 0
setstate KS300 2017-02-24 14:24:39 avg_day T: 6.7  H: 66  W: 2.2  R: 5.1
setstate KS300 2017-02-24 00:00:26 avg_month T: 9.7  H: 35  W: 42.6  R: 3.3
setstate KS300 2017-02-24 14:24:39 checksum 6
setstate KS300 2017-02-24 14:24:39 cum_day 2017-02-24 00:00:26 T: 349283.9  H: 3425431  W: 114638.7  R: 3.3
setstate KS300 2017-02-24 00:00:26 cum_month 2 T: 19.4  H: 71  W: 85.2  R: 3.3
setstate KS300 2017-02-24 14:24:39 humidity 55
setstate KS300 2017-02-24 14:24:39 israining no
setstate KS300 2017-02-24 14:24:39 rain 8.4
setstate KS300 2017-02-24 14:24:39 rain_raw 33
setstate KS300 2017-02-24 14:24:39 rain_raw_adj 33
setstate KS300 2017-02-24 14:24:39 state T: 8.5  H: 55  W: 0.2  R: 8.4  IR: no  Wi: 0
setstate KS300 2017-02-24 14:24:39 temperature 8.5
setstate KS300 2017-02-24 14:24:39 tsecs 1487942679
setstate KS300 2017-02-24 14:24:39 type_raw 7
setstate KS300 2017-02-24 14:24:39 unknown3 1
setstate KS300 2017-02-24 14:24:39 wind 0.2
setstate KS300 2017-02-24 14:24:39 windIndex 0

Wenn man sich die RSSI Werte anschaut sollte, wie es von den Entfernungen eigentlich klar ist, der CUL_0 sein, der die Wert empfängt.
CODE                                                       1234
CUL_0_MSGCNT                                        11
CUL_0_RAWMSG                                       810d04xx4027a00171580552001206
CUL_0_RSSI                                            -85.5
CUL_0_TIME                                             2017-02-24 14:17:02
CUn3_MSGCNT                                         8
CUn3_RAWMSG                                        810d04xx4027a00171580552001206
CUn3_RSSI                                             -93
CUn3_TIME                                              2017-02-24 14:17:02
DEF                                                       1234
IODev                                                     CUL_0
LASTInputDev                                         CUn3
MSGCNT                                                 16
NAME                                                     KS300
NR                                                         236
RAINUNIT                                               255
STATE                                                    T: 8.5 H: 55 W: 0.2 R: 8.4 IR: no Wi: 0
TYPE                                                      KS300
WINDUNIT                                             1

Wie man sieht ist es aber CUn3 der die Wetterstation empfängt?
Das ist zwar "relativ zuverlässig", aber alle 4-5 Sendungen kommt es zu Aussetzern von 10-15 Minuten, was ich auf schlechten Empfang zurück führe.
Habe auch schon Kombinationen von sens 8db und Frequenz 868,350MHz versucht.
Leider ohne Erfolg.

Kann da Jemand helfen?


Des weiteren stimmen offensichtlich die Werte vom Windsensor nicht.
Gestern hat es hier wie in vielen Regionen sehr gestürmt in Deutschland. Geloggt wurden aber maximal 5-6 KM/h. Realistisch sind es aber 50-60 KM/h hier gewesen, was auch so im Wetterdienst gemeldet wurde.
Bei meiner Forensuche lass ich in einem älteren Beitrag (glaube aus 2013) das dies irgend wie gefixt werden sollte.
Da ich ja sicher nicht der einzige mit dieser Wetterstation bin, kann ich mir nicht vorstellen das es bis Heute noch nicht gemacht wurde.
Mein Fhem ist aktuell, muss ich noch was zusätzlich einstellen um in Genuss richtiger Werte für den Wind zu kommen?

Vielen Dank für eure Hilfe!!
Gruß Martin

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16608
Antw:Bitte etwas Hilfe zur HMS KS300 Wetterstation
« Antwort #1 am: 24 Februar 2017, 15:22:57 »
Zitat
Wie man sieht ist es aber CUn3 der die Wetterstation empfängt?
Wie ich das sehe, empfangen beide: CUL_0 hat 11, CUn3 8 Pakete empfangen. IODev ist nur fuers Senden relevant. An dem Windsensor-Code war mW noch nie was zu fixen, meine Daten sind seit 10 Jahren realistisch, nur der Feuchtigkeitsmesser hat neuerdings angefangen zu spinnen.

Da der Windsensor ein beweglicher Gegenstand ist, ist auch ein mechanisches Problem denkbar. Wenn man eine Methode zum Sensorkalibrieren gefunden hat, dann kann man einen Korrekturfaktor in der Definition angeben.

Offline marty29ak

  • Full Member
  • ***
  • Beiträge: 134
Antw:Bitte etwas Hilfe zur HMS KS300 Wetterstation
« Antwort #2 am: 24 Februar 2017, 15:38:39 »
Ok mit dem IODev hätte ich angenommen IO= in/out.

Was das Windrad angeht, das läuft extrem leicht und es recht eine kleine Prise um es an zu schieben. Denke das ist ok so.
Hatte diesen Beitrag gefunden>>  https://forum.fhem.de/index.php/topic,5368.msg19767.html#msg19767

Da wird das mit dem um Faktor 10 zu wenig angezeigtem Wert beschrieben.
Verstehe aber die Lösung nicht wirklich.
Gruß Martin

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 16608
Antw:Bitte etwas Hilfe zur HMS KS300 Wetterstation
« Antwort #3 am: 24 Februar 2017, 16:00:19 »
Zitat
Verstehe aber die Lösung nicht wirklich.
Das war vor knapp 9 Jahren. Laut Martins Theorie muesste ich bei Werten > 100 anders skalieren. Das mag sein, ich habe es aber nie eingebaut, und ich wuesste nicht, woran ich das erkennen soll. In den letzten zehn Jahren habe ich hier keine Werte > 70 gesehen.

Wenn "deine" Theorie stimmen wuerde, und ich vergessen haette mit 10 zu multiplizieren, dann haette das Geraet hier heute 250-350km/h gemessen, das halte ich fuer unplausibel.

Offline marty29ak

  • Full Member
  • ***
  • Beiträge: 134
Antw:Bitte etwas Hilfe zur HMS KS300 Wetterstation
« Antwort #4 am: 24 Februar 2017, 20:25:15 »
Na ja was heisst meine Theorie ....suche halt nach einer Erklärung und mal zehn hätten die angezeigten Werte gut gepasst.
Bin jetzt jeden Falls noch mal auf`s Dach und habe alles genau überprüft, den Mast penibel mit der Wasserwaage ausgerichtet und die Lager von dem Windrad etwas zusätzlich geschmiert.
Allerdings haben wir jetzt praktisch keinen Wind, so das ich erst mal warten muss....
Melde mich dann wieder....
Gruß Martin