Autor Thema: Bluetooth Raspberry PI 3  (Gelesen 1446 mal)

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 5105
    • Otto's Technik Blog
Antw:Bluetooth Raspberry PI 3
« Antwort #15 am: 28 Februar 2017, 11:37:42 »
Hi,

prinzipiell ist es in mehreren Wiki Einträgen beschrieben, z.B. hier.

Bei einem aktuellen und frischen Jessie erfolgt auch der Tausch der seriellen Interfaces (wie oft beschrieben) von alleine. Also nur
dtoverlay=pi3-miniuart-bt verwenden und feste Frequenz einstellen!

console Einträge auf serial0 (und serial1) entfernen und  und serial-getty deaktivieren. Aber steht alles im Wiki.

Per Script ohne nachzudenken installierbar.

Gruß Otto
 
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #16 am: 01 März 2017, 00:10:20 »
Hi und danke erstmal,

bin jetzt soweit mit fast allen befehlen durch

pi@raspberrypi:~ $ ls -l /dev/ser*
lrwxrwxrwx 1 root root 7 Feb 28 23:59 /dev/serial0 -> ttyAMA0
lrwxrwxrwx 1 root root 5 Feb 28 23:59 /dev/serial1 -> ttyS0

das sieht schon mal gut aus, lt. deinem Howto
allerdings bekomme ich dennoch kein Device :

pi@raspberrypi:~ $ hcitool dev
Devices:
pi@raspberrypi:~ $ hcitool scan
Device is not available: No such device
pi@raspberrypi:~ $

glaub bin zu müde oder zu blind.
habt Ihr eine Idee ??

danke
« Letzte Änderung: 01 März 2017, 00:19:13 von Micky »

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 5105
    • Otto's Technik Blog
Antw:Bluetooth Raspberry PI 3
« Antwort #17 am: 01 März 2017, 18:14:59 »
Hi,

wie sieht Deine /lib/systemd/system/hciuart.service aus ?

Ich verstehe es nicht, bei mir funktioniert da auf Anhieb.

Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #18 am: 01 März 2017, 18:49:55 »
hi,

so:

pi@raspberrypi:~ $ cat  /lib/systemd/system/hciuart.service
[Unit]
Description=Configure Bluetooth Modems connected by UART
ConditionPathIsDirectory=/proc/device-tree/soc/gpio@7e200000/bt_pins
Before=bluetooth.service
After=dev-ttyS0.device

[Service]
Type=forking
ExecStart=/usr/bin/hciattach /dev/ttyS0 bcm43xx 921600 noflow -

[Install]
WantedBy=multi-user.target

evtl. liegt es am Z-Wave Modul, das dass bluetooth reaktiviert wird?
« Letzte Änderung: 01 März 2017, 20:26:02 von Micky »

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 5105
    • Otto's Technik Blog
Antw:Bluetooth Raspberry PI 3
« Antwort #19 am: 01 März 2017, 21:57:11 »
Hi,

keine Ahnung warum Deine so aussieht. Meine ist so:
cat  /lib/systemd/system/hciuart.service
[Unit]
Description=Configure Bluetooth Modems connected by UART
ConditionPathIsDirectory=/proc/device-tree/soc/gpio@7e200000/bt_pins
Before=bluetooth.service
After=dev-serial1.device

[Service]
Type=forking
ExecStart=/usr/bin/hciattach /dev/serial1 bcm43xx 921600 noflow -

[Install]
WantedBy=multi-user.target
Und ich habe da nichts dran gemacht.
Keine Ahnung was das zwave Modul macht.
Eigentlich sollte es egal sein ob serial1 oder ttyS0 dort steht.


Gruß Otto
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #20 am: 03 März 2017, 11:26:17 »
morgen, vielleicht ist das Bluetooth bei mir einfach defekt,

mit dem Bluetooth stick klappt es zumindest auf anhieb !

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #21 am: 09 März 2017, 22:25:27 »
Hi,

sollte ich das z-Wave Module mal abziehen um zu testen ob bluetooth dann evtl. wieder funktioniert ?
Nur um ein HW-Defekt auszuschliessen ?


evtl. kann jemand was damit anfangen?

pi@raspberrypi:~ $  systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Do 2017-03-09 22:05:23 CET; 22s ago
     Docs: man:bluetoothd(8)
 Main PID: 794 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─794 /usr/lib/bluetooth/bluetoothd
pi@raspberrypi:~ $ sudo service bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Do 2017-03-09 22:05:23 CET; 27s ago
     Docs: man:bluetoothd(8)
 Main PID: 794 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─794 /usr/lib/bluetooth/bluetoothd

pi@raspberrypi:~ $ sudo hciconfig dev
Can't get device info: No such device

pi@raspberrypi:~ $ sudo bluetoothctl
[bluetooth]# agent on
Agent registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
No default controller available
[bluetooth]# exit
Agent unregistered


pi@raspberrypi:~ $ dmesg | grep Blue
[   22.873317] Bluetooth: Core ver 2.22
[   22.873369] Bluetooth: HCI device and connection manager initialized
[   22.873381] Bluetooth: HCI socket layer initialized
[   22.873389] Bluetooth: L2CAP socket layer initialized
[   22.873408] Bluetooth: SCO socket layer initialized
[  103.040851] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  103.040860] Bluetooth: BNEP filters: protocol multicast
[  103.040871] Bluetooth: BNEP socket layer initialized

Danke nochmal

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 5105
    • Otto's Technik Blog
Antw:Bluetooth Raspberry PI 3
« Antwort #22 am: 09 März 2017, 22:30:13 »
Bei mir liefert dmesg noch dies :
[    9.196321] Bluetooth: HCI UART driver ver 2.3
[    9.196339] Bluetooth: HCI UART protocol H4 registered
[    9.196344] Bluetooth: HCI UART protocol Three-wire (H5) registered
[    9.196475] Bluetooth: HCI UART protocol BCM registered
Viele Grüße aus Leipzig
RaspberryPi,HMLAN,HMUART,Homematic,Fritz!Box 7490,Sonos,ET9200,Arduino nano,ESP8266

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #23 am: 09 März 2017, 22:33:37 »
hmm ok,

weiss man damit woran es liegt oder ist es nur eine generelle Feststellung ?

HW-
Raspberry PI 3 B
z-wave Modul aufgesteckt (PINs innen)

danke

Online DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2623
  • Das könnte EINE mögliche Lösung sein...
Antw:Bluetooth Raspberry PI 3
« Antwort #24 am: 09 März 2017, 22:37:29 »
Evtl. das BT Modul noch geblacklisted?

Gruß
Dan
FHEM 5.8, Brix, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 98_Hyperion, 22_HOMEMODE, 98_FileLogConvert

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #25 am: 09 März 2017, 22:41:18 »
Hi DeeSpe,

dh ? Sorry bin wirklich Anfänger

Online DeeSPe

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2623
  • Das könnte EINE mögliche Lösung sein...
Antw:Bluetooth Raspberry PI 3
« Antwort #26 am: 09 März 2017, 22:44:39 »
Hi DeeSpe,

dh ? Sorry bin wirklich Anfänger


Nur Du kannst wissen ob Du das gemacht hast was ich Dir im o.g. Beitrag geraten hatte.

Gruß
Dan
FHEM 5.8, Brix, Debian Jessie, ZME_UZB1
HM-CFG-LAN, HM-MOD-UART-WIFI, HUE, HarmonyHub, JeeLink, CO20
Hyperion auf RPi Zero W, Sonos, viel Z-Wave und HM
alles per HomeKit steuerbar
MAINTAINER: 98_Hyperion, 22_HOMEMODE, 98_FileLogConvert

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #27 am: 09 März 2017, 22:52:19 »
meinst du das hier:

pi@raspberrypi:~ $ sudo cat /etc/modprobe.d/raspi-blacklist.conf

pi@raspberrypi:~ $

die ist leer ?

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #28 am: 10 März 2017, 00:23:53 »
so alles was mit Bluetooth zu tun hat gelöscht und folgendes getan

sudo apt-get install raspberrypi-sys-mods

sudo apt-get --reinstall install pi-bluetooth

sudo shutdown -r now


dann

sudo systemctl start hciuart.service
pi@raspberrypi:~ $ systemctl status hciuart.service
● hciuart.service - Configure Bluetooth Modems connected by UART
   Loaded: loaded (/lib/systemd/system/hciuart.service; disabled)
   Active: active (running) since Fr 2017-03-10 00:17:11 CET; 5s ago
  Process: 951 ExecStart=/usr/bin/btuart (code=exited, status=0/SUCCESS)
 Main PID: 962 (hciattach)
   CGroup: /system.slice/hciuart.service
           └─962 /usr/bin/hciattach /dev/serial1 bcm43xx 460800 noflow -



und siehe da!!!

pi@raspberrypi:~ $ hcitool dev
Devices:
hci0 B8:27:EB:90:BC:6D

es geht!!

danke an alle!

Offline Micky

  • Jr. Member
  • **
  • Beiträge: 53
Antw:Bluetooth Raspberry PI 3
« Antwort #29 am: 16 März 2017, 20:52:10 »
kleine Frage,

lief einige Tage super,

jetzt ist der State meines Gtags ständig auf Disconnected.


hab auch bluetooth neu gestartet und den respberry

im log steht folgendes:

2017.03.16 20:19:30 3: Opening MickyGtag device 127.0.0.1:5333
2017.03.16 20:19:30 3: Can't connect to 127.0.0.1:5333: Verbindungsaufbau abgelehnt

state disconnected 2017-03-16 20:49:03

internals
ADDRESS 7C:2F:80:97:xx:xx
DEF lan-bluetooth 7C:2F:80:97:xx:xx 127.0.0.1:5333 120
DeviceName 127.0.0.1:5333

hat jemand eine Idee ?


edit: lepresenced war nicht gestartet, weiss auch nicht wieso script ist ausführbar, jetzt gehts wieder
« Letzte Änderung: 16 März 2017, 21:10:03 von Micky »