Autor Thema: Probleme mit dem Update auf einem Ubuntu Server  (Gelesen 1259 mal)

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #15 am: 01 März 2017, 15:13:08 »
OK...
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.10
DISTRIB_CODENAME=wily
DISTRIB_DESCRIPTION="Ubuntu 15.10"

Tja wie vermutet nicht die die ich installiert habe. Das ist sicher durch dist-upgrade entstanden...

Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Mitch

  • Hero Member
  • *****
  • Beiträge: 1942
  • Give more - Expect less
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #16 am: 01 März 2017, 15:16:12 »
ich hatte nie die Version geändert

aber mit apt-get dist-upgrade schon.

Ich würde einfach nochmal sauber 16.04 aufsetzten und gut.
FHEM auf Intel NUC mit Ubuntu Server, CUNOv2 - FHZ1300 - FritzDECT - 2x HM-LAN - Z-Wave - SIGNALduino@433 - SIGNALduino@868 - Homebridge - Alexa - Nest Protect
RaspberryPi als Room Node per FHEM2FHEM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #17 am: 01 März 2017, 15:21:03 »
das ist mir momentan zu heikel da ich keine zweite Fhem Instanz auf einem anderen Gerät habe...

Ich könnte noch dieses machen...

New release '16.04.2 LTS' available.
Run 'do-release-upgrade' to upgrade to it.
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #18 am: 01 März 2017, 15:27:40 »
1. dist-upgrade macht ein release-upgrade, es wurde also schon mal do-release-upgrade durchgeführt
2. Ob DU "neu machst" oder "do-release-upgrade" .... wenn Du sagst, das es dir zu heikel, dann "LASS ES!". do-release-upgrade ist heikler als neumachen.
3. Probiere bitte erstmal ein normales update
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #19 am: 01 März 2017, 15:50:06 »
Habe ich schon gemacht, dass normale Update...
Bisher läuft es
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #20 am: 01 März 2017, 16:04:17 »
also ein "apt-get upgrade" wirft immer noch den Fehler?

ansonsten .. hast De den Link gelesen?
sudo apt-get install -f
sudo apt-get install --only-upgrade apt

Edit:
Eigentlich ist es ein Ubuntu/Debian-Problem ..
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #21 am: 01 März 2017, 17:57:38 »
also ein "apt-get upgrade" wirft immer noch den Fehler?

ansonsten .. hast De den Link gelesen?
sudo apt-get install -f
sudo apt-get install --only-upgrade apt

nach apt-get upgrade kommt folgendes

Die folgenden Pakete sind zurückgehalten worden:
  accountsservice acpid apport apt apt-transport-https apt-utils aptitude
  aptitude-common at autofs bsdutils build-essential console-setup cpp crda
  cron curl dbus dpkg friendly-recovery g++ gcc gcc-4.9-base gettext-base
  gir1.2-glib-2.0 ifupdown init-system-helpers initramfs-tools
  initramfs-tools-bin initscripts irqbalance isc-dhcp-client isc-dhcp-common
  keyboard-configuration kmod libaccountsservice0 libalgorithm-diff-xs-perl
  libatomic1 libc-bin libc-dev-bin libc6 libc6-dev libcgmanager0 libcloog-isl4
  libcommon-sense-perl libcurl3 libcurl3-gnutls libdatetime-perl
  libdatetime-timezone-perl libdbus-1-3 libfcgi-perl libfile-fcntllock-perl
  libgcc1 libgcr-base-3-1 libgd3 libglib2.0-0 libgnutls-openssl27 libgomp1
  libhtml-parser-perl libio-socket-ssl-perl libitm1 libjson-xs-perl
  libldap-2.4-2 liblist-moreutils-perl liblocale-gettext-perl
  liblog-message-simple-perl libnet-ssleay-perl libpackage-stash-xs-perl
  libpam-modules libpam-modules-bin libpam-systemd libparams-classify-perl
  libparams-util-perl libparams-validate-perl libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpython-stdlib libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libquadmath0 libsocket6-perl libstdc++6 libsub-name-perl
  libsystemd-daemon0 libtext-charwidth-perl libtext-iconv-perl
  libtext-soundex-perl libtirpc1 libtsan0 libudev1 libxml-parser-perl libxml2
  linux-headers-generic linux-signed-generic linux-signed-image-generic
  lsb-base lshw mount mountall nfs-common ntfs-3g openssh-client
  openssh-server openssh-sftp-server parted perl perl-base perl-modules
  plymouth plymouth-theme-ubuntu-text ppp pppconfig procps python python-apt
  python-minimal python-openssl python-requests python-twisted-core
  python-urllib3 python-xapian python2.7 python2.7-minimal python3-apt
  python3-gi resolvconf rpcbind rsyslog ssh-import-id systemd-services
  systemd-shim sysvinit-utils tmux ubuntu-standard udev ufw
  unattended-upgrades update-notifier-common upstart ureadahead util-linux
  uuid-runtime wpasupplicant
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 144 nicht aktualisiert.

ja den Link habe ich gesehen und angeschaut aber sehr wenig verstanden  :-\
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #22 am: 01 März 2017, 18:03:12 »
die von dir oben erwähnten
sudo apt-get install -f
sudo apt-get install --only-upgrade apt

habe ich durchgeführt, dann sollte ich einmal apt-get autoremove machen

und nun erfolgt nach einem apt-get upgrade dieses.. paar weniger  :-\

root@FHEM-Server:~# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete sind zurückgehalten worden:
  accountsservice acpid apport at autofs bsdutils build-essential console-setup cpp crda cron curl dbus dpkg friendly-recovery g++ gcc gettext-base
  gir1.2-glib-2.0 ifupdown init-system-helpers initramfs-tools initramfs-tools-bin initscripts irqbalance isc-dhcp-client isc-dhcp-common
  keyboard-configuration kmod libaccountsservice0 libalgorithm-diff-xs-perl libc-bin libc-dev-bin libc6 libc6-dev libcgmanager0 libcloog-isl4
  libcommon-sense-perl libcurl3 libcurl3-gnutls libdatetime-perl libdatetime-timezone-perl libdbus-1-3 libfcgi-perl libfile-fcntllock-perl
  libgcr-base-3-1 libgd3 libglib2.0-0 libgnutls-openssl27 libhtml-parser-perl libio-socket-ssl-perl libjson-xs-perl libldap-2.4-2
  liblist-moreutils-perl liblocale-gettext-perl liblog-message-simple-perl libnet-ssleay-perl libpackage-stash-xs-perl libpam-modules
  libpam-modules-bin libpam-systemd libparams-classify-perl libparams-util-perl libparams-validate-perl libpolkit-backend-1-0 libpolkit-gobject-1-0
  libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libsocket6-perl libsub-name-perl libsystemd-daemon0 libtext-charwidth-perl
  libtext-iconv-perl libtext-soundex-perl libtirpc1 libudev1 libxml-parser-perl libxml2 linux-headers-generic linux-signed-generic
  linux-signed-image-generic lsb-base mount mountall nfs-common ntfs-3g openssh-client openssh-server openssh-sftp-server parted perl perl-base
  perl-modules plymouth plymouth-theme-ubuntu-text ppp pppconfig procps python python-minimal python-openssl python-requests python-twisted-core
  python-urllib3 python2.7 python2.7-minimal python3-gi resolvconf rpcbind rsyslog ssh-import-id systemd-services systemd-shim sysvinit-utils tmux
  ubuntu-standard udev ufw unattended-upgrades update-notifier-common upstart ureadahead util-linux uuid-runtime wpasupplicant
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 127 nicht aktualisiert.
« Letzte Änderung: 01 März 2017, 18:16:01 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #23 am: 02 März 2017, 08:10:57 »
Da in der Liste auch apt-updates ... mache bitte ein:
sudo apt-get dist-upgrade
Und keine Angst .. das kriegen wir wieder hin.
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #24 am: 02 März 2017, 12:53:04 »
Und keine Angst .. das kriegen wir wieder hin.
super, ich danke schon mal für die weitere Unterstützung..!

Das kommt bei einem apt-get dist-upgrade

root@FHEM-Server:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 fhem : Hängt ab von: libdevice-serialport-perl (>= 1.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

"libdevice-serialport-perl"
dieses Teil hatte ich schon mal versucht neu zu installieren, aber die Ausgabe bleibt die gleiche.
Evtl. muss ich das teil einmal raus schmeißen..?
« Letzte Änderung: 02 März 2017, 12:57:26 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #25 am: 02 März 2017, 13:05:44 »
Was für eine Ausgabe kommt denn, wenn Du die Libary installieren willst?
apt-get install libdevice-serialport-perl
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #26 am: 02 März 2017, 13:18:32 »
das kommt..
root@FHEM-Server:~# apt-get install libdevice-serialport-perl
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libdevice-serialport-perl ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 127 nicht aktualisiert.

suche schon parallel im Internet aber so richtig finde ich nichts dazu auch hier im Forum gab es mal etwas dazu
« Letzte Änderung: 02 März 2017, 13:20:58 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #27 am: 02 März 2017, 13:48:07 »
Was ist den die installierte Version von libdevice-serialport-perl ?
dpkg -s <package> | grep VersionIrgendwie sieht mir das nach einem "Zirkelbezug" aus...

Weitere Option, aber ein übler Hack, über den evtl. auch nochmal jemand mit mehr Erfahrung drübersehen sollte:
https://askubuntu.com/questions/85748/how-can-i-remove-the-record-of-an-installed-package-without-deleting-any-files

Macht man das, sollte sich apt nicht mehr erinnern, das fhem überhaupt installiert ist (FHEM aber weiterhin funktioniert). Da FHEM-Updates eh' außerhalb der Debian-Mechanismen laufen sollten, dürfte das ausnahmsweise keine üblen Nebenwirkungen haben. In jedem Fall darf debian.fhem.de nicht mehr in den Sourcenlisten stehen.

Hoffe, das hilft weiter,

Beta-User
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #28 am: 02 März 2017, 14:02:48 »
das ist die Version

root@FHEM-Server:~# dpkg -s libdevice-serialport-perl | grep Version
Version: 1.04-2build3
root@FHEM-Server:~#

evtl. hängen auch diese Fehlermeldungen damit zusammen, die ich alle paar Stunden drin habe
Um es genau zu sagen alle 6 Stunden
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130897) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130895) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130893) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130887) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130885) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130883) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130874) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130872) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130870) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130864) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130862) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130860) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130851) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130849) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130847) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130841) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130839) line 1.
2017.03.02 08:53:12 1: PERL WARNING: Use of uninitialized value in string eq at (eval 1130837) line 1.

hier mal die source list
root@FHEM-Server:~# cat /etc/apt/sources.list
#

# deb cdrom:[Ubuntu-Server 14.04 LTS _Trusty Tahr_ - Release amd64 (20140416.2)]/ trusty main restricted

# deb cdrom:[Ubuntu-Server 14.04 LTS _Trusty Tahr_ - Release amd64 (20140416.2)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://de.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://de.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty universe
deb http://de.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://de.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://de.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu trusty main
deb http://mirrors.kernel.org/ubuntu wily main
# deb-src http://mirrors.kernel.org/ubuntu wily main
# deb-src http://extras.ubuntu.com/ubuntu trusty main

da hast du wohl recht von Fhem steht da nichts mehr drin  ;)
« Letzte Änderung: 02 März 2017, 14:11:49 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #29 am: 02 März 2017, 14:12:57 »
Hast Du eventuell stable und unstable sourcen gemischt?

Vielleicht postest Du mal Deine sourcen?

Dass die Perl-Warnung was damit zu tun hat, glaube ich nicht. Das sieht wirklich aus wie eine kaputte Paketverwaltung (die Abhängigkeiten sind ja eigentlich sauber erfüllt, nur apt hat das noch nicht mitbekommen).
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

 

decade-submarginal