Autor Thema: Probleme mit dem Update auf einem Ubuntu Server  (Gelesen 1260 mal)

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #30 am: 02 März 2017, 14:13:47 »
siehe Edit oben..

Also ich habe da nichts gemischt, soweit reichen meine Linux Kenntnisse nicht. Das sollte dann irgendwie bei einem Update passiert sein :-\
« Letzte Änderung: 02 März 2017, 14:18:04 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #31 am: 02 März 2017, 14:20:06 »
ich habe hier noch etwas gefunden für die installierten Pakete...
Evtl. kann man hier was sehen, sieht aber soweit ich das einschätzen kann gut aus...
Mich irritiert Fhem 5.6 ich habe eigentlich ein Update auf 5.7 und dann 5.8 gemacht

root@FHEM-Server:~# dpkg -l | grep -v '^ii \|^un '
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name                                  Version                      Architektur  Beschreibung
+++-=====================================-============================-============-===============================================================================
hi  fhem                                  5.6.                         all          GPL'd perl server for house automation.
rc  libboost-iostreams1.54.0:amd64        1.54.0-4ubuntu3.1            amd64        Boost.Iostreams Library
rc  libcwidget3                           0.5.16-3.5ubuntu1            amd64        high-level terminal interface library for C++ (runtime files)
rc  libept1.4.12:amd64                    1.0.12                       amd64        High-level library for managing Debian package information
rc  libjasper1:amd64                      1.900.1-debian1-2.4          amd64        JasPer JPEG-2000 runtime library
rc  libsigc++-2.0-0c2a:amd64              2.2.10-0.2ubuntu2            amd64        type-safe Signal Framework for C++ - runtime
rc  libxapian22                           1.2.16-2ubuntu1              amd64        Search engine library
rc  linux-image-3.13.0-100-generic        3.13.0-100.147               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-101-generic        3.13.0-101.148               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-103-generic        3.13.0-103.150               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-105-generic        3.13.0-105.152               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-107-generic        3.13.0-107.154               amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-24-generic         3.13.0-24.47                 amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-65-generic         3.13.0-65.106                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-66-generic         3.13.0-66.108                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-68-generic         3.13.0-68.111                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-70-generic         3.13.0-70.113                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-71-generic         3.13.0-71.114                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-73-generic         3.13.0-73.116                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-74-generic         3.13.0-74.118                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-76-generic         3.13.0-76.120                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-77-generic         3.13.0-77.121                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-79-generic         3.13.0-79.123                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-83-generic         3.13.0-83.127                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-85-generic         3.13.0-85.129                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-86-generic         3.13.0-86.131                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-87-generic         3.13.0-87.133                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-88-generic         3.13.0-88.135                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-91-generic         3.13.0-91.138                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-92-generic         3.13.0-92.139                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-93-generic         3.13.0-93.140                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-95-generic         3.13.0-95.142                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-96-generic         3.13.0-96.143                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-3.13.0-98-generic         3.13.0-98.145                amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-100-generic  3.13.0-100.147               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-101-generic  3.13.0-101.148               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-103-generic  3.13.0-103.150               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-105-generic  3.13.0-105.152               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-107-generic  3.13.0-107.154               amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-24-generic   3.13.0-24.47                 amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-65-generic   3.13.0-65.106                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-66-generic   3.13.0-66.108                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-68-generic   3.13.0-68.111                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-70-generic   3.13.0-70.113                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-71-generic   3.13.0-71.114                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-73-generic   3.13.0-73.116                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-74-generic   3.13.0-74.118                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-76-generic   3.13.0-76.120                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-77-generic   3.13.0-77.121                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-79-generic   3.13.0-79.123                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-83-generic   3.13.0-83.127                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-85-generic   3.13.0-85.129                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-86-generic   3.13.0-86.131                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-87-generic   3.13.0-87.133                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-88-generic   3.13.0-88.135                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-91-generic   3.13.0-91.138                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-92-generic   3.13.0-92.139                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-93-generic   3.13.0-93.140                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-95-generic   3.13.0-95.142                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-96-generic   3.13.0-96.143                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-image-extra-3.13.0-98-generic   3.13.0-98.145                amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
rc  linux-signed-image-3.13.0-100-generic 3.13.0-100.147               amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-101-generic 3.13.0-101.148               amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-103-generic 3.13.0-103.150               amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-105-generic 3.13.0-105.152               amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-107-generic 3.13.0-107.154               amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-24-generic  3.13.0-24.47                 amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-65-generic  3.13.0-65.106                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-66-generic  3.13.0-66.108                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-68-generic  3.13.0-68.111                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-70-generic  3.13.0-70.113                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-71-generic  3.13.0-71.114                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-73-generic  3.13.0-73.116                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-74-generic  3.13.0-74.118                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-76-generic  3.13.0-76.120                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-77-generic  3.13.0-77.121                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-79-generic  3.13.0-79.123                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-83-generic  3.13.0-83.127                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-85-generic  3.13.0-85.129                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-86-generic  3.13.0-86.131                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-87-generic  3.13.0-87.133                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-88-generic  3.13.0-88.135                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-91-generic  3.13.0-91.138                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-92-generic  3.13.0-92.139                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-93-generic  3.13.0-93.140                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-95-generic  3.13.0-95.142                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-96-generic  3.13.0-96.143                amd64        Signed kernel image generic
rc  linux-signed-image-3.13.0-98-generic  3.13.0-98.145                amd64        Signed kernel image generic
rc  php5-common                           5.5.9+dfsg-1ubuntu4.14       amd64        Common files for packages built from the php5 source
rc  php5-json                             1.3.2-2build1                amd64        JSON module for php5
root@FHEM-Server:~#
« Letzte Änderung: 02 März 2017, 14:23:31 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #32 am: 02 März 2017, 14:26:41 »
also:
deb http://mirrors.kernel.org/ubuntu wily main solltest Du noch deaktivieren.

Dann könnte es weitere sourcen geben (liegen in einem Verzeichnis sources.d dort, wo auch die sources.list zu finden ist). Schau doch mal nach, ob dort noch was verborgen ist.

Ansonsten habe ich auch vorerst keine Idee :(...

Btw: Wenn das mit dem Update dann irgendwann doch geklappt hat, könntest Du die ganzen alten Kernel usw. auch rauswerfen (autoremove, vorher nachsehen, dass nicht FHEM versehentlich gelöscht wird (sollte die -s Option sein)).
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #33 am: 02 März 2017, 14:30:02 »
Btw: Wenn das mit dem Update dann irgendwann doch geklappt hat, könntest Du die ganzen alten Kernel usw. auch rauswerfen (autoremove, vorher nachsehen, dass nicht FHEM versehentlich gelöscht wird (sollte die -s Option sein)).

Das mußt du mir dann nochmal genau erklären, damit ich da keinen Fehler mache...
Ok ich werde das mal auskommentieren und weiter berichten.

Muss nur jetzt erst mal los... sollte euch noch was einfallen immer schreiben heute Abend gehts weiter  ;)
Vielen Dank

Jetzt sieht es dann so aus nach einem apt-get update und einem apt-get upgrade
root@FHEM-Server:~#  apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete sind zurückgehalten worden:
  linux-headers-generic linux-signed-generic linux-signed-image-generic
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 3 nicht aktualisiert.

3 nicht aktualisiert ist ja mal schon was gegenüber vorher 127  ;)


Aber dieses wily ist ja die 15.10
deb http://mirrors.kernel.org/ubuntu wily main
deshalb also auch weniger Pakete
« Letzte Änderung: 02 März 2017, 14:36:34 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #34 am: 02 März 2017, 14:41:26 »
3 nicht aktualisiert ist ja mal schon was gegenüber vorher 127  ;)
Versuch's einfach nochmal, manchmal braucht es mehrere Anläufe...

Das mußt du mir dann nochmal genau erklären, damit ich da keinen Fehler mache...
Man kann akutalisierte/nicht mehr benutzte Pakete auch wieder löschen (wie die vielen Kernel), mit
apt-get autoremoveDa wir sicherstellen wollen, dass wir versehenlich nicht auch Daten von FHEM löschen, vorher simulieren, also:
apt-get -s autoremoveIst da nichts dabei, was weh tun könnte, kann's losgehen ;).
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #35 am: 02 März 2017, 14:49:14 »
Wenn Du fhem (intern) updatest, ex ein update über apt gibt, dann ..... setzt Du die Version auf den Stand von apt zurück ...

Ich würde jetzt aquch:
- Sourcen Bereinigen (wie gesagt)
- Du hast 2 Versionen gemischt, laut lsb-release wily 15.04 aber ansonsten trusty ????
- Wie gesagt solltest Du cleanen
- - - apt-get -s autoremove
- - - apt-get -s autoclean
- - - apt-get -s clean

Bitte erstmal mit "-s" testen und im Zweifel posten ...
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #36 am: 02 März 2017, 14:51:50 »
so letzte Meldung... alles wieder OK

Habe apt-get update und apt-get upgrade gemacht zwischenzeitlich
dann doch nochmal ein
apt-get update && apt-get dist-upgrade

die 3 Pakete wurden installiert und die folgenden mit autoremove entfernt
linux-headers-3.13.0-106 linux-headers-3.13.0-106-generic linux-image-3.13.0-106-generic linux-image-extra-3.13.0-106-generic linux-signed-image-3.13.0-106-generic
erst mal jetzt nichts mehr was meckert... Aber ich denke ich werde demnächst eine komplette Neuinstallation machen müssen um das sauber wieder hinzubekommen und dann in der Zukunft nicht mehr mit
"apt-get update && apt-get dist-upgrade" Updaten..!!!  ;)

Vorher übe ich mal auf einer anderen Maschine  ;) habe ja noch ein Cubitruck oder den Dell T20 da werde ich dann alles genau aufschreiben wie und was ich mache.. damit das hier auf meinem FHEM Server gut klappt und schnell geht  :D

Danke nochmal an alle hier die mir geholfen haben  :D ;D
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #37 am: 02 März 2017, 14:57:06 »
Ich würde jetzt aquch:
- Sourcen Bereinigen (wie gesagt)
- Du hast 2 Versionen gemischt, laut lsb-release wily 15.04 aber ansonsten trusty ????
- Wie gesagt solltest Du cleanen
- - - apt-get -s autoremove
- - - apt-get -s autoclean
- - - apt-get -s clean

Bitte erstmal mit "-s" testen und im Zweifel posten ...
OK habe ich gemacht:
mit autoremove ist nichts mehr, dass hatte ich jaschon
root@FHEM-Server:~# apt-get -s autoremove
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

mit apt-get -s autoclean jede menge
Del libwind0-heimdal 1.6~rc2+dfsg-10ubuntu1 [47,7 kB]
Del python3-pycurl 7.19.5.1-1ubuntu2 [36,0 kB]
Del grub-efi-amd64 2.02~beta2-29 [65,4 kB]
Del sed 4.2.2-6.1 [139 kB]
Del python3-commandnotfound 0.3ubuntu15.10.1 [5.756 B]
Del libjson-c2 0.11-4ubuntu2 [22,3 kB]
Del libx11-data 2:1.6.3-1ubuntu2 [113 kB]
Del libpangocairo-1.0-0 1.36.8-3 [20,6 kB]
Del libquadmath0 5.2.1-22ubuntu2 [131 kB]
Del file 1:5.22+15-2ubuntu1 [20,7 kB]
Del libfontenc1 1:1.1.3-1 [13,9 kB]
Del libgeoip1 1.6.6-1 [69,3 kB]
Del libbsd0 0.7.0-2 [34,9 kB]
Del info 6.0.0.dfsg.1-3 [97,1 kB]
Del python3-software-properties 0.96.13 [19,5 kB]
Del systemd-services 204-5ubuntu20.21 [197 kB]
Del libaudit1 1:2.4.2-1ubuntu1 [35,2 kB]
Del libxcb1 1.11-0ubuntu1 [40,1 kB]
Del libmodule-pluggable-perl 5.1-2 [21,4 kB]
Del libnih-dbus1 1.0.3-4ubuntu27 [14,8 kB]
Del debconf-i18n 1.5.57ubuntu1 [206 kB]
Del libsemanage-common 2.3-1build2 [6.238 B]
Del keyutils 1.5.9-5ubuntu1 [47,9 kB]
Del gcc-5-base 5.2.1-22ubuntu2 [16,7 kB]
Del libpango-1.0-0 1.36.8-3 [152 kB]
Del pppoeconf 1.21ubuntu1 [14,8 kB]
Del fonts-dejavu-extra 2.35-1 [1.749 kB]
Del groff-base 1.22.3-1 [1.183 kB]
Del iproute2 4.1.1-1ubuntu1 [461 kB]
Del libxtables10 1.4.21-2ubuntu2 [26,6 kB]
Del libcroco3 0.6.8-3 [83,2 kB]
Del libfuse2 2.9.4-1ubuntu1 [90,9 kB]
Del libxrender1 1:0.9.9-0ubuntu1 [18,5 kB]
Del libjson-perl 2.90-1 [79,4 kB]
Del sudo 1.8.12-1ubuntu3 [356 kB]
Del libapt-pkg4.16 1.0.10.2ubuntu1 [637 kB]
Del libterm-ui-perl 0.46-1 [18,6 kB]
Del lsb-release 4.1+Debian11ubuntu8 [11,6 kB]
Del libreadline6 6.3-8ubuntu1 [117 kB]
Del grep 2.21-2 [149 kB]
Del liburi-perl 1.69-1 [84,5 kB]
Del python-twisted-bin 15.2.1-1ubuntu2 [11,8 kB]
Del language-pack-en-base 1:15.10+20151016 [493 kB]
Del ed 1.10-2 [49,4 kB]
Del vim 2:7.4.712-2ubuntu4 [1.028 kB]
Del fakeroot 1.20.2-1ubuntu1 [61,8 kB]
Del os-prober 1.63ubuntu2 [18,1 kB]
Del libaudit-common 1:2.4.2-1ubuntu1 [4.080 B]
Del libdatrie1 0.2.9-2 [17,2 kB]
Del libusb-1.0-0 2:1.0.19-1 [42,4 kB]
Del libudev1 204-5ubuntu20.22 [34,7 kB]
Del grub2-common 2.02~beta2-29 [510 kB]
Del python3 3.4.3-4ubuntu1 [8.810 B]
Del libasn1-8-heimdal 1.6~rc2+dfsg-10ubuntu1 [175 kB]
Del python-zope.interface 4.1.2-1build1 [81,7 kB]
Del linux-headers-generic 3.13.0.108.116 [2.296 B]
Del libprocps3 1:3.3.9-1ubuntu8 [31,7 kB]
Del udev 204-5ubuntu20.22 [736 kB]
Del libp11-kit0 0.23.1-3 [107 kB]
Del efibootmgr 0.12-4 [20,3 kB]
Del libmodule-runtime-perl 0.014-2 [15,6 kB]
Del apt 1.0.10.2ubuntu1 [986 kB]
Del passwd 1:4.1.5.1-1.1ubuntu7 [765 kB]
Del libpython3-stdlib 3.4.3-4ubuntu1 [7.014 B]
Del dpkg-dev 1.18.2ubuntu5 [583 kB]
Del python3-newt 0.52.18-1ubuntu1 [19,0 kB]
Del libpci3 1:3.3.1-1ubuntu1 [23,9 kB]
Del libgdk-pixbuf2.0-0 2.32.1-1 [158 kB]
Del libpackage-stash-perl 0.37-1 [18,3 kB]
Del geoip-database 20150810-1 [1.512 kB]
Del libsigsegv2 2.10-4 [14,1 kB]
Del libudev1 204-5ubuntu20.21 [34,3 kB]
Del ucf 3.0030 [55,5 kB]
Del libmagic1 1:5.22+15-2ubuntu1 [211 kB]
Del mtr-tiny 0.85-3 [36,6 kB]
Del python-pam 0.4.2-13.1ubuntu4 [10,0 kB]
Del rsync 3.1.1-3 [330 kB]
Del fonts-dejavu 2.35-1 [3.184 B]
Del libpam-systemd 204-5ubuntu20.22 [25,5 kB]
Del libusb-1.0-0-dev 2:1.0.19-1 [57,6 kB]
Del dh-python 2.20150826ubuntu1 [69,3 kB]
Del libnih1 1.0.3-4ubuntu27 [49,8 kB]
Del command-not-found 0.3ubuntu15.10.1 [3.668 B]
Del libpolkit-agent-1-0 0.105-11ubuntu2 [15,1 kB]
Del libgcc1 1:5.2.1-22ubuntu2 [38,8 kB]
Del libbz2-1.0 1.0.6-8 [30,8 kB]
Del wireless-regdb 2014.11.18-1ubuntu1 [8.326 B]
Del libdebconfclient0 0.192ubuntu1 [6.310 B]
Del apt-utils 1.0.10.2ubuntu1 [180 kB]
Del wget 1.16.1-1ubuntu1 [282 kB]
Del libgssapi-krb5-2 1.13.2+dfsg-2 [119 kB]
Del ncurses-bin 5.9+20150516-2ubuntu1 [139 kB]
Del install-info 6.0.0.dfsg.1-3 [51,2 kB]
Del libkrb5-3 1.13.2+dfsg-2 [275 kB]
Del libxcb-render0 1.11-0ubuntu1 [11,6 kB]
Del libhttp-cookies-perl 6.01-1 [17,2 kB]
Del libuuid1 2.26.2-6ubuntu3 [15,0 kB]
Del libssl1.0.0 1.0.2d-0ubuntu1 [1.091 kB]
Del python3-update-manager 1:15.10.3 [31,6 kB]
Del libsasl2-modules-db 2.1.26.dfsg1-14 [14,6 kB]
Del libcap2 1:2.24-9 [12,8 kB]
Del libpam0g 1.1.8-3.1ubuntu3 [58,1 kB]
Del byobu 5.97-0ubuntu1 [106 kB]
Del libevent-2.0-5 2.0.21-stable-2 [113 kB]
Del libpam-systemd 204-5ubuntu20.21 [25,5 kB]
Del libalgorithm-diff-perl 1.19.03-1 [47,6 kB]
Del libgdk-pixbuf2.0-common 2.32.1-1 [10,1 kB]
Del libclass-singleton-perl 1.5-1 [13,0 kB]
Del libncursesw5 5.9+20150516-2ubuntu1 [122 kB]
Del xkb-data 2.12-1ubuntu1 [297 kB]
Del patch 2.7.5-1 [90,4 kB]
Del python-apt-common 1.0.1build1 [18,3 kB]
Del python3-dbus 1.2.0-2build3 [83,3 kB]
Del libgssapi3-heimdal 1.6~rc2+dfsg-10ubuntu1 [93,9 kB]
Del iptables 1.4.21-2ubuntu2 [262 kB]
Del libgcr-3-common 3.16.0-1ubuntu2 [8.940 B]
Del libdb5.3 5.3.28-11 [670 kB]
Del libisccfg90 1:9.9.5.dfsg-11ubuntu1 [36,5 kB]
Del libelf1 0.163-4ubuntu1 [39,0 kB]
Del e2fslibs 1.42.12-1ubuntu2 [189 kB]
Del libthai0 0.1.22-2 [17,0 kB]
Del bind9-host 1:9.9.5.dfsg-11ubuntu1 [46,9 kB]
Del gpgv 1.4.18-7ubuntu1 [165 kB]
Del python3-apt 1.0.1build1 [142 kB]
Del module-init-tools 21-1ubuntu1 [1.946 B]
Del binutils 2.25.1-6ubuntu1 [2.279 kB]
Del libtimedate-perl 2.3000-2 [37,5 kB]
Del liblwp-protocol-https-perl 6.06-2 [8.682 B]
Del libfakeroot 1.20.2-1ubuntu1 [25,5 kB]
Del python3-apport 2.19.1-0ubuntu3 [79,1 kB]
Del python-debian 0.1.27ubuntu1 [64,2 kB]
Del libgd-text-perl 0.86-9 [36,3 kB]
Del libsystemd-login0 204-5ubuntu20.22 [28,2 kB]
Del libjbig0 2.1-3.1 [26,6 kB]
Del python-apt 1.0.1build1 [143 kB]
Del sbsigntool 0.6-0ubuntu8 [50,9 kB]
Del libarchive-extract-perl 0.76-1 [20,6 kB]
Del installation-report 2.56ubuntu1 [7.694 B]
Del bsdmainutils 9.0.6ubuntu1 [175 kB]
Del vim-common 2:7.4.712-2ubuntu4 [103 kB]
Del dosfstools 3.0.28-1 [63,2 kB]
Del hostname 3.15ubuntu2 [11,7 kB]
Del base-passwd 3.5.38 [56,3 kB]
Del python-gdbm 2.7.9-1 [11,9 kB]
Del python3.4 3.4.3-9ubuntu1 [186 kB]
Del git 1:2.5.0-1 [2.951 kB]
Del readline-common 6.3-8ubuntu1 [51,6 kB]
Del base-files 7.2ubuntu11 [59,8 kB]
Del libgpg-error0 1.19-2 [33,2 kB]
Del libxmuu1 2:1.1.2-1ubuntu1 [9.668 B]
Del libedit2 3.1-20150325-1ubuntu1 [76,6 kB]
Del landscape-common 14.12-0ubuntu1 [167 kB]
Del libreadline5 5.2+dfsg-3 [101 kB]
Del libdns100 1:9.9.5.dfsg-11ubuntu1 [653 kB]
Del shared-mime-info 1.3-1 [389 kB]
Del debianutils 4.5.1 [85,0 kB]
Del linux-firmware 1.149 [29,1 MB]
Del python-six 1.9.0-5 [10,7 kB]
Del libboost-iostreams1.58.0 1.58.0+dfsg-3.1ubuntu1 [28,3 kB]
Del libpython3.4-minimal 3.4.3-9ubuntu1 [466 kB]
Del cpio 2.11+dfsg-4.1ubuntu1 [74,2 kB]
Del ubuntu-minimal 1.341 [2.626 B]
Del libefivar0 0.21-1 [44,1 kB]
Del time 1.7-25.1 [26,2 kB]
Del nano 2.4.2-1 [191 kB]
Del git-man 1:2.5.0-1 [727 kB]
Del libio-html-perl 1.001-1 [14,9 kB]
Del libheimntlm0-heimdal 1.6~rc2+dfsg-10ubuntu1 [15,1 kB]
Del dnsutils 1:9.9.5.dfsg-11ubuntu1 [98,0 kB]
Del libtinfo5 5.9+20150516-2ubuntu1 [76,1 kB]
Del libmodule-implementation-perl 0.09-1 [12,2 kB]
Del librsvg2-common 2.40.10-1 [5.038 B]
Del libjasper1 1.900.1-debian1-2.4 [131 kB]
Del xfonts-encodings 1:1.0.4-2 [573 kB]
Del libconvert-binhex-perl 1.123-2 [29,6 kB]
Del multiarch-support 2.21-0ubuntu4 [7.234 B]
Del python3-problem-report 2.19.1-0ubuntu3 [10,3 kB]
Del apt-xapian-index 0.46ubuntu1 [56,8 kB]
Del libparse-debianchangelog-perl 1.2.0-5 [50,6 kB]
Del ubuntu-release-upgrader-core 1:15.10.13 [24,4 kB]
Del adduser 3.113+nmu3ubuntu4 [162 kB]
Del libtry-tiny-perl 0.22-1 [17,8 kB]
Del libnet-http-perl 6.09-1 [24,0 kB]
Del libmailtools-perl 2.13-1 [82,6 kB]
Del libdpkg-perl 1.18.2ubuntu5 [194 kB]
Del insserv 1.14.0-5ubuntu3 [38,2 kB]
Del language-selector-common 0.151 [213 kB]
Del libdevmapper1.02.1 2:1.02.99-1ubuntu1 [121 kB]
Del ethtool 1:3.16-1 [94,4 kB]
Del coreutils 8.23-4ubuntu2 [1.138 kB]
Del libmpdec2 2.4.1-1 [82,7 kB]
Del libpam-cap 1:2.24-9 [7.374 B]
Del libpixman-1-0 0.32.6-3 [237 kB]
Del apt-transport-https 1.0.10.2ubuntu1 [25,4 kB]
Del dash 0.5.7-4ubuntu2 [87,0 kB]
Del libxcb-shm0 1.11-0ubuntu1 [5.766 B]
Del libgd-graph-perl 1.48-2 [379 kB]
Del libsemanage1 2.3-1build2 [71,2 kB]
Del libmpc3 1.0.3-1 [39,7 kB]
Del grub-efi-amd64-bin 2.02~beta2-29 [651 kB]
Del libclass-load-perl 0.23-1 [13,5 kB]
Del policykit-1 0.105-11ubuntu2 [51,8 kB]
Del libxapian22v5 1.2.21-1.2 [585 kB]
Del libisc95 1:9.9.5.dfsg-11ubuntu1 [149 kB]
Del pciutils 1:3.3.1-1ubuntu1 [232 kB]
Del python-chardet 2.3.0-1build1 [96,2 kB]
Del mlocate 0.26-1ubuntu2 [45,4 kB]
Del libffi6 3.2.1-3 [17,8 kB]
Del iso-codes 3.60-1 [2.298 kB]
Del tasksel-data 2.88ubuntu17 [6.618 B]
Del libxdmcp6 1:1.1.2-1 [11,2 kB]
Del libfribidi0 0.19.7-1 [25,1 kB]
Del xfonts-utils 1:7.7+3 [75,3 kB]
Del libhtml-format-perl 2.11-2 [41,3 kB]
Del gnupg 1.4.18-7ubuntu1 [624 kB]
Del libnl-3-200 3.2.26-1 [52,6 kB]
Del libhx509-5-heimdal 1.6~rc2+dfsg-10ubuntu1 [107 kB]
Del libroken18-heimdal 1.6~rc2+dfsg-10ubuntu1 [40,4 kB]
Del libdbus-glib-1-2 0.104-1build1 [66,9 kB]
Del libsasl2-2 2.1.26.dfsg1-14 [49,0 kB]
Del libhcrypto4-heimdal 1.6~rc2+dfsg-10ubuntu1 [85,9 kB]
Del libattr1 1:2.4.47-2 [9.756 B]
Del vim-tiny 2:7.4.712-2ubuntu4 [426 kB]
Del libpam-runtime 1.1.8-3.1ubuntu3 [39,8 kB]
Del python3.4-minimal 3.4.3-9ubuntu1 [1.483 kB]
Del grub-efi-amd64-signed 1.55+2.02~beta2-29 [245 kB]
Del krb5-locales 1.13.2+dfsg-2 [12,7 kB]
Del grub-common 2.02~beta2-29 [1.704 kB]
Del libck-connector0 0.4.6-5 [8.784 B]
Del python3-gdbm 3.4.3-4 [14,1 kB]
Del libsigc++-2.0-0v5 2.4.1-2 [10,8 kB]
Del command-not-found-data 0.3ubuntu15.10.1 [862 kB]
Del libpipeline1 1.4.1-1 [24,9 kB]
Del findutils 4.4.2-9build1 [275 kB]
Del linux-signed-image-generic 3.13.0.108.116 [2.348 B]
Del libmpfr4 3.1.3-1 [190 kB]
Del man-db 2.7.4-1 [858 kB]
Del language-pack-de-base 1:15.10+20151016 [3.137 kB]
Del make 4.0-8.2 [149 kB]
Del libexpat1 2.1.0-7 [71,4 kB]
Del dmidecode 2.12-4 [46,5 kB]
Del libusb-1.0-doc 2:1.0.19-1 [115 kB]
Del libatomic1 5.2.1-22ubuntu2 [8.950 B]
Del libslang2 2.3.0-2ubuntu1 [413 kB]
Del linux-libc-dev 3.13.0-108.155 [772 kB]
Del libselinux1 2.3-2build1 [59,2 kB]
Del libjson0 0.11-4ubuntu2 [1.136 B]
Del libmount1 2.26.2-6ubuntu3 [115 kB]
Del language-pack-de 1:15.10+20151016 [1.812 B]
Del bzip2 1.0.6-8 [32,7 kB]
Del libfontconfig1 2.11.1-0ubuntu6 [127 kB]
Del libustr-1.0-1 1.0.4-5 [68,4 kB]
Del ftp 0.17-33 [52,4 kB]
Del x11-common 1:7.7+7ubuntu4 [58,6 kB]
Del update-manager-core 1:15.10.3 [5.338 B]
Del gawk 1:4.1.1+dfsg-1 [393 kB]
Del debconf 1.5.57ubuntu1 [136 kB]
Del libnfnetlink0 1.0.1-3 [13,3 kB]

mit apt-get -s clean

root@FHEM-Server:~# apt-get -s clean
Del /var/cache/apt/archives/* /var/cache/apt/archives/partial/*
Del /var/cache/apt/pkgcache.bin /var/cache/apt/srcpkgcache.bin

OK jetzt muss ich aber erst mal los... :-\
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #38 am: 02 März 2017, 15:01:55 »
Schön, dass es wieder auf einem funktionierenden Stand ist, aber:

Zukünftig auf updates& upgrades zu verzichten ist keine Option!

Lieber ein backup bereithalten und zumindest immer auf die aktuelle LTS-Version wechseln/upgraden (aber erst, wenn die .1 erschienen ist). Wenn nicht zu viel "Gemüse" drumrum installiert ist, sollte das bei Debian bzw. Ubuntu kein Problem sein, man darf nur keine exotischen Fremdquellen nutzen oder Versionen mischen ;). Habe das auf einigen Maschinen in der Vergangenheit immer wieder gemacht, meistens war es kein Problem und wenn, dann eine der o.g. Ursachen ::).

Hier war nur das Problem, dass Du aus irgendeinem Grund einen aktuelleren Kernel haben wolltest (vermutlich weil der NUC vom alten trusty-Kernel noch nicht voll unterstützt wurde, als Du das das erste Mal installiert hast, Du aber nicht gewagt hast, was anderes zu installieren als LTS).
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #39 am: 02 März 2017, 15:02:47 »
Kannst es dann mal ohne "-s" machen ...

Wir können auch weiter bereinigen .. kannst Du uns zur Info mal geben:
dpkg --get-selections | grep deinstall
Edit:
Ich würde eher sagen, der Fehler war, automatisch ohne "lesen" ein update machen!

Besser vorher mal gucken, was er machen will und dann erst ...

Edit2:
Kleinen "Fehler" oben beseitigt ...
« Letzte Änderung: 02 März 2017, 16:15:23 von Wernieman »
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #40 am: 03 März 2017, 13:13:12 »
Zukünftig auf updates& upgrades zu verzichten ist keine Option!
nein, nein das natürlich nicht... damit war gemeint das ich keine update && dist-upgrade mehr mache, weil er dann wohl auch auf aktuellere Distris geht...

Ich werde wohl am besten
apt-get update && apt-get upgrade -y && apt-get autoremove -ymachen

hier nun die Ausgabe von
dpkg --get-selections | grep deinstall
da ist einiges was wohl weg kann...! Habe jetzt noch nicht ohne -s gemacht

root@FHEM-Server:~# dpkg --get-selections | grep deinstall
libboost-iostreams1.54.0:amd64                  deinstall
libcwidget3                                     deinstall
libept1.4.12:amd64                              deinstall
libjasper1:amd64                                deinstall
libsigc++-2.0-0c2a:amd64                        deinstall
libxapian22                                     deinstall
linux-image-3.13.0-100-generic                  deinstall
linux-image-3.13.0-101-generic                  deinstall
linux-image-3.13.0-103-generic                  deinstall
linux-image-3.13.0-105-generic                  deinstall
linux-image-3.13.0-106-generic                  deinstall
linux-image-3.13.0-107-generic                  deinstall
linux-image-3.13.0-24-generic                   deinstall
linux-image-3.13.0-65-generic                   deinstall
linux-image-3.13.0-66-generic                   deinstall
linux-image-3.13.0-68-generic                   deinstall
linux-image-3.13.0-70-generic                   deinstall
linux-image-3.13.0-71-generic                   deinstall
linux-image-3.13.0-73-generic                   deinstall
linux-image-3.13.0-74-generic                   deinstall
linux-image-3.13.0-76-generic                   deinstall
linux-image-3.13.0-77-generic                   deinstall
linux-image-3.13.0-79-generic                   deinstall
linux-image-3.13.0-83-generic                   deinstall
linux-image-3.13.0-85-generic                   deinstall
linux-image-3.13.0-86-generic                   deinstall
linux-image-3.13.0-87-generic                   deinstall
linux-image-3.13.0-88-generic                   deinstall
linux-image-3.13.0-91-generic                   deinstall
linux-image-3.13.0-92-generic                   deinstall
linux-image-3.13.0-93-generic                   deinstall
linux-image-3.13.0-95-generic                   deinstall
linux-image-3.13.0-96-generic                   deinstall
linux-image-3.13.0-98-generic                   deinstall
linux-image-extra-3.13.0-100-generic            deinstall
linux-image-extra-3.13.0-101-generic            deinstall
linux-image-extra-3.13.0-103-generic            deinstall
linux-image-extra-3.13.0-105-generic            deinstall
linux-image-extra-3.13.0-106-generic            deinstall
linux-image-extra-3.13.0-107-generic            deinstall
linux-image-extra-3.13.0-24-generic             deinstall
linux-image-extra-3.13.0-65-generic             deinstall
linux-image-extra-3.13.0-66-generic             deinstall
linux-image-extra-3.13.0-68-generic             deinstall
linux-image-extra-3.13.0-70-generic             deinstall
linux-image-extra-3.13.0-71-generic             deinstall
linux-image-extra-3.13.0-73-generic             deinstall
linux-image-extra-3.13.0-74-generic             deinstall
linux-image-extra-3.13.0-76-generic             deinstall
linux-image-extra-3.13.0-77-generic             deinstall
linux-image-extra-3.13.0-79-generic             deinstall
linux-image-extra-3.13.0-83-generic             deinstall
linux-image-extra-3.13.0-85-generic             deinstall
linux-image-extra-3.13.0-86-generic             deinstall
linux-image-extra-3.13.0-87-generic             deinstall
linux-image-extra-3.13.0-88-generic             deinstall
linux-image-extra-3.13.0-91-generic             deinstall
linux-image-extra-3.13.0-92-generic             deinstall
linux-image-extra-3.13.0-93-generic             deinstall
linux-image-extra-3.13.0-95-generic             deinstall
linux-image-extra-3.13.0-96-generic             deinstall
linux-image-extra-3.13.0-98-generic             deinstall
linux-signed-image-3.13.0-100-generic           deinstall
linux-signed-image-3.13.0-101-generic           deinstall
linux-signed-image-3.13.0-103-generic           deinstall
linux-signed-image-3.13.0-105-generic           deinstall
linux-signed-image-3.13.0-106-generic           deinstall
linux-signed-image-3.13.0-107-generic           deinstall
linux-signed-image-3.13.0-24-generic            deinstall
linux-signed-image-3.13.0-65-generic            deinstall
linux-signed-image-3.13.0-66-generic            deinstall
linux-signed-image-3.13.0-68-generic            deinstall
linux-signed-image-3.13.0-70-generic            deinstall
linux-signed-image-3.13.0-71-generic            deinstall
linux-signed-image-3.13.0-73-generic            deinstall
linux-signed-image-3.13.0-74-generic            deinstall
linux-signed-image-3.13.0-76-generic            deinstall
linux-signed-image-3.13.0-77-generic            deinstall
linux-signed-image-3.13.0-79-generic            deinstall
linux-signed-image-3.13.0-83-generic            deinstall
linux-signed-image-3.13.0-85-generic            deinstall
linux-signed-image-3.13.0-86-generic            deinstall
linux-signed-image-3.13.0-87-generic            deinstall
linux-signed-image-3.13.0-88-generic            deinstall
linux-signed-image-3.13.0-91-generic            deinstall
linux-signed-image-3.13.0-92-generic            deinstall
linux-signed-image-3.13.0-93-generic            deinstall
linux-signed-image-3.13.0-95-generic            deinstall
linux-signed-image-3.13.0-96-generic            deinstall
linux-signed-image-3.13.0-98-generic            deinstall
php5-common                                     deinstall
php5-json                                       deinstall


Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #41 am: 03 März 2017, 13:25:00 »
nein, nein das natürlich nicht... damit war gemeint das ich keine update && dist-upgrade mehr mache, weil er dann wohl auch auf aktuellere Distris geht...
Kommt wohl auf die Distri an, was dist-upgrade macht. Nach meinen aktuellen Erfahrungen mit Raspbian jessie und Ubuntu würde ich sagen, das dist-upgrade sorgt z.B. auch für neue Kernel, und nicht mehr für einen vollen Versions-update, dazu braucht es eines richtigen Schubses. M.E. kann und sollte man also ruhig auch dist-upgrades machen, sonst hat man irgendwann eine irre lange Liste zurückgehaltener Pakete. In der Regel sind das wirklich erst mal nur Kernel-Pakete, da kann man im Notfall auch beim Booten eine andere Auswahl treffen und fehlerhafte Kernel wieder rauswerfen (das Kernel nicht funktionieren, ist aber eher sehr selten).

Ich werde wohl am besten
apt-get update && apt-get upgrade -y && apt-get autoremove -ymachen

Das "assume yes" (-y) ist m.E. nicht unproblematisch. Ich werde eigentlich doch z.B. gerne mal gefragt, ob er jetzt die config aus der Paketquelle nehmen soll oder die vorhandene (letzteres ist -y, das macht aber nur in den Fällen Sinn, in denen ich die überhaupt angefaßt habe).
Und vorher mal drüberzusehen, welche Pakete überhaupt aktualisiert werden, kann auch nicht schaden ;). Macht man regelmäßige Updates, ist das in der Regel beides schnell erledigt.

Gruß, Beta-User
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2998
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #42 am: 03 März 2017, 13:29:15 »
1. apt-get update && apt-get upgrade -y && apt-get autoremove -y
NEIN ... Du sollt KONTROLLIEREN und nicht gleich pauschal rüberbügeln.
Und ein dist-upgrade macht bei ubuntu KEIN aktuelle Distri. Das hat derhenige gemacht, der Dir in der "source.list" eine aktuelle Source eingebaut hat.

2. Diese Packete haben noch reste auf dem System. Wenn Du willst, kann ich Dir zum lösen einen EInzeiler schreiben, ABER ... alle Angaben ohne Gewähr
# !!Angabe ohne Gewähr!!
apt-get purge -y $(dpkg --get-selections | grep deinstall | awk { print $1 })


Allerdings befürchte ich mittelfristig, das DU ein upgrade auf 16.04 durchführen must, um das System "sauber" zu kriegen ... das erfolgt aber mit "do-release-upgrade"

Edit:@Beta-User
Du hast recht, das es die Distries verschieden händeln. Bei Ubuntu ist ein dist-upgrade z.B: aktuallisierungen auf "Neuen Hardwarestack". Ein normales update dagegen aktuallisiert nicht in diesem Bereich.
« Letzte Änderung: 03 März 2017, 13:32:34 von Wernieman »
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline moonsorrox

  • Hero Member
  • *****
  • Beiträge: 2609
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #43 am: 03 März 2017, 14:10:14 »
1. apt-get update && apt-get upgrade -y && apt-get autoremove -y
NEIN ... Du sollt KONTROLLIEREN und nicht gleich pauschal rüberbügeln.
Und ein dist-upgrade macht bei ubuntu KEIN aktuelle Distri. Das hat derhenige gemacht, der Dir in der "source.list" eine aktuelle Source eingebaut hat.
also ich habe jetzt ein wenig etwas falsches geschrieben da oben...!

Nochmal richtig jetzt:
da ich jetzt nicht solch erfahrener Linux User bin auch weil ich eigentlich ein System immer am laufen halten möchte habe ich brav immer Updates gemacht mit...
apt-get update && apt-get dist-upgrade
so und nur so habe ich es gemacht...  ;)

wer oder was mir nun die source.list verändert hat, weiß ich nicht, denn ich war es nicht  ;) wirklich nicht. :-\
Damit ich es nun demnächst wirklich auch richtig mache, ist dass OK oder besser eine andere Variante.?

Allerdings befürchte ich mittelfristig, das DU ein upgrade auf 16.04 durchführen must, um das System "sauber" zu kriegen ... das erfolgt aber mit "do-release-upgrade"

ja das werde ich machen, denn es wird mir ja auch schon länger beim login immer angezeigt:
login as: root
root@10.0.0.50's password:
Welcome to Ubuntu 15.10 (GNU/Linux 3.13.0-111-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Fri Mar  3 13:48:59 CET 2017

  System load:  0.07              Processes:           111
  Usage of /:   9.2% of 46.65GB   Users logged in:     0
  Memory usage: 4%                IP address for eth0: 10.0.0.50
  Swap usage:   0%

  Graph this data and manage this system at:
    https://landscape.canonical.com/

0 packages can be updated.
0 updates are security updates.

Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

New release '16.04.2 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

OK nun zum weiteren vorgehen, sollte ich nun erst einmal mit deinem Einzeiler, alles beseitigen was noch drin ist oder soll ich das lieber händisch/manuell machen wie oben schon geschrieben ohne "-s"

UND.... danach, sollte ich das so machen mit dem "do-release-upgrade" empfiehlt ihr es mir..? oder doch besser dann irgendwann komplett Neu...
Ich weiß ich nerve vllt. etwas aber möchte nicht allzu viel falsch machen  ;)

Letzter Stand:
Zitat
Paketlisten werden gelesen... Fertig
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root@FHEM-Server:~#





« Letzte Änderung: 03 März 2017, 14:29:02 von moonsorrox »
Intel-NUC i3: FHEM-Server 5.8 :: Perl v5.18.2

Homematic: HM-USB-CFG2,HM-CFG-LAN Adapter, HM-LC-BL1-FM, HM-LC-Sw1PBU-FM, HM-LC-Sw1-PI-2, HM-WDS10-TH-O, HM-CC-TC, HM-LC-SW2-FM

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 1079
  • Hausaufgaben schon gemacht?
    • Perpetual beta
Antw:Probleme mit dem Update auf einem Ubuntu Server
« Antwort #44 am: 03 März 2017, 14:32:12 »
UND.... danach, sollte ich das so machen mit dem "do-release-upgrade" empfiehlt ihr es mir..? oder doch besser dann irgendwann komplett Neu...
Ich weiß ich nerve vllt. etwas aber möchte nicht allzu viel falsch machen  ;)
Es ist m.E. schwer ok, wenn man sich Sorgen um ein zentrales System macht :).

Du solltest ein aktuelles System verwenden. Je nachdem, wäre zu überlegen, ob Du nicht schlicht eine andere HDD/SSD nimmst, dann kannst Du (fast) parallel arbeiten. Wenn so, dann Neuaufsatz und Umzug von FHEM via Backup, zu den benötigten Paketen steht einiges im Wiki zum PI.

Ansonsten würde ich als erstes ein Backup machen (evtl. mit einer anderen Linux-Maschine (geht auch temporär) via "dd" als komplettes Abbild der Festplatte) und natürlich ein FHEM-Backup.
Dann das release-upgrade versuchen. In der Regel klappt das, besonders, wenn sonst nicht viel installiert ist oder eben weitere Paketquellen eingebunden waren. Geht es nicht: Neuaufsatz...

jm2ct

Gruß, Beta-User
Ubuntu 16.04@ARM-TV-Box | ConfigDB | VCCU | MySensors seriell (2.1.1) | DS18B20@MySensors | Milight@ESP-GW | SIGNALduino

 

decade-submarginal