Autor Thema: [Gelöst] Keine Kommunikation über knxd / EIBMarkt IP Schnittstelle auf Pi3  (Gelesen 505 mal)

Offline Weisnich

  • New Member
  • *
  • Beiträge: 17
Hallo zusammen,

ich bin ein absoluter Neuling. Nicht was KNX angeht, sondern was Linux, knxd etc angeht.

Meine Infrastruktur sieht so aus: PC -> PI3 (192.168.0.106) via ssh -> Lan-Lan VPN über 2 Fritzboxen -> EIBMarkt IP Schnittstelle (192.168.1.31/1.1.2) -> EIB (bei ETS5 über IP Schnittstelle an Adresse 1.1.5)

Ich habe ein Raspberry Pi 3B, installiert ist Jessie, knxd und fhem. Das war nicht einfach aber klappt.

in der knxd.conf habe ich den Eintrag geändert auf: KNXD_OPTS="-e 1.1.5 -E 1.1.6:9 -DTRS -b ipt:192.168.1.31" und siehe da, das ETS sieht den PI unter 1.1.5.
Ping an 192.168.1.31 klappt.
Auf die Statusabfrage "systemctl status knxd.service" bekomme ich Antwort.

Jetzt wollte ich die Kommunikation testen mit dem Befehl "knxtool groupread ip:192.168.1.31 2.1.0" (Ein Präsenzmelder-Ausgang) testen, ich erhalte aber keine Antwort.

Was nun? Ist eine Einstellung falsch? Prüfe ich falsch?


Gruß,
Weisnich
« Letzte Änderung: 12 März 2017, 14:52:58 von Weisnich »

Offline Merlin123

  • Full Member
  • ***
  • Beiträge: 107
Antw:Newbee, keine Kommunikation über knxd/EIBMarkt auf Pi3
« Antwort #1 am: 09 März 2017, 22:40:15 »
Ich habe eine Weinzierl 730er Schnittstelle auf 192.168.0.100 und bei mir steht das drin.

 KNXD_OPTS="-e 0.0.1 -E 0.0.2:9 -D -T -S -b ipt:192.168.0.100"

Läuft wunderbar. Kannst Du in FHEM mit autocreate Geräte anlegen lassen?
« Letzte Änderung: 09 März 2017, 22:42:11 von Merlin123 »
Gruß,
Oliver

Offline Weisnich

  • New Member
  • *
  • Beiträge: 17
[Gelöst] Newbee, keine Kommunikation über knxd/EIBMarkt auf Pi3
« Antwort #2 am: 12 März 2017, 13:54:31 »
Hallo Merlin,

vielen Dank für deinen Hinweis.

Ich denke, das Problem sind die vielen veralteten Artikel bzw. die großen Veränderungen an den einzelnen Programmen und meine fehlende Linux-Erfahrung.

Ich finde einigen Beiträgen hier fehlt auch etwas das Verständnis für noobs, daher versuche ich mal eine ausführlichere Antwort, die ich mir gewünscht hätte.

Ich bin mittlerweile (nach mehreren Neuinstallationen etc) auch mit deiner Hilfe zu folgendem Setup gekommen:
Putty:
sudo nano /etc/knxd.conf->
KNXD_OPTS="-e 1.1.5 -E 1.1.6:9 -u /tmp/eib -B single --send-delay=70 -c -b ipt:192.168.1.31"
Wie bin ich da hingekommen?

Man starte mit der Grundinstallation. Wenn man damit fertig ist, fragt man in Putty:
service knxd status
und sollte etwas erhalten wie
● knxd.service - KNX Daemon
   Loaded: loaded (/lib/systemd/system/knxd.service; enabled)
   Active: active (running) since Sa 2017-03-11 22:37:20 UTC; 13h ago
 Main PID: 1477 (knxd)
   CGroup: /system.slice/knxd.service
           └─1477 /usr/bin/knxd -e 0.0.1 -b ipt:192.168.1.31"

Die letzte Zeile kann ich nicht mehr genau nachvollziehen. Es sollte halt der Haken mit der Meldung vorhanden sein, ansonsten stimmt meiner Erfahrung nach etwas nicht mit der Installation.

Dann geht man per Putty wieder in die config
sudo nano /etc/knxd.conf
ändert jeweils nur ein Detail an seiner KNXD_OPTS-Zeile, speichert und startet den service neu
sudo service knxd restart
um ihn dann wieder neu zu prüfen mit
service knxd status
bis man eine funktionierende Konfiguration erstellt hat.

Diese scheint sehr system- und paketabhängig zu sein, denn viele der Einstellungen aus dem Netz führen zu keinen funktionierenden Ergebnissen.

Warum habe ich die Einstellunugen gewählt:
-e 1.1.5 : Einstellung aus ETS
-E 1.1.6:9 : das EIBMarktdingen hat 6 Gates, ich benutze nur 3+1=4
-u /tmp/eib : Standard, hier werden die Logs abgelegt, wenn ich mich recht erinnere
-B single : damit meine IP Schnittstelle nicht meint mit einem KNX-Netz verbunden zu werden
--send-delay=70 : damit meine IP Schnittstelle auch bei hoher Buslast nichts verschluckt
-c : Cache, damit Werte aus dem Log geholt werden, statt z.B. nach FHEM Neustart neu abzugefragen.
-b ipt:192.168.1.31 : die IP meiner Schnittstelle.

Ich empfehle die Lektüre von Grundlagen zum knxd und auch dem knxd-Wiki.


Gruß,
Weisnich



« Letzte Änderung: 12 März 2017, 14:37:21 von Weisnich »