Autor Thema: Installation von Net::SIP da libnet-sip-perl veraltet ist  (Gelesen 275 mal)

Offline franky08

  • Hero Member
  • *****
  • Beiträge: 3882
  • jetzt DBLog befreit
Hallo, ich würde für das SIP.pm Modul das Paket Net::SIP benötigen. Eine Installation über die Paketverwaltung von Wheezy mittels apt-get install libnet-sip-perl bringt leider nur eine uralte Version des Pakets. Ist es ratsam cpan auf dem System zu installieren um an das neuere Modul Net::SIP zu kommen oder wie könnte man noch vorgehen?

P.S. Die Version libnet-sip-perl (0.687-1) ist zwar neuer aber wenn ich das richtig sehe, für Jessie

VG
Frank
« Letzte Änderung: 04 März 2017, 10:33:03 von franky08 »
Debian Wheezy auf ZBOX nano (240GB SSD) FHEM2FHEM an 2xRaspiB
22Zoll ViewSonic als Infodislay (WVC)
3xHMLAN mit vccu ,fhem5.8, WH1080 fowsr an 2.RaspiB
Raspi B mit COC für ESA 2000 und CO2-Sensor
ECMD an AVR-NET-IO mit DAC u. ADC an Junkers Stetigregelung, Siemens LOGO!8

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2824
Antw:Installation von Net::SIP da libnet-sip-perl veraltet ist
« Antwort #1 am: 04 März 2017, 13:22:03 »
Ich befürchte, Du hast dafür nur 2 Möglichkeiten:
1) upgrade der Distri
2) Verwendung von CPAN

Ich persönlich würde 1) machen, weil ich bestimmt beim nächsten Upgrade CPAN vergessen werde und mir damit das Upgrade ....

Aber wie gesagt, ist Geschmacksache mit jeweils Vor/Nachteilen
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline franky08

  • Hero Member
  • *****
  • Beiträge: 3882
  • jetzt DBLog befreit
Antw:Installation von Net::SIP da libnet-sip-perl veraltet ist
« Antwort #2 am: 04 März 2017, 21:44:43 »
Zitat
...bestimmt beim nächsten Upgrade CPAN vergessen werde und mir damit das Upgrade ....

Ja, das befürchte ich auch...  :o

VG
Frank
Debian Wheezy auf ZBOX nano (240GB SSD) FHEM2FHEM an 2xRaspiB
22Zoll ViewSonic als Infodislay (WVC)
3xHMLAN mit vccu ,fhem5.8, WH1080 fowsr an 2.RaspiB
Raspi B mit COC für ESA 2000 und CO2-Sensor
ECMD an AVR-NET-IO mit DAC u. ADC an Junkers Stetigregelung, Siemens LOGO!8

Offline franky08

  • Hero Member
  • *****
  • Beiträge: 3882
  • jetzt DBLog befreit
Antw:Installation von Net::SIP da libnet-sip-perl veraltet ist
« Antwort #3 am: 05 März 2017, 15:34:22 »
Der Autor vom Modul 96_SIP.pm hat einen entscheidenden Hinweis gegeben:

https://forum.fhem.de/index.php/topic,67443.msg598836.html#msg598836

VG
Frank
Debian Wheezy auf ZBOX nano (240GB SSD) FHEM2FHEM an 2xRaspiB
22Zoll ViewSonic als Infodislay (WVC)
3xHMLAN mit vccu ,fhem5.8, WH1080 fowsr an 2.RaspiB
Raspi B mit COC für ESA 2000 und CO2-Sensor
ECMD an AVR-NET-IO mit DAC u. ADC an Junkers Stetigregelung, Siemens LOGO!8

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 2824
Antw:Installation von Net::SIP da libnet-sip-perl veraltet ist
« Antwort #4 am: 05 März 2017, 16:39:09 »
Wobei auch dort das Problem ist, das bei einem Update das Modul selber auch upgedatet werden sollte ...
- Bitte um Input für Output
- When there is a Shell, there is a Way

FHEM auf Gentoo/Ubuntu-Server
incl. CUL (433,868), JeeLink und SISPM

Offline franky08

  • Hero Member
  • *****
  • Beiträge: 3882
  • jetzt DBLog befreit
Antw:Installation von Net::SIP da libnet-sip-perl veraltet ist
« Antwort #5 am: 05 März 2017, 17:05:07 »
Stimmt, die Paketverwaltung weiß ja nichts von dem Modul...

VG
Frank
Debian Wheezy auf ZBOX nano (240GB SSD) FHEM2FHEM an 2xRaspiB
22Zoll ViewSonic als Infodislay (WVC)
3xHMLAN mit vccu ,fhem5.8, WH1080 fowsr an 2.RaspiB
Raspi B mit COC für ESA 2000 und CO2-Sensor
ECMD an AVR-NET-IO mit DAC u. ADC an Junkers Stetigregelung, Siemens LOGO!8

Offline knopf_piano

  • Full Member
  • ***
  • Beiträge: 254
Bananapi-R1, fhem-trunk, tablet-ui,  pywws, raspi, yamaha-671, ufs910-titan, freetz trunk 7490