Autor Thema: [gelöst] S.USV Fehler beim Start mit aktuellem Jessie  (Gelesen 694 mal)

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1129
[gelöst] S.USV Fehler beim Start mit aktuellem Jessie
« am: 05 März 2017, 18:08:01 »
Mir ist in der syslog für die S.USV folgender Fehler aufgefallen der früher nicht vorhanden war.
systemd[1]: susvd.service: control process exited, code=exited status=1
systemd[1]: Failed to start This service monitors the status of the S.USV In case of any voltage loss the service automatically s$
systemd[1]: Unit susvd.service entered failed state.
Hat jemand damit schon Erfahrungen waran das liegt?
« Letzte Änderung: 27 März 2017, 19:39:35 von Burny4600 »
Mfg Chris

Raspberry Pi 2/3 / Betriebssystem: Jessie Lite
Schnittstellen: RFXtrx433E (Oregon) / SIGNALduino / nanoCUL 868MHz (FS20), nanoCUL 433 MHz (IT), LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, FS20, IT, WMR200, TEK603, YouLess, Resol VBUS & DL2, Fronius Datalogger Web 2

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1129
Antw:S.USV Fehler beim Start mit aktuellem Jessie
« Antwort #1 am: 12 März 2017, 15:22:36 »
Der Fehler liegt an WiringPi.
WiringPi funktioniert mit aktuellem Jessie nicht mehr.
Auch Updates von WiringPi beseitigen nicht das Problem.

sudo ./susvd -start
S.USV Daemon started..
Unable to determine hardware version. I see: Hardware   : BCM2835
,
- expecting BCM2708 or BC2709. Please report this to projects@drogon.net
gpio version: 2.44
Copyright (c) 2012-2017 Gordon Henderson
This is free software with ABSOLUTELY NO WARRANTY.
For details type: gpio -warranty

Raspberry Pi Details:
 Type: Pi 3, Revision: 02, Memory: 1024MB, Maker: Sony
 * Device tree is enabled.
 *--> Raspberry Pi 3 Model B Rev 1.2
 * This Raspberry Pi supports user-level GPIO access.
uname -a
Linux ccs-ht-rasp01 4.9.13-v7+ #974 SMP Wed Mar 1 20:09:48 GMT 2017 armv7l GNU/Linux
« Letzte Änderung: 12 März 2017, 15:25:36 von Burny4600 »
Mfg Chris

Raspberry Pi 2/3 / Betriebssystem: Jessie Lite
Schnittstellen: RFXtrx433E (Oregon) / SIGNALduino / nanoCUL 868MHz (FS20), nanoCUL 433 MHz (IT), LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, FS20, IT, WMR200, TEK603, YouLess, Resol VBUS & DL2, Fronius Datalogger Web 2

Offline dieter114

  • Full Member
  • ***
  • Beiträge: 118
Antw:S.USV Fehler beim Start mit aktuellem Jessie
« Antwort #2 am: 24 März 2017, 20:59:28 »
Also ich habe die Version 2.2 laufen.
WiringPi neueste Version installiert:
Internals

Firmware 2.20
I2C_Address 15
Model  Basic
NAME usv
NR 399
STATE opened
TYPE SUSV
filehandle

Readings

BatteryCapacity 100.00 2017-03-24 20:52:11
BatteryState charged 2017-03-24 20:52:11
BatteryVoltage 4.20 2017-03-24 20:52:11
ChargingCircuit ONLINE 2017-03-24 20:52:11
ChargingCurrent 300 mA 2017-03-24 20:52:11
PowerBattery 02017-03-24 20:52:11
PowerExtern n/a 2017-03-24 20:52:11
PowerSource RPI 2017-03-24 20:52:11
VoltageIn 59.60 2017-03-24 20:52:11

Probleme sehe ich nur bei der Eingangsspannung
59,6V gibt es da nirgends also irgendwas geht immer noch nicht richtig,

Gruß Wolfdieter
Raspb_Pi I +III, SUSV, OWFS/OWServer,DS2423,DS2401,DS18B20,Solar,Gas,Stromverbrauchswerte,HM Zisterne,CUL HM,CUL868,Sduino433,Sduino868,WH1080, ESPEasy DHT, HTTPMod WU-Upload

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1129
Antw:S.USV Fehler beim Start mit aktuellem Jessie
« Antwort #3 am: 25 März 2017, 18:45:44 »
Das Problem war bei mir die Firmware V2.10 welche den WiringPi Fehler in Zusammenhang mit der Kernel V4.9.13-v7+ verursacht hatte.
Mit der aktuellen Firmware V2.20 und Software V2.20 funktioniert wieder alles mit der gleichen oder neueren Kernel Version.
Dafür funktioniert S.USV nicht mehr mit dem Kernel V4.4.50-v7+ einwandfrei!

Bei den Modellen der Revision 1.x ist zu beachten, dass die Kernel V4.4.50-v7+ und keine neuere Version verwendet wird, sonst kommt wieder die gleiche Fehlermeldung (Firmware V1.32 und Software V1.32).

Bei der Revision 2.x und der Firmware V2.20, hat sich einiges an den übermittelten Daten geändert.
Diese müssten in der 52_I2C_SUSV.pm für die Revision 2.x nachgeführt werden.
Mfg Chris

Raspberry Pi 2/3 / Betriebssystem: Jessie Lite
Schnittstellen: RFXtrx433E (Oregon) / SIGNALduino / nanoCUL 868MHz (FS20), nanoCUL 433 MHz (IT), LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, FS20, IT, WMR200, TEK603, YouLess, Resol VBUS & DL2, Fronius Datalogger Web 2

Offline FunkOdyssey

  • Sr. Member
  • ****
  • Beiträge: 904
Antw:[gelöst] S.USV Fehler beim Start mit aktuellem Jessie
« Antwort #4 am: 06 Juni 2017, 22:33:52 »
Für die Revision 1.x gibt es eine neue Software-Version 1.33, welches das Problem löst.
FHEM@RasPi